aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/libosmium/Makefile2
-rw-r--r--astro/libosmpbf/Makefile2
-rw-r--r--audio/acoustid-fingerprinter/Makefile2
-rw-r--r--audio/aqualung/Makefile2
-rw-r--r--audio/ardour5/Makefile3
-rw-r--r--audio/clementine-player/Makefile3
-rw-r--r--audio/cmus/Makefile2
-rw-r--r--audio/hydrogen-devel/Makefile2
-rw-r--r--audio/hydrogen/Makefile2
-rw-r--r--audio/mixxx/Makefile3
-rw-r--r--audio/ncmpcpp/Makefile2
-rw-r--r--audio/praat/Makefile2
-rw-r--r--audio/rezound/Makefile2
-rw-r--r--audio/terminatorx/Makefile2
-rw-r--r--benchmarks/dbs/Makefile2
-rw-r--r--biology/seqtools/Makefile2
-rw-r--r--cad/cider/Makefile3
-rw-r--r--cad/libopencad/Makefile3
-rw-r--r--cad/solvespace/Makefile2
-rw-r--r--cad/stepcode/Makefile2
-rw-r--r--chinese/pyzy/Makefile5
-rw-r--r--chinese/telnet/Makefile2
-rw-r--r--comms/direwolf/Makefile2
-rw-r--r--comms/linrad/Makefile7
-rw-r--r--comms/uarduno/Makefile2
-rw-r--r--converters/osm2pgsql/Makefile2
-rw-r--r--databases/mariadb-connector-c/Makefile3
-rw-r--r--databases/mysql-connector-c++/Makefile2
-rw-r--r--databases/xapian-bindings12/Makefile3
-rw-r--r--deskutils/charmtimetracker/Makefile2
-rw-r--r--devel/ccache-memcached-static/Makefile2
-rw-r--r--devel/cctz/Makefile2
-rw-r--r--devel/cheritrace-devel/Makefile2
-rw-r--r--devel/clanlib22/Makefile5
-rw-r--r--devel/cppcheck/Makefile2
-rw-r--r--devel/cpprestsdk/Makefile2
-rw-r--r--devel/creduce/Makefile2
-rw-r--r--devel/dia2code+/Makefile2
-rw-r--r--devel/gcc-msp430-ti-toolchain/Makefile3
-rw-r--r--devel/include-what-you-use/Makefile2
-rw-r--r--devel/libgrading/Makefile2
-rw-r--r--devel/liblas/Makefile5
-rw-r--r--devel/linenoise-ng/Makefile6
-rw-r--r--devel/log4cpp/Makefile4
-rw-r--r--devel/pecl-grpc/Makefile2
-rw-r--r--devel/php5-pinba/Makefile2
-rw-r--r--devel/pure-stldict/Makefile2
-rw-r--r--devel/py-grpcio/Makefile2
-rw-r--r--devel/py-ice/Makefile2
49 files changed, 111 insertions, 15 deletions
diff --git a/astro/libosmium/Makefile b/astro/libosmium/Makefile
index 70202367b3e4..19cd6f408a47 100644
--- a/astro/libosmium/Makefile
+++ b/astro/libosmium/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= sparsehash>=0:devel/sparsehash \
${LOCALBASE}/include/utf8.h:devel/utf8cpp
RUN_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp
+BROKEN_powerpc64= fails to compile: types_from_string.hpp: error: 'strtoll' is not a member of 'std'
+
USE_GITHUB= yes
GH_ACCOUNT= osmcode
diff --git a/astro/libosmpbf/Makefile b/astro/libosmpbf/Makefile
index 9e5ccd809485..866cf505a221 100644
--- a/astro/libosmpbf/Makefile
+++ b/astro/libosmpbf/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING.osmpbf
LIB_DEPENDS= libprotobuf.so:devel/protobuf
+BROKEN_powerpc64= fails to compile: metadata_lite.h: class 'google::protobuf::internal::InternalMetadataWithArenaLite' does not have any field named 'InternalMetadataWithArenaBase'
+
USE_GITHUB= yes
GH_ACCOUNT= scrosby
GH_PROJECT= OSM-binary
diff --git a/audio/acoustid-fingerprinter/Makefile b/audio/acoustid-fingerprinter/Makefile
index 509f93b6ea52..214f0d3f931a 100644
--- a/audio/acoustid-fingerprinter/Makefile
+++ b/audio/acoustid-fingerprinter/Makefile
@@ -14,6 +14,8 @@ LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
libtag.so:audio/taglib \
libavcodec.so:multimedia/ffmpeg
+BROKEN_powerpc64= fails to compile: libchromaprint.so: undefined reference to std::__cxx11::basic_string
+
USES= cmake desktop-file-utils
USE_QT4= corelib gui network \
qmake_build moc_build rcc_build uic_build
diff --git a/audio/aqualung/Makefile b/audio/aqualung/Makefile
index 02d29efe17ee..84e707e3000f 100644
--- a/audio/aqualung/Makefile
+++ b/audio/aqualung/Makefile
@@ -30,6 +30,8 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libcdio_paranoia.so:sysutils/libcdio-paranoia \
liblrdf.so:textproc/liblrdf
+BROKEN_powerpc64= fails to link: libicuuc.so: undefined reference to __cxa_throw_bad_array_new_length
+
USES= gettext localbase lua pkgconfig
USE_GNOME= gtk20 libxml2 libxslt
GNU_CONFIGURE= yes
diff --git a/audio/ardour5/Makefile b/audio/ardour5/Makefile
index b1c771808c39..6a48cf56fed3 100644
--- a/audio/ardour5/Makefile
+++ b/audio/ardour5/Makefile
@@ -48,7 +48,8 @@ USE_GNOME= atk cairo cairomm gdkpixbuf2 glib20 glibmm gtk20 gtkmm24 pango
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-BROKEN_aarch64= Fails to configure: Could not find the program gas,as,gcc
+BROKEN_aarch64= fails to configure: Could not find the program gas,as,gcc
+BROKEN_powerpc64= fails to compile: configuration_variable.cc: 'strtof' is not a member of 'std'
PLIST_SUB= ARDOURVERSION=${PORTVERSION}
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 47252e15a684..dfd0bc6da222 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -14,7 +14,6 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
-
LIB_DEPENDS= libtag.so:audio/taglib \
libchromaprint.so:audio/chromaprint \
libprotobuf.so:devel/protobuf \
@@ -24,6 +23,8 @@ LIB_DEPENDS= libtag.so:audio/taglib \
libechonest.so:audio/libechonest \
libcryptopp.so:security/cryptopp
+BROKEN_powerpc64= fails to compile: tagreader.cpp: undefined reference to TagLib::String::String
+
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}${PKGNAMESUFFIX}
GH_PROJECT= Clementine
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index 55c47f98f4e4..9a1bb27416e9 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -18,6 +18,8 @@ COMMENT= Console-based music player with really cool features
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to configure: checking for successful build of ffmpeg.c... no
+
USE_GITHUB= yes
USES= gmake iconv ncurses pkgconfig
diff --git a/audio/hydrogen-devel/Makefile b/audio/hydrogen-devel/Makefile
index a806df71b3d7..1ea9621b44ab 100644
--- a/audio/hydrogen-devel/Makefile
+++ b/audio/hydrogen-devel/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsndfile.so:audio/libsndfile
+BROKEN_powerpc64= fails to link: libicuuc.so. undefined reference to __cxa_throw_bad_array_new_length
+
CONFLICTS= hydrogen-0.*
USE_GITHUB= yes
diff --git a/audio/hydrogen/Makefile b/audio/hydrogen/Makefile
index 859830a33f1a..3c4cd2ad1c45 100644
--- a/audio/hydrogen/Makefile
+++ b/audio/hydrogen/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libsndfile.so:audio/libsndfile
+BROKEN_powerpc64= fails to link: libicuuc.so. undefined reference to __cxa_throw_bad_array_new_length
+
CONFLICTS= hydrogen-devel-0.*
USE_GITHUB= yes
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index e74a13584426..ee7efa59fc44 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -28,7 +28,8 @@ LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-BROKEN_aarch64= Fails to compile: Exception("invalid machine type")
+BROKEN_aarch64= fails to compile: Exception("invalid machine type")
+BROKEN_powerpc64= fails to configure: unmet dependencies: Could not find libprotobuf, libchromaprint, libmp4, and libwavpack
USES= scons iconv pkgconfig
USE_QT4= corelib gui network opengl script scripttools sql svg \
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index 83c7b9ccd9a3..15c5001f3ae0 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= libmpdclient.so:audio/libmpdclient \
libicuuc.so:devel/icu \
libboost_filesystem.so:devel/boost-libs
+BROKEN_powerpc64= fails to compile: tags.cpp: undefined reference to TagLib::String::to8Bit
+
USES= compiler:c++11-lib iconv libtool localbase ncurses pkgconfig readline tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= glib20
diff --git a/audio/praat/Makefile b/audio/praat/Makefile
index 17e21c587a65..cb64ed81ee4a 100644
--- a/audio/praat/Makefile
+++ b/audio/praat/Makefile
@@ -12,6 +12,8 @@ COMMENT= Phonetics by Computer
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=gnu++11"
+
USE_GITHUB= yes
DOS2UNIX_REGEX= .*Makefile
USES= dos2unix iconv pkgconfig
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index 84ba49092417..a4a2ed3a54cb 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libFOX-1.6.so:x11-toolkits/fox16
+BROKEN_powerpc64= fails to compile: CAtomicCounter.h: boost/detail/atomic_count.hpp: No such file or directory
+
USES= bison pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsa
diff --git a/audio/terminatorx/Makefile b/audio/terminatorx/Makefile
index 2f0379ca945a..227adb53a9a0 100644
--- a/audio/terminatorx/Makefile
+++ b/audio/terminatorx/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa \
LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
liblrdf.so:textproc/liblrdf
+BROKEN_powerpc64= fails to configure: checking for XOpenDisplay in -lX11... no
+
OPTIONS_DEFINE= ALSA JACK MPG123 SOX VORBIS MAD
OPTIONS_DEFAULT= JACK MPG123 SOX VORBIS MAD
SOX_DESC= sox (.au) support
diff --git a/benchmarks/dbs/Makefile b/benchmarks/dbs/Makefile
index ff981789a4c4..f1f55a6b732c 100644
--- a/benchmarks/dbs/Makefile
+++ b/benchmarks/dbs/Makefile
@@ -13,6 +13,8 @@ COMMENT= Distributed network benchmarking system
RUN_DEPENDS= gnuplot:math/gnuplot
+BROKEN_FreeBSD_12= tcp_debug.h: field has incomplete type 'struct tcpcb'
+
BUILD_WRKSRC= ${WRKSRC}/obj/${OPSYS}
INSTALL_WRKSRC= ${WRKSRC}/obj/${OPSYS}
diff --git a/biology/seqtools/Makefile b/biology/seqtools/Makefile
index a242be63b953..a76ddf96aa65 100644
--- a/biology/seqtools/Makefile
+++ b/biology/seqtools/Makefile
@@ -16,6 +16,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
+BROKEN_powerpc64= fails to compile: jsoncpp.cpp: 'snprintf' is not a member of 'std'
+
USES= compiler:c++14-lang execinfo gettext libtool pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= cairo gdkpixbuf2 gtk20
diff --git a/cad/cider/Makefile b/cad/cider/Makefile
index 045935993f70..4ce01ee9e530 100644
--- a/cad/cider/Makefile
+++ b/cad/cider/Makefile
@@ -11,7 +11,8 @@ DISTNAME= cider1b1
MAINTAINER= ports@FreeBSD.org
COMMENT= Mixed-level circuit and device simulator (includes SPICE3)
-BROKEN_aarch64= Fails to link: missing sbrk
+BROKEN_aarch64= fails to link: missing sbrk
+BROKEN_powerpc64= fails to compile: ccache: cc: FreeBSD: No such file or directory
CONFLICTS= spice-[0-9]*
WRKSRC= ${WRKDIR}/sim
diff --git a/cad/libopencad/Makefile b/cad/libopencad/Makefile
index 4778aaeb3bf8..438ac7621580 100644
--- a/cad/libopencad/Makefile
+++ b/cad/libopencad/Makefile
@@ -12,6 +12,9 @@ COMMENT= Library which provides a way to read/write CAD (DWG/DXF/DXFB) files
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_armv6= fails to compile: cadheader.cpp: ambiguous conversion for functional-style cast from 'time_t' to 'CADVariant'
+BROKEN_powerpc64= fails to compile: r2000.cpp: 'to_string' was not declared in this scope
+
USE_GITHUB= yes
GH_ACCOUNT= sandyre
diff --git a/cad/solvespace/Makefile b/cad/solvespace/Makefile
index 852ab3a1c464..10a6d1768824 100644
--- a/cad/solvespace/Makefile
+++ b/cad/solvespace/Makefile
@@ -17,6 +17,8 @@ LIB_DEPENDS= libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
libgtkmm-2.4.so:x11-toolkits/gtkmm24
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
USE_GITHUB= yes
GH_PROJECT= libdxfrw:libdxfrw
GH_TAGNAME= 8f95895:libdxfrw
diff --git a/cad/stepcode/Makefile b/cad/stepcode/Makefile
index 81ed95373505..ee9d3d37369e 100644
--- a/cad/stepcode/Makefile
+++ b/cad/stepcode/Makefile
@@ -13,6 +13,8 @@ COMMENT= Generates C++ and Python from ISO10303 files
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to configure: Schema scan for 15926-0002-lifecycle_integration.exp exited with error code 1
+
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/chinese/pyzy/Makefile b/chinese/pyzy/Makefile
index 973fbe45a479..78b1e066ca6f 100644
--- a/chinese/pyzy/Makefile
+++ b/chinese/pyzy/Makefile
@@ -21,8 +21,9 @@ SHEBANG_FILES= data/db/android/create_db.py
USE_GNOME= glib20
USE_LDCONFIG= yes
-BROKEN_aarch64= Fails to compile: error: constant expression evaluates to -1
-BROKEN_armv6= Fails to compile: error: constant expression evaluates to -1
+BROKEN_aarch64= fails to compile: constant expression evaluates to -1
+BROKEN_armv6= fails to compile: constant expression evaluates to -1
+BROKEN_powerpc64= fails to compile: narrowing conversion of '-1' from 'int' to 'char'
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking --disable-boost
diff --git a/chinese/telnet/Makefile b/chinese/telnet/Makefile
index a5d50228d979..f979cee5fce0 100644
--- a/chinese/telnet/Makefile
+++ b/chinese/telnet/Makefile
@@ -25,7 +25,7 @@ IGNORE= need to build this port with the source code of telnet
.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1100000
-BROKEN= does not build
+BROKEN= does not build: libtelnet/Makefile: Could not find src.opts.mk
.endif
BROKEN_DragonFly= does not build
diff --git a/comms/direwolf/Makefile b/comms/direwolf/Makefile
index d22adfedfdba..2d4985d6a7d2 100644
--- a/comms/direwolf/Makefile
+++ b/comms/direwolf/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libhamlib.so:comms/hamlib \
libgps.so:astro/gpsd
+BROKEN_powerpc64= fails to link: direwolf-1.4_1 depends on shared library: libgpsd.so - not found
+
USE_GITHUB= yes
GH_ACCOUNT= wb2osz
GH_TAGNAME= 6207e2e
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index ccb2f4a29ca4..7a71eca7b67d 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -32,9 +32,10 @@ LINRAD_DOCFILES= z_APM.txt z_BUFFERS.txt z_CALIBRATE.txt \
z_PARALLEL_PORT.txt z_SETTINGS.txt \
z_USERS_EXTRA.txt z_USERS_HWARE.txt
-BROKEN_aarch64= Fails to compile: implicit declaration of function outb
-BROKEN_armv6= Fails to configure: can not find /nxb-bin/usr/bin/cc
-BROKEN_sparc64= Fails to compile: implicit declaration of function outb
+BROKEN_aarch64= fails to compile: implicit declaration of function outb
+BROKEN_armv6= fails to configure: can not find /nxb-bin/usr/bin/cc
+BROKEN_powerpc64= fails to compile: implicit declaration of function outb
+BROKEN_sparc64= fails to compile: implicit declaration of function outb
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
diff --git a/comms/uarduno/Makefile b/comms/uarduno/Makefile
index 6b725473c55f..e4c8f5d0276a 100644
--- a/comms/uarduno/Makefile
+++ b/comms/uarduno/Makefile
@@ -12,6 +12,8 @@ COMMENT= FreeBSD Kernel Driver for the Arduino Uno USB interface
LICENSE= BSD4CLAUSE
+BROKEN_powerpc64= fails to compile: pcpu.h: error: size of array '__assert_0' is negative
+
USES= kmod uidfix
# some test targets need a predictable source directory
diff --git a/converters/osm2pgsql/Makefile b/converters/osm2pgsql/Makefile
index e020a461d279..67927f2ce9fc 100644
--- a/converters/osm2pgsql/Makefile
+++ b/converters/osm2pgsql/Makefile
@@ -17,6 +17,8 @@ LIB_DEPENDS= libproj.so:graphics/proj \
libboost_system.so:devel/boost-libs \
libexpat.so:textproc/expat2
+BROKEN_powerpc64= fails to compile: node-ram-cache.hpp: cstdint: No such file or directory
+
USE_GITHUB= yes
GH_ACCOUNT= openstreetmap
diff --git a/databases/mariadb-connector-c/Makefile b/databases/mariadb-connector-c/Makefile
index 81f5489f1b4f..0d04ba666f71 100644
--- a/databases/mariadb-connector-c/Makefile
+++ b/databases/mariadb-connector-c/Makefile
@@ -19,6 +19,9 @@ COMMENT= MariaDB database connector for C
LICENSE= LGPL21
+BROKEN_armv6= fails to configure: CMake Error: Generator: execution of make failed
+BROKEN_powerpc64= fails to compile: my_stmt_codec.c: error: invalid use of void expression
+
CONFLICTS_INSTALL= mariadb[0-9]*-client-* \
mariadb102-server-* \
mysql[0-9]*-client-* \
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index 144ab909ed0d..ef4abf3dcb17 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
+BROKEN_powerpc64= fails to configure: the compiler doesn't support C++11
+
USES= cmake:outsource mysql ssl
USE_LDCONFIG= yes
CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}"
diff --git a/databases/xapian-bindings12/Makefile b/databases/xapian-bindings12/Makefile
index 0ea509fd66f6..18966929c8f3 100644
--- a/databases/xapian-bindings12/Makefile
+++ b/databases/xapian-bindings12/Makefile
@@ -22,6 +22,9 @@ OPTIONS_DEFINE= DOCS LUA PHP PYTHON RUBY
OPTIONS_DEFAULT=PHP PYTHON RUBY
OPTIONS_SUB= yes
+# BROKEN: ruby.h: error: wrong number of arguments specified for 'deprecated' attribute
+OPTIONS_EXCLUDE_powerpc64= RUBY
+
PORTSCOUT= limitw:1,even
CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
diff --git a/deskutils/charmtimetracker/Makefile b/deskutils/charmtimetracker/Makefile
index 0439c9ad0a4c..4c60536db9e6 100644
--- a/deskutils/charmtimetracker/Makefile
+++ b/deskutils/charmtimetracker/Makefile
@@ -10,6 +10,8 @@ COMMENT= Time tracker
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++0x"
+
USE_GITHUB= yes
GH_ACCOUNT= KDAB
GH_PROJECT= Charm
diff --git a/devel/ccache-memcached-static/Makefile b/devel/ccache-memcached-static/Makefile
index 2cd4b8a1ad9d..c0a8de3b9f3b 100644
--- a/devel/ccache-memcached-static/Makefile
+++ b/devel/ccache-memcached-static/Makefile
@@ -8,4 +8,6 @@ OPTIONS_SLAVE= MEMCACHED STATIC
CONFLICTS_INSTALL= ccache-[0-9]* ccache-memcached[0-9]* ccache-static[0-9]*
+BROKEN_powerpc64= fails to configure: checking for memcached in -lmemcached... no
+
.include "${MASTERDIR}/Makefile"
diff --git a/devel/cctz/Makefile b/devel/cctz/Makefile
index 73f0183c93e0..c8cb11ae2e58 100644
--- a/devel/cctz/Makefile
+++ b/devel/cctz/Makefile
@@ -12,6 +12,8 @@ COMMENT= C++ library for handling dates, times, and time zones
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_powerpc64= fails to compile: time_tool.cc: 'stoll' is not a member of 'std'
+
GH_ACCOUNT= google
USE_GITHUB= yes
USES= compiler:c++11-lib gmake
diff --git a/devel/cheritrace-devel/Makefile b/devel/cheritrace-devel/Makefile
index 7952be4172c4..8b9ae976d357 100644
--- a/devel/cheritrace-devel/Makefile
+++ b/devel/cheritrace-devel/Makefile
@@ -12,6 +12,8 @@ COMMENT= Library and tool for interacting with CHERI streamtraces
BUILD_DEPENDS= llvm-config-cheri:devel/llvm-cheri
LIB_DEPENDS= libLLVMCore.so:devel/llvm-cheri
+BROKEN_powerpc64= fails to compile: addressmap.cc: 'stoll' is not a member of 'std'
+
USES= cmake compiler:c++11-lib
USE_GITHUB= yes
GH_ACCOUNT= CTSRD-CHERI
diff --git a/devel/clanlib22/Makefile b/devel/clanlib22/Makefile
index 3fa4247acaae..d8282b44f189 100644
--- a/devel/clanlib22/Makefile
+++ b/devel/clanlib22/Makefile
@@ -48,8 +48,9 @@ INSTALL_TARGET= install-strip
PLIST_SUB+= VER=${PORTVERSION:R} \
SHORT_VER=${PORTVERSION:R:R}${PORTVERSION:R:E}
-BROKEN_aarch64= Fails to configure: error: Requires SSE2 Support
-BROKEN_sparc64= Fails to configure: error: Requires SSE2 Support
+BROKEN_aarch64= fails to configure: error: Requires SSE2 Support
+BROKEN_powerpc64= fails to configure: error: Requires SSE2 Support
+BROKEN_sparc64= fails to configure: error: Requires SSE2 Support
post-patch:
@${REINPLACE_CMD} -e '/^extra_LIBS_clanSqlite/s|-ldl||g' \
diff --git a/devel/cppcheck/Makefile b/devel/cppcheck/Makefile
index 4793f23cbeec..b697a0de8aeb 100644
--- a/devel/cppcheck/Makefile
+++ b/devel/cppcheck/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libtinyxml2.so:textproc/tinyxml2
+BROKEN_powerpc64= fails to compile: analyzerinfo.cpp: 'to_string' is not a member of 'std'
+
USES= compiler:c++11-lib execinfo gmake python shebangfix tar:bzip2
SHEBANG_FILES= htmlreport/cppcheck-htmlreport
USE_CXXSTD= c++11
diff --git a/devel/cpprestsdk/Makefile b/devel/cpprestsdk/Makefile
index 077fca1abf8b..1a130bf525f8 100644
--- a/devel/cpprestsdk/Makefile
+++ b/devel/cpprestsdk/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/../license.txt
LIB_DEPENDS= libboost_system.so:devel/boost-libs
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
USE_GITHUB= yes
GH_ACCOUNT= Microsoft
diff --git a/devel/creduce/Makefile b/devel/creduce/Makefile
index bbbaa1a4ad19..e67d669f04bb 100644
--- a/devel/creduce/Makefile
+++ b/devel/creduce/Makefile
@@ -19,6 +19,8 @@ RUN_DEPENDS= llvm-config39:devel/llvm39 \
devel/p5-Sys-Cpu>=0:devel/p5-Sys-Cpu \
p5-Getopt-Tabular>=0:devel/p5-Getopt-Tabular
+BROKEN_powerpc64= fails to configure: cannot compile and link test program with selected LLVM
+
GNU_CONFIGURE= yes
CONFIGURE_FLAGS= --with-llvm=${LOCALBASE}
CONFIGURE_ENV= LLVM_CONFIG=${LOCALBASE}/bin/llvm-config39 \
diff --git a/devel/dia2code+/Makefile b/devel/dia2code+/Makefile
index 9cadd1a9b551..3ece282bad26 100644
--- a/devel/dia2code+/Makefile
+++ b/devel/dia2code+/Makefile
@@ -14,6 +14,8 @@ COMMENT= Complete rewrite of dia2code in C++
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: GenerateCodePhp.cpp: 'stoi' is not a member of 'std'
+
USES= autoreconf:build compiler:gcc-c++11-lib iconv
USE_GNOME= libxml2
GNU_CONFIGURE= yes
diff --git a/devel/gcc-msp430-ti-toolchain/Makefile b/devel/gcc-msp430-ti-toolchain/Makefile
index 3fd69c28e480..cefeb72aac4a 100644
--- a/devel/gcc-msp430-ti-toolchain/Makefile
+++ b/devel/gcc-msp430-ti-toolchain/Makefile
@@ -37,6 +37,9 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libisl.so:devel/isl
BROKEN_aarch64= fails to compile: c++: error: unsupported option -print-multi-os-directory
+BROKEN_mips= fails to configure: cannot compute suffix of object files
+BROKEN_mips64= fails to configure: cannot compute suffix of object files
+BROKEN_powerpc64= fails to compile: longlong.h: internal compiler error: Segmentation fault
USES= bison compiler cpe gmake iconv libtool makeinfo ncurses \
tar:bzip2
diff --git a/devel/include-what-you-use/Makefile b/devel/include-what-you-use/Makefile
index 85cbfae958f4..e06e2f1f11dd 100644
--- a/devel/include-what-you-use/Makefile
+++ b/devel/include-what-you-use/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
BUILD_DEPENDS= clang39:devel/llvm39
RUN_DEPENDS= clang39:devel/llvm39
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
USES= cmake:outsource ncurses python:run shebangfix
USE_GITHUB= yes
diff --git a/devel/libgrading/Makefile b/devel/libgrading/Makefile
index d2dcb471d351..0e5ab688b4f6 100644
--- a/devel/libgrading/Makefile
+++ b/devel/libgrading/Makefile
@@ -13,6 +13,8 @@ LICENSE= APACHE20
LIB_DEPENDS= libdistance.so:devel/libdistance
+BROKEN_powerpc64= fails to compile: Arguments.cpp: 'atol' is not a member of 'std'
+
USE_GITHUB= yes
GH_ACCOUNT= trombonehero
diff --git a/devel/liblas/Makefile b/devel/liblas/Makefile
index d155720ab26c..218af0cd11d6 100644
--- a/devel/liblas/Makefile
+++ b/devel/liblas/Makefile
@@ -26,7 +26,8 @@ USE_GITHUB= yes
GH_ACCOUNT= libLAS
GH_PROJECT= ${GH_ACCOUNT}
-BROKEN_aarch64= Fails to compile: file liblas/detail/endian.hpp needs to be set up for your CPU type
-BROKEN_armv6= Fails to compile: file liblas/detail/endian.hpp needs to be set up for your CPU type
+BROKEN_aarch64= fails to compile: file liblas/detail/endian.hpp needs to be set up for your CPU type
+BROKEN_armv6= fails to compile: file liblas/detail/endian.hpp needs to be set up for your CPU type
+BROKEN_powerpc64= fails to compile: undefined reference to boost::program_options::to_internal
.include <bsd.port.mk>
diff --git a/devel/linenoise-ng/Makefile b/devel/linenoise-ng/Makefile
index 68d5b2d77458..b6607500ed19 100644
--- a/devel/linenoise-ng/Makefile
+++ b/devel/linenoise-ng/Makefile
@@ -12,7 +12,11 @@ COMMENT= Small, portable readline replacement
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake
+BROKEN_mips= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+BROKEN_mips64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
+USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= arangodb
GH_PROJECT= linenoise-ng
diff --git a/devel/log4cpp/Makefile b/devel/log4cpp/Makefile
index c5f5470bd5e1..f982674ca59e 100644
--- a/devel/log4cpp/Makefile
+++ b/devel/log4cpp/Makefile
@@ -12,6 +12,10 @@ COMMENT= Library of C++ classes for flexible logging
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_mips= fails to compile: Appender.cpp: extra ';'
+BROKEN_mips64= fails to compile: Appender.cpp: extra ';'
+BROKEN_powerpc64= fails to compile: Appender.cpp: extra ';'
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= gmake libtool pathfix
diff --git a/devel/pecl-grpc/Makefile b/devel/pecl-grpc/Makefile
index 3b50ad20411f..86d4fb578b74 100644
--- a/devel/pecl-grpc/Makefile
+++ b/devel/pecl-grpc/Makefile
@@ -11,7 +11,9 @@ COMMENT= High performance, general RPC framework
LICENSE= BSD3CLAUSE
BROKEN_aarch64= fails to compile: fatal error: sys/auxv.h file not found
+BROKEN_mips= fails to compile: fatal error: sys/auxv.h file not found
BROKEN_mips64= fails to compile: fatal error: sys/auxv.h file not found
+BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option "-Wno-parentheses-equality"
USES= php:pecl
diff --git a/devel/php5-pinba/Makefile b/devel/php5-pinba/Makefile
index a2d582e6991c..a2625132bcc1 100644
--- a/devel/php5-pinba/Makefile
+++ b/devel/php5-pinba/Makefile
@@ -12,6 +12,8 @@ COMMENT= PHP-extension part of statistics server for PHP
LIB_DEPENDS= libprotobuf.so:devel/protobuf
+BROKEN_powerpc64= fails to compile: class 'google::protobuf::internal::InternalMetadataWithArenaLite' does not have any field named 'InternalMetadataWithArenaBase'
+
USE_GITHUB= yes
GH_ACCOUNT= tony2001
GH_PROJECT= pinba_extension
diff --git a/devel/pure-stldict/Makefile b/devel/pure-stldict/Makefile
index 892b5fc5cf69..5a5d34e19b71 100644
--- a/devel/pure-stldict/Makefile
+++ b/devel/pure-stldict/Makefile
@@ -13,6 +13,8 @@ COMMENT= Pure interface to C++ STL map/unordered_map
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++0x"
+
USES= pkgconfig pure
CXXFLAGS+= -std=c++0x -DHAVE_STD_IS_PERMUTATION
diff --git a/devel/py-grpcio/Makefile b/devel/py-grpcio/Makefile
index 4682c76c1c79..be260a7f5313 100644
--- a/devel/py-grpcio/Makefile
+++ b/devel/py-grpcio/Makefile
@@ -16,6 +16,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>1:devel/py-six \
${PYTHON_PKGNAMEPREFIX}enum34>1:devel/py-enum34
LIB_DEPENDS= libcares.so:dns/c-ares
+BROKEN_powerpc64= fails to compile: cpu-ppc64le.c: 'AT_HWCAP2' undeclared
+
USES= python
USE_PYTHON= distutils
CFLAGS+= -Ithird_party/boringssl/include \
diff --git a/devel/py-ice/Makefile b/devel/py-ice/Makefile
index cd9e2a596363..20b9995795e9 100644
--- a/devel/py-ice/Makefile
+++ b/devel/py-ice/Makefile
@@ -12,6 +12,8 @@ LICENSE= GPLv2
BUILD_DEPENDS= mcpp:devel/mcpp
LIB_DEPENDS= libIce.so.${LIB_VRS}:devel/ice
+BROKEN_powerpc64= fails to compile: gmake: Ice_BuiltinSequences_ice.py: Segmentation fault (core dumped)
+
USES= python shebangfix
USE_PYTHON= py3kplist
SLAVE_PORT= yes