aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/adacontrol/Makefile3
-rw-r--r--lang/asis/Makefile7
-rw-r--r--textproc/adabrowse/Makefile3
-rw-r--r--x11-toolkits/qtada/Makefile3
4 files changed, 8 insertions, 8 deletions
diff --git a/lang/adacontrol/Makefile b/lang/adacontrol/Makefile
index e872ff4f06c1..996e210c8cb6 100644
--- a/lang/adacontrol/Makefile
+++ b/lang/adacontrol/Makefile
@@ -15,8 +15,7 @@ COMMENT= Tool for detecting use or non-use of specific Ada constructs
LICENSE= GPLv2 GMGPL
LICENSE_COMB= multi
-BUILD_DEPENDS= asis>=2011:${PORTSDIR}/lang/asis \
- gnat_util>=2013:${PORTSDIR}/lang/gnat_util
+BUILD_DEPENDS= asis>=2011:${PORTSDIR}/lang/asis
USES= ada gmake
WRKSRC= ${WRKDIR}/adactl-${PORTVERSION}
diff --git a/lang/asis/Makefile b/lang/asis/Makefile
index 28802315beb8..a307e6d9d24c 100644
--- a/lang/asis/Makefile
+++ b/lang/asis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= asis
PORTVERSION= 2011
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= http://downloads.dragonlace.net/src/
DISTNAME= ${PORTNAME}-gpl-${PORTVERSION}-src
@@ -15,11 +15,14 @@ COMMENT= GNAT implementation of Ada Semantic Interface Specification
LICENSE= GPLv2
BUILD_DEPENDS= gnat_util>=2013:${PORTSDIR}/lang/gnat_util \
- xmlada>=3.2:${PORTSDIR}/textproc/xmlada
+ xmlada>=3.2:${PORTSDIR}/textproc/xmlada \
+ ${GUSTATIC}:${PORTSDIR}/lang/gnat_util
+RUN_DEPENDS= ${GUSTATIC}:${PORTSDIR}/lang/gnat_util
USES= ada gmake
NO_MTREE= yes
MAKE_ENV= PROCESSORS=${MAKE_JOBS_NUMBER}
+GUSTATIC= ${LOCALBASE}/lib/gnat_util/libgnat_util.a
post-extract:
@${REINPLACE_CMD} -e 's|OPSYS|ASISOPSYS|g' \
diff --git a/textproc/adabrowse/Makefile b/textproc/adabrowse/Makefile
index 4ed95dc95d96..b0c0df80068b 100644
--- a/textproc/adabrowse/Makefile
+++ b/textproc/adabrowse/Makefile
@@ -13,8 +13,7 @@ COMMENT= HTML generator for Ada 95 library unit specifications
LICENSE= GPLv2
-BUILD_DEPENDS= asis>=2011:${PORTSDIR}/lang/asis \
- gnat_util>=2013:${PORTSDIR}/lang/gnat_util
+BUILD_DEPENDS= asis>=2011:${PORTSDIR}/lang/asis
USES= ada
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
diff --git a/x11-toolkits/qtada/Makefile b/x11-toolkits/qtada/Makefile
index aa2273f1b7b3..ede264adb1d3 100644
--- a/x11-toolkits/qtada/Makefile
+++ b/x11-toolkits/qtada/Makefile
@@ -14,7 +14,6 @@ COMMENT= Ada2005 language bindings to Qt4 framework
LICENSE= GPLv2
BUILD_DEPENDS= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild \
- gnat_util>=2013:${PORTSDIR}/lang/gnat_util \
asis>=2011:${PORTSDIR}/lang/asis
USES= ada gmake pkgconfig
@@ -28,7 +27,7 @@ post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share
${MV} ${STAGEDIR}${PREFIX}/examples ${STAGEDIR}${PREFIX}/share/
@cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} > ${TMPPLIST}
+ ${SORT} >> ${TMPPLIST}
@cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | \
${SORT} -r | ${SED} -e '/lib\/gnat$$/d' -e '/share\/doc$$/d' \
-e '/share\/gps$$/d' -e '/share\/gps\/plug-ins$$/d' \