aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/couchdb/Makefile3
-rw-r--r--databases/mongodb/Makefile3
-rw-r--r--lang/p5-JavaScript-SpiderMonkey/Makefile3
-rw-r--r--net/mediatomb/Makefile5
-rw-r--r--www/openvrml/Makefile4
5 files changed, 10 insertions, 8 deletions
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
index 4e5ee00b2b12..bf82fb80e0f0 100644
--- a/databases/couchdb/Makefile
+++ b/databases/couchdb/Makefile
@@ -8,6 +8,7 @@
PORTNAME= couchdb
PORTVERSION= 1.2.0
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= couchdb/releases/${PORTVERSION}
@@ -17,7 +18,7 @@ MAINTAINER= till@php.net
COMMENT= A document database server, accessible via a RESTful JSON API
LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu \
- js:${PORTSDIR}/lang/spidermonkey \
+ js:${PORTSDIR}/lang/spidermonkey17 \
curl:${PORTSDIR}/ftp/curl
BUILD_DEPENDS= ${LOCALBASE}/bin/help2man:${PORTSDIR}/misc/help2man \
erlc:${PORTSDIR}/lang/erlang
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index de8e178124db..c94f31de210f 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mongodb
PORTVERSION= 2.0.6
+PORTREVISION= 1
CATEGORIES= databases net
MASTER_SITES= http://downloads.mongodb.org/src/
DISTNAME= ${PORTNAME}-src-r${PORTVERSION}
@@ -50,7 +51,7 @@ SCONS_ARGS+= --usev8
LIB_DEPENDS+= v8:${PORTSDIR}/lang/v8
.else
SCONS_ARGS+= --usesm
-LIB_DEPENDS+= js:${PORTSDIR}/lang/spidermonkey
+LIB_DEPENDS+= js:${PORTSDIR}/lang/spidermonkey17
.endif
post-install:
diff --git a/lang/p5-JavaScript-SpiderMonkey/Makefile b/lang/p5-JavaScript-SpiderMonkey/Makefile
index 7ac6b66fd474..7f377710d72f 100644
--- a/lang/p5-JavaScript-SpiderMonkey/Makefile
+++ b/lang/p5-JavaScript-SpiderMonkey/Makefile
@@ -7,6 +7,7 @@
PORTNAME= JavaScript-SpiderMonkey
PORTVERSION= 0.21
+PORTREVISION= 1
CATEGORIES= lang perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Perl interface to Mozilla JavaScript implementation
-LIB_DEPENDS= js.1:${PORTSDIR}/lang/spidermonkey
+LIB_DEPENDS= js.1:${PORTSDIR}/lang/spidermonkey17
TEST_DEPENDS= p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl
diff --git a/net/mediatomb/Makefile b/net/mediatomb/Makefile
index 14a039b724d4..a4afe54feaf1 100644
--- a/net/mediatomb/Makefile
+++ b/net/mediatomb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mediatomb
PORTVERSION= 0.12.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net multimedia
MASTER_SITES= SF/${PORTNAME}/MediaTomb/${PORTVERSION}
@@ -88,8 +88,7 @@ CONFIGURE_ARGS+= --disable-mysql
CONFIGURE_ARGS+= --enable-libjs \
--with-js-h="${LOCALBASE}/include" \
--with-js-libs="${LOCALBASE}/lib"
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libjs.so:${PORTSDIR}/lang/spidermonkey
-RUN_DEPENDS+= ${LOCALBASE}/lib/libjs.so:${PORTSDIR}/lang/spidermonkey
+LIB_DEPENDS+= js:${PORTSDIR}/lang/spidermonkey17
.else
CONFIGURE_ARGS+= --disable-libjs
.endif
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index d62648c771dd..e378353999eb 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openvrml
PORTVERSION= 0.18.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www graphics
MASTER_SITES= SF
@@ -16,7 +16,7 @@ COMMENT= VRML97 runtime and browser
BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
- js.1:${PORTSDIR}/lang/spidermonkey \
+ js.1:${PORTSDIR}/lang/spidermonkey17 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
curl.6:${PORTSDIR}/ftp/curl \