aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--dns/Makefile1
-rw-r--r--dns/fastresolve/Makefile15
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fastresolve/Makefile59
-rw-r--r--sysutils/fastresolve/distinfo2
-rw-r--r--sysutils/fastresolve/files/patch-configure.in138
-rw-r--r--sysutils/fastresolve/files/patch-dns-terror::DatedStringDb.cc14
-rw-r--r--sysutils/fastresolve/pkg-descr10
-rw-r--r--sysutils/fastresolve/pkg-plist22
10 files changed, 11 insertions, 252 deletions
diff --git a/MOVED b/MOVED
index 94bb030d97f2..69f1c8ff10eb 100644
--- a/MOVED
+++ b/MOVED
@@ -1220,3 +1220,4 @@ devel/autoconf|devel/autoconf253|2004-08-03|autotools cleanup
devel/automake|devel/automake15|2004-08-03|autotools cleanup
mail/balsa2|mail/balsa|2004-08-06|Balsa 2.x has been moved to the balsa port
net/pdtpd|net/squall|2004-08-08|The project has been renamed
+sysutils/fastresolve|dns/fastresolve|2004-08-08|Move to the right category
diff --git a/dns/Makefile b/dns/Makefile
index 67f5215f204a..3104c85d364e 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -29,6 +29,7 @@
SUBDIR += dnswalk
SUBDIR += domtools
SUBDIR += ez-ipupdate
+ SUBDIR += fastresolve
SUBDIR += firedns
SUBDIR += fpdns
SUBDIR += geta
diff --git a/dns/fastresolve/Makefile b/dns/fastresolve/Makefile
index a43fa467f7b6..e3eaa9f6967c 100644
--- a/dns/fastresolve/Makefile
+++ b/dns/fastresolve/Makefile
@@ -7,8 +7,8 @@
PORTNAME= fastresolve
PORTVERSION= 2.10
-PORTREVISION= 1
-CATEGORIES= sysutils
+PORTREVISION= 2
+CATEGORIES= dns
MASTER_SITES= http://www.djmnet.org/sw/dist/
MAINTAINER= martin@tradex.sk
@@ -31,15 +31,18 @@ WITH_BDB_VER?= 3
.if ${WITH_BDB_VER} == 3
LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
-CONFIGURE_ARGS= --with-bdb-lib=-ldb3_cxx --with-bdb-incdir=${LOCALBASE}/include/db3
+CONFIGURE_ARGS= --with-bdb-lib=-ldb3_cxx --with-bdb-incdir=${LOCALBASE}/include/db3
.elif ${WITH_BDB_VER} == 4
LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
-CONFIGURE_ARGS= --with-bdb-lib=-ldb4_cxx --with-bdb-incdir=${LOCALBASE}/include/db4
+CONFIGURE_ARGS= --with-bdb-lib=-ldb4_cxx --with-bdb-incdir=${LOCALBASE}/include/db4
.elif ${WITH_BDB_VER} == 41
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
-CONFIGURE_ARGS= --with-bdb-lib=-ldb41_cxx --with-bdb-incdir=${LOCALBASE}/include/db41
+CONFIGURE_ARGS= --with-bdb-lib=-ldb41_cxx --with-bdb-incdir=${LOCALBASE}/include/db41
+.elif ${WITH_BDB_VER} == 42
+LIB_DEPENDS+= db-4.2:${PORTSDIR}/databases/db42
+CONFIGURE_ARGS= --with-bdb-lib=-ldb_cxx-4.2 --with-bdb-incdir=${LOCALBASE}/include/db42
.else
-.error WITH_BDB_VER must be one between 3, 4 and 41
+.error WITH_BDB_VER must be one between 3, 4, 41 or 42
.endif
MAN1= dns-terror.1 btree-dump.1 convert-dom-db.1 convert-ip-db.1 \
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 15daec1b9c84..0aafcbd60d80 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -112,7 +112,6 @@
SUBDIR += etcmerge
SUBDIR += extipl
SUBDIR += fastest_cvsup
- SUBDIR += fastresolve
SUBDIR += fcron
SUBDIR += fetchlog
SUBDIR += ffsrecov
diff --git a/sysutils/fastresolve/Makefile b/sysutils/fastresolve/Makefile
deleted file mode 100644
index a43fa467f7b6..000000000000
--- a/sysutils/fastresolve/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-# New ports collection makefile for: fastresolve
-# Date created: 11 June 2002
-# Whom: verm@drunkmonk.net
-#
-# $FreeBSD$
-#
-
-PORTNAME= fastresolve
-PORTVERSION= 2.10
-PORTREVISION= 1
-CATEGORIES= sysutils
-MASTER_SITES= http://www.djmnet.org/sw/dist/
-
-MAINTAINER= martin@tradex.sk
-COMMENT= Programs that process web logs to get DNS and domain ownership info
-
-LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
-
-USE_BZIP2= yes
-USE_PERL5= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- CXXFLAGS="-I${LOCALBASE}/include" \
- PERL=${PERL}
-USE_AUTOMAKE_VER= 14
-USE_AUTOCONF_VER= 213
-
-# Default to db3
-WITH_BDB_VER?= 3
-
-.if ${WITH_BDB_VER} == 3
-LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
-CONFIGURE_ARGS= --with-bdb-lib=-ldb3_cxx --with-bdb-incdir=${LOCALBASE}/include/db3
-.elif ${WITH_BDB_VER} == 4
-LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
-CONFIGURE_ARGS= --with-bdb-lib=-ldb4_cxx --with-bdb-incdir=${LOCALBASE}/include/db4
-.elif ${WITH_BDB_VER} == 41
-LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
-CONFIGURE_ARGS= --with-bdb-lib=-ldb41_cxx --with-bdb-incdir=${LOCALBASE}/include/db41
-.else
-.error WITH_BDB_VER must be one between 3, 4 and 41
-.endif
-
-MAN1= dns-terror.1 btree-dump.1 convert-dom-db.1 convert-ip-db.1 \
- expire-ip-db.1 getdominfo.1 rebuild-dom-db.1 rebuild-ip-db.1 \
- reresolve.1 make-report.1
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for f in AUTHORS COPYING ChangeLog INSTALL NEWS README
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
- @${INSTALL_DATA} ${WRKSRC}/doc/TODO ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/timings ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>
diff --git a/sysutils/fastresolve/distinfo b/sysutils/fastresolve/distinfo
deleted file mode 100644
index 9d8eeb3e81b4..000000000000
--- a/sysutils/fastresolve/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (fastresolve-2.10.tar.bz2) = 56650c9bd027c4eb2f98a26e1f06c8d1
-SIZE (fastresolve-2.10.tar.bz2) = 66314
diff --git a/sysutils/fastresolve/files/patch-configure.in b/sysutils/fastresolve/files/patch-configure.in
deleted file mode 100644
index 31048a8cf5cb..000000000000
--- a/sysutils/fastresolve/files/patch-configure.in
+++ /dev/null
@@ -1,138 +0,0 @@
---- configure.in.orig Sat May 17 20:15:26 2003
-+++ configure.in Mon Sep 8 00:44:07 2003
-@@ -1,6 +1,5 @@
- AC_INIT
- AM_INIT_AUTOMAKE([fastresolve], [2.10])
--AC_ARG_PROGRAM
- AC_PATH_PROGS(PERL, [perl5 perl], [/usr/bin/perl])
- AC_PROG_CC
- AC_PROG_CXX
-@@ -26,6 +25,41 @@
- AC_DEFUN(DJM_LIB_DB_CXX,
- [dnl Check for a C++ interface, either version.
-
-+AC_ARG_WITH(bdb-lib,
-+ [ --with-bdb-lib=PATH Path to Berkeley DB C++ library],
-+ with_bdb_lib=$withval,
-+ [ test "${with_bdb_lib+set}" = set || with_bdb_lib=none])
-+AC_ARG_WITH(bdb-incdir,
-+ [ --with-bdb-incdir=DIR Berkeley DB C++ includes are in DIR],
-+ with_bdb_incdir=$withval,
-+ [ test "${with_bdb_incdir+set}" = set || with_bdb_incdir=none])
-+
-+if test $with_bdb_incdir != none; then
-+CXXFLAGS="$CXXFLAGS -I$with_bdb_incdir"
-+fi
-+
-+if test $with_bdb_lib != none; then
-+
-+dnl Berkeley DB from supplied path
-+AC_MSG_CHECKING([for Db::open in ${with_bdb_lib}])
-+AC_LANG_SAVE
-+AC_LANG_CPLUSPLUS
-+djm_save_LIBS="$LIBS"
-+LIBS="$LIBS $with_bdb_lib"
-+AC_TRY_LINK([#include <db_cxx.h>], [Db *d = new Db(NULL, 0);],
-+ djm_cv_lib_bdb_cxx_Db=yes, djm_cv_lib_bdb_cxx_Db=no)
-+LIBS="$djm_save_LIBS"
-+AC_LANG_RESTORE
-+AC_MSG_RESULT($djm_cv_lib_bdb_cxx_Db)
-+
-+if test $djm_cv_lib_bdb_cxx_Db = yes; then
-+ LIBS="$LIBS $with_bdb_lib"
-+else
-+ AC_MSG_ERROR([Berkeley DB library 2.x-4.x configured with --enable-cxx is required])
-+fi
-+
-+else
-+
- dnl Berkeley DB 2.x.
- AC_CACHE_CHECK([for Db::open in -ldb], djm_cv_lib_db_Dbopen,
- [AC_LANG_SAVE
-@@ -41,54 +75,69 @@
- LIBS="$LIBS -ldb"
- else
-
--dnl Berkeley DB 3.x installed as libdb.
--AC_CACHE_CHECK([for Db::open in -ldb_cxx], djm_cv_lib_db_cxx_Dbopen,
-+
-+dnl Berkeley DB 3.x or 4.x installed as libdb.
-+AC_CACHE_CHECK([for Db in -ldb_cxx], djm_cv_lib_db_cxx_Db,
- [AC_LANG_SAVE
- AC_LANG_CPLUSPLUS
- djm_save_LIBS="$LIBS"
- LIBS="$LIBS -ldb -ldb_cxx"
--AC_TRY_LINK([#include <db_cxx.h>], [Db *d = new Db(NULL, 0);
--d->open(NULL, NULL, DB_BTREE, DB_CREATE, 0);],
-- djm_cv_lib_db_cxx_Dbopen=yes, djm_cv_lib_db_cxx_Dbopen=no)
-+AC_TRY_LINK([#include <db_cxx.h>], [Db *d = new Db(NULL, 0);],
-+ djm_cv_lib_db_cxx_Db=yes, djm_cv_lib_db_cxx_Db=no)
- LIBS="$djm_save_LIBS"
- AC_LANG_RESTORE])
-
--if test $djm_cv_lib_db_cxx_Dbopen = yes; then
-+if test $djm_cv_lib_db_cxx_Db = yes; then
- LIBS="$LIBS -ldb -ldb_cxx"
- else
-
- dnl Berkeley DB 3.x installed as libdb3 (as on FreeBSD).
--AC_CACHE_CHECK([for Db::open in -ldb3_cxx], djm_cv_lib_db3_cxx_Dbopen,
-+AC_CACHE_CHECK([for Db in -ldb3_cxx], djm_cv_lib_db3_cxx_Db,
- [AC_LANG_SAVE
- AC_LANG_CPLUSPLUS
- djm_save_LIBS="$LIBS"
- LIBS="$LIBS -ldb3 -ldb3_cxx"
--AC_TRY_LINK([#include <db_cxx.h>], [Db *d = new Db(NULL, 0);
--d->open(NULL, NULL, DB_BTREE, DB_CREATE, 0);],
-- djm_cv_lib_db3_cxx_Dbopen=yes, djm_cv_lib_db3_cxx_Dbopen=no)
-+AC_TRY_LINK([#include <db_cxx.h>], [Db *d = new Db(NULL, 0);],
-+ djm_cv_lib_db3_cxx_Db=yes, djm_cv_lib_db3_cxx_Db=no)
- LIBS="$djm_save_LIBS"
- AC_LANG_RESTORE])
-
--if test $djm_cv_lib_db3_cxx_Dbopen = yes; then
-+if test $djm_cv_lib_db3_cxx_Db = yes; then
- LIBS="$LIBS -ldb3 -ldb3_cxx"
- else
-
--dnl Berkeley DB 4.x installed as libdb4 (as on FreeBSD).
--AC_CACHE_CHECK([for Db::open in -ldb4_cxx], djm_cv_lib_db4_cxx_Dbopen,
-+dnl Berkeley DB 4.0.x installed as libdb4 (as on FreeBSD).
-+AC_CACHE_CHECK([for Db in -ldb4_cxx], djm_cv_lib_db4_cxx_Db,
- [AC_LANG_SAVE
- AC_LANG_CPLUSPLUS
- djm_save_LIBS="$LIBS"
- LIBS="$LIBS -ldb4 -ldb4_cxx"
--AC_TRY_LINK([#include <db_cxx.h>], [Db *d = new Db(NULL, 0);
--d->open(NULL, NULL, DB_BTREE, DB_CREATE, 0);],
-- djm_cv_lib_db4_cxx_Dbopen=yes, djm_cv_lib_db4_cxx_Dbopen=no)
-+AC_TRY_LINK([#include <db_cxx.h>], [Db *d = new Db(NULL, 0);],
-+ djm_cv_lib_db4_cxx_Db=yes, djm_cv_lib_db4_cxx_Db=no)
- LIBS="$djm_save_LIBS"
- AC_LANG_RESTORE])
-
--if test $djm_cv_lib_db4_cxx_Dbopen = yes; then
-+if test $djm_cv_lib_db4_cxx_Db = yes; then
- LIBS="$LIBS -ldb4 -ldb4_cxx"
- else
-+
-+dnl Berkeley DB 4.1.x installed as libdb41 (as on FreeBSD).
-+AC_CACHE_CHECK([for Db in -ldb41_cxx], djm_cv_lib_db41_cxx_Db,
-+[AC_LANG_SAVE
-+AC_LANG_CPLUSPLUS
-+djm_save_LIBS="$LIBS"
-+LIBS="$LIBS -ldb41 -ldb41_cxx"
-+AC_TRY_LINK([#include <db_cxx.h>], [Db *d = new Db(NULL, 0);],
-+ djm_cv_lib_db41_cxx_Db=yes, djm_cv_lib_db41_cxx_Db=no)
-+LIBS="$djm_save_LIBS"
-+AC_LANG_RESTORE])
-+
-+if test $djm_cv_lib_db41_cxx_Db = yes; then
-+ LIBS="$LIBS -ldb41 -ldb41_cxx"
-+else
- AC_MSG_ERROR([Berkeley DB library 2.x-4.x configured with --enable-cxx is required])
-+fi
-+fi
- fi
- fi
- fi
diff --git a/sysutils/fastresolve/files/patch-dns-terror::DatedStringDb.cc b/sysutils/fastresolve/files/patch-dns-terror::DatedStringDb.cc
deleted file mode 100644
index 9c231327dee5..000000000000
--- a/sysutils/fastresolve/files/patch-dns-terror::DatedStringDb.cc
+++ /dev/null
@@ -1,14 +0,0 @@
---- dns-terror/DatedStringDb.cc.orig Sat Sep 6 18:38:24 2003
-+++ dns-terror/DatedStringDb.cc Sat Sep 6 18:38:31 2003
-@@ -69,7 +69,11 @@
- env->set_cachesize(0, MPOOL_SIZE, 0);
- env->open(dbhome, DB_CREATE|DB_INIT_MPOOL|DB_PRIVATE, 0644);
- db = new Db(env, 0);
-+#if DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1 || DB_VERSION_MAJOR > 4
-+ db->open(NULL, storename, NULL, DB_BTREE, DB_CREATE, 0644);
-+#else
- db->open(storename, NULL, DB_BTREE, DB_CREATE, 0644);
-+#endif
- #elif DB_VERSION_MAJOR == 2
- env = new DbEnv;
- env->set_error_stream(&cerr);
diff --git a/sysutils/fastresolve/pkg-descr b/sysutils/fastresolve/pkg-descr
deleted file mode 100644
index 40bd79a4eed4..000000000000
--- a/sysutils/fastresolve/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-Fastresolve is a package of programs to process web log files to get DNS
-and domain ownership information for log analysis. It sends out many
-queries in parallel, and caches results, for speed. Its DNS resolver is
-about 10 times as fast as logresolve.pl from the Apache 1.3.9
-distribution, and about 50 times as fast as logresolve.c from that
-distribution. It is 5-20 times as fast as the adnslogres program that
-comes with the adns library, and about 3 times as fast as jdresolve,
-which is a Perl program that uses similar algorithms.
-
-WWW: http://www.pix.net/staff/djm/sw/fastresolve/
diff --git a/sysutils/fastresolve/pkg-plist b/sysutils/fastresolve/pkg-plist
deleted file mode 100644
index 3bcb6f11a052..000000000000
--- a/sysutils/fastresolve/pkg-plist
+++ /dev/null
@@ -1,22 +0,0 @@
-bin/dns-terror
-bin/btree-dump
-bin/convert-dom-db
-bin/convert-ip-db
-bin/expire-ip-db
-bin/getdominfo
-bin/rebuild-dom-db
-bin/rebuild-ip-db
-bin/reresolve
-bin/make-report
-share/fastresolve/AddrCycle.pm
-share/fastresolve/analog.cfg
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/timings
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm share/fastresolve