aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-wrapt/Makefile17
-rw-r--r--devel/py-wrapt/distinfo2
-rw-r--r--devel/py-wrapt/pkg-descr5
4 files changed, 25 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a0ee074f5dd0..4577d31d6483 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4400,6 +4400,7 @@
SUBDIR += py-wcwidth
SUBDIR += py-weblib
SUBDIR += py-wheel
+ SUBDIR += py-wrapt
SUBDIR += py-wsgi_xmlrpc
SUBDIR += py-wsgitools
SUBDIR += py-wsgiutils
diff --git a/devel/py-wrapt/Makefile b/devel/py-wrapt/Makefile
new file mode 100644
index 000000000000..f42619db6ee0
--- /dev/null
+++ b/devel/py-wrapt/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= wrapt
+PORTVERSION= 1.10.6
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= mva@FreeBSD.org
+COMMENT= Decorators, wrappers and monkey patching
+
+LICENSE= BSD2CLAUSE
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-wrapt/distinfo b/devel/py-wrapt/distinfo
new file mode 100644
index 000000000000..30e1c60482f5
--- /dev/null
+++ b/devel/py-wrapt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wrapt-1.10.6.tar.gz) = 9576869bb74a43cbb36ee39dc3584e6830b8e5c788e83edf0a397eba807734ab
+SIZE (wrapt-1.10.6.tar.gz) = 25134
diff --git a/devel/py-wrapt/pkg-descr b/devel/py-wrapt/pkg-descr
new file mode 100644
index 000000000000..a173f46346ed
--- /dev/null
+++ b/devel/py-wrapt/pkg-descr
@@ -0,0 +1,5 @@
+The aim of the wrapt module is to provide a transparent object proxy for
+Python, which can be used as the basis for the construction of function
+wrappers and decorator functions.
+
+WWW: https://github.com/GrahamDumpleton/wrapt