aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/dkfilter/Makefile34
-rw-r--r--mail/dkfilter/distinfo2
-rw-r--r--mail/dkfilter/pkg-descr7
-rw-r--r--mail/dkfilter/pkg-plist20
5 files changed, 64 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index dfeb7aeb5b67..54eed6c7bdd6 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -58,6 +58,7 @@
SUBDIR += demime
SUBDIR += distribute
SUBDIR += dk-milter
+ SUBDIR += dkfilter
SUBDIR += dkimap4
SUBDIR += dovecot
SUBDIR += drac
diff --git a/mail/dkfilter/Makefile b/mail/dkfilter/Makefile
new file mode 100644
index 000000000000..bd9055a91dae
--- /dev/null
+++ b/mail/dkfilter/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: dkfilter
+# Date created: 3 Nov 2005
+# Whom: Yoshisato YANAGISAWA
+#
+# $FreeBSD$
+#
+
+PORTNAME= dkfilter
+PORTVERSION= 0.8
+CATEGORIES= mail
+MASTER_SITES= http://jason.long.name/dkfilter/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= yanagisawa@csg.is.titech.ac.jp
+COMMENT= Domainkeys filter for Postfix
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/RSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
+ ${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Perl 5.8 or newer required. Install lang/perl5.8 and try again.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/dkfilter/distinfo b/mail/dkfilter/distinfo
new file mode 100644
index 000000000000..a852a9b80334
--- /dev/null
+++ b/mail/dkfilter/distinfo
@@ -0,0 +1,2 @@
+MD5 (dkfilter.tgz) = ab0bab68dc09d3a86acccd1115b4c28a
+SIZE (dkfilter.tgz) = 76885
diff --git a/mail/dkfilter/pkg-descr b/mail/dkfilter/pkg-descr
new file mode 100644
index 000000000000..187dc4b64cc0
--- /dev/null
+++ b/mail/dkfilter/pkg-descr
@@ -0,0 +1,7 @@
+This is implementation of DomainKeys draft standard for the Postfix mail
+transfer agent. DomainKeys is proposed by Yahoo!, Inc. and this is a scheme
+to sign and verify e-mail messages on a per-domain basis.
+Protocol and other issues about this draft standard can be found at
+http://antispam.yahoo.com/domain/keys.
+
+WWW: http://jason.long.name/dkfilter/
diff --git a/mail/dkfilter/pkg-plist b/mail/dkfilter/pkg-plist
new file mode 100644
index 000000000000..74ecf8a8f424
--- /dev/null
+++ b/mail/dkfilter/pkg-plist
@@ -0,0 +1,20 @@
+lib/MSDW/SMTP/Client.pm
+lib/MSDW/SMTP/Server.pm
+lib/Mail/DomainKeys/Key/Private.pm
+lib/Mail/DomainKeys/Key/Public.pm
+lib/Mail/DomainKeys/Header.pm
+lib/Mail/DomainKeys/Key.pm
+lib/Mail/DomainKeys/Message.pm
+lib/Mail/DomainKeys/Policy.pm
+lib/Mail/DomainKeys/Signature.pm
+lib/Mail/DomainKeys.pm
+lib/DKMessage.pm
+bin/auto_responder.pl
+bin/dkverify.pl
+bin/dkfilter.in
+bin/dkfilter.out
+@dirrm lib/Mail/DomainKeys/Key
+@dirrm lib/Mail/DomainKeys
+@dirrm lib/Mail
+@dirrm lib/MSDW/SMTP
+@dirrm lib/MSDW