aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/qt23/Makefile14
-rw-r--r--x11-toolkits/qt30/Makefile14
-rw-r--r--x11-toolkits/qt31/Makefile14
-rw-r--r--x11-toolkits/qt32/Makefile14
-rw-r--r--x11-toolkits/qt33/Makefile14
5 files changed, 35 insertions, 35 deletions
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index ad0f26343d63..c42d48923dad 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -19,13 +19,6 @@ MAINTAINER?= kde@FreeBSD.org
LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
-BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
-.endif
-
-.if ${OSVERSION} >= 500029
-NO_QT_OBJPRELINK= yes
-.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
@@ -69,6 +62,13 @@ PLIST_SUB+= SHARED="" STATIC="@comment "
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500029
+NO_QT_OBJPRELINK= yes
+.endif
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
+BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
+.endif
+
.if ${MACHINE_ARCH} == "alpha" && !defined(NO_ALPHA_UNOPTIMIZATION)
CFLAGS+= -O0
.endif
diff --git a/x11-toolkits/qt30/Makefile b/x11-toolkits/qt30/Makefile
index ad0f26343d63..c42d48923dad 100644
--- a/x11-toolkits/qt30/Makefile
+++ b/x11-toolkits/qt30/Makefile
@@ -19,13 +19,6 @@ MAINTAINER?= kde@FreeBSD.org
LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
-BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
-.endif
-
-.if ${OSVERSION} >= 500029
-NO_QT_OBJPRELINK= yes
-.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
@@ -69,6 +62,13 @@ PLIST_SUB+= SHARED="" STATIC="@comment "
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500029
+NO_QT_OBJPRELINK= yes
+.endif
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
+BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
+.endif
+
.if ${MACHINE_ARCH} == "alpha" && !defined(NO_ALPHA_UNOPTIMIZATION)
CFLAGS+= -O0
.endif
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index ad0f26343d63..c42d48923dad 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -19,13 +19,6 @@ MAINTAINER?= kde@FreeBSD.org
LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
-BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
-.endif
-
-.if ${OSVERSION} >= 500029
-NO_QT_OBJPRELINK= yes
-.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
@@ -69,6 +62,13 @@ PLIST_SUB+= SHARED="" STATIC="@comment "
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500029
+NO_QT_OBJPRELINK= yes
+.endif
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
+BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
+.endif
+
.if ${MACHINE_ARCH} == "alpha" && !defined(NO_ALPHA_UNOPTIMIZATION)
CFLAGS+= -O0
.endif
diff --git a/x11-toolkits/qt32/Makefile b/x11-toolkits/qt32/Makefile
index ad0f26343d63..c42d48923dad 100644
--- a/x11-toolkits/qt32/Makefile
+++ b/x11-toolkits/qt32/Makefile
@@ -19,13 +19,6 @@ MAINTAINER?= kde@FreeBSD.org
LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
-BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
-.endif
-
-.if ${OSVERSION} >= 500029
-NO_QT_OBJPRELINK= yes
-.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
@@ -69,6 +62,13 @@ PLIST_SUB+= SHARED="" STATIC="@comment "
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500029
+NO_QT_OBJPRELINK= yes
+.endif
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
+BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
+.endif
+
.if ${MACHINE_ARCH} == "alpha" && !defined(NO_ALPHA_UNOPTIMIZATION)
CFLAGS+= -O0
.endif
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index ad0f26343d63..c42d48923dad 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -19,13 +19,6 @@ MAINTAINER?= kde@FreeBSD.org
LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
-BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
-.endif
-
-.if ${OSVERSION} >= 500029
-NO_QT_OBJPRELINK= yes
-.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
@@ -69,6 +62,13 @@ PLIST_SUB+= SHARED="" STATIC="@comment "
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500029
+NO_QT_OBJPRELINK= yes
+.endif
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_QT_OBJPRELINK)
+BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
+.endif
+
.if ${MACHINE_ARCH} == "alpha" && !defined(NO_ALPHA_UNOPTIMIZATION)
CFLAGS+= -O0
.endif