aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile26
-rw-r--r--Mk/bsd.drupal.mk2
-rw-r--r--Mk/bsd.fpc.mk2
-rw-r--r--Mk/bsd.java.mk2
-rw-r--r--Mk/bsd.perl.mk2
-rw-r--r--Mk/bsd.php.mk2
6 files changed, 9 insertions, 27 deletions
diff --git a/Makefile b/Makefile
index 2dc83dbe9264..e96ccfb52f87 100644
--- a/Makefile
+++ b/Makefile
@@ -122,13 +122,12 @@ ${INDEXDIR}/${INDEXFILE}:
echo "Before reporting this error, verify that you are running a supported"; \
echo "version of FreeBSD (see http://www.FreeBSD.org/ports/) and that you"; \
echo "have a complete and up-to-date ports collection. (INDEX builds are"; \
- echo "not supported with partial or out-of-date ports collections -- in"; \
- echo "particular, if you are using cvsup, you must cvsup the \"ports-all\""; \
- echo "collection, and have no \"refuse\" files.) If that is the case, then"; \
+ echo "not supported with partial or out-of-date ports collections."; \
+ echo "If that is the case, then"; \
echo "report the failure to ports@FreeBSD.org together with relevant"; \
echo "details of your ports configuration (including FreeBSD version,"; \
echo "your architecture, your environment, and your /etc/make.conf"; \
- echo "settings, especially compiler flags and WITH/WITHOUT settings)."; \
+ echo "settings, especially compiler flags and OPTIONS_SET/UNSET settings)."; \
echo; \
echo "Note: the latest pre-generated version of INDEX may be fetched"; \
echo "automatically with \"make fetchindex\"."; \
@@ -151,28 +150,13 @@ ${INDEXDIR}/${INDEXFILE}:
print-index: ${INDEXDIR}/${INDEXFILE}
@awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\nE-deps:\t%s\nP-deps:\t%s\nF-deps:\t%s\nWWW:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9, $$11, $$12, $$13, $$10); }' < ${INDEXDIR}/${INDEXFILE}
-CVS?= cvs
GIT?= git
SVN?= svn
-SUP?= csup
PORTSNAP?= portsnap
PORTSNAP_FLAGS?= -p ${.CURDIR}
-.if defined(SUPHOST)
-SUPFLAGS+= -h ${SUPHOST}
-.endif
.if !target(update)
update:
-.if defined(SUP_UPDATE) && defined(PORTSSUPFILE)
- @echo "--------------------------------------------------------------"
- @echo ">>> Running ${SUP}"
- @echo "--------------------------------------------------------------"
- @${SUP} ${SUPFLAGS} ${PORTSSUPFILE}
-.elif defined(CVS_UPDATE)
- @echo "--------------------------------------------------------------"
- @echo ">>> Updating ${.CURDIR} from CVS repository" ${CVSROOT}
- @echo "--------------------------------------------------------------"
- cd ${.CURDIR}; ${CVS} -R -q update -A -P -d -I!
-.elif exists(${.CURDIR}/.svn)
+.if exists(${.CURDIR}/.svn)
@echo "--------------------------------------------------------------"
@echo ">>> Updating ${.CURDIR} using Subversion"
@echo "--------------------------------------------------------------"
@@ -190,8 +174,6 @@ update:
@echo "Error: 'make update' uses portsnap(8) by default and"
@echo "needs ${PORTSDIR} to be created by portsnap on its first run."
@echo "Please run 'portsnap fetch extract' first."
- @echo "You can also define SUP_UPDATE and PORTSSUPFILE to use csup(1)"
- @echo "or CVS_UPDATE to use cvs(1) for updating."
.else
@${PORTSNAP} ${PORTSNAP_FLAGS} fetch
@${PORTSNAP} ${PORTSNAP_FLAGS} update
diff --git a/Mk/bsd.drupal.mk b/Mk/bsd.drupal.mk
index b1e60abf6929..c0caf9f7f4ec 100644
--- a/Mk/bsd.drupal.mk
+++ b/Mk/bsd.drupal.mk
@@ -7,7 +7,7 @@
#
# For FreeBSD committers:
# Please send all suggested changes to the maintainer instead of committing
-# them to CVS yourself.
+# them to SVN yourself.
bsd_drupal_mk_MAINTAINER= miwi@FreeBSD.org
diff --git a/Mk/bsd.fpc.mk b/Mk/bsd.fpc.mk
index b18e1651fffd..8cdb194df7e1 100644
--- a/Mk/bsd.fpc.mk
+++ b/Mk/bsd.fpc.mk
@@ -7,7 +7,7 @@
#
# For FreeBSD committers:
# Please send all suggested changes to the maintainer instead of committing
-# them to CVS yourself.
+# them to SVN yourself.
#
# USE_FPC - If you set this to "yes", this automatically will install
# free pascal compiler, if you need install additional fpc
diff --git a/Mk/bsd.java.mk b/Mk/bsd.java.mk
index e196c5062974..98df7cdc773c 100644
--- a/Mk/bsd.java.mk
+++ b/Mk/bsd.java.mk
@@ -7,7 +7,7 @@
#
# For FreeBSD committers:
# Please send all suggested changes to the maintainer instead of committing
-# them to CVS yourself.
+# them to svn yourself.
#
# $FreeBSD$
#
diff --git a/Mk/bsd.perl.mk b/Mk/bsd.perl.mk
index 9c3ad04803d7..bab736fc1357 100644
--- a/Mk/bsd.perl.mk
+++ b/Mk/bsd.perl.mk
@@ -9,7 +9,7 @@
#
# For FreeBSD committers:
# Please send all suggested changes to the maintainer instead of committing
-# them to CVS yourself.
+# them to SVN yourself.
#
# PERL5 - Set to full path of perl5, either in the system or
# installed from a port.
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index 7227db6c4baa..fc56542bec93 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -5,7 +5,7 @@
#
# For FreeBSD committers:
# Please send all suggested changes to the maintainer instead of committing
-# them to CVS yourself.
+# them to SVN yourself.
#
# $FreeBSD$
#