aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/renamedlgplugins/Makefile35
-rw-r--r--misc/renamedlgplugins/distinfo2
-rw-r--r--misc/renamedlgplugins/pkg-descr3
-rw-r--r--misc/renamedlgplugins/pkg-plist7
5 files changed, 48 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 3a6d42234169..297566f55147 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -325,6 +325,7 @@
SUBDIR += quotes
SUBDIR += quranref
SUBDIR += reed
+ SUBDIR += renamedlgplugins
SUBDIR += rfc
SUBDIR += ringtonetools
SUBDIR += rname
diff --git a/misc/renamedlgplugins/Makefile b/misc/renamedlgplugins/Makefile
new file mode 100644
index 000000000000..fe427110e2eb
--- /dev/null
+++ b/misc/renamedlgplugins/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: renamedlgplugins
+# Date created: 11 Febrary 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${RENAMEDLGPLUG_PORTNAME}
+PORTVERSION= ${RENAMEDLGPLUG_PORTVERSION}
+PORTREVISION= ${RENAMEDLGPLUG_PORTREVISION}
+CATEGORIES= misc kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= "Plugins for Konqueror's rename dialog"
+
+IGNORE= This port is part of KDE 3.2.1 and is not yet ready
+
+KDE_SPLIT= renamedlgplugins
+KDE_DOC_SPLIT= # none
+USE_KDELIBS_VER=3
+
+USE_BZIP2= yes
+PREFIX= ${KDE_PREFIX}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib/kde3
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include "${.CURDIR}/../../misc/kdeaddons3/Makefile.split"
+.include <bsd.port.mk>
diff --git a/misc/renamedlgplugins/distinfo b/misc/renamedlgplugins/distinfo
new file mode 100644
index 000000000000..95aca618ce40
--- /dev/null
+++ b/misc/renamedlgplugins/distinfo
@@ -0,0 +1,2 @@
+MD5 (KDE/kdeaddons-3.2.1.tar.bz2) = c73c1777d3f5c25f46cd782fcca9fc35
+SIZE (KDE/kdeaddons-3.2.1.tar.bz2) = 1371322
diff --git a/misc/renamedlgplugins/pkg-descr b/misc/renamedlgplugins/pkg-descr
new file mode 100644
index 000000000000..3410012cc335
--- /dev/null
+++ b/misc/renamedlgplugins/pkg-descr
@@ -0,0 +1,3 @@
+Plugins for Konqueror's rename dialog.
+
+WWW: http://www.kde.org
diff --git a/misc/renamedlgplugins/pkg-plist b/misc/renamedlgplugins/pkg-plist
new file mode 100644
index 000000000000..b240a6f0cbe8
--- /dev/null
+++ b/misc/renamedlgplugins/pkg-plist
@@ -0,0 +1,7 @@
+lib/kde3/librenaudioplugin.la
+lib/kde3/librenaudioplugin.so
+lib/kde3/librenimageplugin.la
+lib/kde3/librenimageplugin.so
+share/applications/kdeaddons-renamedlg-plugins-3.2.1
+share/services/renaudiodlg.desktop
+share/services/renimagedlg.desktop