aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/pamtester/Makefile25
-rw-r--r--security/pamtester/distinfo2
-rw-r--r--security/pamtester/files/patch-src_app.c12
-rw-r--r--security/pamtester/pkg-descr11
5 files changed, 51 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 991aa02aa092..d6bb69b428a5 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -344,6 +344,7 @@
SUBDIR += pam_pop3
SUBDIR += pam_pwdfile
SUBDIR += pam_smb
+ SUBDIR += pamtester
SUBDIR += pear-Auth
SUBDIR += pear-Auth_HTTP
SUBDIR += pear-Auth_PrefManager
diff --git a/security/pamtester/Makefile b/security/pamtester/Makefile
new file mode 100644
index 000000000000..f794bf441105
--- /dev/null
+++ b/security/pamtester/Makefile
@@ -0,0 +1,25 @@
+# Ports collection Makefile for: pamtester
+# Date created: 24/05/2005
+# Whom: andy@fud.org.nz
+#
+# $FreeBSD$
+#
+
+PORTNAME= pamtester
+PORTVERSION= 0.1.0
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= andy@fud.org.nz
+COMMENT= A command line pam authentication tester
+
+MAN1= pamtester.1
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_GMAKE= yes
+
+PLIST_FILES= bin/pamtester
+
+.include <bsd.port.mk>
diff --git a/security/pamtester/distinfo b/security/pamtester/distinfo
new file mode 100644
index 000000000000..7d5a7015b177
--- /dev/null
+++ b/security/pamtester/distinfo
@@ -0,0 +1,2 @@
+MD5 (pamtester-0.1.0.tar.gz) = 7f94faa913a0da5a179f3f1fa11e5acf
+SIZE (pamtester-0.1.0.tar.gz) = 280052
diff --git a/security/pamtester/files/patch-src_app.c b/security/pamtester/files/patch-src_app.c
new file mode 100644
index 000000000000..54f36999ebfb
--- /dev/null
+++ b/security/pamtester/files/patch-src_app.c
@@ -0,0 +1,12 @@
+--- src/app.c.orig Tue May 24 20:19:17 2005
++++ src/app.c Tue May 24 20:20:30 2005
+@@ -60,6 +60,9 @@
+
+ #ifdef HAVE_SECURITY_PAM_MISC_H
+ #include <security/pam_misc.h>
++#else
++#include <security/openpam.h>
++#define misc_conv openpam_ttyconv
+ #endif
+
+ #ifdef HAVE_PAM_PAM_MISC_H
diff --git a/security/pamtester/pkg-descr b/security/pamtester/pkg-descr
new file mode 100644
index 000000000000..30f279274a14
--- /dev/null
+++ b/security/pamtester/pkg-descr
@@ -0,0 +1,11 @@
+pamtester is a tiny utility program to test the pluggable authentication
+modules (PAM) facility, which is a de facto standard of unified authentication
+management mechanism in many unices and similar OSes including Solaris, HP-UX,
+*BSD, MacOSX and Linux.
+
+While specifically designed to help PAM module authors to test their modules,
+that might also be handy for system administrators interested in building a
+centralised authentication system using common standards such as NIS, SASL and
+LDAP.
+
+WWW: http://pamtester.sourceforge.net/