aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Cache-Mmap/Makefile25
-rw-r--r--devel/p5-Cache-Mmap/distinfo1
-rw-r--r--devel/p5-Cache-Mmap/pkg-comment1
-rw-r--r--devel/p5-Cache-Mmap/pkg-descr7
-rw-r--r--devel/p5-Cache-Mmap/pkg-plist7
6 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6a0ecd261eee..3e1bf374b93b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -433,6 +433,7 @@
SUBDIR += p5-BSD-stat
SUBDIR += p5-C-Scan
SUBDIR += p5-Cache-Cache
+ SUBDIR += p5-Cache-Mmap
SUBDIR += p5-Carp-Assert
SUBDIR += p5-Carp-Datum
SUBDIR += p5-Cdk
diff --git a/devel/p5-Cache-Mmap/Makefile b/devel/p5-Cache-Mmap/Makefile
new file mode 100644
index 000000000000..ee5fe4616bf3
--- /dev/null
+++ b/devel/p5-Cache-Mmap/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Cache-Mmap
+# Date created: January 25th 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cache-Mmap
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Cache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Cache::Mmap.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Cache-Mmap/distinfo b/devel/p5-Cache-Mmap/distinfo
new file mode 100644
index 000000000000..ac8689159cfd
--- /dev/null
+++ b/devel/p5-Cache-Mmap/distinfo
@@ -0,0 +1 @@
+MD5 (Cache-Mmap-0.05.tar.gz) = 9b402dd02f6a15e4b98a23a344cd15a1
diff --git a/devel/p5-Cache-Mmap/pkg-comment b/devel/p5-Cache-Mmap/pkg-comment
new file mode 100644
index 000000000000..54620cced8d0
--- /dev/null
+++ b/devel/p5-Cache-Mmap/pkg-comment
@@ -0,0 +1 @@
+Cache::Mmap - Shared data cache using memory mapped files
diff --git a/devel/p5-Cache-Mmap/pkg-descr b/devel/p5-Cache-Mmap/pkg-descr
new file mode 100644
index 000000000000..b45594838509
--- /dev/null
+++ b/devel/p5-Cache-Mmap/pkg-descr
@@ -0,0 +1,7 @@
+This module provides a shared cache, using a memory mapped file. Very useful
+for mod_perl applications. If routines are provided which interact with the
+underlying data, access to the cache is completely transparent, and the module
+handles all the details of refreshing cache contents, and updating underlying
+data, if necessary.
+
+WWW: http://search.cpan.org/dist/Cache-Mmap/
diff --git a/devel/p5-Cache-Mmap/pkg-plist b/devel/p5-Cache-Mmap/pkg-plist
new file mode 100644
index 000000000000..d2d07423be3c
--- /dev/null
+++ b/devel/p5-Cache-Mmap/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Cache/Mmap/Mmap.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Cache/Mmap/Mmap.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Cache/Mmap/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cache/Mmap.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Cache/Mmap
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Cache 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cache 2>/dev/null || true