aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/freetds/Makefile8
-rw-r--r--databases/postgresql10-server/Makefile4
-rw-r--r--ftp/lftp/Makefile4
-rw-r--r--ftp/proftpd/Makefile4
-rw-r--r--ftp/wget/Makefile8
-rw-r--r--lang/erlang-runtime20/Makefile8
-rw-r--r--multimedia/librtmp/Makefile8
-rw-r--r--net/libvncserver/Makefile8
-rw-r--r--net/socat/Makefile3
-rw-r--r--security/libssh2/Makefile4
-rw-r--r--sysutils/bacula9-server/Makefile4
-rw-r--r--www/lynx/Makefile8
-rw-r--r--www/nginx/Makefile2
13 files changed, 6 insertions, 67 deletions
diff --git a/databases/freetds/Makefile b/databases/freetds/Makefile
index 531a83eeb5aa..3dff79443e9a 100644
--- a/databases/freetds/Makefile
+++ b/databases/freetds/Makefile
@@ -71,10 +71,4 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/interfaces ${STAGEDIR}${ETCDIR}/interfaces.sample
-.include <bsd.port.pre.mk>
-
-.if ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/postgresql10-server/Makefile b/databases/postgresql10-server/Makefile
index 69be2cc62f60..2f0d2b79f882 100644
--- a/databases/postgresql10-server/Makefile
+++ b/databases/postgresql10-server/Makefile
@@ -219,10 +219,6 @@ CONFIGURE_ARGS+=--with-krb5
# For testing files in FILESDIR
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MSSL} && ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
.if defined(SERVER_ONLY)
pre-build:
@${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index 69cc920104e9..14f3b0d43080 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -60,8 +60,4 @@ post-install-DOCS-on:
USE_GCC= yes
.endif
-.if ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
.include <bsd.port.post.mk>
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 90ff5a675d0d..f85335b252ae 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -176,10 +176,6 @@ CONFIGURE_ARGS+= --with-libraries=${LIBDIRS}
.include <bsd.port.pre.mk>
-.if ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
.if !defined(_BUILDING_PROFTPD_MODULE)
.if empty(ICONV_PREFIX)
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index a877b8f93f75..1453f708c96e 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -97,10 +97,4 @@ post-patch-DOCS-off:
-e '/^install-data-am:/ s, install-info-am,,' \
${WRKSRC}/doc/Makefile.in
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MOPENSSL} && ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/erlang-runtime20/Makefile b/lang/erlang-runtime20/Makefile
index 557fc9ce68bd..29890d655e1d 100644
--- a/lang/erlang-runtime20/Makefile
+++ b/lang/erlang-runtime20/Makefile
@@ -249,10 +249,4 @@ post-install:
| ${SORT} \
>> ${TMPPLIST}
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MOPENSSL} && ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/librtmp/Makefile b/multimedia/librtmp/Makefile
index 39ac0aef78d8..dea0e49fd9b9 100644
--- a/multimedia/librtmp/Makefile
+++ b/multimedia/librtmp/Makefile
@@ -17,10 +17,4 @@ CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
WRKSRC= ${WRKDIR}/${DISTNAME}/librtmp
-.include <bsd.port.pre.mk>
-
-.if ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/libvncserver/Makefile b/net/libvncserver/Makefile
index af4591406219..9585f2ce4c84 100644
--- a/net/libvncserver/Makefile
+++ b/net/libvncserver/Makefile
@@ -49,10 +49,4 @@ VAAPI_CONFIGURE_WITH= libva
post-install:
${INSTALL_DATA} ${WRKSRC}/rfb/default8x16.h ${STAGEDIR}${PREFIX}/include/rfb
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MOPENSSL} && ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/socat/Makefile b/net/socat/Makefile
index fd8ba957fd27..262f1bd0614d 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -33,9 +33,6 @@ READLINE_USES= readline
.include <bsd.port.pre.mk>
.if ${SSL_DEFAULT} != base
-.if ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.endif
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index d6ed61a4e4fb..4280651c7218 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -35,10 +35,6 @@ ZLIB_CONFIGURE_WITH= libz
.include <bsd.port.pre.mk>
-.if empty(PORT_OPTIONS:MGCRYPT) && ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/Libs:/s/@LIBS@//' \
${WRKSRC}/libssh2.pc.in
diff --git a/sysutils/bacula9-server/Makefile b/sysutils/bacula9-server/Makefile
index 499a58f49366..5f71b3d0227e 100644
--- a/sysutils/bacula9-server/Makefile
+++ b/sysutils/bacula9-server/Makefile
@@ -129,10 +129,6 @@ MTX_RUN_DEPENDS= ${LOCALBASE}/sbin/mtx:misc/mtx
.include <bsd.port.pre.mk>
-.if ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
.if ${readline_ARGS} == "port"
readline_CONFIGURE= ${LOCALBASE}
.else
diff --git a/www/lynx/Makefile b/www/lynx/Makefile
index ebe69b13cedf..e9f5a8f1bf0b 100644
--- a/www/lynx/Makefile
+++ b/www/lynx/Makefile
@@ -64,10 +64,4 @@ post-install-DOCS-on:
(cd ${STAGEDIR}${L_HELP} && ${LN} -sf ../doc/lynx/${doc} .)
.endfor
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MSSL} && ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 8849416b82cc..18dd4ddf2598 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -1172,8 +1172,6 @@ GROUPS?=${WWWGRP}
.if defined(NGINX_OPENSSL)
USES+= ssl
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= undefined reference to SSLeay_version
.endif
pre-everything::