aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-Math_Fraction/Makefile26
-rw-r--r--devel/pear-Math_Fraction/distinfo3
-rw-r--r--devel/pear-Math_Fraction/pkg-descr11
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d55bbd0325a8..554bd6e91e5a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1713,6 +1713,7 @@
SUBDIR += pear-HTML_Template_Sigma
SUBDIR += pear-HTML_TreeMenu
SUBDIR += pear-I18N
+ SUBDIR += pear-Math_Fraction
SUBDIR += pear-OLE
SUBDIR += pear-PEAR_Info
SUBDIR += pear-PEAR_PackageFileManager
diff --git a/devel/pear-Math_Fraction/Makefile b/devel/pear-Math_Fraction/Makefile
new file mode 100644
index 000000000000..05671e408763
--- /dev/null
+++ b/devel/pear-Math_Fraction/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-Math_Fraction
+# Date created: 05 August 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math_Fraction
+PORTVERSION= 0.4.1
+CATEGORIES= devel www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Classes that represent and manipulate fractions.
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= Math
+FILES= Fraction.php FractionOp.php
+
+EXAMPLES= using_fractionop.php
+_EXAMPLESDIR= docs/examples
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Math_Fraction/distinfo b/devel/pear-Math_Fraction/distinfo
new file mode 100644
index 000000000000..ad8334b049d0
--- /dev/null
+++ b/devel/pear-Math_Fraction/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Math_Fraction-0.4.1.tgz) = 351f230b32ec265cb48ff08165bf9652
+SHA256 (PEAR/Math_Fraction-0.4.1.tgz) = 00109cc650596dae902a62cc5d018e1ddb4b6458d803a4271308566dff87d855
+SIZE (PEAR/Math_Fraction-0.4.1.tgz) = 4171
diff --git a/devel/pear-Math_Fraction/pkg-descr b/devel/pear-Math_Fraction/pkg-descr
new file mode 100644
index 000000000000..017511abc032
--- /dev/null
+++ b/devel/pear-Math_Fraction/pkg-descr
@@ -0,0 +1,11 @@
+Classes that represent and manipulate fractions (x = a/b).
+
+The Math_FractionOp static class contains definitions for:
+- basic arithmetic operations
+- comparing fractions
+- greatest common divisor (gcd) and least common multiple (lcm)
+ of two integers
+- simplifying (reducing) and getting the reciprocal of a fraction
+- converting a float to fraction.
+
+WWW: http://pear.php.net/package/Math_Fraction/