aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/gnustep-gui/Makefile3
-rw-r--r--x11-toolkits/gnustep-gui/pkg-plist1
2 files changed, 3 insertions, 1 deletions
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index 204b4ecc59e4..8912a97a6336 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -38,7 +38,8 @@ GNU_ARCH= ix86
.else
GNU_ARCH= ${MACHINE_ARCH}
.endif
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION}
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION} \
+ MAJORVERSION=${PORTVERSION:C/([0-9]).*/\1/1}
SYSLIBDIR= ${PREFIX}/System/Libraries
diff --git a/x11-toolkits/gnustep-gui/pkg-plist b/x11-toolkits/gnustep-gui/pkg-plist
index c13dcab118bc..7258dec900ea 100644
--- a/x11-toolkits/gnustep-gui/pkg-plist
+++ b/x11-toolkits/gnustep-gui/pkg-plist
@@ -507,6 +507,7 @@ System/Libraries/Resources/PrinterTypes/Printers
System/Libraries/Resources/PrinterTypes/Spanish.lproj/Linotronic_300.ppd
System/Libraries/Resources/PrinterTypes/Swedish.lproj/Linotronic_300.ppd
System/Libraries/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libgmodel.so.%%VERSION%%
+System/Libraries/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libgnustep-gui.so.%%MAJORVERSION%%
System/Libraries/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libgnustep-gui.so.%%VERSION%%
System/Library/Model/ColorPanel.gmodel
System/Library/Model/SavePanel.gmodel