aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/p4/Makefile8
-rw-r--r--devel/p4d/Makefile8
-rw-r--r--devel/p4ftpd/Makefile8
-rw-r--r--devel/p4p/Makefile8
-rw-r--r--devel/p4web/Makefile8
-rw-r--r--devel/perforce/Makefile8
6 files changed, 36 insertions, 12 deletions
diff --git a/devel/p4/Makefile b/devel/p4/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4/Makefile
+++ b/devel/p4/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
diff --git a/devel/p4d/Makefile b/devel/p4d/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4d/Makefile
+++ b/devel/p4d/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
diff --git a/devel/p4ftpd/Makefile b/devel/p4ftpd/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4ftpd/Makefile
+++ b/devel/p4ftpd/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
diff --git a/devel/p4p/Makefile b/devel/p4p/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4p/Makefile
+++ b/devel/p4p/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
diff --git a/devel/p4web/Makefile b/devel/p4web/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4web/Makefile
+++ b/devel/p4web/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
diff --git a/devel/perforce/Makefile b/devel/perforce/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/perforce/Makefile
+++ b/devel/perforce/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif