aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/tor-devel/Makefile6
-rw-r--r--security/tor-devel/distinfo4
-rw-r--r--security/tor-devel/files/pkg-message.in2
-rw-r--r--security/tor/Makefile30
-rw-r--r--security/tor/distinfo4
-rw-r--r--security/tor/files/pkg-message.in2
-rw-r--r--security/tor/files/tor.in2
-rw-r--r--security/tor/pkg-plist2
8 files changed, 18 insertions, 34 deletions
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index d71a3a4a3c75..6b2b437e8949 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tor
-DISTVERSION= 0.2.6.3-alpha
+DISTVERSION= 0.2.6.6
CATEGORIES= security net ipv6
MASTER_SITES= TOR
PKGNAMESUFFIX= -devel
@@ -15,8 +15,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cpe gmake
CPE_VENDOR= torproject
-CPE_VERSION= ${DISTVERSION:C/-.*//}
-CPE_UPDATE= ${DISTVERSION:C/.*-//}
+#CPE_VERSION= ${DISTVERSION:C/-.*//}
+#CPE_UPDATE= ${DISTVERSION:C/.*-//}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl-dir="${OPENSSLBASE}" --disable-asciidoc
CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include" \
diff --git a/security/tor-devel/distinfo b/security/tor-devel/distinfo
index 4113b2f1c0b9..73a822e35a72 100644
--- a/security/tor-devel/distinfo
+++ b/security/tor-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tor-0.2.6.3-alpha.tar.gz) = 5e31a0ccbb1fbe9ac6fc64d157c5c3db9b478908ea09bbe15adea2f1fd11d670
-SIZE (tor-0.2.6.3-alpha.tar.gz) = 3526195
+SHA256 (tor-0.2.6.6.tar.gz) = c3349e457c71b8e5c138c656927b2bbca0bfa03539ffee8579b0e568ffb10283
+SIZE (tor-0.2.6.6.tar.gz) = 3594452
diff --git a/security/tor-devel/files/pkg-message.in b/security/tor-devel/files/pkg-message.in
index e15abac87d5e..cf0accc2329e 100644
--- a/security/tor-devel/files/pkg-message.in
+++ b/security/tor-devel/files/pkg-message.in
@@ -16,4 +16,6 @@ before starting the tor server. Tor users are strongly advised to prevent traffi
analysis that exploits sequential IP IDs by setting:
sysctl net.inet.ip.random_id=1
+
+(see sysctl.conf(5)).
================================================================================
diff --git a/security/tor/Makefile b/security/tor/Makefile
index 2e6d4d736b6c..1db266fe2eed 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tor
-DISTVERSION= 0.2.5.10
-PORTREVISION= 1
+DISTVERSION= 0.2.6.6
CATEGORIES= security net ipv6
MASTER_SITES= TOR
@@ -13,20 +12,19 @@ COMMENT= Anonymizing overlay network for TCP
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake
+USES= cpe gmake
+CPE_VENDOR= torproject
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl-dir="${OPENSSLBASE}" --disable-asciidoc
CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include" \
TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/" \
TOR_LIBEVENT_LIBS="${TOR_LIBEVENT_LIBS}"
-OPTIONS_DEFINE= BUFFEREVENTS BUFFREELISTS INSTR_DOWNLOADS MEMPOOLS \
- STATIC_TOR TCMALLOC THREADS TOR2WEB TRANSPARENT
+OPTIONS_DEFINE= BUFFEREVENTS INSTR_DOWNLOADS \
+ STATIC_TOR TCMALLOC TOR2WEB TRANSPARENT
BUFFEREVENTS_DESC= Use libevent's buffered IO
-BUFFREELISTS_DESC= Freelists for buffer RAM
INSTR_DOWNLOADS_DESC= Instrument downloads for analysis
-MEMPOOLS_DESC= Mempools for relay cells
STATIC_TOR_DESC= Build a static tor
TCMALLOC_DESC= Use the tcmalloc memory allocation library
TOR2WEB_DESC= Faster but non-anonymous hidden services
@@ -60,24 +58,12 @@ CONFIGURE_ARGS+= --enable-bufferevents
CONFIGURE_ARGS+= --disable-bufferevents
.endif
-.if ${PORT_OPTIONS:MBUFFREELISTS}
-CONFIGURE_ARGS+= --enable-buf-freelists
-.else
-CONFIGURE_ARGS+= --disable-buf-freelists
-.endif
-
.if ${PORT_OPTIONS:MINSTR_DOWNLOADS}
CONFIGURE_ARGS+= --enable-instrument-downloads
.else
CONFIGURE_ARGS+= --disable-instrument-downloads
.endif
-.if ${PORT_OPTIONS:MMEMPOOLS}
-CONFIGURE_ARGS+= --enable-mempools
-.else
-CONFIGURE_ARGS+= --disable-mempools
-.endif
-
.if ${PORT_OPTIONS:MSTATIC_TOR}
BUILD_DEPENDS += ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent2
CONFIGURE_ARGS+= --enable-static-tor \
@@ -104,12 +90,6 @@ LIB_DEPENDS+= libtcmalloc.so:${PORTSDIR}/devel/google-perftools
.endif
.endif
-.if ${PORT_OPTIONS:MTHREADS}
-CONFIGURE_ARGS+= --enable-threads
-.else
-CONFIGURE_ARGS+= --disable-threads
-.endif
-
.if ${PORT_OPTIONS:MTOR2WEB}
CONFIGURE_ARGS+= --enable-tor2web-mode
.endif
diff --git a/security/tor/distinfo b/security/tor/distinfo
index 361f09e3b09f..73a822e35a72 100644
--- a/security/tor/distinfo
+++ b/security/tor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tor-0.2.5.10.tar.gz) = b3dd02a5dcd2ffe14d9a37956f92779d4427edf7905c0bba9b1e3901b9c5a83b
-SIZE (tor-0.2.5.10.tar.gz) = 3166480
+SHA256 (tor-0.2.6.6.tar.gz) = c3349e457c71b8e5c138c656927b2bbca0bfa03539ffee8579b0e568ffb10283
+SIZE (tor-0.2.6.6.tar.gz) = 3594452
diff --git a/security/tor/files/pkg-message.in b/security/tor/files/pkg-message.in
index e15abac87d5e..cf0accc2329e 100644
--- a/security/tor/files/pkg-message.in
+++ b/security/tor/files/pkg-message.in
@@ -16,4 +16,6 @@ before starting the tor server. Tor users are strongly advised to prevent traffi
analysis that exploits sequential IP IDs by setting:
sysctl net.inet.ip.random_id=1
+
+(see sysctl.conf(5)).
================================================================================
diff --git a/security/tor/files/tor.in b/security/tor/files/tor.in
index f7af2d3375ac..54c37308d478 100644
--- a/security/tor/files/tor.in
+++ b/security/tor/files/tor.in
@@ -3,7 +3,7 @@
# $FreeBSD$
#
# PROVIDE: tor
-# REQUIRE: NETWORKING SERVERS USR
+# REQUIRE: DAEMON FILESYSTEMS
# BEFORE: LOGIN
#
# Add the following lines to /etc/rc.conf to enable tor.
diff --git a/security/tor/pkg-plist b/security/tor/pkg-plist
index ae2a98dbdda7..1d8a482892cc 100644
--- a/security/tor/pkg-plist
+++ b/security/tor/pkg-plist
@@ -2,7 +2,7 @@ bin/tor
bin/tor-gencert
bin/tor-resolve
bin/torify
-etc/tor/torrc.sample
+@sample etc/tor/torrc.sample
man/man1/tor-gencert.1.gz
man/man1/tor-resolve.1.gz
man/man1/tor.1.gz