aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/nocc/Makefile9
-rw-r--r--mail/nocc/distinfo5
-rw-r--r--mail/nocc/files/patch-action.php40
-rw-r--r--mail/nocc/files/patch-functions.php26
-rw-r--r--mail/nocc/files/patch-send.php32
-rw-r--r--mail/nocc/pkg-plist155
6 files changed, 81 insertions, 186 deletions
diff --git a/mail/nocc/Makefile b/mail/nocc/Makefile
index c80eb7939afc..3468edb304d0 100644
--- a/mail/nocc/Makefile
+++ b/mail/nocc/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= nocc
-PORTVERSION= 0.9.7
-PORTREVISION= 1
+DISTVERSION= 1.0.0rc1
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/RC/}
MAINTAINER= ale@FreeBSD.org
COMMENT= A web-based e-mail system which access POP3 and IMAP mail servers
@@ -20,9 +18,12 @@ USE_PHP= imap pcre session
WANT_PHP_WEB= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
-WRKSRC= ${WRKDIR}
NO_BUILD= yes
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
pre-patch:
@${SED} 's|%%PREFIX%%|${PREFIX}|g' \
${PKGDIR}/pkg-message > ${PKGMESSAGE}
diff --git a/mail/nocc/distinfo b/mail/nocc/distinfo
index 8f543c60b9b0..716a2f4dae4a 100644
--- a/mail/nocc/distinfo
+++ b/mail/nocc/distinfo
@@ -1,2 +1,3 @@
-MD5 (nocc-0.9.7.tar.gz) = 15cb929f5a0fb262921359331c9b8bd4
-SIZE (nocc-0.9.7.tar.gz) = 181063
+MD5 (nocc-1.0.0rc1.tar.gz) = 3afd4ab1432dc347573f5a24967a205a
+SHA256 (nocc-1.0.0rc1.tar.gz) = e0774a175faccb447bd2195c2a537ab6207214653bbcfa88dff33257c702ae6d
+SIZE (nocc-1.0.0rc1.tar.gz) = 183228
diff --git a/mail/nocc/files/patch-action.php b/mail/nocc/files/patch-action.php
deleted file mode 100644
index 08a00084fcaf..000000000000
--- a/mail/nocc/files/patch-action.php
+++ /dev/null
@@ -1,40 +0,0 @@
---- action.php.orig Thu Jun 30 07:34:45 2005
-+++ action.php Fri Oct 7 21:01:29 2005
-@@ -77,7 +77,8 @@
- if ($conf->display_img_attach && (eregi('image', $tmp['mime']) && ($tmp['number'] != '')))
- {
- // if it's an image, display it
-- $img_type = array_pop(explode('/', $tmp['mime']));
-+ $exploded = explode('/', $tmp['mime']);
-+ $img_type = array_pop($exploded);
- if (eregi('JPEG', $img_type) || eregi('JPG', $img_type) || eregi('GIF', $img_type) || eregi ('PNG', $img_type))
- {
- echo '<hr />';
-@@ -156,10 +157,12 @@
- if (isset($user_prefs->reply_leadin) && ($user_prefs->reply_leadin != ''))
- {
- $parsed_leadin = NOCCUserPrefs::parseLeadin($user_prefs->reply_leadin, $content);
-- $mail_body = mailquote(strip_tags($content['body'], ''), $parsed_leadin, '');
-+ $stripped_content = strip_tags($content['body'], '');
-+ $mail_body = mailquote($stripped_content, $parsed_leadin, '');
- }
- else
-- $mail_body = mailquote(strip_tags($content['body'], ''), $content['from'], $html_wrote);
-+ $stripped_content = strip_tags($content['body'], '');
-+ $mail_body = mailquote($stripped_content, $content['from'], $html_wrote);
- }
-
- // Add signature
-@@ -204,8 +207,10 @@
- // Set body
- if(isset($user_prefs->outlook_quoting) && $user_prefs->outlook_quoting)
- $mail_body = $original_msg . "\n" . $html_from . ': ' . $content['from'] . "\n" . $html_to . ': ' . $content['to'] . "\n" . $html_sent.': ' . $content['complete_date'] . "\n" . $html_subject . ': '. $content['subject'] . "\n\n" . strip_tags2($content['body'], '');
-- else
-- $mail_body = mailquote(strip_tags2($content['body'], ''), $content['from'], $html_wrote);
-+ else {
-+ $stripped_content = strip_tags2($content['body'], '');
-+ $mail_body = mailquote($stripped_content, $content['from'], $html_wrote);
-+ }
-
- // Add signature
- add_signature($mail_body);
diff --git a/mail/nocc/files/patch-functions.php b/mail/nocc/files/patch-functions.php
deleted file mode 100644
index 5480dbbd39f1..000000000000
--- a/mail/nocc/files/patch-functions.php
+++ /dev/null
@@ -1,26 +0,0 @@
---- functions.php 2005/09/13 19:19:36 1.207
-+++ functions.php 2005/09/14 18:57:08 1.208
-@@ -45,9 +45,10 @@
- {
- $subject = $from = $to = '';
- $msgnum = $sorted[$i];
-- $ref_contenu_message = $pop->headerinfo($pop->msgno($msgnum), $ev);
-+ $pop_msgno_msgnum = $pop->msgno($msgnum);
-+ $ref_contenu_message = $pop->headerinfo($pop_msgno_msgnum, $ev);
- if(NoccException::isException($ev)) return;
-- $struct_msg = $pop->fetchstructure($pop->msgno($msgnum), $ev);
-+ $struct_msg = $pop->fetchstructure($pop_msgno_msgnum, $ev);
- if(NoccException::isException($ev)) return;
- $subject_array = nocc_imap::mime_header_decode($ref_contenu_message->subject);
- for ($j = 0; $j < count($subject_array); $j++)
-@@ -182,7 +183,9 @@
- if ($struct_msg->type == 3 || (isset($struct_msg->parts) && (sizeof($struct_msg->parts) > 0)))
- GetPart($attach_tab, $struct_msg, NULL, $conf->display_rfc822);
- else {
-- GetSinglePart($attach_tab, $struct_msg, $pop->fetchheader($mail, $ev), $pop->body($mail, $ev));
-+ $pop_fetchheader_mail_ev = $pop->fetchheader($mail, $ev);
-+ $pop_body_mail_ev = $pop->body($mail, $ev);
-+ GetSinglePart($attach_tab, $struct_msg, $pop_fetchheader_mail_ev, $pop_body_mail_ev);
- if(NoccException::isException($ev)) return;
- }
-
diff --git a/mail/nocc/files/patch-send.php b/mail/nocc/files/patch-send.php
deleted file mode 100644
index 2cf598028427..000000000000
--- a/mail/nocc/files/patch-send.php
+++ /dev/null
@@ -1,32 +0,0 @@
---- send.php 2005/07/03 20:43:02 1.134
-+++ send.php 2005/09/14 18:57:08 1.135
-@@ -102,7 +102,8 @@
- $mail->smtp_server = $_SESSION['nocc_smtp_server'];
- $mail->smtp_port = $_SESSION['nocc_smtp_port'];
- $mail->charset = $charset;
-- $mail->from = cut_address(trim($mail_from), $charset);
-+ $trim_mail_from = trim($mail_from);
-+ $mail->from = cut_address($trim_mail_from, $charset);
- $mail->from = $mail->from[0];
- $mail->priority = $_REQUEST['priority'];
- $mail->receipt = isset($_REQUEST['receipt']);
-@@ -110,13 +111,16 @@
- // $ip = (getenv('HTTP_X_FORWARDED_FOR') ? getenv('HTTP_X_FORWARDED_FOR') : getenv('REMOTE_ADDR'));
- // $mail->headers .= 'X-Originating-Ip: [' . $ip . ']' . $mail->crlf;
- $mail->headers .= 'User-Agent: ' . $conf->nocc_name . ' <' . $conf->nocc_url . '>';
-- $mail->to = cut_address(trim($mail_to), $charset);
-- $mail->cc = cut_address(trim($mail_cc), $charset);
-+ $trim_mail_to = trim($mail_to);
-+ $trim_mail_cc = trim($mail_cc);
-+ $mail->to = cut_address($trim_mail_to, $charset);
-+ $mail->cc = cut_address($trim_mail_cc, $charset);
- $user_prefs = $_SESSION['nocc_user_prefs'];
- if(isset($user_prefs->cc_self) && $user_prefs->cc_self) {
- array_unshift($mail->cc, $mail->from);
- }
-- $mail->bcc = cut_address(trim($mail_bcc), $charset);
-+ $trim_mail_bcc = trim($mail_bcc);
-+ $mail->bcc = cut_address($trim_mail_bcc, $charset);
- if ($mail_subject != '')
- $mail->subject = trim($mail_subject);
-
diff --git a/mail/nocc/pkg-plist b/mail/nocc/pkg-plist
index c331d8e4986a..661efefb7162 100644
--- a/mail/nocc/pkg-plist
+++ b/mail/nocc/pkg-plist
@@ -7,6 +7,7 @@ www/nocc/common.php
@unexec if cmp -s %D/www/nocc/conf.php %D/www/nocc/conf.php.dist; then rm -f %D/www/nocc/conf.php; fi
www/nocc/conf.php.dist
@exec [ -f %B/conf.php ] || cp %B/%f %B/conf.php
+www/nocc/conf_charset.php
www/nocc/conf_lang.php
www/nocc/contacts.php
www/nocc/contacts_manager.php
@@ -18,6 +19,7 @@ www/nocc/exception.php
www/nocc/functions.php
www/nocc/get_img.php
www/nocc/help.php
+www/nocc/html_entity_decode.php
www/nocc/index.php
www/nocc/is_uploaded_file.php
www/nocc/logout.php
@@ -49,9 +51,9 @@ www/nocc/html/send.php
www/nocc/html/send_confirmed.php
www/nocc/html/send_error.php
www/nocc/lang/add_message.sh
-www/nocc/lang/ar-win.php
www/nocc/lang/ar.php
www/nocc/lang/bg.php
+www/nocc/lang/ca.php
www/nocc/lang/cs.php
www/nocc/lang/da.php
www/nocc/lang/de.php
@@ -76,8 +78,6 @@ www/nocc/lang/pt-br.php
www/nocc/lang/pt.php
www/nocc/lang/remove_message.sh
www/nocc/lang/ro.php
-www/nocc/lang/ru-iso.php
-www/nocc/lang/ru-koi.php
www/nocc/lang/ru.php
www/nocc/lang/sk.php
www/nocc/lang/sl.php
@@ -89,95 +89,86 @@ www/nocc/lang/xx-hacker.php
www/nocc/lang/zh-gb.php
www/nocc/lang/zh-tw.php
www/nocc/rss.php
-www/nocc/themes/blue/colors.php
-www/nocc/themes/blue/style.css
-www/nocc/themes/blue/img/attach.gif
+www/nocc/themes/blue/img/attach.png
www/nocc/themes/blue/img/button.png
-www/nocc/themes/blue/img/confused.gif
-www/nocc/themes/blue/img/cool.gif
-www/nocc/themes/blue/img/cry.gif
-www/nocc/themes/blue/img/delete.gif
-www/nocc/themes/blue/img/down.gif
-www/nocc/themes/blue/img/embarassed.gif
-www/nocc/themes/blue/img/flat.gif
-www/nocc/themes/blue/img/grin.gif
-www/nocc/themes/blue/img/happy.gif
-www/nocc/themes/blue/img/left_arrow.gif
-www/nocc/themes/blue/img/logo.gif
-www/nocc/themes/blue/img/love.gif
-www/nocc/themes/blue/img/new.gif
-www/nocc/themes/blue/img/right_arrow.gif
-www/nocc/themes/blue/img/spacer.gif
-www/nocc/themes/blue/img/surprised.gif
-www/nocc/themes/blue/img/tongue.gif
-www/nocc/themes/blue/img/unhappy.gif
-www/nocc/themes/blue/img/up.gif
-www/nocc/themes/blue/img/wink.gif
-www/nocc/themes/newlook/colors.php
-www/nocc/themes/newlook/style.css
-www/nocc/themes/newlook/img/attach.gif
-www/nocc/themes/newlook/img/bg.gif
+www/nocc/themes/blue/img/down.png
+www/nocc/themes/blue/img/error.png
+www/nocc/themes/blue/img/left_arrow.png
+www/nocc/themes/blue/img/logo.png
+www/nocc/themes/blue/img/new.png
+www/nocc/themes/blue/img/right_arrow.png
+www/nocc/themes/blue/img/rss.png
+www/nocc/themes/blue/img/smilies/confused.png
+www/nocc/themes/blue/img/smilies/cool.png
+www/nocc/themes/blue/img/smilies/cry.png
+www/nocc/themes/blue/img/smilies/embarassed.png
+www/nocc/themes/blue/img/smilies/flat.png
+www/nocc/themes/blue/img/smilies/grin.png
+www/nocc/themes/blue/img/smilies/happy.png
+www/nocc/themes/blue/img/smilies/love.png
+www/nocc/themes/blue/img/smilies/surprised.png
+www/nocc/themes/blue/img/smilies/tongue.png
+www/nocc/themes/blue/img/smilies/unhappy.png
+www/nocc/themes/blue/img/smilies/wink.png
+www/nocc/themes/blue/img/up.png
+www/nocc/themes/blue/style.css
+www/nocc/themes/newlook/img/attach.png
www/nocc/themes/newlook/img/button.png
-www/nocc/themes/newlook/img/confused.gif
-www/nocc/themes/newlook/img/cool.gif
-www/nocc/themes/newlook/img/cry.gif
-www/nocc/themes/newlook/img/delete.gif
-www/nocc/themes/newlook/img/down.gif
-www/nocc/themes/newlook/img/embarassed.gif
-www/nocc/themes/newlook/img/flat.gif
-www/nocc/themes/newlook/img/grin.gif
-www/nocc/themes/newlook/img/happy.gif
-www/nocc/themes/newlook/img/left_arrow.gif
-www/nocc/themes/newlook/img/logo.gif
-www/nocc/themes/newlook/img/love.gif
-www/nocc/themes/newlook/img/new.gif
-www/nocc/themes/newlook/img/right_arrow.gif
-www/nocc/themes/newlook/img/shtamp.gif
-www/nocc/themes/newlook/img/spacer.gif
-www/nocc/themes/newlook/img/surprised.gif
-www/nocc/themes/newlook/img/tongue.gif
-www/nocc/themes/newlook/img/unhappy.gif
-www/nocc/themes/newlook/img/up.gif
-www/nocc/themes/newlook/img/wink.gif
-www/nocc/themes/standard/colors.php
-www/nocc/themes/standard/style.css
-www/nocc/themes/standard/img/attach.gif
+www/nocc/themes/newlook/img/down.png
+www/nocc/themes/newlook/img/error.png
+www/nocc/themes/newlook/img/left_arrow.png
+www/nocc/themes/newlook/img/logo.png
+www/nocc/themes/newlook/img/new.png
+www/nocc/themes/newlook/img/right_arrow.png
+www/nocc/themes/newlook/img/rss.png
+www/nocc/themes/newlook/img/shtamp.png
+www/nocc/themes/newlook/img/smilies/confused.png
+www/nocc/themes/newlook/img/smilies/cool.png
+www/nocc/themes/newlook/img/smilies/cry.png
+www/nocc/themes/newlook/img/smilies/embarassed.png
+www/nocc/themes/newlook/img/smilies/flat.png
+www/nocc/themes/newlook/img/smilies/grin.png
+www/nocc/themes/newlook/img/smilies/happy.png
+www/nocc/themes/newlook/img/smilies/love.png
+www/nocc/themes/newlook/img/smilies/surprised.png
+www/nocc/themes/newlook/img/smilies/tongue.png
+www/nocc/themes/newlook/img/smilies/unhappy.png
+www/nocc/themes/newlook/img/smilies/wink.png
+www/nocc/themes/newlook/img/up.png
+www/nocc/themes/newlook/style.css
+www/nocc/themes/standard/img/attach.png
www/nocc/themes/standard/img/button.png
-www/nocc/themes/standard/img/confused.gif
-www/nocc/themes/standard/img/cool.gif
-www/nocc/themes/standard/img/cry.gif
-www/nocc/themes/standard/img/delete.gif
-www/nocc/themes/standard/img/down.gif
-www/nocc/themes/standard/img/embarassed.gif
-www/nocc/themes/standard/img/flat.gif
-www/nocc/themes/standard/img/grin.gif
-www/nocc/themes/standard/img/happy.gif
-www/nocc/themes/standard/img/left_arrow.gif
-www/nocc/themes/standard/img/logo.gif
-www/nocc/themes/standard/img/love.gif
-www/nocc/themes/standard/img/new.gif
-www/nocc/themes/standard/img/right_arrow.gif
-www/nocc/themes/standard/img/spacer.gif
-www/nocc/themes/standard/img/surprised.gif
-www/nocc/themes/standard/img/tongue.gif
-www/nocc/themes/standard/img/unhappy.gif
-www/nocc/themes/standard/img/up.gif
-www/nocc/themes/standard/img/wink.gif
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/KNOWN_BUGS
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
+www/nocc/themes/standard/img/down.png
+www/nocc/themes/standard/img/error.png
+www/nocc/themes/standard/img/left_arrow.png
+www/nocc/themes/standard/img/logo.png
+www/nocc/themes/standard/img/new.png
+www/nocc/themes/standard/img/right_arrow.png
+www/nocc/themes/standard/img/rss.png
+www/nocc/themes/standard/img/smilies/confused.png
+www/nocc/themes/standard/img/smilies/cool.png
+www/nocc/themes/standard/img/smilies/cry.png
+www/nocc/themes/standard/img/smilies/embarassed.png
+www/nocc/themes/standard/img/smilies/flat.png
+www/nocc/themes/standard/img/smilies/grin.png
+www/nocc/themes/standard/img/smilies/happy.png
+www/nocc/themes/standard/img/smilies/love.png
+www/nocc/themes/standard/img/smilies/surprised.png
+www/nocc/themes/standard/img/smilies/tongue.png
+www/nocc/themes/standard/img/smilies/unhappy.png
+www/nocc/themes/standard/img/smilies/wink.png
+www/nocc/themes/standard/img/up.png
+www/nocc/themes/standard/style.css
+@dirrm www/nocc/themes/standard/img/smilies
@dirrm www/nocc/themes/standard/img
@dirrm www/nocc/themes/standard
+@dirrm www/nocc/themes/newlook/img/smilies
@dirrm www/nocc/themes/newlook/img
@dirrm www/nocc/themes/newlook
+@dirrm www/nocc/themes/blue/img/smilies
@dirrm www/nocc/themes/blue/img
@dirrm www/nocc/themes/blue
@dirrm www/nocc/themes
@dirrm www/nocc/lang
@dirrm www/nocc/html
@dirrm www/nocc
-%%PORTDOCS%%@dirrm %%DOCSDIR%%