aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/Makefile1
-rw-r--r--comms/splat/Makefile41
-rw-r--r--comms/splat/distinfo2
-rw-r--r--comms/splat/pkg-descr9
4 files changed, 53 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 7cf3e7f232c0..3f8a1280b370 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -89,6 +89,7 @@
SUBDIR += smstools
SUBDIR += snooper
SUBDIR += spandsp
+ SUBDIR += splat
SUBDIR += sredird
SUBDIR += thebridge
SUBDIR += tilp
diff --git a/comms/splat/Makefile b/comms/splat/Makefile
new file mode 100644
index 000000000000..667863a44968
--- /dev/null
+++ b/comms/splat/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: splat
+# Date created: 8 July 2005
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= splat
+PORTVERSION= 1.1.0
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/ham
+
+MAINTAINER= db@db.net
+COMMENT= Used in calculating path losses, useful to ham radio and others
+
+PORTDOCS= README README2 CHANGES
+PLIST_FILES= bin/splat bin/citydecoder bin/usgs2sdf bin/fontdata
+MAN1= splat.1
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CXX} ${CXXFLAGS} -lm -lbz2 -o splat itm.cpp splat.cpp
+ cd ${WRKSRC}/utils && \
+ ${CC} ${CFLAGS} -o citydecoder citydecoder.c && \
+ ${CC} ${CFLAGS} -o usgs2sdf usgs2sdf.c && \
+ ${CC} ${CFLAGS} -lz -o fontdata fontdata.c
+
+do-install:
+.for f in splat utils/citydecoder utils/usgs2sdf utils/fontdata
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/splat.1 ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/splat/distinfo b/comms/splat/distinfo
new file mode 100644
index 000000000000..0dc7cf87c0a6
--- /dev/null
+++ b/comms/splat/distinfo
@@ -0,0 +1,2 @@
+MD5 (splat-1.1.0.tar.gz) = 216761c2fc77e74578370492f20b27d2
+SIZE (splat-1.1.0.tar.gz) = 142804
diff --git a/comms/splat/pkg-descr b/comms/splat/pkg-descr
new file mode 100644
index 000000000000..30a76ef35ab2
--- /dev/null
+++ b/comms/splat/pkg-descr
@@ -0,0 +1,9 @@
+SPLAT! is an RF Signal Propagation, Loss, And Terrain analysis tool for
+the spectrum between 20 MHz and 20 GHz. Useful to Amateur Radio operators.
+
+Written by John A. Magliacane, KD2BD
+
+WWW: http://www.qsl.net/kd2bd/splat.html
+
+- Diane Bruce, VA3DB
+db@db.net