aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/copperspice/Makefile3
-rw-r--r--graphics/gexiv2/Makefile2
-rw-r--r--graphics/kix-kmod/Makefile2
-rw-r--r--graphics/libjxr/Makefile6
-rw-r--r--graphics/luminance/Makefile2
-rw-r--r--graphics/mapnik/Makefile3
-rw-r--r--graphics/perceptualdiff/Makefile2
-rw-r--r--graphics/plasma-kmod/Makefile2
-rw-r--r--graphics/pngwriter/Makefile4
-rw-r--r--graphics/py-pivy/Makefile2
-rw-r--r--graphics/rawstudio/Makefile2
-rw-r--r--graphics/simpleviewer/Makefile2
-rw-r--r--graphics/tulip/Makefile2
-rw-r--r--irc/lostirc/Makefile2
-rw-r--r--irc/weechat/Makefile3
-rw-r--r--japanese/mozc-server/Makefile8
-rw-r--r--japanese/nethack34/Makefile2
-rw-r--r--lang/cling/Makefile3
-rw-r--r--lang/gcc47/Makefile2
-rw-r--r--lang/gcc6/Makefile3
-rw-r--r--lang/hugs/Makefile5
-rw-r--r--lang/racket-minimal/Makefile7
-rw-r--r--lang/racket/Makefile6
-rw-r--r--mail/cyrus-imapd30/Makefile2
-rw-r--r--mail/rmilter/Makefile7
-rw-r--r--math/acalc/Makefile2
-rw-r--r--math/clblas/Makefile2
-rw-r--r--math/gap/Makefile5
-rw-r--r--math/reduce/Makefile2
-rw-r--r--multimedia/libvdpau-va-gl/Makefile3
-rw-r--r--multimedia/oggvideotools/Makefile2
-rw-r--r--net-mgmt/netdata/Makefile2
-rw-r--r--net-mgmt/ng_ipacct/Makefile2
-rw-r--r--net-p2p/bitcoin/Makefile2
-rw-r--r--net-p2p/dogecoin/Makefile4
-rw-r--r--net-p2p/litecoin/Makefile5
-rw-r--r--net-p2p/namecoin/Makefile2
-rw-r--r--net-p2p/zetacoin/Makefile5
-rw-r--r--net/aoe/Makefile6
-rw-r--r--net/freediameter/Makefile2
-rw-r--r--net/intel-em-kmod/Makefile3
-rw-r--r--net/isboot-kmod/Makefile3
-rw-r--r--net/kea/Makefile2
-rw-r--r--net/lft/Makefile2
44 files changed, 112 insertions, 28 deletions
diff --git a/graphics/copperspice/Makefile b/graphics/copperspice/Makefile
index d0b4096082da..708104f6a611 100644
--- a/graphics/copperspice/Makefile
+++ b/graphics/copperspice/Makefile
@@ -45,10 +45,11 @@ CONFIGURE_ARGS= ${OVERRIDE_INS}
MAKE_ARGS= ${OVERRIDE_INS}
PLIST_SUB= LONG_VER=1.3
-BROKEN_aarch64= Fails to build: Unable to detect architecture, please update
BROKEN_i386= qx11embed_x11.cpp:470:20: non-constant-expression\
cannot be narrowed from type 'unsigned int' to 'long'\
in initializer list [-Wc++11-narrowing]
+NOT_FOR_ARCHS= aarch64 armv6 powerpc64
+NOT_FOR_ARCHS_REASON= fails to build: Unable to detect architecture, please update
post-patch:
# fix something wrong with v1.3.2 generatior
diff --git a/graphics/gexiv2/Makefile b/graphics/gexiv2/Makefile
index 212ab55379f1..2901ff441705 100644
--- a/graphics/gexiv2/Makefile
+++ b/graphics/gexiv2/Makefile
@@ -16,6 +16,8 @@ BUILD_DEPENDS= gm4:devel/m4 \
vala>=0:lang/vala
LIB_DEPENDS= libexiv2.so:graphics/exiv2
+BROKEN_powerpc64= fails to compile: gexiv2-metadata-gps.cpp: 'overflow_error' is not a member of 'std'
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-introspection=yes \
--enable-vala=yes
diff --git a/graphics/kix-kmod/Makefile b/graphics/kix-kmod/Makefile
index dbff252dbd07..5c41d09d6507 100644
--- a/graphics/kix-kmod/Makefile
+++ b/graphics/kix-kmod/Makefile
@@ -12,6 +12,8 @@ PKGNAMESUFFIX= -kmod
MAINTAINER= jon@witchspace.com
COMMENT= Graphical screensaver kernel module
+BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
+
USES= kmod
MAKE_ENV+= WERROR=
diff --git a/graphics/libjxr/Makefile b/graphics/libjxr/Makefile
index b5a2ecdca19f..50887f75cd26 100644
--- a/graphics/libjxr/Makefile
+++ b/graphics/libjxr/Makefile
@@ -13,8 +13,10 @@ COMMENT= Library for JPEG XR, a.k.a. Windows MediaTM Photo
LICENSE= BSD
-BROKEN_aarch64= fails to link: cc: error: linker command failed with exit code 1 (use -v to see invocation)
-BROKEN_mips64= fails to build
+BROKEN_aarch64= fails to link: cc: linker command failed with exit code 1 (use -v to see invocation)
+BROKEN_mips= fails to compile: cc1: unrecognized command line option "-Wno-extra-tokens"
+BROKEN_mips64= fails to compile: cc1: unrecognized command line option "-Wno-extra-tokens"
+BROKEN_powerpc64= fails to compile: cc1: unrecognized command line option "-Wno-extra-tokens"
USES= dos2unix uidfix
USE_LDCONFIG= yes
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index 335f25e6678b..339ecb9b1ea5 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -21,6 +21,8 @@ LIB_DEPENDS= libfftw3f.so:math/fftw3-float \
libraw_r.so:graphics/libraw \
libboost_system.so:devel/boost-libs
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-msse2"
+
USES= cmake jpeg tar:bzip2
USE_QT4= gui sql webkit xml linguist_build moc_build qmake_build \
rcc_build uic_build imageformats_run
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index a885ebe1b36c..9c850cedf150 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= libicuuc.so:devel/icu \
libfreetype.so:print/freetype2 \
libharfbuzz.so:print/harfbuzz
-BROKEN_powerpc= does not install: runs out of virtual memory
+BROKEN_powerpc= fails to install: runs out of virtual memory
+BROKEN_powerpc64= fails to link: libmapnik.so: undefined reference to boost::match_results
USES= compiler:c++11-lib pkgconfig python scons tar:bzip2
USE_GNOME= libxml2
diff --git a/graphics/perceptualdiff/Makefile b/graphics/perceptualdiff/Makefile
index c26bf66b0bc9..0b0d04deefb3 100644
--- a/graphics/perceptualdiff/Makefile
+++ b/graphics/perceptualdiff/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libfreeimage.so:graphics/freeimage
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++0x"
+
PLIST_FILES= bin/perceptualdiff
USE_GITHUB= yes
diff --git a/graphics/plasma-kmod/Makefile b/graphics/plasma-kmod/Makefile
index e1b0f6eb5971..fe70984ce01c 100644
--- a/graphics/plasma-kmod/Makefile
+++ b/graphics/plasma-kmod/Makefile
@@ -13,6 +13,8 @@ COMMENT= Plasma-effect screensaver kernel module
LICENSE= BSD3CLAUSE
+BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
+
PLIST_FILES= ${KMODDIR}/plasma_saver.ko
USES= kmod uidfix
diff --git a/graphics/pngwriter/Makefile b/graphics/pngwriter/Makefile
index 7c584ab4c2d0..b3ae5f7453fb 100644
--- a/graphics/pngwriter/Makefile
+++ b/graphics/pngwriter/Makefile
@@ -14,6 +14,10 @@ LICENSE_FILE= ${WRKSRC}/doc/LICENSE
LIB_DEPENDS= libpng.so:graphics/png \
libfreetype.so:print/freetype2
+BROKEN_mips= fails to build: ios_base.h: 'std::ios_base::ios_base(const std::ios_base&)' is private
+BROKEN_mips64= fails to build: ios_base.h: 'std::ios_base::ios_base(const std::ios_base&)' is private
+BROKEN_powerpc64= fails to build: ios_base.h: 'std::ios_base::ios_base(const std::ios_base&)' is private
+
USES= cmake:outsource
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/graphics/py-pivy/Makefile b/graphics/py-pivy/Makefile
index 67822b49c9b5..d0bf2825dc6b 100644
--- a/graphics/py-pivy/Makefile
+++ b/graphics/py-pivy/Makefile
@@ -15,6 +15,8 @@ LICENSE= MIT
BUILD_DEPENDS= ${LOCALBASE}/bin/swig:devel/swig13
LIB_DEPENDS= libSoQt.so:x11-toolkits/soqt
+BROKEN_powerpc64= fails to link: coin_wrap.o: relocation truncated to fit: R_PPC64_TOC16_DS
+
USES= zip python:2
USE_PYTHON= autoplist distutils
diff --git a/graphics/rawstudio/Makefile b/graphics/rawstudio/Makefile
index d491f0b7fed2..850c64e26264 100644
--- a/graphics/rawstudio/Makefile
+++ b/graphics/rawstudio/Makefile
@@ -22,6 +22,8 @@ LIB_DEPENDS= libpng.so:graphics/png \
libgphoto2.so:graphics/libgphoto2
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
+BROKEN_powerpc64= fails to link: libicuuc.so. undefined reference to __cxa_throw_bad_array_new_length
+
USES= desktop-file-utils gettext gmake jpeg libtool pathfix pkgconfig \
sqlite
GNU_CONFIGURE= yes
diff --git a/graphics/simpleviewer/Makefile b/graphics/simpleviewer/Makefile
index ecd4ee77fa96..8edfe6462162 100644
--- a/graphics/simpleviewer/Makefile
+++ b/graphics/simpleviewer/Makefile
@@ -24,6 +24,8 @@ LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR \
libtiff.so:graphics/tiff \
libwebp.so:graphics/webp
+BROKEN_powerpc64= fails to build: fileslist.cpp: '::printf' has not been declared
+
USES= cmake compiler:c++11-lang jpeg pkgconfig tar:bzip2
USE_GL= glu
USE_XORG= ice sm x11 xcursor xext xinerama xrandr xxf86vm
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index ea297e79175f..42c879d9f57c 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= libquazip.so:archivers/quazip \
libOGDF.so:math/ogdf \
libfreetype.so:print/freetype2
+BROKEN_powerpc64= fails to link: libOGDF.so: undefined reference to CoinPackedVector::CoinPackedVector
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= cmake:outsource compiler:c++11-lib dos2unix execinfo jpeg python \
diff --git a/irc/lostirc/Makefile b/irc/lostirc/Makefile
index de415e98403d..7e7c25616d02 100644
--- a/irc/lostirc/Makefile
+++ b/irc/lostirc/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgtkmm-2.4.so:x11-toolkits/gtkmm24
+BROKEN_powerpc64= fails to build: Socket.cpp: 'strerror' was not declared in this scope
+
USES= compiler:c++11-lang pathfix pkgconfig gettext
USE_CXXSTD= c++11
USE_GNOME= gnomeprefix
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 0d426fa0b91a..04815593a0af 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -26,6 +26,9 @@ OPTIONS_DEFINE= BACKTRACE DOCS CA_BUNDLE GNUTLS ICON ICONV MANPAGES NLS
OPTIONS_DEFAULT= ASPELL BACKTRACE CA_BUNDLE CHARSET GNUTLS ICON LUA MANPAGES PERL PYTHON RUBY TCL
OPTIONS_SUB= yes
+# BROKEN: ruby.h: error: wrong number of arguments specified for 'deprecated' attribute
+OPTIONS_EXCLUDE_powerpc64= RUBY
+
OPTIONS_GROUP= PLUGINS
OPTIONS_GROUP_PLUGINS= ASPELL CHARSET JAVASCRIPT LUA PERL PYTHON RUBY TCL
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index db30a1faaf0c..3405d6ecf212 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -20,6 +20,10 @@ LIB_DEPENDS= libprotobuf.so:devel/protobuf \
libzinnia.so:japanese/zinnia
RUN_DEPENDS= xdg-open:devel/xdg-utils
+BROKEN_powerpc= fails to compile: segfault
+BROKEN_powerpc64= fails to install: gyp: Call to 'which clang' returned exit status 1 while in client/client.gyp
+BROKEN_sparc64= fails to compile: segfault
+
USE_GITHUB= yes
GH_TUPLE= hrs-allbsd:${PORTNAME}:${DISTVERSIONPREFIX}${DISTVERSION} \
hiroyuki-komatsu:japanese-usage-dictionary:e5b3425:udic
@@ -68,10 +72,6 @@ _CCTYPE= gcc
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile: segfault
-.endif
-
GYP_DEFINES= use_libprotobuf=1 \
channel_dev=0 \
enable_unittest=0 \
diff --git a/japanese/nethack34/Makefile b/japanese/nethack34/Makefile
index b43ddcf3d6b1..573bab6a5cf4 100644
--- a/japanese/nethack34/Makefile
+++ b/japanese/nethack34/Makefile
@@ -15,6 +15,8 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
COMMENT= Japanized NetHack
+BROKEN_FreeBSD_12= fails to build: stdlib.h: conflicting types for 'srandom'
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= gmake tar:tgz
diff --git a/lang/cling/Makefile b/lang/cling/Makefile
index bc615a2d7436..dea822ee573d 100644
--- a/lang/cling/Makefile
+++ b/lang/cling/Makefile
@@ -18,6 +18,9 @@ LICENSE_FILE_LLVM= ${WRKSRC}/LICENSE.TXT
LICENSE_FILE_NCSA= ${WRKSRC}/tools/cling/LICENSE.TXT
LICENSE_PERMS_LLVM= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_armv6= fails to compile: AArch64TargetMachine.cpp: relocation truncated to fit: R_ARM_CALL against symbol '__aeabi_uldivmod'
+BROKEN_powerpc64= fails to compile: IncrementalParser.cpp: 'to_string' is not a member of 'std'
+
WRKSRC= ${WRKDIR}/src
LLVM_RELEASE= 3.9.0
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 882b8f55bef5..4ebd356568ab 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -21,6 +21,8 @@ LIB_DEPENDS= libgmp.so:math/gmp \
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
+BROKEN_powerpc64= fails to compile: libgcc2.c: In function '__powisf2': internal compiler error: Segmentation fault
+
.if defined(MAINTAINER_MODE)
BUILD_DEPENDS+= runtest:misc/dejagnu
.endif
diff --git a/lang/gcc6/Makefile b/lang/gcc6/Makefile
index 9c7d43788efb..fe02295604f9 100644
--- a/lang/gcc6/Makefile
+++ b/lang/gcc6/Makefile
@@ -20,6 +20,9 @@ LIB_DEPENDS= libgmp.so:math/gmp \
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
+BROKEN_powerpc64= fails to build: close.c: implicit declaration of function 'strdup'
+BROKEN_sparc64= fails to configure: cannot compute suffix of object files: cannot compile
+
.if defined(MAINTAINER_MODE)
BUILD_DEPENDS+= runtest:misc/dejagnu
.endif
diff --git a/lang/hugs/Makefile b/lang/hugs/Makefile
index 5a916ab1a292..b061ec98210c 100644
--- a/lang/hugs/Makefile
+++ b/lang/hugs/Makefile
@@ -13,6 +13,9 @@ COMMENT= Interpreter for the functional programming language Haskell 98
BUILD_DEPENDS= bash:shells/bash
+BROKEN_armv6= fails to compile: cppinput.c: invalid preprocessing directive \#!
+BROKEN_powerpc64= fails to compile: cppinput.c: detected recursion whilst expanding macro "vector"
+
WRKSRC= ${WRKDIR}/${DISTNAME}
HUGS_DATE= Sep2006
@@ -26,8 +29,6 @@ CONFIGURE_ARGS+= --with-pthreads
USE_GL= glut
USE_XORG= sm ice xmu xi x11
-BROKEN_ia64= dumps core during build
-
post-patch:
@${REINPLACE_CMD} 's/LIBS/LIBRARIES/' ${WRKSRC}/libraries/Makefile.in
@${REINPLACE_CMD} -e '/^install :: install_notes/d ; \
diff --git a/lang/racket-minimal/Makefile b/lang/racket-minimal/Makefile
index be6026f47212..4843e4652738 100644
--- a/lang/racket-minimal/Makefile
+++ b/lang/racket-minimal/Makefile
@@ -21,11 +21,10 @@ LICENSE= LGPL3
LIB_DEPENDS= libffi.so:devel/libffi
-BROKEN_armv6= does not build: error: GNU lightning does not support the current target
-BROKEN_aarch64= does not build: error: Unported platform
-BROKEN_powerpc64= does not build: jit.c: error: JIT_LOCAL4 undeclared
-BROKEN_sparc64= does not build
BROKEN_i386= does not build on i386 (Seg fault (internal error) at 0x606060a)
+BROKEN_powerpc64= fails to build: jit.c: 'JIT_LOCAL4' undeclared (first use in this function)
+NOT_FOR_ARCHS= armv6 aarch64 sparc64
+NOT_FOR_ARCHS_REASON= not yet ported to this arch
MAKE_JOBS_UNSAFE=yes
diff --git a/lang/racket/Makefile b/lang/racket/Makefile
index c41d3b5e08e3..39d98005ef86 100644
--- a/lang/racket/Makefile
+++ b/lang/racket/Makefile
@@ -22,12 +22,12 @@ LIB_DEPENDS= libffi.so:devel/libffi \
libcairo.so:graphics/cairo \
libpng.so:graphics/png
-BROKEN_armv6= does not build: error: GNU lightning does not support the current target
-BROKEN_aarch64= does not build: error: Unported platform
-BROKEN_sparc64= does not build
+BROKEN_powerpc64= fails to build: jit.c: 'JIT_LOCAL4' undeclared (first use in this function)
BROKEN_FreeBSD_10_i386= segfaults during build
BROKEN_FreeBSD_11_i386= segfaults during build
BROKEN_FreeBSD_12_i386= segfaults during build
+NOT_FOR_ARCHS= armv6 aarch64 sparc64
+NOT_FOR_ARCHS_REASON= not yet ported to this arch
MAKE_JOBS_UNSAFE=yes
diff --git a/mail/cyrus-imapd30/Makefile b/mail/cyrus-imapd30/Makefile
index 125cc63e6a4a..334047f49d3f 100644
--- a/mail/cyrus-imapd30/Makefile
+++ b/mail/cyrus-imapd30/Makefile
@@ -19,6 +19,8 @@ LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2 \
libjansson.so:devel/jansson \
libpcre.so:devel/pcre
+BROKEN_powerpc64= fails to compile: mailbox.h: redefinition of typedef 'message_t'
+
CONFLICTS_INSTALL= cyrus-imapd-2.* cyrus-imapd2*
USE_RC_SUBR= imapd
diff --git a/mail/rmilter/Makefile b/mail/rmilter/Makefile
index 6cc5b24d3181..a12b88a3463c 100644
--- a/mail/rmilter/Makefile
+++ b/mail/rmilter/Makefile
@@ -11,9 +11,10 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libpcre.so:devel/pcre
-BROKEN_armv6= Fails to configure in cmake
-BROKEN_mips= Fails to compile: error: Unsupported word size
-BROKEN_sparc64= Fails to compile: error: Unsupported word size
+BROKEN_armv6= fails to configure in cmake
+BROKEN_powerpc64= fails to build: btrie.c: '__SIZEOF_POINTER__' undeclared here
+NOT_FOR_ARCHS= mips sparc64
+NOT_FOR_ARCHS_REASON= fails to compile: error: Unsupported word size
USE_GITHUB= yes
GH_ACCOUNT= vstakhov
diff --git a/math/acalc/Makefile b/math/acalc/Makefile
index ac9105cfa854..20c9349db46d 100644
--- a/math/acalc/Makefile
+++ b/math/acalc/Makefile
@@ -10,6 +10,8 @@ COMMENT= Simple and pretty Qt4-based expression calculator
LICENSE= BSD4CLAUSE
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
USE_GITHUB= yes
GH_ACCOUNT= anpp
diff --git a/math/clblas/Makefile b/math/clblas/Makefile
index 0024cf54b8e2..5d8ab222be2b 100644
--- a/math/clblas/Makefile
+++ b/math/clblas/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= libOpenCL.so:devel/ocl-icd \
libboost_program_options.so:devel/boost-libs
RUN_DEPENDS= opencl>=0:devel/opencl
+BROKEN_powerpc64= fails to compile: xgemm.cc: error: extra ';'
+
USE_GITHUB= yes
GH_ACCOUNT= clMathLibraries
GH_PROJECT= clBLAS
diff --git a/math/gap/Makefile b/math/gap/Makefile
index adc7824b4b0c..af79ecc7cb5f 100644
--- a/math/gap/Makefile
+++ b/math/gap/Makefile
@@ -17,6 +17,9 @@ LICENSE= GPLv2+
LIB_DEPENDS= libgmp.so:math/gmp
+BROKEN_aarch64= fails to link: undefined reference to SyAllocBags
+BROKEN_powerpc64= fails to package: 2_manifolds_54.scb: No such file or directory
+
USES= gmake shebangfix tar:bzip2
SHEBANG_FILES= configure \
pkg/GAPDoc-*/*/clean \
@@ -42,8 +45,6 @@ GAP_LIBDIR= ${PREFIX}/lib/${GAP_VERSION}
WRKSRC= ${WRKDIR}/${GAP_VERSION}
PLIST_FILES= bin/gap
-BROKEN_aarch64= Fails to link: undefined reference to SyAllocBags
-
post-patch:
@${REINPLACE_CMD} -i '' -e '1s|/usr/bin/sh|/bin/sh|' \
${WRKSRC}/pkg/happrime/make_tarball
diff --git a/math/reduce/Makefile b/math/reduce/Makefile
index 58f461ce72f0..a2c2bfd3aafd 100644
--- a/math/reduce/Makefile
+++ b/math/reduce/Makefile
@@ -14,6 +14,8 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= gnuplot:math/gnuplot
+BROKEN_powerpc64= fails to compile: arith01.cpp: 'statuc' does not name a type
+
USES= autoreconf:build gmake libtool ncurses
TARGET_SDIR= ${ARCH:S/amd64/x86_64/}-unknown-${OPSYS:tl}${OSREL}
CONFIGURE_ARGS= --build=${TARGET_SDIR}
diff --git a/multimedia/libvdpau-va-gl/Makefile b/multimedia/libvdpau-va-gl/Makefile
index dc372e04c496..854bbe7a3349 100644
--- a/multimedia/libvdpau-va-gl/Makefile
+++ b/multimedia/libvdpau-va-gl/Makefile
@@ -16,6 +16,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libva-x11.so:multimedia/libva
+BROKEN_armv6= fails to configure: CMake Error: Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- broken
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
USE_GITHUB= yes
GH_ACCOUNT= i-rinat
diff --git a/multimedia/oggvideotools/Makefile b/multimedia/oggvideotools/Makefile
index 3ec6262db3e6..160ae073b5d4 100644
--- a/multimedia/oggvideotools/Makefile
+++ b/multimedia/oggvideotools/Makefile
@@ -19,6 +19,8 @@ LIB_DEPENDS= libgd.so:graphics/gd \
libtheora.so:multimedia/libtheora \
libvorbis.so:audio/libvorbis
+BROKEN_powerpc64= fails to build: decoderTest.cpp: 'memset' was not declared in this scope
+
USES= cmake compiler:c++11-lib localbase:ldflags pkgconfig tar:bz2
USE_CXXSTD= c++11
USE_SDL= sdl
diff --git a/net-mgmt/netdata/Makefile b/net-mgmt/netdata/Makefile
index 4767efa2d5c7..2c3e4a79e2e6 100644
--- a/net-mgmt/netdata/Makefile
+++ b/net-mgmt/netdata/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv3
BUILD_DEPENDS+= ${LOCALBASE}/include/uuid/uuid.h:misc/e2fsprogs-libuuid
LIB_DEPENDS+= libuuid.so:misc/e2fsprogs-libuuid
+BROKEN_FreeBSD_12= fails to compile: freebsd_sysctl.c: storage size of 'vmmeter_data' isn't known
+
USE_GITHUB= yes
GH_ACCOUNT= firehol
GH_TAGNAME= f5fa346
diff --git a/net-mgmt/ng_ipacct/Makefile b/net-mgmt/ng_ipacct/Makefile
index 4b83b2ca9c94..b8ecdcdc759e 100644
--- a/net-mgmt/ng_ipacct/Makefile
+++ b/net-mgmt/ng_ipacct/Makefile
@@ -10,6 +10,8 @@ COMMENT= Netgraph IP accounting
LICENSE= BSD2CLAUSE
+BROKEN_powerpc64= fails to build: pcpu.h: error: size of array '__assert_0' is negative
+
USE_GITHUB= yes
USES= kmod uidfix
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index b0aaa8375c7f..3088411d85a3 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -15,6 +15,8 @@ LICENSE= MIT
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libevent.so:devel/libevent
+BROKEN_powerpc64= fails to compile: util.cpp: undefined reference to boost::program_options::to_internal
+
USES= autoreconf compiler:c++0x gmake libtool pkgconfig shebangfix ssl
SHEBANG_FILES= src/test/*.py
USE_GITHUB= yes
diff --git a/net-p2p/dogecoin/Makefile b/net-p2p/dogecoin/Makefile
index 94b198aa7b98..8465aebf3693 100644
--- a/net-p2p/dogecoin/Makefile
+++ b/net-p2p/dogecoin/Makefile
@@ -13,9 +13,11 @@ COMMENT= Virtual Peer-to-Peer Currency Client
LICENSE= MIT
BUILD_DEPENDS= protoc:devel/protobuf
-
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+NOT_FOR_ARCHS= powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= fails to configure: "Big Endian not supported"
+
OPTIONS_DEFINE= GUI UPNP QRCODES
OPTIONS_DEFAULT= GUI QRCODES
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index f52b39b19e75..747572c27d7f 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -16,6 +16,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+NOT_FOR_ARCHS= powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= fails to configure: "Big Endian not supported"
+
USES+= autoreconf gmake libtool pkgconfig shebangfix ssl
SHEBANG_FILES= src/test/*.py
USE_GITHUB= yes
@@ -96,7 +99,7 @@ PLIST_FILES?= bin/litecoin-qt share/applications/litecoin-qt.desktop \
.if ${SSL_DEFAULT:Mlibressl*}
# The configure script will output this message, so save the user the trouble
-IGNORE= Detected LibreSSL: This is NOT supported, and may break consensus compatibility!
+IGNORE= detected LibreSSL: This is NOT supported, and may break consensus compatibility!
.endif
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
diff --git a/net-p2p/namecoin/Makefile b/net-p2p/namecoin/Makefile
index ffd6188bee52..fb13d4dbb695 100644
--- a/net-p2p/namecoin/Makefile
+++ b/net-p2p/namecoin/Makefile
@@ -16,6 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+BROKEN_powerpc64= fails to build: util.cpp: undefined reference to boost::program_options::to_internal
+
OPTIONS_DEFINE= X11 UPNP QRCODES DBUS
OPTIONS_DEFAULT= X11 QRCODES
diff --git a/net-p2p/zetacoin/Makefile b/net-p2p/zetacoin/Makefile
index 753f698636bc..041e0787d7a4 100644
--- a/net-p2p/zetacoin/Makefile
+++ b/net-p2p/zetacoin/Makefile
@@ -18,7 +18,8 @@ USES+= autoreconf compiler:c++0x gmake libtool pkgconfig:build ssl
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
-BROKEN_armv6= AtomicPointer not implemented
+BROKEN_armv6= AtomicPointer not implemented
+BROKEN_powerpc64= fails to configure: No working boost sleep implementation found
USE_GITHUB= yes
@@ -98,7 +99,7 @@ GROUPS= ${PORTNAME}
.if ${SSL_DEFAULT:Mlibressl*}
# The configure script will output this message, so save the user the trouble
-IGNORE= Detected LibreSSL: This is NOT supported, and may break consensus compatibility!
+IGNORE= detected LibreSSL: This is NOT supported, and may break consensus compatibility!
.endif
post-patch:
diff --git a/net/aoe/Makefile b/net/aoe/Makefile
index 95ca7cfb31b9..d71523c0afbf 100644
--- a/net/aoe/Makefile
+++ b/net/aoe/Makefile
@@ -18,8 +18,10 @@ KMODDIR= ${PREFIX}/lib/aoe
USE_RC_SUBR= aoe
-BROKEN_aarch64= Fails to compile: error: redefinition of frame
-BROKEN_sparc64= Fails to compile: error: redefinition of frame
+BROKEN_aarch64= fails to compile: error: redefinition of frame
+BROKEN_armv6= fails to compile: error: redefinition of frame
+BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
+BROKEN_sparc64= fails to compile: error: redefinition of frame
do-install:
${INSTALL_KLD} ${WRKSRC}/aoe.ko ${STAGEDIR}${PREFIX}/lib/aoe
diff --git a/net/freediameter/Makefile b/net/freediameter/Makefile
index 6eb7287acd2e..dee23ecde467 100644
--- a/net/freediameter/Makefile
+++ b/net/freediameter/Makefile
@@ -16,6 +16,8 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgnutls.so:security/gnutls \
libidn.so:dns/libidn
+BROKEN_powerpc64= fails to build: CMake Error at CMakeLists.txt: Unable to find idna.h header or idna_to_ascii_8z function
+
USES= cmake bison
USE_LDCONFIG= yes
CMAKE_ARGS= -DSCTP_USE_MAPPED_ADDRESSES:BOOL=ON
diff --git a/net/intel-em-kmod/Makefile b/net/intel-em-kmod/Makefile
index efa6d0c42579..fa65f50e1bbf 100644
--- a/net/intel-em-kmod/Makefile
+++ b/net/intel-em-kmod/Makefile
@@ -12,4 +12,7 @@ MASTERDIR= ${.CURDIR}/../intel-ixl-kmod
PKGDIR= ${.CURDIR}
DISTINFO_FILE= ${.CURDIR}/distinfo
+BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
+BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
+
.include "${MASTERDIR}/Makefile"
diff --git a/net/isboot-kmod/Makefile b/net/isboot-kmod/Makefile
index abdb6b181447..667d95e99186 100644
--- a/net/isboot-kmod/Makefile
+++ b/net/isboot-kmod/Makefile
@@ -12,6 +12,9 @@ COMMENT= Kernel module enabling iSCSI boot
LICENSE= BSD2CLAUSE
+BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
+BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
+
USES= kmod uidfix
SUB_FILES= pkg-message
WRKSRC_SUBDIR= src
diff --git a/net/kea/Makefile b/net/kea/Makefile
index 842d86c912c7..f2004e93cb6e 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= liblog4cplus.so:devel/log4cplus \
libboost_system.so:devel/boost-libs
+BROKEN_powerpc64= fails to configure: checking for log4cplus library... no
+
USES= autoreconf compiler:c++11-lang libtool pathfix python:3.3+ ssl
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
diff --git a/net/lft/Makefile b/net/lft/Makefile
index fb12cbefed51..18b3568e8a3d 100644
--- a/net/lft/Makefile
+++ b/net/lft/Makefile
@@ -15,6 +15,8 @@ LICENSE_NAME= VOSTROM
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror auto-accept
+BROKEN_FreeBSD_12= fails to compile: lft_types.h: pcap-int.h: No such file or directory
+
GNU_CONFIGURE= yes
PLIST_FILES= sbin/lft bin/whob man/man8/lft.8.gz man/man8/whob.8.gz