aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile2
-rw-r--r--devel/py-pytz/Makefile2
-rw-r--r--devel/py-pytz3/Makefile10
-rw-r--r--devel/py3-pytz/Makefile23
-rw-r--r--devel/py3-pytz/distinfo2
-rw-r--r--devel/py3-pytz/pkg-descr6
7 files changed, 34 insertions, 12 deletions
diff --git a/MOVED b/MOVED
index a64b8600c9e6..243cbe4f008a 100644
--- a/MOVED
+++ b/MOVED
@@ -7942,3 +7942,4 @@ databases/mariadb-client||2015-11-18|Vulnerable, no updates expected, use mariad
databases/mariadb-server||2015-11-18|Vulnerable, no updates expected, use mariadb55 or mariadb100 instead
databases/mariadb-scripts||2015-11-18|Vulnerable, no updates expected, use mariadb55 or mariadb100 instead
devel/py-asn1|devel/py-pyasn1|2015-11-18|Renamed to match upstream naming
+devel/py-pytz3|devel/py3-pytz|2015-11-19|Port Renamed
diff --git a/devel/Makefile b/devel/Makefile
index 30b60ae652f8..d962e12aec10 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4228,7 +4228,6 @@
SUBDIR += py-pytools
SUBDIR += py-pytrie
SUBDIR += py-pytz
- SUBDIR += py-pytz3
SUBDIR += py-pyutil
SUBDIR += py-pyvisa
SUBDIR += py-pyvisa-py
@@ -4475,6 +4474,7 @@
SUBDIR += py3-dbus
SUBDIR += py3-gobject3
SUBDIR += py3-libpeas
+ SUBDIR += py3-pytz
SUBDIR += py3-xdg
SUBDIR += py_static_check
SUBDIR += pybugz
diff --git a/devel/py-pytz/Makefile b/devel/py-pytz/Makefile
index 95e1bd0990a7..bf5da3dab22e 100644
--- a/devel/py-pytz/Makefile
+++ b/devel/py-pytz/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER?= lwhsu@FreeBSD.org
+MAINTAINER= lwhsu@FreeBSD.org
COMMENT= World Timezone Definitions for Python
LICENSE= MIT
diff --git a/devel/py-pytz3/Makefile b/devel/py-pytz3/Makefile
deleted file mode 100644
index 18ea73b59f5d..000000000000
--- a/devel/py-pytz3/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-# Created by: Muhammad Moinur Rahman <bofh@FreeBSD.org>
-# $FreeBSD$
-
-MAINTAINER= bofh@FreeBSD.org
-
-PYTHON_VERSION= python${PYTHON3_DEFAULT}
-
-MASTERDIR= ${.CURDIR}/../py-pytz
-
-.include "${MASTERDIR}/Makefile"
diff --git a/devel/py3-pytz/Makefile b/devel/py3-pytz/Makefile
new file mode 100644
index 000000000000..3d8cc45452bb
--- /dev/null
+++ b/devel/py3-pytz/Makefile
@@ -0,0 +1,23 @@
+# Created by: Muhammad Moinur Rahman <bofh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pytz
+PORTVERSION= 2015.7
+PORTEPOCH= 1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= World Timezone Definitions for Python
+
+LICENSE= MIT
+
+USES= python:3 tar:bzip2
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|=True|=False|' ${WRKSRC}/${PYSETUP}
+
+.include <bsd.port.mk>
diff --git a/devel/py3-pytz/distinfo b/devel/py3-pytz/distinfo
new file mode 100644
index 000000000000..e0723c4c4c1c
--- /dev/null
+++ b/devel/py3-pytz/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pytz-2015.7.tar.bz2) = fbd26746772c24cb93c8b97cbdad5cb9e46c86bbdb1b9d8a743ee00e2fb1fc5d
+SIZE (pytz-2015.7.tar.bz2) = 156812
diff --git a/devel/py3-pytz/pkg-descr b/devel/py3-pytz/pkg-descr
new file mode 100644
index 000000000000..f9716e76d24e
--- /dev/null
+++ b/devel/py3-pytz/pkg-descr
@@ -0,0 +1,6 @@
+pytz brings the Olson tz database into Python. This library allows accurate and
+cross platform timezone calculations. It also solves the issue of ambiguous
+times at the end of daylight savings, which you can read more about in the
+Python Library Reference (datetime.tzinfo).
+
+WWW: http://pytz.sourceforge.net