aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/sudo/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 415532288ac2..94b6a348b9c2 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -30,7 +30,9 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-long-otp-prompt \
--with-pam
-.ifdef(WITH_OPIE)
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPIE) || ${OSVERSION} > 500021
CONFIGURE_ARGS+=--with-opie
.else
CONFIGURE_ARGS+=--with-skey
@@ -45,4 +47,4 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/sample.sudoers ${PREFIX}/etc/sudoers.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>