aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/tnt/Makefile35
-rw-r--r--devel/tnt/distinfo2
-rw-r--r--devel/tnt/pkg-descr19
-rw-r--r--devel/tnt/pkg-plist93
5 files changed, 150 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 44593da7bb36..f796c375670e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -931,6 +931,7 @@
SUBDIR += tkp4
SUBDIR += tkref
SUBDIR += tmake
+ SUBDIR += tnt
SUBDIR += towitoko
SUBDIR += tpasm
SUBDIR += tpg
diff --git a/devel/tnt/Makefile b/devel/tnt/Makefile
new file mode 100644
index 000000000000..cb17cbc3de5c
--- /dev/null
+++ b/devel/tnt/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: tnt
+# Date created: Mar 15, 2003
+# Whom: Pedro F. Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tnt
+PORTVERSION= 1.1.1
+CATEGORIES= devel math
+MASTER_SITES= http://math.nist.gov/tnt/
+DISTNAME= ${PORTNAME}111
+.ifndef NOPORTDOCS
+DISTFILES=${DISTNAME}${EXTRACT_SUFX} tnt110doc.zip
+.endif
+DIST_SUBDIR= tnt
+EXTRACT_ONLY=
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Template Numerical Toolkit
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/tnt
+ ${EXTRACT_CMD} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
+ -d ${PREFIX}/include/tnt
+.ifndef NOPORTDOCS
+ ${MKDIR} ${DOCSDIR}
+ ${EXTRACT_CMD} ${DISTDIR}/${DIST_SUBDIR}/tnt110doc \
+ -d ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/tnt/distinfo b/devel/tnt/distinfo
new file mode 100644
index 000000000000..3876b88b1147
--- /dev/null
+++ b/devel/tnt/distinfo
@@ -0,0 +1,2 @@
+MD5 (tnt/tnt111.zip) = fdb1c4328915b9a7bf77026bb146d8d2
+MD5 (tnt/tnt110doc.zip) = d042af87f1218bd1e05c15d99e2d86b6
diff --git a/devel/tnt/pkg-descr b/devel/tnt/pkg-descr
new file mode 100644
index 000000000000..9e0780a7d685
--- /dev/null
+++ b/devel/tnt/pkg-descr
@@ -0,0 +1,19 @@
+The Template Numerical Toolkit (TNT) is a collection of interfaces and
+reference implementations of numerical objects useful for scientific
+computing in C++. The toolkit defines interfaces for basic data
+structures, such as multidimensional arrays and sparse matrices, commonly
+used in numerical applications. The goal of this package is to provide
+reusable software components that address many of the portability and
+maintenance problems with C++ codes.
+TNT provides a distinction between "interfaces" and "implementations" of
+TNT components. For example, there is a TNT interface for two-dimensional
+arrays which describes how individual elements are accessed and how
+certain information, such as the array dimensions, can be used in
+algorithms; however, there can be several implementations of such an
+interface: one that uses expression templates, or one that uses BLAS
+kernels, or another that is instrumented to provide debugging
+information. By specifying only the interface, applications codes may
+utilize such algorithms, while giving library developers the greatest
+flexibility in employing optimization or portability strategies.
+
+WWW: http://math.nist.gov/tnt/
diff --git a/devel/tnt/pkg-plist b/devel/tnt/pkg-plist
new file mode 100644
index 000000000000..c01d099391be
--- /dev/null
+++ b/devel/tnt/pkg-plist
@@ -0,0 +1,93 @@
+include/tnt/tnt.h
+include/tnt/tnt_array1d.h
+include/tnt/tnt_array1d_utils.h
+include/tnt/tnt_array2d.h
+include/tnt/tnt_array2d_utils.h
+include/tnt/tnt_array3d.h
+include/tnt/tnt_array3d_utils.h
+include/tnt/tnt_cmat.h
+include/tnt/tnt_fortran_array1d.h
+include/tnt/tnt_fortran_array1d_utils.h
+include/tnt/tnt_fortran_array2d.h
+include/tnt/tnt_fortran_array2d_utils.h
+include/tnt/tnt_fortran_array3d.h
+include/tnt/tnt_fortran_array3d_utils.h
+include/tnt/tnt_math_utils.h
+include/tnt/tnt_sparse_matrix_csr.h
+include/tnt/tnt_stopwatch.h
+include/tnt/tnt_subscript.h
+include/tnt/tnt_vec.h
+include/tnt/tnt_version.h
+@dirrm include/tnt/
+%%PORTDOCS%%%%DOCSDIR%%/html/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Array1D-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Array1D.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Array2D-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Array2D.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Array3D-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Array3D.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Fortran_Array1D-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Fortran_Array1D.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Fortran_Array2D-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Fortran_Array2D.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Fortran_Array3D-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Fortran_Array3D.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Matrix-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Matrix.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Sparse_Matrix_CompRow-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Sparse_Matrix_CompRow.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Stopwatch-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Stopwatch.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Vector-members.html
+%%PORTDOCS%%%%DOCSDIR%%/html/class_TNT__Vector.html
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/files.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/namespace_TNT.html
+%%PORTDOCS%%%%DOCSDIR%%/html/namespacemembers.html
+%%PORTDOCS%%%%DOCSDIR%%/html/namespaces.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array1d_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array1d_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array1d_utils_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array1d_utils_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array2d_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array2d_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array2d_utils_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array2d_utils_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array3d_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array3d_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array3d_utils_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_array3d_utils_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_cmat_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_cmat_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array1d_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array1d_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array1d_utils_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array1d_utils_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array2d_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array2d_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array2d_utils_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array2d_utils_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array3d_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array3d_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array3d_utils_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_fortran_array3d_utils_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_math_utils_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_math_utils_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_sparse_matrix_csr_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_sparse_matrix_csr_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_stopwatch_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_stopwatch_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_subscript_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_subscript_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_vec_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_vec_h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_version_h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tnt_version_h.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/