aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--net-im/Makefile2
-rw-r--r--net-im/sim-im/Makefile37
-rw-r--r--net-im/sim-im/distinfo6
-rw-r--r--net-im/sim-im/files/patch-configure10
-rw-r--r--net-im/sim-im/files/patch-sim-api-fetch.cpp11
-rw-r--r--net-im/sim-im/files/patch-weather.cpp22
-rw-r--r--net-im/sim-im/pkg-descr2
-rw-r--r--net-im/sim-im/pkg-plist99
-rw-r--r--net-im/simicq/Makefile65
-rw-r--r--net-im/simicq/distinfo3
-rw-r--r--net-im/simicq/files/patch-configure10
-rw-r--r--net-im/simicq/files/patch-sim-api-fetch.cpp11
-rw-r--r--net-im/simicq/files/patch-weather.cpp22
-rw-r--r--net-im/simicq/pkg-descr17
-rw-r--r--net-im/simicq/pkg-plist179
16 files changed, 98 insertions, 399 deletions
diff --git a/MOVED b/MOVED
index 4da067c6b921..95e49ec86474 100644
--- a/MOVED
+++ b/MOVED
@@ -2413,3 +2413,4 @@ www/p5-Catalyst|www/p5-Catalyst-Runtime|2006-07-10|follow CPAN split of package
textproc/p5-JSON-Syck|textproc/p5-YAML-Syck|2006-07-12|The textproc/p5-YAML-Syck port now includes JSON functionality
sysutils/ledit||2006-07-14|Has expired: Does not build
x11/settitle||2006-07-14|Has expired: Download unavailable anymore
+net-im/simicq|net-im/sim-im|2006-07-15|renamed
diff --git a/net-im/Makefile b/net-im/Makefile
index fd8e3d2efd03..c1dd8b58563a 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -108,8 +108,8 @@
SUBDIR += py-xmpppy-irc
SUBDIR += ruby-xmpp4r
SUBDIR += sendxmpp
+ SUBDIR += sim-im
SUBDIR += sim-im-devel
- SUBDIR += simicq
SUBDIR += sulci
SUBDIR += tik
SUBDIR += tkabber
diff --git a/net-im/sim-im/Makefile b/net-im/sim-im/Makefile
index c3dacdfcf3e1..bb7809dacd40 100644
--- a/net-im/sim-im/Makefile
+++ b/net-im/sim-im/Makefile
@@ -1,39 +1,36 @@
-# New Ports Collection Makefile for: sim-icq
+# New Ports Collection Makefile for: sim-im
# Date created: 4 Nov 2002
# Whom: Josef El-Rayes <j.el-rayes@daemon.li>
#
# $FreeBSD$
-PORTNAME= simicq
-PORTVERSION= 0.9.3
-PORTREVISION= 5
+PORTNAME= sim-im
+PORTVERSION= 0.9.4
CATEGORIES= net-im kde
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
-DISTNAME= ${PORTNAME:S/icq//}-${PORTVERSION}-2
+MASTER_SITES= ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME:S/-im//}-${PORTVERSION}
MAINTAINER= markus@FreeBSD.org
COMMENT= Plugin-based instant messenger
LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-WRKSRC= ${WRKDIR}/${DISTNAME:S/-2//}
+CONFLICTS= simicq-[0-9]* sim-im-devel-[0-9]*
+
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+
+USE_BZIP2= yes
USE_GMAKE= yes
USE_QT_VER= 3
USE_PERL5_BUILD=yes
USE_AUTOTOOLS= libtool:15
+USE_OPENSSL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-PLIST_SUB+= SSL=""
-.else
-CONFIGURE_ARGS+=--disable-openssl
-PLIST_SUB+= SSL="@comment "
-.endif
-
.if defined(WITHOUT_KDE)
CONFIGURE_ARGS+=--disable-kde --enable-mt
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
@@ -46,20 +43,14 @@ PLIST_SUB+= KDE="" \
.endif
pre-everything::
-.if !defined(WITHOUT_SSL)
- @${ECHO_MSG} "You can disable SSL support by defining WITHOUT_SSL."
-.endif
.if !defined(WITHOUT_KDE)
@${ECHO_MSG} "You can disable KDE support by defining WITHOUT_KDE."
.endif
post-patch:
+.if defined(WITHOUT_KDE)
@${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
${CONFIGURE_WRKSRC}/configure
-
-post-configure:
-.if defined(WITHOUT_SSL)
- @${REINPLACE_CMD} -e 's|plugins/yahoo||g' ${WRKSRC}/Makefile
.endif
.include <bsd.port.mk>
diff --git a/net-im/sim-im/distinfo b/net-im/sim-im/distinfo
index ac693bfec41d..a87f71b35d95 100644
--- a/net-im/sim-im/distinfo
+++ b/net-im/sim-im/distinfo
@@ -1,3 +1,3 @@
-MD5 (sim-0.9.3-2.tar.gz) = b16e462076540acc13da81832ae79d00
-SHA256 (sim-0.9.3-2.tar.gz) = 38241297d052ee15bfb2536ddef8c0e16804ae665cca7541a0f2f4f76894e450
-SIZE (sim-0.9.3-2.tar.gz) = 3728770
+MD5 (sim-0.9.4.tar.bz2) = 1a54b2b7a7f34d7dc7a218fd1c699e49
+SHA256 (sim-0.9.4.tar.bz2) = d751583a21d41f4ddc1eb67cdbc813988cdb06886f810dc094c53cd2807ca8ee
+SIZE (sim-0.9.4.tar.bz2) = 3358617
diff --git a/net-im/sim-im/files/patch-configure b/net-im/sim-im/files/patch-configure
deleted file mode 100644
index dc006c222265..000000000000
--- a/net-im/sim-im/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Tue Nov 4 09:52:54 2003
-+++ configure Tue Nov 4 09:53:21 2003
-@@ -19002,6 +19002,7 @@
- ;;
- freebsd*)
- CPPFLAGS="$CPPFLAGS -D_THREAD_SAFE"
-+ LIBS="$LIBS -lpthread"
- echo "Setting FreeBSD pthread compilation options"
- ;;
- aix*)
diff --git a/net-im/sim-im/files/patch-sim-api-fetch.cpp b/net-im/sim-im/files/patch-sim-api-fetch.cpp
deleted file mode 100644
index 982bc837c1dd..000000000000
--- a/net-im/sim-im/files/patch-sim-api-fetch.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- sim/api/fetch.cpp.orig Fri Oct 15 01:17:45 2004
-+++ sim/api/fetch.cpp Fri Oct 15 01:21:31 2004
-@@ -24,6 +24,8 @@
- #include <qthread.h>
- #include <qtimer.h>
-
-+#include <time.h>
-+
- typedef map<my_string, string> HEADERS_MAP;
-
- class FetchThread;
diff --git a/net-im/sim-im/files/patch-weather.cpp b/net-im/sim-im/files/patch-weather.cpp
deleted file mode 100644
index 34f44292749c..000000000000
--- a/net-im/sim-im/files/patch-weather.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- plugins/weather/weather.cpp.orig Fri Apr 2 12:21:54 2004
-+++ plugins/weather/weather.cpp Fri Apr 2 12:23:55 2004
-@@ -534,8 +534,8 @@
- res = res.replace(QRegExp("\\%h"), number(getHumidity()) + "%");
- res = res.replace(QRegExp("\\%w"), number(getWind_speed()) + " " + i18n(getUS()));
- res = res.replace(QRegExp("\\%x"), QString::number(getWind_speed() * 10 / 36) + " " + i18n("m/s"));
-- res = res.replace(QRegExp("\\%g"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust()) + i18n(getUS()) + ")" : "");
-- res = res.replace(QRegExp("\\%y"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust() * 10 / 36) + " " + i18n("m/s") + ")" : "");
-+ res = res.replace(QRegExp("\\%g"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust()) + i18n(getUS()) + ")" : QString(""));
-+ res = res.replace(QRegExp("\\%y"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust() * 10 / 36) + " " + i18n("m/s") + ")" : QString(""));
- res = res.replace(QRegExp("\\%p"), number(getPressure()) + " " + i18n(getUP()));
- res = res.replace(QRegExp("\\%a"), number(getPressure() * 75 / 100));
- res = res.replace(QRegExp("\\%q"), i18n("weather", getPressureD()));
-@@ -545,7 +545,7 @@
- res = res.replace(QRegExp("\\%r"), getSun_raise());
- res = res.replace(QRegExp("\\%s"), getSun_set());
- res = res.replace(QRegExp("\\%c"), i18n_conditions(getConditions()));
-- res = res.replace(QRegExp("\\%v"), i18n("weather", getVisibility()) + (atol(getVisibility()) ? QString(" ") + i18n(getUD()) : ""));
-+ res = res.replace(QRegExp("\\%v"), i18n("weather", getVisibility()) + (atol(getVisibility()) ? QString(" ") + i18n(getUD()) : QString("")));
- return res;
- }
-
diff --git a/net-im/sim-im/pkg-descr b/net-im/sim-im/pkg-descr
index d360feb72d62..54140a34e895 100644
--- a/net-im/sim-im/pkg-descr
+++ b/net-im/sim-im/pkg-descr
@@ -14,4 +14,4 @@ Supported protocols:
* Yahoo!
* LiveJournal
-WWW: http://sim-icq.sourceforge.net/
+WWW: http://sim-im.org/
diff --git a/net-im/sim-im/pkg-plist b/net-im/sim-im/pkg-plist
index 9b7073417bf3..24981d79803c 100644
--- a/net-im/sim-im/pkg-plist
+++ b/net-im/sim-im/pkg-plist
@@ -1,86 +1,123 @@
bin/sim
bin/simctrl
-lib/libsimapi.a
-lib/libsimapi.la
-lib/libsimapi.so
-lib/libsimapi.so.0
-lib/libsimui.a
-lib/libsimui.la
-lib/libsimui.so
-lib/libsimui.so.0
-lib/menu/sim-kde.menu
+lib/libsim.a
+lib/libsim.la
+lib/libsim.so
+lib/libsim.so.0
lib/sim/__homedir.a
+lib/sim/__homedir.la
lib/sim/__homedir.so
lib/sim/__migrate.a
+lib/sim/__migrate.la
lib/sim/__migrate.so
lib/sim/_core.a
+lib/sim/_core.la
lib/sim/_core.so
lib/sim/about.a
+lib/sim/about.la
lib/sim/about.so
lib/sim/action.a
+lib/sim/action.la
lib/sim/action.so
lib/sim/autoaway.a
+lib/sim/autoaway.la
lib/sim/autoaway.so
lib/sim/background.a
+lib/sim/background.la
lib/sim/background.so
lib/sim/dock.a
+lib/sim/dock.la
lib/sim/dock.so
lib/sim/filter.a
+lib/sim/filter.la
lib/sim/filter.so
lib/sim/floaty.a
+lib/sim/floaty.la
lib/sim/floaty.so
lib/sim/forward.a
+lib/sim/forward.la
lib/sim/forward.so
lib/sim/gpg.a
+lib/sim/gpg.la
lib/sim/gpg.so
lib/sim/icons.a
+lib/sim/icons.la
lib/sim/icons.so
lib/sim/icq.a
+lib/sim/icq.la
lib/sim/icq.so
lib/sim/jabber.a
+lib/sim/jabber.la
lib/sim/jabber.so
lib/sim/livejournal.a
+lib/sim/livejournal.la
lib/sim/livejournal.so
lib/sim/logger.a
+lib/sim/logger.la
lib/sim/logger.so
-%%SSL%%lib/sim/msn.a
-%%SSL%%lib/sim/msn.so
+lib/sim/msn.a
+lib/sim/msn.la
+lib/sim/msn.so
lib/sim/navigate.a
+lib/sim/navigate.la
lib/sim/navigate.so
lib/sim/netmonitor.a
+lib/sim/netmonitor.la
lib/sim/netmonitor.so
%%KDE%%lib/sim/ontop.a
+%%KDE%%lib/sim/ontop.la
%%KDE%%lib/sim/ontop.so
lib/sim/osd.a
+lib/sim/osd.la
lib/sim/osd.so
lib/sim/proxy.a
+lib/sim/proxy.la
lib/sim/proxy.so
lib/sim/remote.a
+lib/sim/remote.la
lib/sim/remote.so
lib/sim/replace.a
+lib/sim/replace.la
lib/sim/replace.so
lib/sim/shortcuts.a
+lib/sim/shortcuts.la
lib/sim/shortcuts.so
+lib/sim/sms.a
+lib/sim/sms.la
+lib/sim/sms.so
lib/sim/sound.a
+lib/sim/sound.la
lib/sim/sound.so
%%SPELL%%lib/sim/spell.a
+%%SPELL%%lib/sim/spell.la
%%SPELL%%lib/sim/spell.so
lib/sim/splash.a
+lib/sim/splash.la
lib/sim/splash.so
lib/sim/styles.a
+lib/sim/styles.la
lib/sim/styles.so
%%KDE%%lib/sim/transparent.a
+%%KDE%%lib/sim/transparent.la
%%KDE%%lib/sim/transparent.so
-lib/sim/update.a
-lib/sim/update.so
lib/sim/weather.a
+lib/sim/weather.la
lib/sim/weather.so
-%%SSL%%lib/sim/yahoo.a
-%%SSL%%lib/sim/yahoo.so
+lib/sim/yahoo.a
+lib/sim/yahoo.la
+lib/sim/yahoo.so
lib/sim/zodiak.a
+lib/sim/zodiak.la
lib/sim/zodiak.so
-share/applnk/Internet/sim.desktop
+share/applications/kde/sim.desktop
share/apps/sim/COPYING
+share/apps/sim/icons/additional.jisp
+share/apps/sim/icons/icq5.1.jisp
+share/apps/sim/icons/icq5.jisp
+share/apps/sim/icons/icqlite.jisp
+share/apps/sim/icons/sim.jisp
+share/apps/sim/icons/smiles.jisp
+share/apps/sim/icons/weather.jisp
share/apps/sim/pict/connect.gif
share/apps/sim/pict/connect.mng
share/apps/sim/pict/splash.png
@@ -94,6 +131,7 @@ share/apps/sim/sounds/mailpager.wav
share/apps/sim/sounds/message.wav
share/apps/sim/sounds/message2.wav
share/apps/sim/sounds/msgsent.wav
+share/apps/sim/sounds/phone.wav
share/apps/sim/sounds/sms.wav
share/apps/sim/sounds/startup.wav
share/apps/sim/sounds/system.wav
@@ -103,6 +141,9 @@ share/apps/sim/sounds/web.wav
share/apps/sim/styles/SIM.2.xsl
share/apps/sim/styles/SIM.3.xsl
share/apps/sim/styles/SIM.4.(2+3).xsl
+share/apps/sim/styles/SIM.5.2.2.xsl
+share/apps/sim/styles/SIM.5.2.xsl
+share/apps/sim/styles/SIM.5.xsl
share/apps/sim/styles/SIM.xsl
share/apps/sim/styles/Separated.2.xsl
share/apps/sim/styles/Separated.3.xsl
@@ -138,7 +179,9 @@ share/locale/pl/LC_MESSAGES/sim.mo
share/locale/pt_BR/LC_MESSAGES/sim.mo
share/locale/ru/LC_MESSAGES/sim.mo
share/locale/sk/LC_MESSAGES/sim.mo
+share/locale/sv/LC_MESSAGES/sim.mo
share/locale/sw/LC_MESSAGES/sim.mo
+share/locale/th/LC_MESSAGES/sim.mo
share/locale/tr/LC_MESSAGES/sim.mo
share/locale/uk/LC_MESSAGES/sim.mo
share/locale/zh_TW/LC_MESSAGES/sim.mo
@@ -147,6 +190,22 @@ share/services/simctrl.desktop
@dirrmtry share/services
@dirrmtry share/mimelnk/application
@dirrmtry share/mimelnk
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sw/LC_MESSAGES
+@dirrmtry share/locale/sw
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
@dirrmtry share/icons/locolor/32x32/apps
@dirrmtry share/icons/locolor/32x32
@dirrmtry share/icons/locolor/22x22/apps
@@ -166,14 +225,12 @@ share/services/simctrl.desktop
@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
-@dirrmtry share/locale/sw/LC_MESSAGES
-@dirrmtry share/locale/sw
@dirrm share/apps/sim/styles
@dirrm share/apps/sim/sounds
@dirrm share/apps/sim/pict
+@dirrm share/apps/sim/icons
@dirrm share/apps/sim
@dirrmtry share/apps
-@dirrmtry share/applnk/Internet
-@dirrmtry share/applnk
+@dirrmtry share/applications/kde
+@dirrmtry share/applications
@dirrm lib/sim
-@dirrmtry lib/menu
diff --git a/net-im/simicq/Makefile b/net-im/simicq/Makefile
deleted file mode 100644
index c3dacdfcf3e1..000000000000
--- a/net-im/simicq/Makefile
+++ /dev/null
@@ -1,65 +0,0 @@
-# New Ports Collection Makefile for: sim-icq
-# Date created: 4 Nov 2002
-# Whom: Josef El-Rayes <j.el-rayes@daemon.li>
-#
-# $FreeBSD$
-
-PORTNAME= simicq
-PORTVERSION= 0.9.3
-PORTREVISION= 5
-CATEGORIES= net-im kde
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
-DISTNAME= ${PORTNAME:S/icq//}-${PORTVERSION}-2
-
-MAINTAINER= markus@FreeBSD.org
-COMMENT= Plugin-based instant messenger
-
-LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt
-
-WRKSRC= ${WRKDIR}/${DISTNAME:S/-2//}
-USE_GMAKE= yes
-USE_QT_VER= 3
-USE_PERL5_BUILD=yes
-USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
-
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-PLIST_SUB+= SSL=""
-.else
-CONFIGURE_ARGS+=--disable-openssl
-PLIST_SUB+= SSL="@comment "
-.endif
-
-.if defined(WITHOUT_KDE)
-CONFIGURE_ARGS+=--disable-kde --enable-mt
-LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
-PLIST_SUB+= KDE="@comment " \
- SPELL=""
-.else
-USE_KDELIBS_VER=3
-PLIST_SUB+= KDE="" \
- SPELL="@comment "
-.endif
-
-pre-everything::
-.if !defined(WITHOUT_SSL)
- @${ECHO_MSG} "You can disable SSL support by defining WITHOUT_SSL."
-.endif
-.if !defined(WITHOUT_KDE)
- @${ECHO_MSG} "You can disable KDE support by defining WITHOUT_KDE."
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
- ${CONFIGURE_WRKSRC}/configure
-
-post-configure:
-.if defined(WITHOUT_SSL)
- @${REINPLACE_CMD} -e 's|plugins/yahoo||g' ${WRKSRC}/Makefile
-.endif
-
-.include <bsd.port.mk>
diff --git a/net-im/simicq/distinfo b/net-im/simicq/distinfo
deleted file mode 100644
index ac693bfec41d..000000000000
--- a/net-im/simicq/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (sim-0.9.3-2.tar.gz) = b16e462076540acc13da81832ae79d00
-SHA256 (sim-0.9.3-2.tar.gz) = 38241297d052ee15bfb2536ddef8c0e16804ae665cca7541a0f2f4f76894e450
-SIZE (sim-0.9.3-2.tar.gz) = 3728770
diff --git a/net-im/simicq/files/patch-configure b/net-im/simicq/files/patch-configure
deleted file mode 100644
index dc006c222265..000000000000
--- a/net-im/simicq/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Tue Nov 4 09:52:54 2003
-+++ configure Tue Nov 4 09:53:21 2003
-@@ -19002,6 +19002,7 @@
- ;;
- freebsd*)
- CPPFLAGS="$CPPFLAGS -D_THREAD_SAFE"
-+ LIBS="$LIBS -lpthread"
- echo "Setting FreeBSD pthread compilation options"
- ;;
- aix*)
diff --git a/net-im/simicq/files/patch-sim-api-fetch.cpp b/net-im/simicq/files/patch-sim-api-fetch.cpp
deleted file mode 100644
index 982bc837c1dd..000000000000
--- a/net-im/simicq/files/patch-sim-api-fetch.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- sim/api/fetch.cpp.orig Fri Oct 15 01:17:45 2004
-+++ sim/api/fetch.cpp Fri Oct 15 01:21:31 2004
-@@ -24,6 +24,8 @@
- #include <qthread.h>
- #include <qtimer.h>
-
-+#include <time.h>
-+
- typedef map<my_string, string> HEADERS_MAP;
-
- class FetchThread;
diff --git a/net-im/simicq/files/patch-weather.cpp b/net-im/simicq/files/patch-weather.cpp
deleted file mode 100644
index 34f44292749c..000000000000
--- a/net-im/simicq/files/patch-weather.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- plugins/weather/weather.cpp.orig Fri Apr 2 12:21:54 2004
-+++ plugins/weather/weather.cpp Fri Apr 2 12:23:55 2004
-@@ -534,8 +534,8 @@
- res = res.replace(QRegExp("\\%h"), number(getHumidity()) + "%");
- res = res.replace(QRegExp("\\%w"), number(getWind_speed()) + " " + i18n(getUS()));
- res = res.replace(QRegExp("\\%x"), QString::number(getWind_speed() * 10 / 36) + " " + i18n("m/s"));
-- res = res.replace(QRegExp("\\%g"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust()) + i18n(getUS()) + ")" : "");
-- res = res.replace(QRegExp("\\%y"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust() * 10 / 36) + " " + i18n("m/s") + ")" : "");
-+ res = res.replace(QRegExp("\\%g"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust()) + i18n(getUS()) + ")" : QString(""));
-+ res = res.replace(QRegExp("\\%y"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust() * 10 / 36) + " " + i18n("m/s") + ")" : QString(""));
- res = res.replace(QRegExp("\\%p"), number(getPressure()) + " " + i18n(getUP()));
- res = res.replace(QRegExp("\\%a"), number(getPressure() * 75 / 100));
- res = res.replace(QRegExp("\\%q"), i18n("weather", getPressureD()));
-@@ -545,7 +545,7 @@
- res = res.replace(QRegExp("\\%r"), getSun_raise());
- res = res.replace(QRegExp("\\%s"), getSun_set());
- res = res.replace(QRegExp("\\%c"), i18n_conditions(getConditions()));
-- res = res.replace(QRegExp("\\%v"), i18n("weather", getVisibility()) + (atol(getVisibility()) ? QString(" ") + i18n(getUD()) : ""));
-+ res = res.replace(QRegExp("\\%v"), i18n("weather", getVisibility()) + (atol(getVisibility()) ? QString(" ") + i18n(getUD()) : QString("")));
- return res;
- }
-
diff --git a/net-im/simicq/pkg-descr b/net-im/simicq/pkg-descr
deleted file mode 100644
index d360feb72d62..000000000000
--- a/net-im/simicq/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-SIM (Simple Instant Messenger) is a plugin-based instant messenger with
-support for various protocols (QT is needed, can be build for KDE).
-
-All protocols support richtext-messages, file transfer, typing notification,
-server-side contact list (with postponed synchronization - you can change
-contact list in offline mode and after log on all changes will be
-synchronized with server), new account registration and various searches.
-You can use several accounts for each protocol.
-
-Supported protocols:
- * Oscar - ICQ and AIM support
- * Jabber
- * MSN
- * Yahoo!
- * LiveJournal
-
-WWW: http://sim-icq.sourceforge.net/
diff --git a/net-im/simicq/pkg-plist b/net-im/simicq/pkg-plist
deleted file mode 100644
index 9b7073417bf3..000000000000
--- a/net-im/simicq/pkg-plist
+++ /dev/null
@@ -1,179 +0,0 @@
-bin/sim
-bin/simctrl
-lib/libsimapi.a
-lib/libsimapi.la
-lib/libsimapi.so
-lib/libsimapi.so.0
-lib/libsimui.a
-lib/libsimui.la
-lib/libsimui.so
-lib/libsimui.so.0
-lib/menu/sim-kde.menu
-lib/sim/__homedir.a
-lib/sim/__homedir.so
-lib/sim/__migrate.a
-lib/sim/__migrate.so
-lib/sim/_core.a
-lib/sim/_core.so
-lib/sim/about.a
-lib/sim/about.so
-lib/sim/action.a
-lib/sim/action.so
-lib/sim/autoaway.a
-lib/sim/autoaway.so
-lib/sim/background.a
-lib/sim/background.so
-lib/sim/dock.a
-lib/sim/dock.so
-lib/sim/filter.a
-lib/sim/filter.so
-lib/sim/floaty.a
-lib/sim/floaty.so
-lib/sim/forward.a
-lib/sim/forward.so
-lib/sim/gpg.a
-lib/sim/gpg.so
-lib/sim/icons.a
-lib/sim/icons.so
-lib/sim/icq.a
-lib/sim/icq.so
-lib/sim/jabber.a
-lib/sim/jabber.so
-lib/sim/livejournal.a
-lib/sim/livejournal.so
-lib/sim/logger.a
-lib/sim/logger.so
-%%SSL%%lib/sim/msn.a
-%%SSL%%lib/sim/msn.so
-lib/sim/navigate.a
-lib/sim/navigate.so
-lib/sim/netmonitor.a
-lib/sim/netmonitor.so
-%%KDE%%lib/sim/ontop.a
-%%KDE%%lib/sim/ontop.so
-lib/sim/osd.a
-lib/sim/osd.so
-lib/sim/proxy.a
-lib/sim/proxy.so
-lib/sim/remote.a
-lib/sim/remote.so
-lib/sim/replace.a
-lib/sim/replace.so
-lib/sim/shortcuts.a
-lib/sim/shortcuts.so
-lib/sim/sound.a
-lib/sim/sound.so
-%%SPELL%%lib/sim/spell.a
-%%SPELL%%lib/sim/spell.so
-lib/sim/splash.a
-lib/sim/splash.so
-lib/sim/styles.a
-lib/sim/styles.so
-%%KDE%%lib/sim/transparent.a
-%%KDE%%lib/sim/transparent.so
-lib/sim/update.a
-lib/sim/update.so
-lib/sim/weather.a
-lib/sim/weather.so
-%%SSL%%lib/sim/yahoo.a
-%%SSL%%lib/sim/yahoo.so
-lib/sim/zodiak.a
-lib/sim/zodiak.so
-share/applnk/Internet/sim.desktop
-share/apps/sim/COPYING
-share/apps/sim/pict/connect.gif
-share/apps/sim/pict/connect.mng
-share/apps/sim/pict/splash.png
-share/apps/sim/sounds/alert.wav
-share/apps/sim/sounds/auth.wav
-share/apps/sim/sounds/contacts.wav
-share/apps/sim/sounds/error.wav
-share/apps/sim/sounds/file.wav
-share/apps/sim/sounds/filedone.wav
-share/apps/sim/sounds/mailpager.wav
-share/apps/sim/sounds/message.wav
-share/apps/sim/sounds/message2.wav
-share/apps/sim/sounds/msgsent.wav
-share/apps/sim/sounds/sms.wav
-share/apps/sim/sounds/startup.wav
-share/apps/sim/sounds/system.wav
-share/apps/sim/sounds/url.wav
-share/apps/sim/sounds/vip-online.wav
-share/apps/sim/sounds/web.wav
-share/apps/sim/styles/SIM.2.xsl
-share/apps/sim/styles/SIM.3.xsl
-share/apps/sim/styles/SIM.4.(2+3).xsl
-share/apps/sim/styles/SIM.xsl
-share/apps/sim/styles/Separated.2.xsl
-share/apps/sim/styles/Separated.3.xsl
-share/apps/sim/styles/Separated.4.xsl
-share/apps/sim/styles/Separated.5.(2+3).xsl
-share/apps/sim/styles/Separated.6.(2+4).xsl
-share/apps/sim/styles/Separated.7.(3+4).xsl
-share/apps/sim/styles/Separated.8.(2+3+4).xsl
-share/apps/sim/styles/Separated.xsl
-share/apps/sim/styles/XChat.xsl
-share/apps/sim/styles/XChat2seconds.xsl
-share/apps/sim/styles/XChat3fullDate.xsl
-share/icons/hicolor/16x16/apps/sim.png
-share/icons/hicolor/22x22/apps/sim.png
-share/icons/hicolor/32x32/apps/sim.png
-share/icons/hicolor/48x48/apps/sim.png
-share/icons/hicolor/64x64/apps/sim.png
-share/icons/locolor/16x16/apps/sim.png
-share/icons/locolor/22x22/apps/sim.png
-share/icons/locolor/32x32/apps/sim.png
-share/locale/bg/LC_MESSAGES/sim.mo
-share/locale/ca/LC_MESSAGES/sim.mo
-share/locale/cs/LC_MESSAGES/sim.mo
-share/locale/de/LC_MESSAGES/sim.mo
-share/locale/el/LC_MESSAGES/sim.mo
-share/locale/es/LC_MESSAGES/sim.mo
-share/locale/fr/LC_MESSAGES/sim.mo
-share/locale/he/LC_MESSAGES/sim.mo
-share/locale/hu/LC_MESSAGES/sim.mo
-share/locale/it/LC_MESSAGES/sim.mo
-share/locale/nl/LC_MESSAGES/sim.mo
-share/locale/pl/LC_MESSAGES/sim.mo
-share/locale/pt_BR/LC_MESSAGES/sim.mo
-share/locale/ru/LC_MESSAGES/sim.mo
-share/locale/sk/LC_MESSAGES/sim.mo
-share/locale/sw/LC_MESSAGES/sim.mo
-share/locale/tr/LC_MESSAGES/sim.mo
-share/locale/uk/LC_MESSAGES/sim.mo
-share/locale/zh_TW/LC_MESSAGES/sim.mo
-share/mimelnk/application/x-icq.desktop
-share/services/simctrl.desktop
-@dirrmtry share/services
-@dirrmtry share/mimelnk/application
-@dirrmtry share/mimelnk
-@dirrmtry share/icons/locolor/32x32/apps
-@dirrmtry share/icons/locolor/32x32
-@dirrmtry share/icons/locolor/22x22/apps
-@dirrmtry share/icons/locolor/22x22
-@dirrmtry share/icons/locolor/16x16/apps
-@dirrmtry share/icons/locolor/16x16
-@dirrmtry share/icons/locolor
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/64x64
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/22x22/apps
-@dirrmtry share/icons/hicolor/22x22
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
-@dirrmtry share/locale/sw/LC_MESSAGES
-@dirrmtry share/locale/sw
-@dirrm share/apps/sim/styles
-@dirrm share/apps/sim/sounds
-@dirrm share/apps/sim/pict
-@dirrm share/apps/sim
-@dirrmtry share/apps
-@dirrmtry share/applnk/Internet
-@dirrmtry share/applnk
-@dirrm lib/sim
-@dirrmtry lib/menu