aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile3
-rw-r--r--audio/abraca/Makefile2
-rw-r--r--audio/azrael/Makefile30
-rw-r--r--audio/azrael/distinfo3
-rw-r--r--audio/azrael/pkg-descr6
-rw-r--r--audio/cpp-xmms2/Makefile2
-rw-r--r--audio/cpp-xmms2/pkg-plist6
-rw-r--r--audio/esperanza/Makefile4
-rw-r--r--audio/gx2osd/Makefile8
-rw-r--r--audio/gxmms2/Makefile9
-rw-r--r--audio/gxmms2/distinfo6
-rw-r--r--audio/gxmms2/pkg-descr2
-rw-r--r--audio/java-xmms2/Makefile33
-rw-r--r--audio/java-xmms2/pkg-plist2
-rw-r--r--audio/nyello/Makefile30
-rw-r--r--audio/nyello/distinfo3
-rw-r--r--audio/nyello/pkg-descr13
-rw-r--r--audio/p5-xmms2/Makefile2
-rw-r--r--audio/py-xmms2/Makefile2
-rw-r--r--audio/py-xmms2/pkg-plist6
-rw-r--r--audio/ruby-xmms2/Makefile2
-rw-r--r--audio/xmms2-scrobbler/Makefile4
-rw-r--r--audio/xmms2/Makefile14
-rw-r--r--audio/xmms2/distinfo6
-rw-r--r--audio/xmms2/files/patch-src_clients_lib_python_xmmsapi.pyx102
-rw-r--r--audio/xmms2/files/slaveport-src-clients-lib-wscripts90
-rw-r--r--audio/xmms2/files/slaveport-wscript18
-rw-r--r--audio/xmms2/pkg-plist47
28 files changed, 174 insertions, 281 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 3ac9bb129804..d2ce2c29992a 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -51,7 +51,6 @@
SUBDIR += autocd
SUBDIR += autozen
SUBDIR += aylet
- SUBDIR += azrael
SUBDIR += baudline
SUBDIR += beast
SUBDIR += bebocd
@@ -297,7 +296,6 @@
SUBDIR += jack-keyboard
SUBDIR += jack-rack
SUBDIR += jamin
- SUBDIR += java-xmms2
SUBDIR += jid3lib
SUBDIR += jmusic
SUBDIR += juk
@@ -441,7 +439,6 @@
SUBDIR += normalize
SUBDIR += nosefart
SUBDIR += nspmod
- SUBDIR += nyello
SUBDIR += ocp
SUBDIR += ogg2mp3
SUBDIR += oggsplit
diff --git a/audio/abraca/Makefile b/audio/abraca/Makefile
index ac30257c031d..f10ba4961f97 100644
--- a/audio/abraca/Makefile
+++ b/audio/abraca/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://nooms.de/media/abraca/
MAINTAINER= olivier@gid0.org
COMMENT= Abraca is a GTK2 client for the XMMS2 music player
-LIB_DEPENDS= xmmsclient.2:${PORTSDIR}/audio/xmms2 \
+LIB_DEPENDS= xmmsclient.3:${PORTSDIR}/audio/xmms2 \
xmmsclient-glib.1:${PORTSDIR}/audio/xmms2
USE_BZIP2= yes
diff --git a/audio/azrael/Makefile b/audio/azrael/Makefile
deleted file mode 100644
index a1550174e82d..000000000000
--- a/audio/azrael/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# New ports collection makefile for: azrael
-# Date created: 25 Aug 2006
-# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= azrael
-PORTVERSION= 0.3.5
-PORTREVISION= 1
-CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= azrael
-
-MAINTAINER= alexbl@FreeBSD.org
-COMMENT= A GTK2 based XMMS2 client, offering a media library interface
-
-BUILD_DEPENDS= ${LOCALBASE}/lib/libxmmsclient.so:${PORTSDIR}/audio/xmms2
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_GNOME= gtk20
-
-PLIST_FILES=bin/azrael
-
-BROKEN= Not updated to the DrJekyll clientlib API
-
-.include <bsd.port.mk>
diff --git a/audio/azrael/distinfo b/audio/azrael/distinfo
deleted file mode 100644
index 43577ebd7a11..000000000000
--- a/audio/azrael/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (azrael-0.3.5.tar.bz2) = 7e20d0f54a44a4c139c53f8e4db17640
-SHA256 (azrael-0.3.5.tar.bz2) = d24ed7c6c12b7afb649885ab0626b741b5cedb528d64acf4abf86e9d59a2227f
-SIZE (azrael-0.3.5.tar.bz2) = 19532
diff --git a/audio/azrael/pkg-descr b/audio/azrael/pkg-descr
deleted file mode 100644
index 2ad820352bfd..000000000000
--- a/audio/azrael/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Azrael is a client for XMMS2. It is written in C and uses GTK.
-
-Features include:
- * LCD for elapsed time,
- * Nice display of song information
- * Interfaces to the playlist and media library
diff --git a/audio/cpp-xmms2/Makefile b/audio/cpp-xmms2/Makefile
index 895da38e2384..7f34b09a88aa 100644
--- a/audio/cpp-xmms2/Makefile
+++ b/audio/cpp-xmms2/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= alexbl@FreeBSD.org
COMMENT= C++ Bindings for XMMS2
LIB_DEPENDS+= boost_signals.4:${PORTSDIR}/devel/boost \
- xmmsclient.2:${PORTSDIR}/audio/xmms2
+ xmmsclient.3:${PORTSDIR}/audio/xmms2
MASTERDIR= ${.CURDIR}/../xmms2
USE_LDCONFIG= yes
diff --git a/audio/cpp-xmms2/pkg-plist b/audio/cpp-xmms2/pkg-plist
index c62d23acf1c7..c3c1adf9f4dc 100644
--- a/audio/cpp-xmms2/pkg-plist
+++ b/audio/cpp-xmms2/pkg-plist
@@ -1,8 +1,8 @@
-lib/libxmmsclient++.so
-lib/libxmmsclient++.so.1
-lib/libxmmsclient++.so.1.0.0
lib/libxmmsclient++-glib.so
lib/libxmmsclient++-glib.so.1
lib/libxmmsclient++-glib.so.1.0.0
+lib/libxmmsclient++.so
+lib/libxmmsclient++.so.2
+lib/libxmmsclient++.so.2.0.0
libdata/pkgconfig/xmms2-client-cpp-glib.pc
libdata/pkgconfig/xmms2-client-cpp.pc
diff --git a/audio/esperanza/Makefile b/audio/esperanza/Makefile
index e60cf35b4491..0e0fef559f0b 100644
--- a/audio/esperanza/Makefile
+++ b/audio/esperanza/Makefile
@@ -13,8 +13,8 @@ MASTER_SITES= http://xmms2.xmms.se/~tru/esperanza/0.3/
MAINTAINER= alexbl@FreeBSD.org
COMMENT= Advanced QT4 XMMS2 client
-BUILD_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so.1:${PORTSDIR}/audio/cpp-xmms2
-RUN_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so.1:${PORTSDIR}/audio/cpp-xmms2
+BUILD_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so.2:${PORTSDIR}/audio/cpp-xmms2
+RUN_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so.2:${PORTSDIR}/audio/cpp-xmms2
USE_QT_VER= 4
QT_COMPONENTS= gui moc qmake rcc uic xml network imageformats
diff --git a/audio/gx2osd/Makefile b/audio/gx2osd/Makefile
index af130dd7907b..79450b157bef 100644
--- a/audio/gx2osd/Makefile
+++ b/audio/gx2osd/Makefile
@@ -13,10 +13,10 @@ MAINTAINER= alexbl@FreeBSD.org
COMMENT= An OSD client for XMMS2
LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
- glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
- xerces-c.27:${PORTSDIR}/textproc/xerces-c2
-BUILD_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so.1:${PORTSDIR}/audio/cpp-xmms2
-RUN_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so.1:${PORTSDIR}/audio/cpp-xmms2
+ glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
+ xerces-c.27:${PORTSDIR}/textproc/xerces-c2
+BUILD_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so.2:${PORTSDIR}/audio/cpp-xmms2
+RUN_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so.2:${PORTSDIR}/audio/cpp-xmms2
USE_BZIP2= yes
USE_PYTHON_BUILD= yes
diff --git a/audio/gxmms2/Makefile b/audio/gxmms2/Makefile
index 773043854411..a7e607a25934 100644
--- a/audio/gxmms2/Makefile
+++ b/audio/gxmms2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gxmms2
-PORTVERSION= 0.6.5
-PORTREVISION= 1
+PORTVERSION= 0.7.0
CATEGORIES= audio
MASTER_SITES= http://wejp.k.vu/projects/xmms2/
@@ -22,10 +21,8 @@ USE_GMAKE= yes
ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/gxmms2 \
- %%DATADIR%%/gxmms2_mini.xpm
-PLIST_DIRS= %%DATADIR%%
-
-BROKEN= Not updated to DrJekyll clientlib API
+ %%DATADIR%%/gxmms2_mini.xpm
+PLIST_DIRS= %%DATADIR%%
.include <bsd.port.pre.mk>
diff --git a/audio/gxmms2/distinfo b/audio/gxmms2/distinfo
index f5eef2d734c7..ca43121a3f2b 100644
--- a/audio/gxmms2/distinfo
+++ b/audio/gxmms2/distinfo
@@ -1,3 +1,3 @@
-MD5 (gxmms2-0.6.5.tar.gz) = 75a0b6977c84cdfa2e92640c6e73bf36
-SHA256 (gxmms2-0.6.5.tar.gz) = 84b7344d56ee8929809838574d5bfa3138fe9a01448f8748293d6dd68762141b
-SIZE (gxmms2-0.6.5.tar.gz) = 78665
+MD5 (gxmms2-0.7.0.tar.gz) = 5419a977d75e33f201fa63f5c5d196a6
+SHA256 (gxmms2-0.7.0.tar.gz) = 22b3186e625bce45a85f4f08004365944c4797ed6d0b6e2cf2111fcdde0eb5e3
+SIZE (gxmms2-0.7.0.tar.gz) = 75148
diff --git a/audio/gxmms2/pkg-descr b/audio/gxmms2/pkg-descr
index 84fb4979ffde..89acec5b80b1 100644
--- a/audio/gxmms2/pkg-descr
+++ b/audio/gxmms2/pkg-descr
@@ -1,4 +1,4 @@
gxmms2 is a GTK2 based XMMS2 client, written in C. Its main window is small and
simple. It includes a playlist editor and a file details dialog.
-WWW: http://wejp.mooo.com/wejp/xmms2/
+WWW: http://wejp.k.vu/projects/xmms2/
diff --git a/audio/java-xmms2/Makefile b/audio/java-xmms2/Makefile
deleted file mode 100644
index 2fafe0cf3ef9..000000000000
--- a/audio/java-xmms2/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-# New ports collection makefile for: java-xmms2
-# Date created: 18 Mar 2006
-# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
-#
-# $FreeBSD$
-#
-
-PORTREVISION= 2
-CATEGORIES= audio java
-PKGNAMEPREFIX= java-
-
-MAINTAINER= alexbl@FreeBSD.org
-COMMENT= Java Bindings for XMMS2
-
-BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig13 \
- ${LOCALBASE}/lib/libxmmsclient.so:${PORTSDIR}/audio/xmms2
-RUN_DEPENDS+= ${LOCALBASE}/lib/libxmmsclient.so:${PORTSDIR}/audio/xmms2
-
-MASTERDIR= ${.CURDIR}/../xmms2
-
-USE_JAVA= yes
-JAVA_VERSION= 1.4+
-
-USE_LDCONFIG= yes
-PLIST= ${.CURDIR}/pkg-plist
-
-SCONS_BUILDENV= JAVA_HOME=${JAVA_HOME}
-SCONS_TARGET= src/clients/lib/java
-
-BROKEN= Requires Java 1.6 and are no longer included with xmms2
-XMMS2_SLAVE= java
-
-.include "${MASTERDIR}/Makefile"
diff --git a/audio/java-xmms2/pkg-plist b/audio/java-xmms2/pkg-plist
deleted file mode 100644
index fab61a0fc32d..000000000000
--- a/audio/java-xmms2/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/libxmms2java.so
-%%JAVAJARDIR%%/xmms2java.jar
diff --git a/audio/nyello/Makefile b/audio/nyello/Makefile
deleted file mode 100644
index 7ede08c35a3e..000000000000
--- a/audio/nyello/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# New ports collection makefile for: nyello
-# Date created: 03 Mar 2006
-# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= nyello
-PORTVERSION= 0.5.0
-CATEGORIES= audio
-MASTER_SITES= http://sirius.cine7.net/nyello/releases/
-
-MAINTAINER= alexbl@FreeBSD.org
-COMMENT= An advanced command-line interface and shell for xmms2
-
-BUILD_DEPENDS= ${LOCALBASE}/lib/libxmmsclient.so:${PORTSDIR}/audio/xmms2
-RUN_DEPENDS= ${LOCALBASE}/lib/libxmmsclient.so:${PORTSDIR}/audio/xmms2
-
-USE_BZIP2= yes
-GNU_CONFIGURE= yes
-
-CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- CPPFLAGS="${CPPFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
-
-WRKSRC= ${WRKDIR}/${DISTNAME}
-PLIST_FILES= bin/nyello
-
-BROKEN= Not updated to the DrJekyll clientlib API
-
-.include <bsd.port.mk>
diff --git a/audio/nyello/distinfo b/audio/nyello/distinfo
deleted file mode 100644
index b1ba9c51c6fe..000000000000
--- a/audio/nyello/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (nyello-0.5.0.tar.bz2) = 67958b2d62a9b693bafff37a88e3804a
-SHA256 (nyello-0.5.0.tar.bz2) = 2130667117ced8a1e138051bd3e2b464a31578dec832614568069cc9c2cfbf5e
-SIZE (nyello-0.5.0.tar.bz2) = 98871
diff --git a/audio/nyello/pkg-descr b/audio/nyello/pkg-descr
deleted file mode 100644
index dd79d13646e2..000000000000
--- a/audio/nyello/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-nyello is a command-line XMMS2 client.
-
-It aims at providing a high-level interface to the XMMS2 server, with a concise
-and powerful interaction syntax. It boasts (or soon will boast) advanced
-features, such as rich pattern expressions to efficiently browse your library,
-smart completion of commands and custom song collections to organize your
-library.
-
-It can either run a single command or work like a shell (if started without
-argument). As a command-line program, it is mostly targetted at Unix
-power-users.
-
-WWW: http://sirius.cine7.net/nyello/index.php
diff --git a/audio/p5-xmms2/Makefile b/audio/p5-xmms2/Makefile
index cf53993f1219..78e4b7594882 100644
--- a/audio/p5-xmms2/Makefile
+++ b/audio/p5-xmms2/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= alexbl@FreeBSD.org
COMMENT= Perl Bindings for XMMS2
-LIB_DEPENDS+= xmmsclient.2:${PORTSDIR}/audio/xmms2
+LIB_DEPENDS+= xmmsclient.3:${PORTSDIR}/audio/xmms2
MASTERDIR= ${.CURDIR}/../xmms2
diff --git a/audio/py-xmms2/Makefile b/audio/py-xmms2/Makefile
index 7084adcfb8a7..1acdfa841512 100644
--- a/audio/py-xmms2/Makefile
+++ b/audio/py-xmms2/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= alexbl@FreeBSD.org
COMMENT= Python Bindings for XMMS2
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Pyrex/__init__.py:${PORTSDIR}/devel/pyrex
-LIB_DEPENDS+= xmmsclient.2:${PORTSDIR}/audio/xmms2
+LIB_DEPENDS+= xmmsclient.3:${PORTSDIR}/audio/xmms2
MASTERDIR= ${.CURDIR}/../xmms2
diff --git a/audio/py-xmms2/pkg-plist b/audio/py-xmms2/pkg-plist
index f7a7a5440769..645ab38c7f0c 100644
--- a/audio/py-xmms2/pkg-plist
+++ b/audio/py-xmms2/pkg-plist
@@ -1,9 +1,9 @@
%%PYTHON_SITELIBDIR%%/xmmsclient/__init__.py
-%%PYTHON_SITELIBDIR%%/xmmsclient/sync.py
-%%PYTHON_SITELIBDIR%%/xmmsclient/propdict.py
-%%PYTHON_SITELIBDIR%%/xmmsclient/consts.py
%%PYTHON_SITELIBDIR%%/xmmsclient/collections.py
+%%PYTHON_SITELIBDIR%%/xmmsclient/consts.py
%%PYTHON_SITELIBDIR%%/xmmsclient/glib.py
+%%PYTHON_SITELIBDIR%%/xmmsclient/propdict.py
%%PYTHON_SITELIBDIR%%/xmmsclient/qt3.py
+%%PYTHON_SITELIBDIR%%/xmmsclient/sync.py
%%PYTHON_SITELIBDIR%%/xmmsclient/xmmsapi.so
@dirrm %%PYTHON_SITELIBDIR%%/xmmsclient
diff --git a/audio/ruby-xmms2/Makefile b/audio/ruby-xmms2/Makefile
index 261f5591423e..18e4af83b0fd 100644
--- a/audio/ruby-xmms2/Makefile
+++ b/audio/ruby-xmms2/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
MAINTAINER= alexbl@FreeBSD.org
COMMENT= Ruby Bindings for XMMS2
-LIB_DEPENDS+= xmmsclient.2:${PORTSDIR}/audio/xmms2
+LIB_DEPENDS+= xmmsclient.3:${PORTSDIR}/audio/xmms2
MASTERDIR= ${.CURDIR}/../xmms2
diff --git a/audio/xmms2-scrobbler/Makefile b/audio/xmms2-scrobbler/Makefile
index e85182ce0e1f..da1dcebbb54b 100644
--- a/audio/xmms2-scrobbler/Makefile
+++ b/audio/xmms2-scrobbler/Makefile
@@ -22,8 +22,8 @@ USE_RUBY= yes
NO_BUILD= yes
PLIST_FILES= bin/xmms2-scrobbler \
- %%DATADIR%%/filters/britney.rb \
- %%DATADIR%%/filters/musicbrainz.rb
+ %%DATADIR%%/filters/britney.rb \
+ %%DATADIR%%/filters/musicbrainz.rb
PLIST_DIRS= %%DATADIR%%/filters %%DATADIR%%
SUB_FILES= pkg-message
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 5f7a3fe7210d..81c26ca0d12f 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME?= xmms2
-PORTVERSION= 0.2.d.9
-DISTVERSION= 0.2DrJekyll
-PORTREVISION= 2
+PORTVERSION= 0.4.d.0
+DISTVERSION= 0.4DrKosmos
CATEGORIES?= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${DISTVERSION}
MAINTAINER= alexbl@FreeBSD.org
@@ -65,7 +63,9 @@ OPTIONS= FAAD "Support to playback AAC files" on \
.if defined(XMMS2_SLAVE)
EXCLUDE+= --without-xmms2d=1
-EXTRA_PATCHES= ${PATCHDIR}/slaveport-wscript ${PATCHDIR}/slaveport-src_include_wscript
+EXTRA_PATCHES= ${PATCHDIR}/slaveport-wscript\
+ ${PATCHDIR}/slaveport-src_include_wscript\
+ ${PATCHDIR}/slaveport-src-clients-lib-wscripts
.endif
.if defined(XMMS2_SLAVE) && ${XMMS2_SLAVE} == "python"
@@ -253,7 +253,7 @@ PLIST_SUB+= AO="@comment "
BROKEN= You may choose either MDNS_APPLE or MDNS_AVAHI, but not both
.endif
EXCLUDE+= --without-optionals="dns_sd"
-LIB_DEPENDS+= avahi-core:${PORTSDIR}/net/avahi
+LIB_DEPENDS+= avahi-core:${PORTSDIR}/net/avahi-app
PLIST_SUB+= MDNS_AVAHI=""
MAN1+= xmms2-mdns-avahi.1
.else
diff --git a/audio/xmms2/distinfo b/audio/xmms2/distinfo
index d30090122fb7..21c77e755a51 100644
--- a/audio/xmms2/distinfo
+++ b/audio/xmms2/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmms2-0.2DrJekyll.tar.bz2) = 768de76a98b6a9766cec157ff0a12543
-SHA256 (xmms2-0.2DrJekyll.tar.bz2) = 7d46baaeaac50d3f4e6db2d492de4ba8fa4fbaed6d42816df5b57d9116a50ff4
-SIZE (xmms2-0.2DrJekyll.tar.bz2) = 1207014
+MD5 (xmms2-0.4DrKosmos.tar.bz2) = f363857a77606a2d7d14603ab375f454
+SHA256 (xmms2-0.4DrKosmos.tar.bz2) = 0fb76d56a424f1d4bb36bffdf32ed750173a288f406e76dcec2b1f43d6f9783d
+SIZE (xmms2-0.4DrKosmos.tar.bz2) = 1354241
diff --git a/audio/xmms2/files/patch-src_clients_lib_python_xmmsapi.pyx b/audio/xmms2/files/patch-src_clients_lib_python_xmmsapi.pyx
index 7e243d1abecf..e69de29bb2d1 100644
--- a/audio/xmms2/files/patch-src_clients_lib_python_xmmsapi.pyx
+++ b/audio/xmms2/files/patch-src_clients_lib_python_xmmsapi.pyx
@@ -1,102 +0,0 @@
---- src/clients/lib/python/xmmsapi.pyx.orig Sun May 20 08:55:40 2007
-+++ src/clients/lib/python/xmmsapi.pyx Wed Nov 14 15:16:18 2007
-@@ -14,7 +14,7 @@
- void Py_DECREF(object)
-
- cdef extern from "string.h":
-- int strcmp(signed char *s1, signed char *s2)
-+ int strcmp(char *s1, char *s2)
- char *strdup(char *str)
-
- cdef extern from "xmmsc/xmmsc_idnumbers.h":
-@@ -129,17 +129,17 @@
- void xmmsc_result_unref(xmmsc_result_t *res)
- void xmmsc_result_notifier_set_full(xmmsc_result_t *res, xmmsc_result_notifier_t func, void *user_data, xmmsc_user_data_free_func_t free_func)
- void xmmsc_result_wait(xmmsc_result_t *res)
-- signed int xmmsc_result_iserror(xmmsc_result_t *res)
-- signed char *xmmsc_result_get_error(xmmsc_result_t *res)
-+ int xmmsc_result_iserror(xmmsc_result_t *res)
-+ char *xmmsc_result_get_error(xmmsc_result_t *res)
- xmmsc_result_value_type_t xmmsc_result_get_type(xmmsc_result_t *res)
- xmmsc_result_type_t xmmsc_result_get_class(xmmsc_result_t *res)
-
-- signed int xmmsc_result_get_int(xmmsc_result_t *res, int *r)
-- signed int xmmsc_result_get_uint(xmmsc_result_t *res, unsigned int *r)
-- signed int xmmsc_result_get_string(xmmsc_result_t *res, signed char **r)
-- signed int xmmsc_result_get_bin(xmmsc_result_t *res, unsigned char **r, unsigned int *rlen)
-- signed int xmmsc_result_get_playlist_change(xmmsc_result_t *res, unsigned int *change, unsigned int *id, unsigned int *argument)
-- signed int xmmsc_result_get_collection (xmmsc_result_t *conn, xmmsc_coll_t **coll)
-+ int xmmsc_result_get_int(xmmsc_result_t *res, int *r)
-+ int xmmsc_result_get_uint(xmmsc_result_t *res, unsigned int *r)
-+ int xmmsc_result_get_string(xmmsc_result_t *res, char **r)
-+ int xmmsc_result_get_bin(xmmsc_result_t *res, unsigned char **r, unsigned int *rlen)
-+ int xmmsc_result_get_playlist_change(xmmsc_result_t *res, unsigned int *change, unsigned int *id, unsigned int *argument)
-+ int xmmsc_result_get_collection (xmmsc_result_t *conn, xmmsc_coll_t **coll)
-
- ctypedef void(*xmmsc_dict_foreach_func)(void *key, xmmsc_result_value_type_t type, void *value, void *user_data)
- ctypedef void(*xmmsc_propdict_foreach_func)(void *key, xmmsc_result_value_type_t type, void *value, char *source, void *user_data)
-@@ -155,7 +155,7 @@
-
- xmmsc_connection_t *xmmsc_init(char *clientname)
- void xmmsc_disconnect_callback_set(xmmsc_connection_t *c, object(*callback)(object), object userdata)
-- signed int xmmsc_connect(xmmsc_connection_t *c, signed char *p)
-+ int xmmsc_connect(xmmsc_connection_t *c, char *p)
- void xmmsc_unref(xmmsc_connection_t *c)
- xmmsc_result_t *xmmsc_quit(xmmsc_connection_t *conn)
- xmmsc_result_t *xmmsc_plugin_list (xmmsc_connection_t *c, unsigned int type)
-@@ -175,8 +175,8 @@
- xmmsc_result_t *xmmsc_playlist_list_entries(xmmsc_connection_t *, char *playlist)
- xmmsc_result_t *xmmsc_playlist_sort(xmmsc_connection_t *, char *playlist, char **properties)
- xmmsc_result_t *xmmsc_playlist_set_next(xmmsc_connection_t *, int pos)
-- xmmsc_result_t *xmmsc_playlist_set_next_rel(xmmsc_connection_t *, signed int)
-- xmmsc_result_t *xmmsc_playlist_move_entry(xmmsc_connection_t *, char *playlist, unsigned int id, signed int movement)
-+ xmmsc_result_t *xmmsc_playlist_set_next_rel(xmmsc_connection_t *, int)
-+ xmmsc_result_t *xmmsc_playlist_move_entry(xmmsc_connection_t *, char *playlist, unsigned int id, int movement)
- xmmsc_result_t *xmmsc_playlist_current_pos(xmmsc_connection_t *, char *playlist)
- xmmsc_result_t *xmmsc_playlist_current_active(xmmsc_connection_t *)
- xmmsc_result_t *xmmsc_playlist_insert_args(xmmsc_connection_t *, char *playlist, int pos, char *url, int numargs, char **args)
-@@ -188,7 +188,7 @@
- xmmsc_result_t *xmmsc_playlist_radd_encoded(xmmsc_connection_t *c, char *, char *path)
-
- xmmsc_result_t *xmmsc_playlist_load(xmmsc_connection_t *, char *playlist)
-- xmmsc_result_t *xmmsc_playlist_move(xmmsc_connection_t *c, unsigned int id, signed int movement)
-+ xmmsc_result_t *xmmsc_playlist_move(xmmsc_connection_t *c, unsigned int id, int movement)
- xmmsc_result_t *xmmsc_playlist_create(xmmsc_connection_t *c, char *playlist)
-
- xmmsc_result_t *xmmsc_broadcast_playlist_changed(xmmsc_connection_t *c)
-@@ -357,7 +357,7 @@
- i = i + 1
- free(self.lst)
-
--cdef foreach_source_hash(signed char *key, xmmsc_result_value_type_t typ, void *value, char *source, udata):
-+cdef foreach_source_hash(char *key, xmmsc_result_value_type_t typ, void *value, char *source, udata):
- if typ == XMMSC_RESULT_VALUE_TYPE_STRING:
- v = to_unicode(<char *>value)
- elif typ == XMMSC_RESULT_VALUE_TYPE_UINT32:
-@@ -367,7 +367,7 @@
-
- udata[(source,key)]=v
-
--cdef foreach_hash(signed char *key, xmmsc_result_value_type_t typ, void *value, udata):
-+cdef foreach_hash(char *key, xmmsc_result_value_type_t typ, void *value, udata):
- if typ == XMMSC_RESULT_VALUE_TYPE_STRING:
- v = to_unicode(<char *>value)
- elif typ == XMMSC_RESULT_VALUE_TYPE_UINT32:
-@@ -874,7 +874,7 @@
- Get data from the result structure as an int.
- @rtype: int
- """
-- cdef signed int ret
-+ cdef int ret
- self._check()
- if xmmsc_result_get_int(self.res, &ret):
- return ret
-@@ -898,7 +898,7 @@
- Get data from the result structure as a string.
- @rtype: string
- """
-- cdef signed char *ret
-+ cdef char *ret
-
- self._check()
- if xmmsc_result_get_string(self.res, &ret):
diff --git a/audio/xmms2/files/slaveport-src-clients-lib-wscripts b/audio/xmms2/files/slaveport-src-clients-lib-wscripts
new file mode 100644
index 000000000000..c2a0e5229bf5
--- /dev/null
+++ b/audio/xmms2/files/slaveport-src-clients-lib-wscripts
@@ -0,0 +1,90 @@
+--- src/clients/lib/perl/wscript.orig 2008-03-15 22:36:57.000000000 +0600
++++ src/clients/lib/perl/wscript 2008-03-15 22:37:56.000000000 +0600
+@@ -15,7 +15,7 @@
+ XMMSClientResultPropDict.xs
+ XMMSClientResultPropDictTie.xs
+ """.split()
+- obj.uselib_local = 'xmmsclient'
++ obj.uselib = 'xmmsclient'
+ obj.install_var = "INSTALLDIR_PERL_AUTO"
+
+ Common.install_files('INSTALLDIR_PERL_LIB', '', 'pm/XMMSClient.pm')
+--- src/clients/lib/python/wscript.orig 2008-03-15 22:37:03.000000000 +0600
++++ src/clients/lib/python/wscript 2008-03-15 22:38:01.000000000 +0600
+@@ -7,7 +7,7 @@
+ obj.target = 'xmmsapi'
+ obj.includes = '../../../include ../../../includepriv'
+ obj.source = ['xmmsapi.pyx']
+- obj.uselib_local = 'xmmsclient'
++ obj.uselib = 'xmmsclient'
+ obj.install_var = "xmmsclient_PYTHONDIR"
+
+ Common.install_files('xmmsclient_PYTHONDIR', '', 'xmmsclient/__init__.py')
+--- src/clients/lib/ruby/wscript.orig 2007-11-16 00:25:07.000000000 +0600
++++ src/clients/lib/ruby/wscript 2008-03-15 23:01:28.000000000 +0600
+@@ -8,7 +8,7 @@
+ obj.target = 'xmmsclient_ext'
+ obj.includes = '../../../include ../../../includepriv'
+ obj.source = "rb_xmmsclient_main.c rb_xmmsclient.c rb_playlist.c rb_collection.c rb_result.c".split()
+- obj.uselib_local = 'xmmsclient'
++ obj.uselib = 'xmmsclient'
+ obj.install_var = "ARCHDIR_ruby"
+
+ Common.install_files('LIBDIR_ruby', '.', 'xmmsclient.rb')
+@@ -20,8 +20,7 @@
+ obj.target = 'xmmsclient_glib'
+ obj.includes = '../../../include ../../../includepriv'
+ obj.source = ['rb_xmmsclient_glib.c']
+- obj.uselib_local = 'xmmsclient-glib xmmsclient'
+- obj.uselib = 'glib2'
++ obj.uselib = 'glib2 xmmsclient-glib xmmsclient'
+ obj.install_var = "ARCHDIR_ruby"
+ obj.env["shlib_PREFIX"] = ''
+
+@@ -31,8 +30,8 @@
+ obj.target = 'xmmsclient_ecore'
+ obj.includes = '../../../include ../../../includepriv'
+ obj.source = ['rb_xmmsclient_ecore.c']
+- obj.uselib_local = 'xmmsclient-ecore xmmsclient'
+- obj.uselib = 'ecore'
++ obj.uselib_local = 'xmmsclient-ecore'
++ obj.uselib = 'ecore xmmsclient'
+ obj.install_var = "ARCHDIR_ruby"
+ obj.env["shlib_PREFIX"] = ''
+
+--- src/clients/lib/xmmsclient++-glib/wscript.orig 2008-03-15 22:37:31.000000000 +0600
++++ src/clients/lib/xmmsclient++-glib/wscript 2008-03-15 22:38:15.000000000 +0600
+@@ -3,8 +3,7 @@
+ lib = bld.create_obj('cpp', 'shlib')
+ lib.target = 'xmmsclient++-glib'
+ lib.source = 'xmmsclient++-glib.cpp'
+- lib.uselib = 'glib2'
+- lib.uselib_local = 'xmmsclient xmmsclient-glib'
++ lib.uselib = 'glib2 xmmsclient xmmsclient-glib'
+ lib.includes = '../../../include ../../../includepriv'
+ lib.vnum = '1.0.0'
+ tool.add_install_flag(bld, lib)
+--- src/clients/lib/xmmsclient++/wscript.orig 2007-11-16 00:25:07.000000000 +0600
++++ src/clients/lib/xmmsclient++/wscript 2008-03-15 22:38:33.000000000 +0600
+@@ -22,8 +22,7 @@
+ signal.cpp
+ stats.cpp
+ xform.cpp""".split()
+- obj.uselib_local = 'xmmsclient'
+- obj.uselib = 'boosth boostl socket'
++ obj.uselib = 'boosth boostl socket xmmsclient'
+ obj.vnum = '2.0.0'
+ tool.add_install_flag(bld, obj)
+
+--- src/clients/lib/xmmsclient-ecore/wscript.orig 2008-03-15 23:01:53.000000000 +0600
++++ src/clients/lib/xmmsclient-ecore/wscript 2008-03-15 23:02:02.000000000 +0600
+@@ -5,8 +5,7 @@
+ obj.target = 'xmmsclient-ecore'
+ obj.includes = '../../../include'
+ obj.source = 'xmmsclient-ecore.c'
+- obj.uselib = 'ecore'
+- obj.uselib_local = 'xmmsclient'
++ obj.uselib = 'ecore xmmsclient'
+ obj.vnum = '1.0.0'
+ tool.add_install_flag(bld, obj)
+
diff --git a/audio/xmms2/files/slaveport-wscript b/audio/xmms2/files/slaveport-wscript
index 38ee21ff7e29..9f3e33e8ed6c 100644
--- a/audio/xmms2/files/slaveport-wscript
+++ b/audio/xmms2/files/slaveport-wscript
@@ -9,3 +9,21 @@
src/include
src/includepriv
""".split()
+@@ -92,8 +90,6 @@
+ o.version = VERSION
+ o.libs = bld.env_of_name('default')['XMMS_PKGCONF_FILES']
+
+- Common.install_files('SHAREDDIR', '', 'mind.in.a.box-lament_snipplet.ogg')
+-
+
+ ####
+ ## Configuration
+@@ -313,6 +309,8 @@
+ # Default POSIX sockets
+ else:
+ conf.env['socket_impl'] = 'posix'
++ conf.env.append_unique('LIB_xmmsclient', 'xmmsclient')
++ conf.env.append_unique('LIB_xmmsclient-glib', 'xmmsclient-glib')
+
+ # Glib is required by everyone, so check for it here and let them
+ # assume its presence.
diff --git a/audio/xmms2/pkg-plist b/audio/xmms2/pkg-plist
index 03152390727d..8a7ac1627848 100644
--- a/audio/xmms2/pkg-plist
+++ b/audio/xmms2/pkg-plist
@@ -8,8 +8,6 @@ bin/xmms2-launcher
bin/xmms2d
include/xmms2/xmms/xmms_bindata.h
include/xmms2/xmms/xmms_config.h
-include/xmms2/xmms/xmms_effect.h
-include/xmms2/xmms/xmms_effectplugin.h
include/xmms2/xmms/xmms_error.h
include/xmms2/xmms/xmms_ipc.h
include/xmms2/xmms/xmms_log.h
@@ -35,11 +33,13 @@ include/xmms2/xmmsc/xmmsc_stringport.h
include/xmms2/xmmsc/xmmsc_strlist.h
include/xmms2/xmmsc/xmmsc_unistd.h
include/xmms2/xmmsc/xmmsc_util.h
+include/xmms2/xmmsclient/xmmsclient++-glib.h
+include/xmms2/xmmsclient/xmmsclient++.h
include/xmms2/xmmsclient/xmmsclient++/bindata.h
include/xmms2/xmmsclient/xmmsclient++/client.h
-include/xmms2/xmmsclient/xmmsclient++/config.h
include/xmms2/xmmsclient/xmmsclient++/coll.h
include/xmms2/xmmsclient/xmmsclient++/collection.h
+include/xmms2/xmmsclient/xmmsclient++/config.h
include/xmms2/xmmsclient/xmmsclient++/dict.h
include/xmms2/xmmsclient/xmmsclient++/exceptions.h
include/xmms2/xmmsclient/xmmsclient++/helpers.h
@@ -54,8 +54,6 @@ include/xmms2/xmmsclient/xmmsclient++/signal.h
include/xmms2/xmmsclient/xmmsclient++/stats.h
include/xmms2/xmmsclient/xmmsclient++/typedefs.h
include/xmms2/xmmsclient/xmmsclient++/xform.h
-include/xmms2/xmmsclient/xmmsclient++-glib.h
-include/xmms2/xmmsclient/xmmsclient++.h
include/xmms2/xmmsclient/xmmsclient-cf.h
include/xmms2/xmmsclient/xmmsclient-ecore.h
include/xmms2/xmmsclient/xmmsclient-glib.h
@@ -65,54 +63,69 @@ lib/libxmmsclient-glib.so
lib/libxmmsclient-glib.so.1
lib/libxmmsclient-glib.so.1.0.0
lib/libxmmsclient.so
-lib/libxmmsclient.so.2
-lib/libxmmsclient.so.2.0.0
+lib/libxmmsclient.so.3
+lib/libxmmsclient.so.3.0.0
%%AO%%lib/xmms2/libxmms_ao.so
+lib/xmms2/libxmms_asf.so
lib/xmms2/libxmms_asx.so
+%%AVCODEC%%lib/xmms2/libxmms_avcodec.so
+%%AVCODEC%%lib/xmms2/libxmms_avformat.so
lib/xmms2/libxmms_cue.so
%%CURL%%lib/xmms2/libxmms_curl.so
+%%DAAP%%lib/xmms2/libxmms_daap.so
lib/xmms2/libxmms_diskwrite.so
lib/xmms2/libxmms_equalizer.so
-%%DAAP%%lib/xmms2/libxmms_daap.so
%%FAAD%%lib/xmms2/libxmms_faad.so
-%%FLAC%%lib/xmms2/libxmms_flac.so
lib/xmms2/libxmms_file.so
+%%FLAC%%lib/xmms2/libxmms_flac.so
%%GNOMEVFS%%lib/xmms2/libxmms_gnomevfs.so
%%ICES%%lib/xmms2/libxmms_ices.so
-%%LASTFM%%lib/xmms2/libxmms_lastfm.so
-%%LASTFM%%lib/xmms2/libxmms_lastfmeta.so
%%CURL%%lib/xmms2/libxmms_icymetaint.so
lib/xmms2/libxmms_id3v2.so
%%JACK%%lib/xmms2/libxmms_jack.so
+%%LASTFM%%lib/xmms2/libxmms_lastfm.so
+%%LASTFM%%lib/xmms2/libxmms_lastfmeta.so
lib/xmms2/libxmms_m3u.so
-lib/xmms2/libxmms_mad.so
%%MAC%%lib/xmms2/libxmms_mac.so
+lib/xmms2/libxmms_mad.so
%%MMS%%lib/xmms2/libxmms_mms.so
%%MODPLUG%%lib/xmms2/libxmms_modplug.so
%%FAAD%%lib/xmms2/libxmms_mp4.so
%%MUSEPACK%%lib/xmms2/libxmms_musepack.so
+lib/xmms2/libxmms_normalize.so
lib/xmms2/libxmms_null.so
lib/xmms2/libxmms_nulstripper.so
+lib/xmms2/libxmms_ofa.so
lib/xmms2/libxmms_oss.so
lib/xmms2/libxmms_pls.so
lib/xmms2/libxmms_replaygain.so
+lib/xmms2/libxmms_rss.so
%%SAMBA%%lib/xmms2/libxmms_samba.so
%%SID%%lib/xmms2/libxmms_sid.so
%%VOCODER%%lib/xmms2/libxmms_vocoder.so
lib/xmms2/libxmms_vorbis.so
lib/xmms2/libxmms_wave.so
-%%AVCODEC%%lib/xmms2/libxmms_avcodec.so
-%%AVCODEC%%lib/xmms2/libxmms_avformat.so
+lib/xmms2/libxmms_xml.so
+lib/xmms2/libxmms_xspf.so
libdata/pkgconfig/xmms2-client-glib.pc
libdata/pkgconfig/xmms2-client.pc
libdata/pkgconfig/xmms2-plugin.pc
+share/pixmaps/xmms2-128.png
+share/pixmaps/xmms2-16.png
+share/pixmaps/xmms2-32.png
+share/pixmaps/xmms2-48.png
+share/pixmaps/xmms2-black-on-white.svg
+share/pixmaps/xmms2-white-on-black.svg
+share/pixmaps/xmms2.svg
%%DATADIR%%/mind.in.a.box-lament_snipplet.ogg
%%DATADIR%%/scripts/startup.d/xmms2-et-launcher.sh
%%MDNS_AVAHI%%%%DATADIR%%/scripts/startup.d/xmms2-mdns-launcher.sh
%%MDNS_APPLE%%%%DATADIR%%/scripts/startup.d/xmms2-mdns-launcher.sh
-@dirrm %%DATADIR%%/scripts/startup.d
-@dirrm %%DATADIR%%/scripts
-@dirrm %%DATADIR%%
+share/xmms2/scripts/startup.d/xmms2-mlib-updater.sh
+@dirrm share/xmms2/scripts/startup.d
+@dirrm share/xmms2/scripts
+@dirrm share/xmms2
+@dirrm share/pixmaps
@dirrm lib/xmms2
@dirrm include/xmms2/xmmsclient/xmmsclient++
@dirrm include/xmms2/xmmsclient