aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/icpld/Makefile3
-rw-r--r--net/icpld/pkg-plist5
-rw-r--r--net/ipsumdump/Makefile3
-rw-r--r--net/ipsumdump/pkg-plist3
-rw-r--r--net/uplog/Makefile3
-rw-r--r--net/uplog/pkg-plist3
6 files changed, 9 insertions, 11 deletions
diff --git a/net/icpld/Makefile b/net/icpld/Makefile
index 43ee53011895..9b6af6442f4a 100644
--- a/net/icpld/Makefile
+++ b/net/icpld/Makefile
@@ -19,6 +19,9 @@ CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= ${PORTNAME}.1
+PORTDOCS= README
+PLIST_FILES= bin/icpld etc/icpld.conf.sample etc/rc.d/icpld.sh.sample
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 ${MANPREFIX}/man/man1
diff --git a/net/icpld/pkg-plist b/net/icpld/pkg-plist
deleted file mode 100644
index 3c27758654b2..000000000000
--- a/net/icpld/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/icpld
-etc/icpld.conf.sample
-etc/rc.d/icpld.sh.sample
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/net/ipsumdump/Makefile b/net/ipsumdump/Makefile
index 360c1d32be5e..e1135e1cdf1d 100644
--- a/net/ipsumdump/Makefile
+++ b/net/ipsumdump/Makefile
@@ -22,6 +22,9 @@ USE_SIZE= yes
MAN1= ${PORTNAME}.1
+PORTDOCS= README
+PLIST_FILES= bin/ipsumdump
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/net/ipsumdump/pkg-plist b/net/ipsumdump/pkg-plist
deleted file mode 100644
index bccd0385a152..000000000000
--- a/net/ipsumdump/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/ipsumdump
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/net/uplog/Makefile b/net/uplog/Makefile
index 531399939e52..9ebdd67ca840 100644
--- a/net/uplog/Makefile
+++ b/net/uplog/Makefile
@@ -21,6 +21,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+PORTDOCS= README
+PLIST_FILES= bin/uplog
+
post-patch:
${REINPLACE_CMD} -e \
's|#include <malloc.h>||g' \
diff --git a/net/uplog/pkg-plist b/net/uplog/pkg-plist
deleted file mode 100644
index eaa78598ef43..000000000000
--- a/net/uplog/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/uplog
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%