aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/hlextract/Makefile37
-rw-r--r--archivers/hlextract/distinfo3
-rw-r--r--archivers/hlextract/pkg-descr6
4 files changed, 47 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index c2466c0edd4d..f008e4d69904 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -33,6 +33,7 @@
SUBDIR += gzrecover
SUBDIR += ha
SUBDIR += hffzip
+ SUBDIR += hlextract
SUBDIR += hpack.non-usa.only
SUBDIR += jzip.org
SUBDIR += jzlib
diff --git a/archivers/hlextract/Makefile b/archivers/hlextract/Makefile
new file mode 100644
index 000000000000..420f74787150
--- /dev/null
+++ b/archivers/hlextract/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: HLExtract
+# Date created: 22 Oct 2007
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hlextract
+PORTVERSION= 2.0.8
+CATEGORIES= archivers games
+MASTER_SITES= http://nemesis.thewavelength.net/files/files/ \
+ http://freebsd.nsu.ru/distfiles/
+DISTNAME= hllib${PORTVERSION:S/.//g}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Utility to extract data from various Half-Life file formats
+
+LIB_DEPENDS= hl.2:${PORTSDIR}/games/hllib
+
+USE_ZIP= yes
+USE_DOS2UNIX= Main.c
+WRKSRC= ${WRKDIR}/HLExtract
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-extract:
+ @${REINPLACE_CMD} -e 's,linux/limits,sys/param, ; \
+ s,HLExtract\.exe,hlextract,' ${WRKSRC}/Main.c
+
+do-build:
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ ${WRKSRC}/Main.c -o ${WRKSRC}/${PORTNAME} -lhl
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/archivers/hlextract/distinfo b/archivers/hlextract/distinfo
new file mode 100644
index 000000000000..b941dbdee71d
--- /dev/null
+++ b/archivers/hlextract/distinfo
@@ -0,0 +1,3 @@
+MD5 (hllib208.zip) = 4065e54e092ab657a9250393d8e5548d
+SHA256 (hllib208.zip) = 0f43a282887ac007f6ecb0bd081fefb486c1fd63c9e92e3e9febe536f846e7d9
+SIZE (hllib208.zip) = 316370
diff --git a/archivers/hlextract/pkg-descr b/archivers/hlextract/pkg-descr
new file mode 100644
index 000000000000..576f48ff5037
--- /dev/null
+++ b/archivers/hlextract/pkg-descr
@@ -0,0 +1,6 @@
+HLExtract is a command line utility written in C that can load all HLLib
+supported packages and extract multiple items from them while maintaining
+their directory structure. Currently, BSP, GCF, NCF, PAK, WAD, XZP, and
+uncompressed ZIP package formats are supported.
+
+WWW: http://nemesis.thewavelength.net/index.php?p=35