aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-stdnum/Makefile19
-rw-r--r--devel/py-stdnum/distinfo2
-rw-r--r--devel/py-stdnum/pkg-descr6
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 39814cafaf8d..760e2fd29118 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4196,6 +4196,7 @@
SUBDIR += py-speaklater
SUBDIR += py-sqlcc
SUBDIR += py-statgrab
+ SUBDIR += py-stdnum
SUBDIR += py-stevedore
SUBDIR += py-stsci.distutils
SUBDIR += py-subversion
diff --git a/devel/py-stdnum/Makefile b/devel/py-stdnum/Makefile
new file mode 100644
index 000000000000..228053860f3f
--- /dev/null
+++ b/devel/py-stdnum/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= stdnum
+PORTVERSION= 1.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Python module to handle standardized numbers and codes
+
+LICENSE= LGPL21
+
+# Python3 ready
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-stdnum/distinfo b/devel/py-stdnum/distinfo
new file mode 100644
index 000000000000..d90987fe92a8
--- /dev/null
+++ b/devel/py-stdnum/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-stdnum-1.1.tar.gz) = 66ee880bfd60cadeca667eba6f29803b6712eb554a2d19cfb8e1ea86ce42df35
+SIZE (python-stdnum-1.1.tar.gz) = 205495
diff --git a/devel/py-stdnum/pkg-descr b/devel/py-stdnum/pkg-descr
new file mode 100644
index 000000000000..e76166b40f35
--- /dev/null
+++ b/devel/py-stdnum/pkg-descr
@@ -0,0 +1,6 @@
+Python module to parse, validate and reformat standard numbers and codes.
+
+This library offers functions for parsing, validating and reformatting
+standard numbers and codes in various formats.
+
+WWW: https://pypi.python.org/pypi/python-stdnum/