aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Class-C3/Makefile13
-rw-r--r--devel/p5-Moo/Makefile1
-rw-r--r--www/p5-Dancer2/Makefile3
3 files changed, 5 insertions, 12 deletions
diff --git a/devel/p5-Class-C3/Makefile b/devel/p5-Class-C3/Makefile
index 9d4f781d904b..0a44e65fda2c 100644
--- a/devel/p5-Class-C3/Makefile
+++ b/devel/p5-Class-C3/Makefile
@@ -11,19 +11,14 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Pragma to use the C3 method resolution order algorithm
OPTIONS_DEFINE= XS
-XS_DESC= XS speed optimizations
USES= perl5
USE_PERL5= configure
-.include <bsd.port.options.mk>
+XS_BUILD_DEPENDS= p5-Class-C3-XS>=0.13:${PORTSDIR}/devel/p5-Class-C3-XS
+XS_RUN_DEPENDS= p5-Class-C3-XS>=0.13:${PORTSDIR}/devel/p5-Class-C3-XS
-.if ${PORT_OPTIONS:MXS}
-BUILD_DEPENDS+= p5-Class-C3-XS>=0.13:${PORTSDIR}/devel/p5-Class-C3-XS
-RUN_DEPENDS+= p5-Class-C3-XS>=0.13:${PORTSDIR}/devel/p5-Class-C3-XS
-.else
-BUILD_DEPENDS+= p5-Algorithm-C3>=0.07:${PORTSDIR}/devel/p5-Algorithm-C3
-RUN_DEPENDS+= p5-Algorithm-C3>=0.07:${PORTSDIR}/devel/p5-Algorithm-C3
-.endif
+XS_BUILD_DEPENDS_OFF= p5-Algorithm-C3>=0.07:${PORTSDIR}/devel/p5-Algorithm-C3
+XS_RUN_DEPENDS_OFF= p5-Algorithm-C3>=0.07:${PORTSDIR}/devel/p5-Algorithm-C3
.include <bsd.port.mk>
diff --git a/devel/p5-Moo/Makefile b/devel/p5-Moo/Makefile
index 485f55540ff5..180037d8e28a 100644
--- a/devel/p5-Moo/Makefile
+++ b/devel/p5-Moo/Makefile
@@ -26,7 +26,6 @@ USES= perl5
USE_PERL5= configure
OPTIONS_DEFINE= XS
-XS_DESC= Use XS libraries for speed boost
XS_BUILD_DEPENDS= p5-Class-XSAccessor>=1.18:${PORTSDIR}/devel/p5-Class-XSAccessor \
p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
diff --git a/www/p5-Dancer2/Makefile b/www/p5-Dancer2/Makefile
index 80097059ce2c..4ed7ed5f3cb3 100644
--- a/www/p5-Dancer2/Makefile
+++ b/www/p5-Dancer2/Makefile
@@ -47,8 +47,7 @@ TEST_DEPENDS= p5-Test-Memory-Cycle>=0:${PORTSDIR}/devel/p5-Test-Memory-Cycle \
p5-LWP-Protocol-https>0:${PORTSDIR}/www/p5-LWP-Protocol-https \
p5-LWP-Protocol-PSGI>=0.06:${PORTSDIR}/www/p5-LWP-Protocol-PSGI
-OPTIONS_DEFINE= XS
-XS_DESC= Use XS modules for speed boost
+OPTIONS_DEFINE= XS
XS_BUILD_DEPENDS= p5-CGI-Deurl-XS>=0:${PORTSDIR}/www/p5-CGI-Deurl-XS \
p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \