aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/padevchooser/Makefile27
-rw-r--r--audio/padevchooser/distinfo3
-rw-r--r--audio/padevchooser/pkg-descr11
-rw-r--r--audio/padevchooser/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 142399aaecf1..196e4f2c1b87 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -462,6 +462,7 @@
SUBDIR += p5-tagged
SUBDIR += p5-xmms2
SUBDIR += pacpl
+ SUBDIR += padevchooser
SUBDIR += paman
SUBDIR += pd
SUBDIR += pecl-id3
diff --git a/audio/padevchooser/Makefile b/audio/padevchooser/Makefile
new file mode 100644
index 000000000000..c45e60df1f66
--- /dev/null
+++ b/audio/padevchooser/Makefile
@@ -0,0 +1,27 @@
+# Ports collection Makefile for: padevchooser
+# Date created: July 21, 2007
+# Whom: Romain Tartière <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= padevchooser
+PORTVERSION= 0.9.3
+CATEGORIES= audio
+MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
+
+MAINTAINER= romain@blogreen.org
+COMMENT= GTK icon tray for PulseAudio
+
+LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
+ pulse.0:${PORTSDIR}/audio/pulseaudio \
+ notify.1:${PORTSDIR}/devel/libnotify \
+ avahi-core:${PORTSDIR}/net/avahi
+RUN_DEPENDES= dbus-daemon:${PORTSDIR}/devel/dbus
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ARGS= --disable-lynx
+
+.include <bsd.port.mk>
diff --git a/audio/padevchooser/distinfo b/audio/padevchooser/distinfo
new file mode 100644
index 000000000000..21bbf5527758
--- /dev/null
+++ b/audio/padevchooser/distinfo
@@ -0,0 +1,3 @@
+MD5 (padevchooser-0.9.3.tar.gz) = 6a9b52ad349f3fb3d5a3ccdf85958710
+SHA256 (padevchooser-0.9.3.tar.gz) = 3238f19ea5a3c54efef31e4f86c712232c92704d68c9d2bbef0339ba9b4cb674
+SIZE (padevchooser-0.9.3.tar.gz) = 100152
diff --git a/audio/padevchooser/pkg-descr b/audio/padevchooser/pkg-descr
new file mode 100644
index 000000000000..1c63dddb79d0
--- /dev/null
+++ b/audio/padevchooser/pkg-descr
@@ -0,0 +1,11 @@
+PulseAudio Device Chooser (padevchooser) is a simple GTK tool which registers
+an icon in the tray area and allows quick access to some features of the
+PulseAudio sound server. Specifically it can do for you:
+
+ - Notify about new sink/sources becoming available on the LAN
+ - Quickly change the default PulseAudio sink/source/server assigned to the
+ current X11 display, selecting devices available on the LAN
+ - Start the auxiliary tools PulseAudio Volume Control, PulseAudio Volume
+ Meter, PulseAudio Manager, PulseAudio Preferences
+
+WWW: http://0pointer.de/lennart/projects/padevchooser/
diff --git a/audio/padevchooser/pkg-plist b/audio/padevchooser/pkg-plist
new file mode 100644
index 000000000000..d5ec9429c88d
--- /dev/null
+++ b/audio/padevchooser/pkg-plist
@@ -0,0 +1,5 @@
+bin/padevchooser
+share/applications/padevchooser.desktop
+%%DATADIR%%/padevchooser.glade
+@dirrm %%DATADIR%%
+@dirrmtry share/applications