aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/abraca/files/patch-src__components__filter__filter_view.vala12
-rw-r--r--audio/abraca/files/patch-src_coverart.vala20
-rw-r--r--audio/abraca/files/patch-src_toolbar.vala11
-rw-r--r--audio/deadbeef/Makefile2
-rw-r--r--audio/deadbeef/pkg-plist2
-rw-r--r--databases/evolution-data-server/Makefile1
-rw-r--r--databases/mysql-workbench51/files/patch-frontend__linux__workbench__toolbar_manager.cpp11
-rw-r--r--deskutils/gnome-utils/Makefile4
-rw-r--r--devel/anjuta/Makefile4
-rw-r--r--devel/anjuta/pkg-plist3
-rw-r--r--devel/gvfs/Makefile4
-rw-r--r--games/kanatest/Makefile2
-rw-r--r--graphics/k3d/Makefile2
-rw-r--r--graphics/k3d/files/patch-ngui__main_document_window.cpp20
-rw-r--r--graphics/k3d/files/patch-ngui_render.cpp20
-rw-r--r--irc/xchat-gnome/Makefile1
-rw-r--r--mail/evolution-exchange/Makefile1
-rw-r--r--mail/evolution/Makefile1
-rw-r--r--net-im/folks/Makefile1
-rw-r--r--net-im/folks/files/patch-backends_telepathy_lib_tpf-persona-store.vala109
-rw-r--r--net-im/telepathy-glib/Makefile7
-rw-r--r--net-im/telepathy-glib/files/patch-telepathy-glib_Makefile.in22
-rw-r--r--net-im/telepathy-glib/pkg-plist4
-rw-r--r--science/peekabot/Makefile1
-rw-r--r--science/peekabot/files/patch-src_gui_ScreneViewFrame.cc15
-rw-r--r--security/libgnomesu/Makefile4
-rw-r--r--www/gtkhtml3/Makefile6
-rw-r--r--www/gtkhtml3/pkg-plist2
-rw-r--r--x11/libfm/Makefile4
29 files changed, 282 insertions, 14 deletions
diff --git a/audio/abraca/files/patch-src__components__filter__filter_view.vala b/audio/abraca/files/patch-src__components__filter__filter_view.vala
new file mode 100644
index 000000000000..6fe4ef9a0a93
--- /dev/null
+++ b/audio/abraca/files/patch-src__components__filter__filter_view.vala
@@ -0,0 +1,12 @@
+--- ./src/components/filter/filter_view.vala.orig 2011-06-24 14:40:14.000000000 +0200
++++ ./src/components/filter/filter_view.vala 2011-06-24 14:41:00.000000000 +0200
+@@ -370,7 +370,8 @@ namespace Abraca {
+ } else {
+ order = Gtk.SortType.DESCENDING;
+ }
+- sorting = {column.title, order};
++ Sorting tmp = {column.title, order};
++ sorting = tmp;
+ break;
+ }
+ }
diff --git a/audio/abraca/files/patch-src_coverart.vala b/audio/abraca/files/patch-src_coverart.vala
new file mode 100644
index 000000000000..0c3d29d36ae6
--- /dev/null
+++ b/audio/abraca/files/patch-src_coverart.vala
@@ -0,0 +1,20 @@
+--- src/coverart.vala.orig 2011-06-24 14:41:53.000000000 +0200
++++ src/coverart.vala 2011-06-24 14:42:25.000000000 +0200
+@@ -412,7 +412,7 @@ namespace Abraca {
+ if (!get_track_ids (candidates, pixbuf, out ids))
+ return true;
+
+- char[] buffer;
++ uint8[] buffer;
+ if (!pixbuf.save_to_buffer (out buffer, "png"))
+ return true;
+
+@@ -420,7 +420,7 @@ namespace Abraca {
+ /* TODO: Need to store ids here due to a Vala reference bug. */
+ selected_ids = ids;
+
+- client.xmms.bindata_add ((uint8[]) buffer).notifier_set (on_bindata_add);
++ client.xmms.bindata_add (buffer).notifier_set (on_bindata_add);
+
+
+ return true;
diff --git a/audio/abraca/files/patch-src_toolbar.vala b/audio/abraca/files/patch-src_toolbar.vala
new file mode 100644
index 000000000000..9e9b622faf93
--- /dev/null
+++ b/audio/abraca/files/patch-src_toolbar.vala
@@ -0,0 +1,11 @@
+--- src/toolbar.vala.orig 2011-06-24 14:42:58.000000000 +0200
++++ src/toolbar.vala 2011-06-24 14:43:11.000000000 +0200
+@@ -343,7 +343,7 @@ namespace Abraca {
+
+ try {
+ var loader = new Gdk.PixbufLoader();
+- loader.write(data, data.length);
++ loader.write(data);
+ loader.close();
+
+ var pixbuf = loader.get_pixbuf();
diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index 203664b54884..e42e58b0bdf4 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -7,7 +7,7 @@
PORTNAME= deadbeef
PORTVERSION= 0.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/
diff --git a/audio/deadbeef/pkg-plist b/audio/deadbeef/pkg-plist
index c9567d0e78b4..f5f23cd34d3a 100644
--- a/audio/deadbeef/pkg-plist
+++ b/audio/deadbeef/pkg-plist
@@ -211,6 +211,8 @@ share/icons/hicolor/scalable/apps/deadbeef.svg
@dirrmtry share/icons/hicolor/scalable
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
+@dirrmtry %%NLS%%share/locale/lg/LC_MESSAGES
+@dirrmtry %%NLS%%share/locale/lg
@dirrmtry %%NLS%%share/locale/km/LC_MESSAGES
@dirrmtry %%NLS%%share/locale/km
%%DATADIR%%/pixmaps/noartwork.jpg
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 1a0f9f0aa95b..7ff4df03b468 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -81,6 +81,7 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-ldb|-l${BDB_LIB_NAME}|g ; \
s|heimlibs=".*"|heimlibs="${KRB5_LIB}"|g ; \
+ s|-DGTK_DISABLE_DEPRECATED||g ; \
s|-Wl,--no-undefined||g ; \
s|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
diff --git a/databases/mysql-workbench51/files/patch-frontend__linux__workbench__toolbar_manager.cpp b/databases/mysql-workbench51/files/patch-frontend__linux__workbench__toolbar_manager.cpp
new file mode 100644
index 000000000000..3293d7814adb
--- /dev/null
+++ b/databases/mysql-workbench51/files/patch-frontend__linux__workbench__toolbar_manager.cpp
@@ -0,0 +1,11 @@
+--- frontend/linux/workbench/toolbar_manager.cpp.orig 2011-06-14 23:26:35.000000000 +0200
++++ frontend/linux/workbench/toolbar_manager.cpp 2011-06-14 23:28:22.000000000 +0200
+@@ -30,7 +30,7 @@
+ }
+
+ Glib::RefPtr<Gtk::ListStore> model= Gtk::ListStore::create(*color_combo_columns);
+- Gtk::ComboBox *combo= new Gtk::ComboBox(model);
++ Gtk::ComboBox *combo= new Gtk::ComboBox(Glib::RefPtr<Gtk::TreeModel>(model));
+
+ combo->pack_start(color_combo_columns->image);
+
diff --git a/deskutils/gnome-utils/Makefile b/deskutils/gnome-utils/Makefile
index 1aa2282d76c9..90318480eccf 100644
--- a/deskutils/gnome-utils/Makefile
+++ b/deskutils/gnome-utils/Makefile
@@ -38,4 +38,8 @@ GCONF_SCHEMAS= gnome-dictionary.schemas gnome-screenshot.schemas \
gnome-search-tool.schemas baobab.schemas \
gnome-system-log.schemas
+post-patch:
+ @${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/gsearchtool/libgnomeui-deprecated/Makefile.in
+
.include <bsd.port.mk>
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index 4b2de9a9d786..e7f17c4b345f 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -8,7 +8,7 @@
PORTNAME= anjuta
PORTVERSION= 2.32.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -21,7 +21,6 @@ BUILD_DEPENDS= autogen:${PORTSDIR}/devel/autogen \
p5-Locale-gettext>=1.05:${PORTSDIR}/devel/p5-Locale-gettext
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
gladeui-1.10:${PORTSDIR}/devel/glade3 \
- vala-0.10.0:${PORTSDIR}/lang/vala \
unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
gdl-1.3:${PORTSDIR}/x11-toolkits/gdl
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
@@ -45,6 +44,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-symbol-db-shm=/tmp \
+ --disable-vala \
--enable-introspection=no
USE_LDCONFIG= yes
GCONF_SCHEMAS= anjuta-build-basic-autotools-plugin.schemas \
diff --git a/devel/anjuta/pkg-plist b/devel/anjuta/pkg-plist
index 534e4ca10c7a..1e0be022fd83 100644
--- a/devel/anjuta/pkg-plist
+++ b/devel/anjuta/pkg-plist
@@ -129,7 +129,6 @@ lib/anjuta/anjuta-starter.plugin
%%SVN%%lib/anjuta/anjuta-subversion.plugin
lib/anjuta/anjuta-terminal.plugin
lib/anjuta/anjuta-tools.plugin
-lib/anjuta/anjuta-vala.plugin
lib/anjuta/file-manager.plugin
lib/anjuta/gbf-am.plugin
lib/anjuta/gbf-mkfile.plugin
@@ -163,8 +162,6 @@ lib/anjuta/libanjuta-gtodo.la
lib/anjuta/libanjuta-gtodo.so
lib/anjuta/libanjuta-language-cpp-java.la
lib/anjuta/libanjuta-language-cpp-java.so
-lib/anjuta/libanjuta-language-vala.la
-lib/anjuta/libanjuta-language-vala.so
lib/anjuta/libanjuta-loader.la
lib/anjuta/libanjuta-loader.so
lib/anjuta/libanjuta-message-view.la
diff --git a/devel/gvfs/Makefile b/devel/gvfs/Makefile
index 36465443dd3e..6353d38d69e2 100644
--- a/devel/gvfs/Makefile
+++ b/devel/gvfs/Makefile
@@ -88,4 +88,8 @@ CONFIGURE_ARGS+=--disable-hal
PLIST_SUB+= HAL="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/gconf/Makefile.in
+
.include <bsd.port.post.mk>
diff --git a/games/kanatest/Makefile b/games/kanatest/Makefile
index c4314b70d254..d85ceec6b41a 100644
--- a/games/kanatest/Makefile
+++ b/games/kanatest/Makefile
@@ -23,6 +23,8 @@ MAKE_ENV+= LIBINTL="-lintl"
post-patch: .SILENT
${REINPLACE_CMD} '/LIBS/s|-lxml|-L${LOCALBASE}/lib &|' \
${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/src/Makefile.in
${REINPLACE_CMD} -e '/^%.mo:/,/^$$/s/test[^;]*/${TRUE}/' \
-e '\|/usr/bin| { s||${LOCALBASE}/bin|; s|=|?=|; }' \
${WRKSRC}/po/Makefile.in
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
index 2ad254022aa9..ee3e02d9c543 100644
--- a/graphics/k3d/Makefile
+++ b/graphics/k3d/Makefile
@@ -9,7 +9,7 @@
PORTNAME= k3d
PORTVERSION= 0.6.7.0
DISTVERSIONSUFFIX=-src
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/K-3D%20Source/K-3D%20${PORTVERSION}
diff --git a/graphics/k3d/files/patch-ngui__main_document_window.cpp b/graphics/k3d/files/patch-ngui__main_document_window.cpp
new file mode 100644
index 000000000000..d51a8e792bff
--- /dev/null
+++ b/graphics/k3d/files/patch-ngui__main_document_window.cpp
@@ -0,0 +1,20 @@
+--- ngui/main_document_window.cpp.orig 2007-01-23 05:06:31.000000000 +0100
++++ ngui/main_document_window.cpp 2011-07-26 20:57:07.000000000 +0200
+@@ -1501,7 +1501,7 @@ private:
+ Gtk::HBox import_box(false, 5);
+ Gtk::Label import_label(_("Choose import plugin:"));
+
+- Gtk::ComboBox import_combo(model);
++ Gtk::ComboBox import_combo((Glib::RefPtr<Gtk::TreeModel> &) model);
+ import_combo.pack_start(columns.icon, false);
+ import_combo.pack_start(columns.label);
+ import_combo.set_active(0);
+@@ -1582,7 +1582,7 @@ private:
+ Gtk::HBox export_box(false, 5);
+ Gtk::Label export_label(_("Choose export plugin:"));
+
+- Gtk::ComboBox export_combo(model);
++ Gtk::ComboBox export_combo((Glib::RefPtr<Gtk::TreeModel> &) model);
+ export_combo.pack_start(columns.icon, false);
+ export_combo.pack_start(columns.label);
+ export_combo.set_active(0);
diff --git a/graphics/k3d/files/patch-ngui_render.cpp b/graphics/k3d/files/patch-ngui_render.cpp
new file mode 100644
index 000000000000..0089646734b7
--- /dev/null
+++ b/graphics/k3d/files/patch-ngui_render.cpp
@@ -0,0 +1,20 @@
+--- ngui/render.cpp.orig 2007-01-24 06:12:37.000000000 +0100
++++ ngui/render.cpp 2011-07-26 21:00:55.000000000 +0200
+@@ -162,7 +162,7 @@
+ row[columns.separator] = false;
+ }
+
+- Gtk::ComboBox combo(model);
++ Gtk::ComboBox combo((Glib::RefPtr<Gtk::TreeModel> &) model);
+
+ combo.pack_start(columns.icon, false);
+
+@@ -286,7 +286,7 @@
+ row[columns.separator] = false;
+ }
+
+- Gtk::ComboBox combo(model);
++ Gtk::ComboBox combo((Glib::RefPtr<Gtk::TreeModel> &) model);
+
+ combo.pack_start(columns.icon, false);
+
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index a02a85060842..8c59f58402c6 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -113,6 +113,7 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|PY_LIBS=.*|PY_LIBS="-L\$$PY_EXEC_PREFIX/lib/python\$$PY_VER/config -lpython\$$PY_VER ${PTHREAD_LIBS} -lutil"|' \
-e 's|tcl-8.4/lib|lib/tcl8.3|g' \
-e 's|-DGTK_DISABLE_DEPRECATED||g' \
+ -e 's|-DGDK_DISABLE_DEPRECATED||g' \
-e 's|-fgnu89-inline||g' \
${WRKSRC}/configure
diff --git a/mail/evolution-exchange/Makefile b/mail/evolution-exchange/Makefile
index a92cf0dcc2ee..d9459c32e264 100644
--- a/mail/evolution-exchange/Makefile
+++ b/mail/evolution-exchange/Makefile
@@ -64,6 +64,7 @@ IGNORE= build fails when ${LOCALBASE}/include/mapi.h exists in system, run pkg_i
post-patch:
@${REINPLACE_CMD} -e 's|-ldb|-l${BDB_LIB_NAME}|g' \
-e 's|-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi|${KRB5_LIB}|g' \
+ -e 's|-DGTK_DISABLE_DEPRECATED||g' \
-e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 21b9edd2d2fa..ef6ed6f3081b 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -107,6 +107,7 @@ post-patch:
@${REINPLACE_CMD} -e '/^plugins_standard_always/s/audio-inline//' \
-e 's|-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi|${KRB5_LIB}|g' \
-e 's|-Wl,--no-undefined||g' \
+ -e 's|-DGTK_DISABLE_DEPRECATED||g' \
-e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr|${LOCALBASE}|g' \
diff --git a/net-im/folks/Makefile b/net-im/folks/Makefile
index dc4484a65f19..1083d01f2888 100644
--- a/net-im/folks/Makefile
+++ b/net-im/folks/Makefile
@@ -8,6 +8,7 @@
PORTNAME= folks
PORTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= GNOME
diff --git a/net-im/folks/files/patch-backends_telepathy_lib_tpf-persona-store.vala b/net-im/folks/files/patch-backends_telepathy_lib_tpf-persona-store.vala
new file mode 100644
index 000000000000..8e8e86cd2da2
--- /dev/null
+++ b/net-im/folks/files/patch-backends_telepathy_lib_tpf-persona-store.vala
@@ -0,0 +1,109 @@
+--- backends/telepathy/lib/tpf-persona-store.vala.orig 2011-07-22 14:19:09.000000000 +0200
++++ backends/telepathy/lib/tpf-persona-store.vala 2011-07-22 14:30:40.000000000 +0200
+@@ -22,7 +22,6 @@
+ using GLib;
+ using Gee;
+ using TelepathyGLib;
+-using TelepathyGLib.ContactFeature;
+ using Folks;
+
+ /**
+@@ -36,6 +35,15 @@ public class Tpf.PersonaStore : Folks.Pe
+ {
+ private string[] undisplayed_groups = { "publish", "stored", "subscribe" };
+
++ private static ContactFeature[] _contact_features =
++ {
++ ContactFeature.ALIAS,
++ ContactFeature.AVATAR_DATA,
++ ContactFeature.AVATAR_TOKEN,
++ ContactFeature.CAPABILITIES,
++ ContactFeature.PRESENCE
++ };
++
+ private HashTable<string, Persona> _personas;
+ /* universal, contact owner handles (not channel-specific) */
+ private HashMap<uint, Persona> handle_persona_map;
+@@ -407,7 +415,7 @@ public class Tpf.PersonaStore : Folks.Pe
+ if (change_maps.size < 1)
+ return;
+
+- foreach (var entry in change_maps)
++ foreach (var entry in change_maps.entries)
+ {
+ var changes = entry.key;
+
+@@ -640,7 +648,7 @@ public class Tpf.PersonaStore : Folks.Pe
+ /*
+ * remove all persona-keyed entries
+ */
+- foreach (var entry in this.channel_group_personas_map)
++ foreach (var entry in this.channel_group_personas_map.entries)
+ {
+ var channel = (Channel) entry.key;
+ var members = this.channel_group_personas_map[channel];
+@@ -648,9 +656,8 @@ public class Tpf.PersonaStore : Folks.Pe
+ members.remove (persona);
+ }
+
+- foreach (var entry in this.group_outgoing_adds)
++ foreach (var name in this.group_outgoing_adds.keys)
+ {
+- var name = (string) entry.key;
+ var members = this.group_outgoing_adds[name];
+ if (members != null)
+ members.remove (persona);
+@@ -866,14 +873,6 @@ public class Tpf.PersonaStore : Folks.Pe
+ Channel channel,
+ Array<uint> channel_handles)
+ {
+- ContactFeature[] features =
+- {
+- ALIAS,
+- AVATAR_DATA,
+- AVATAR_TOKEN,
+- PRESENCE
+- };
+-
+ uint[] contact_handles = {};
+ for (var i = 0; i < channel_handles.length; i++)
+ {
+@@ -891,7 +890,7 @@ public class Tpf.PersonaStore : Folks.Pe
+
+ GLib.List<TelepathyGLib.Contact> contacts =
+ yield this.ll.connection_get_contacts_by_handle_async (
+- this.conn, contact_handles, (uint[]) features);
++ this.conn, contact_handles, (uint[]) _contact_features);
+
+ if (contacts == null || contacts.length () < 1)
+ return;
+@@ -918,19 +917,11 @@ public class Tpf.PersonaStore : Folks.Pe
+ private async GLib.List<Tpf.Persona>? create_personas_from_contact_ids (
+ string[] contact_ids) throws GLib.Error
+ {
+- ContactFeature[] features =
+- {
+- ALIAS,
+- AVATAR_DATA,
+- AVATAR_TOKEN,
+- PRESENCE
+- };
+-
+ if (contact_ids.length > 0)
+ {
+ GLib.List<TelepathyGLib.Contact> contacts =
+ yield this.ll.connection_get_contacts_by_id_async (
+- this.conn, contact_ids, (uint[]) features);
++ this.conn, contact_ids, (uint[]) _contact_features);
+
+ GLib.List<Persona> personas = new GLib.List<Persona> ();
+ uint err_count = 0;
+@@ -1027,7 +1018,7 @@ public class Tpf.PersonaStore : Folks.Pe
+
+ private void channel_groups_add_new_personas ()
+ {
+- foreach (var entry in this.channel_group_incoming_adds)
++ foreach (var entry in this.channel_group_incoming_adds.entries)
+ {
+ var channel = (Channel) entry.key;
+ var members_added = new GLib.List<Persona> ();
diff --git a/net-im/telepathy-glib/Makefile b/net-im/telepathy-glib/Makefile
index ff25c75aec3a..7273ab234f2d 100644
--- a/net-im/telepathy-glib/Makefile
+++ b/net-im/telepathy-glib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= telepathy-glib
PORTVERSION= 0.12.7
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
@@ -17,12 +18,12 @@ LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
- vapigen-0.10:${PORTSDIR}/lang/vala-vapigen \
+ vapigen:${PORTSDIR}/lang/vala-vapigen \
g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g} \
- vapigen-0.10:${PORTSDIR}/lang/vala-vapigen
+ vapigen:${PORTSDIR}/lang/vala-vapigen
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
@@ -35,7 +36,7 @@ CONFIGURE_ARGS= --enable-vala-bindings
post-patch:
@${REINPLACE_CMD} -e 's|\(^pkgconfigdir =\).*|\1 ${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/telepathy-glib/Makefile.in
- @${REINPLACE_CMD} -e 's|datarootdir)/vala/vapi|datarootdir)/vala-0.10/vapi|g' \
+ @${REINPLACE_CMD} -e 's|datarootdir)/vala/vapi|datarootdir)/vala-0.12/vapi|g' \
${WRKSRC}/vala/Makefile.in
.include <bsd.port.mk>
diff --git a/net-im/telepathy-glib/files/patch-telepathy-glib_Makefile.in b/net-im/telepathy-glib/files/patch-telepathy-glib_Makefile.in
new file mode 100644
index 000000000000..d88266770456
--- /dev/null
+++ b/net-im/telepathy-glib/files/patch-telepathy-glib_Makefile.in
@@ -0,0 +1,22 @@
+--- telepathy-glib/Makefile.in.orig 2011-07-22 13:41:13.000000000 +0200
++++ telepathy-glib/Makefile.in 2011-07-22 14:00:23.000000000 +0200
+@@ -1649,7 +1649,7 @@
+ @HAVE_INTROSPECTION_TRUE@ $(AM_V_GEN)$(INTROSPECTION_SCANNER) -v \
+ @HAVE_INTROSPECTION_TRUE@ --namespace TelepathyGLib \
+ @HAVE_INTROSPECTION_TRUE@ --nsversion=0.12 \
+-@HAVE_INTROSPECTION_TRUE@ $(gi_identifier_prefix_arg)=Tp \
++@HAVE_INTROSPECTION_TRUE@ --identifier-prefix=Tp \
+ @HAVE_INTROSPECTION_TRUE@ -I$(top_builddir) \
+ @HAVE_INTROSPECTION_TRUE@ -I$(top_srcdir) \
+ @HAVE_INTROSPECTION_TRUE@ --include=GLib-2.0 \
+@@ -1658,7 +1658,9 @@
+ @HAVE_INTROSPECTION_TRUE@ --library=libtelepathy-glib.la \
+ @HAVE_INTROSPECTION_TRUE@ --pkg gio-2.0 \
+ @HAVE_INTROSPECTION_TRUE@ --pkg dbus-glib-1 \
+-@HAVE_INTROSPECTION_TRUE@ $(gi_warn_all_arg) \
++@HAVE_INTROSPECTION_TRUE@ --pkg-export telepathy-glib \
++@HAVE_INTROSPECTION_TRUE@ --c-include="telepathy-glib/telepathy-glib.h" \
++@HAVE_INTROSPECTION_TRUE@ --warn-all \
+ @HAVE_INTROSPECTION_TRUE@ --output _gen/$@.tmp \
+ @HAVE_INTROSPECTION_TRUE@ $(INTROSPECTION_FILES)
+ @HAVE_INTROSPECTION_TRUE@ @xsltproc $(srcdir)/kludge.xsl _gen/$@.tmp > $@
diff --git a/net-im/telepathy-glib/pkg-plist b/net-im/telepathy-glib/pkg-plist
index 6295b7ff9285..457fc925a6f1 100644
--- a/net-im/telepathy-glib/pkg-plist
+++ b/net-im/telepathy-glib/pkg-plist
@@ -236,8 +236,8 @@ share/gtk-doc/html/telepathy-glib/telepathy-glib-util.html
share/gtk-doc/html/telepathy-glib/telepathy-glib.devhelp
share/gtk-doc/html/telepathy-glib/telepathy-glib.devhelp2
share/gtk-doc/html/telepathy-glib/up.png
-share/vala-0.10/vapi/telepathy-glib.deps
-share/vala-0.10/vapi/telepathy-glib.vapi
+share/vala-0.12/vapi/telepathy-glib.deps
+share/vala-0.12/vapi/telepathy-glib.vapi
@dirrm share/gtk-doc/html/telepathy-glib
@dirrmtry share/gtk-doc/html
@dirrmtry share/gtk-doc
diff --git a/science/peekabot/Makefile b/science/peekabot/Makefile
index ef5d2049ec18..0ed11dd14257 100644
--- a/science/peekabot/Makefile
+++ b/science/peekabot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= peekabot
PORTVERSION= 0.8.4
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}.x/
diff --git a/science/peekabot/files/patch-src_gui_ScreneViewFrame.cc b/science/peekabot/files/patch-src_gui_ScreneViewFrame.cc
new file mode 100644
index 000000000000..cd19e2052f91
--- /dev/null
+++ b/science/peekabot/files/patch-src_gui_ScreneViewFrame.cc
@@ -0,0 +1,15 @@
+--- src/gui/SceneViewFrame.cc.orig 2011-06-26 14:46:09.000000000 +0200
++++ src/gui/SceneViewFrame.cc 2011-06-26 14:46:56.000000000 +0200
+@@ -50,10 +50,11 @@
+ m_gui(layout.get_gui()),
+ m_gl_area(m_gui.get_gl_config(), true),
+ m_cameras_model(Gtk::ListStore::create(m_camera_cols)),
+- m_cameras(m_cameras_model),
+ m_cam_id(0xFFFFFFFF),
+ m_layer_table(2, 5, true)
+ {
++ m_cameras.set_model(m_cameras_model);
++
+ for( std::size_t i = 0; i < NUMBER_OF_LAYERS; ++i )
+ m_layers[i] = (i == 0);
+
diff --git a/security/libgnomesu/Makefile b/security/libgnomesu/Makefile
index 1ff574cc9660..6e7a919b71ff 100644
--- a/security/libgnomesu/Makefile
+++ b/security/libgnomesu/Makefile
@@ -21,6 +21,10 @@ CONFIGURE_ARGS+=--disable-install-pam
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/src/Makefile.in
+
post-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/gnomesu-pam.sample ${EXAMPLESDIR}
diff --git a/www/gtkhtml3/Makefile b/www/gtkhtml3/Makefile
index d031c6952059..8bb25d59c711 100644
--- a/www/gtkhtml3/Makefile
+++ b/www/gtkhtml3/Makefile
@@ -3,11 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/gtkhtml3/Makefile,v 1.177 2010/11/15 16:59:05 kwm Exp $
+# $MCom: ports/www/gtkhtml3/Makefile,v 1.180 2011/03/19 17:33:16 mezz Exp $
#
PORTNAME= gtkhtml3
PORTVERSION= 3.32.1
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/3$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -40,7 +41,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|@INTLTOOL_LIBDIR@|${LOCALBASE}/libdata|' \
${WRKSRC}/intltool-merge.in
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g ; \
+ s|-DGTK_DISABLE_DEPRECATED||g ; \
s|-DGDK_DISABLE_DEPRECATED||g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|gtkhtml-editor-test[$$]|gtkhtml3-editor-test$$|' \
+ ${WRKSRC}/components/editor/Makefile.in
.include <bsd.port.mk>
diff --git a/www/gtkhtml3/pkg-plist b/www/gtkhtml3/pkg-plist
index 3a36ed5b8cbf..fe5d58315d79 100644
--- a/www/gtkhtml3/pkg-plist
+++ b/www/gtkhtml3/pkg-plist
@@ -1,4 +1,4 @@
-bin/gtkhtml-editor-test
+bin/gtkhtml3-editor-test
include/libgtkhtml-%%VERSION%%/editor/gtkhtml-editor-actions.h
include/libgtkhtml-%%VERSION%%/editor/gtkhtml-editor-common.h
include/libgtkhtml-%%VERSION%%/editor/gtkhtml-editor-widgets.h
diff --git a/x11/libfm/Makefile b/x11/libfm/Makefile
index c9b8cdadf5c1..bb2aa7364d91 100644
--- a/x11/libfm/Makefile
+++ b/x11/libfm/Makefile
@@ -37,6 +37,10 @@ PLIST_SUB+= NLS="@comment "
.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/src/Makefile.in
+
pre-install:
cd ${WRKDIR}/libfm-${PORTVERSION} && ${CHMOD} 755 install-sh