aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/log4cpp/Makefile6
-rw-r--r--devel/seed/Makefile2
-rw-r--r--mail/dspam/Makefile2
-rw-r--r--sysutils/bsdconfig/Makefile4
4 files changed, 7 insertions, 7 deletions
diff --git a/devel/log4cpp/Makefile b/devel/log4cpp/Makefile
index 7e1e91e7bda4..ee0d33fbe372 100644
--- a/devel/log4cpp/Makefile
+++ b/devel/log4cpp/Makefile
@@ -17,18 +17,18 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
# doxygen build is BROKEN atm
-#.if exists (${LOCALBASE}/bin/doxygen) || !defined (NOPORTDOCS)
+#.if exists (${LOCALBASE}/bin/doxygen) || ${PORT_OPTIONS:MDOCS}
#BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
#.else
CONFIGURE_ARGS+= --disable-doxygen
#.endif
-#.if !exists (${LOCALBASE}/bin/doxygen) && !defined (NOPORTDOCS)
+#.if !exists (${LOCALBASE}/bin/doxygen) && ${PORT_OPTIONS:MDOCS}
#pre-everything::
# @${ECHO_CMD}
# @${ECHO_CMD} By default, this port uses doxygen to build its documentation.\
#It currently is not present your system, and if you do not want to install it, abort\
-#this build by hitting CTRL+C and re-run the installation with -DNOPORTDOCS | ${FMT} 74
+#this build by hitting CTRL+C and re-run the installation with OPTIONS_UNSET=DOCS | ${FMT} 74
# @${ECHO_CMD}
# @sleep 3
#.endif
diff --git a/devel/seed/Makefile b/devel/seed/Makefile
index dabe37504422..c744f1932ccc 100644
--- a/devel/seed/Makefile
+++ b/devel/seed/Makefile
@@ -42,7 +42,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|reference||g' ${WRKSRC}/doc/Makefile.in
# @${FIND} ${WRKSRC}/examples -name Makefile.in -type f | ${XARGS} ${REINPLACE_CMD} -e \
# 's|$$(datadir)/doc/seed/examples|${EXAMPLESDIR}|g'
-#.if defined(NOPORTEXAMPLES)
+#.if empty(PORT_OPTIONS:MEXAMPLES)
# @${REINPLACE_CMD} -e 's|examples||g' \
# ${WRKSRC}/Makefile.in
#.endif
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 80136bcb29b9..c8c8fbb6ff6a 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -503,7 +503,7 @@ post-install:
cd ${WRKSRC}/src/tools.sqlite_drv && \
${INSTALL_DATA} *.sql ${STAGEDIR}${EXAMPLESDIR}/sqlite
.endif
-.endif # NOPORTEXAMPLES
+.endif # PORT_OPTIONS:MEXAMPLES
.if ${PORT_OPTIONS:MWEBUI}
${MV} ${WRKSRC}/webui/cgi-bin/configure.pl ${WRKSRC}/webui/cgi-bin/configure.pl.sample
diff --git a/sysutils/bsdconfig/Makefile b/sysutils/bsdconfig/Makefile
index 0f19efd928f6..1445bae968de 100644
--- a/sysutils/bsdconfig/Makefile
+++ b/sysutils/bsdconfig/Makefile
@@ -30,7 +30,7 @@ MAKE_ARGS+= LIBEXECDIR="${PREFIX}/libexec" \
OPTIONS_DEFINE= EXAMPLES
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD
. if ${OSVERSION} < 900030
@@ -51,4 +51,4 @@ post-patch:
-e 's|^\(BSDCONFIG=\).*|\1${PREFIX}/sbin/${PORTNAME}|' \
${WRKSRC}/dot/dot
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>