aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile2
-rw-r--r--math/fftw3-float/Makefile16
-rw-r--r--math/fftw3-long/Makefile15
3 files changed, 33 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 91329229a02c..6f46eeff7595 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -45,6 +45,8 @@
SUBDIR += fftpack
SUBDIR += fftw
SUBDIR += fftw3
+ SUBDIR += fftw3-float
+ SUBDIR += fftw3-long
SUBDIR += freefem
SUBDIR += freefem++
SUBDIR += fudgit
diff --git a/math/fftw3-float/Makefile b/math/fftw3-float/Makefile
new file mode 100644
index 000000000000..86abebdebaba
--- /dev/null
+++ b/math/fftw3-float/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: fftw3-float
+# Date created: 2004-09-01
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Fast C routines (Single Percision)
+
+FFTW3_FLAVOR= float
+MASTERDIR= ${.CURDIR}/../../math/fftw3
+
+.include "${MASTERDIR}/Makefile"
diff --git a/math/fftw3-long/Makefile b/math/fftw3-long/Makefile
new file mode 100644
index 000000000000..dcdcd6935c59
--- /dev/null
+++ b/math/fftw3-long/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: fftw3-long
+# Date created: 2004-09-01
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+
+COMMENT= Fast C routines (Long Double Percision)
+
+FFTW3_FLAVOR= long
+MASTERDIR= ${.CURDIR}/../../math/fftw3
+
+.include "${MASTERDIR}/Makefile"