aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/mongodb32-tools/Makefile2
-rw-r--r--databases/mongodb34-tools/Makefile2
-rw-r--r--devel/arduino-builder/Makefile1
-rw-r--r--devel/arduinoOTA/Makefile2
-rw-r--r--devel/gb/Makefile1
-rw-r--r--devel/git-codereview/Makefile2
-rw-r--r--devel/grumpy/Makefile2
-rw-r--r--devel/jfrog-cli/Makefile2
-rw-r--r--editors/micro/Makefile2
-rw-r--r--misc/exercism/Makefile2
-rw-r--r--net-mgmt/kapacitor/Makefile2
-rw-r--r--net-mgmt/telegraf/Makefile2
-rw-r--r--net/cf/Makefile2
-rw-r--r--net/concourse-fly/Makefile2
-rw-r--r--net/nsq/Makefile2
-rw-r--r--net/rclone/Makefile2
-rw-r--r--net/syncthing-cli/Makefile2
-rw-r--r--net/syncthing-discosrv/Makefile2
-rw-r--r--security/ssh-vault/Makefile2
-rw-r--r--sysutils/consul-alerts/Makefile2
-rw-r--r--sysutils/epazote/Makefile2
-rw-r--r--sysutils/ipfs-go/Makefile2
-rw-r--r--sysutils/node_exporter/Makefile2
-rw-r--r--sysutils/nomad/Makefile2
-rw-r--r--sysutils/restic/Makefile1
-rw-r--r--sysutils/siegfried/Makefile2
-rw-r--r--sysutils/zfs-snap-diff/Makefile2
-rw-r--r--textproc/spiff/Makefile2
-rw-r--r--www/go-www/Makefile2
-rw-r--r--www/grafana3/Makefile2
-rw-r--r--www/minio-client/Makefile1
-rw-r--r--www/uchiwa/Makefile2
32 files changed, 0 insertions, 60 deletions
diff --git a/databases/mongodb32-tools/Makefile b/databases/mongodb32-tools/Makefile
index 5c6a3c47228b..81a320dcf437 100644
--- a/databases/mongodb32-tools/Makefile
+++ b/databases/mongodb32-tools/Makefile
@@ -29,8 +29,6 @@ SSL_USE= my_tags=ssl
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than i386 and amd64"
-STRIP= # Stripping can break go binaries
-
# Go is not our friend. Without below, ignores user-supplied flags.
MAKE_CMD= ${LOCALBASE}/bin/go build
MAKE_ENV= GOPATH="${WRKSRC}/.gopath:${WRKSRC}/vendor" \
diff --git a/databases/mongodb34-tools/Makefile b/databases/mongodb34-tools/Makefile
index 032708d0193f..adf4da377c9a 100644
--- a/databases/mongodb34-tools/Makefile
+++ b/databases/mongodb34-tools/Makefile
@@ -30,8 +30,6 @@ SSL_USE= my_tags=ssl
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than i386 and amd64"
-STRIP= # Stripping can break go binaries
-
# Go is not our friend. Without below, ignores user-supplied flags.
MAKE_CMD= ${LOCALBASE}/bin/go build
MAKE_ENV= GOPATH="${WRKSRC}/.gopath:${WRKSRC}/vendor" \
diff --git a/devel/arduino-builder/Makefile b/devel/arduino-builder/Makefile
index a87d5cce51fc..c85fa71985ee 100644
--- a/devel/arduino-builder/Makefile
+++ b/devel/arduino-builder/Makefile
@@ -27,7 +27,6 @@ TOOLS_RUN_DEPENDS= arduino-tools>=${_COMPAT_VER}:devel/arduino-tools
TOOLS_PLIST_FILES= arduino/arduino-builder.options
GO_ENV+= GOPATH=${WRKSRC}
-STRIP= # stripping can break go binaries
_COMPAT_VER= 1.6.12
_IDE_VER= 10612
diff --git a/devel/arduinoOTA/Makefile b/devel/arduinoOTA/Makefile
index 11ffec34ce90..0af6f152845d 100644
--- a/devel/arduinoOTA/Makefile
+++ b/devel/arduinoOTA/Makefile
@@ -18,8 +18,6 @@ GH_TAGNAME= c2b8306
PLIST_FILES= bin/${PORTNAME}
COMPILEINFO= ${OPSYS}${OSREL}-${ARCH}-${GH_TAGNAME}
-STRIP= # stripping can break go binaries
-
do-build:
(cd ${WRKSRC} && ${SETENV} ${GO_ENV} go build -o ${PORTNAME} -ldflags "-X main.compileInfo=${COMPILEINFO}" main.go)
diff --git a/devel/gb/Makefile b/devel/gb/Makefile
index 40bb88e521c7..dffd240bf735 100644
--- a/devel/gb/Makefile
+++ b/devel/gb/Makefile
@@ -19,7 +19,6 @@ PLIST_FILES= bin/gb bin/gb-vendor
PORTDOCS= README.md
-STRIP= # stripping can break go binaries
GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
GO_TARGET= ./...
diff --git a/devel/git-codereview/Makefile b/devel/git-codereview/Makefile
index 48a6a3b28add..c968279a8ff4 100644
--- a/devel/git-codereview/Makefile
+++ b/devel/git-codereview/Makefile
@@ -16,8 +16,6 @@ GH_TAGNAME= 77ae237
PLIST_FILES= bin/git-codereview
-STRIP= # stripping can break go binaries
-
post-patch:
@${MKDIR} ${WRKSRC}/src/golang.org/x/review
.for src in .gitattributes AUTHORS CONTRIBUTING.md CONTRIBUTORS LICENSE PATENTS \
diff --git a/devel/grumpy/Makefile b/devel/grumpy/Makefile
index f2b67e5e9922..4d61bc775a99 100644
--- a/devel/grumpy/Makefile
+++ b/devel/grumpy/Makefile
@@ -25,8 +25,6 @@ PLIST_SUB= ARCH=amd64
PLIST_SUB= ARCH=386
.endif
-STRIP= # stripping can break go binaries
-
do-install:
cd ${WRKSRC}/build/pkg && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/go/pkg/
cd ${WRKSRC}/build/src && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/go/src/
diff --git a/devel/jfrog-cli/Makefile b/devel/jfrog-cli/Makefile
index d88614b3e90d..08a7459b8fc9 100644
--- a/devel/jfrog-cli/Makefile
+++ b/devel/jfrog-cli/Makefile
@@ -15,8 +15,6 @@ GH_PROJECT= jfrog-cli-go
PLIST_FILES= bin/jfrog
-STRIP= # stripping can break go binaries
-
post-extract:
@${MV} ${WRKSRC}/vendor/ ${WRKSRC}/src
@${MKDIR} ${WRKSRC}/src/github.com/jfrogdev/jfrog-cli-go
diff --git a/editors/micro/Makefile b/editors/micro/Makefile
index 57e3a110b78a..ba3b80f165c6 100644
--- a/editors/micro/Makefile
+++ b/editors/micro/Makefile
@@ -37,8 +37,6 @@ GH_TUPLE= \
BUILD_HASH= 5dc8fe4
BUILD_DATE= February 10, 2017
-STRIP= # stripping can break go binaries
-
PLIST_FILES= bin/micro
PORTDOCS= README.md
diff --git a/misc/exercism/Makefile b/misc/exercism/Makefile
index 262399c3aaaa..2e4bb053a70d 100644
--- a/misc/exercism/Makefile
+++ b/misc/exercism/Makefile
@@ -14,8 +14,6 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
USE_GITHUB= yes
GH_PROJECT= cli
-STRIP= # stripping can break go binaries
-
PLIST_FILES= bin/exercism
post-patch:
diff --git a/net-mgmt/kapacitor/Makefile b/net-mgmt/kapacitor/Makefile
index e8446d909a26..10e8e1d4efd3 100644
--- a/net-mgmt/kapacitor/Makefile
+++ b/net-mgmt/kapacitor/Makefile
@@ -28,8 +28,6 @@ SUB_FILES= kapacitord
SUB_LIST+= KAPACITORD_PIDDIR=${KAPACITORD_PIDDIR}
PLIST_SUB= KAPACITORD_PIDDIR=${KAPACITORD_PIDDIR}
-STRIP= # stripping can break go binaries
-
post-patch:
@${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}
@cd ${WRKSRC} && ${MV} \
diff --git a/net-mgmt/telegraf/Makefile b/net-mgmt/telegraf/Makefile
index 11651ad41186..b68feb4bd18c 100644
--- a/net-mgmt/telegraf/Makefile
+++ b/net-mgmt/telegraf/Makefile
@@ -90,8 +90,6 @@ SUB_FILES= telegraf
SUB_LIST+= TELEGRAF_PIDDIR=${TELEGRAF_PIDDIR}
PLIST_SUB= TELEGRAF_PIDDIR=${TELEGRAF_PIDDIR}
-STRIP= # stripping can break go binaries
-
post-patch:
@${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}
@cd ${WRKSRC} && ${MV} CHANGELOG.md CONTRIBUTING.md Godeps Godeps_windows \
diff --git a/net/cf/Makefile b/net/cf/Makefile
index 4dbb1870452c..db5c49df2ca9 100644
--- a/net/cf/Makefile
+++ b/net/cf/Makefile
@@ -24,8 +24,6 @@ PLIST_FILES= bin/cf
PORTDOCS= CHANGELOG.md NOTICE README.md
-STRIP= # stripping can break go binaries
-
OPTIONS_DEFINE= DOCS
do-build:
diff --git a/net/concourse-fly/Makefile b/net/concourse-fly/Makefile
index 6724adba9a74..7701cd2d5774 100644
--- a/net/concourse-fly/Makefile
+++ b/net/concourse-fly/Makefile
@@ -22,8 +22,6 @@ CONFLICTS_INSTALL= fly
PLIST_FILES= bin/fly
-STRIP= # stripping can break go binaries
-
# The build instructions for `fly` suggest to clone the global Concourse
# repository, which contains many Git submodules, including fly, and
# build from there. So basically:
diff --git a/net/nsq/Makefile b/net/nsq/Makefile
index ea0964f72f83..f395c0628077 100644
--- a/net/nsq/Makefile
+++ b/net/nsq/Makefile
@@ -39,8 +39,6 @@ GH_TUPLE= BurntSushi:toml:v0.2.0:toml/src/github.com/BurntSushi/toml \
TARGETS= nsqd nsqlookupd nsqadmin nsq_pubsub nsq_to_nsq nsq_to_file \
nsq_to_http nsq_tail nsq_stat to_nsq
-STRIP=
-
.for _t in ${TARGETS}
build-${_t}:
cd ${GO_WRKSRC}/apps/${_t}; \
diff --git a/net/rclone/Makefile b/net/rclone/Makefile
index 8854d0ebc6d8..f85c99a772db 100644
--- a/net/rclone/Makefile
+++ b/net/rclone/Makefile
@@ -41,8 +41,6 @@ GH_TUPLE+= \
PLIST_FILES= bin/rclone
-STRIP= # stripping can break go binaries
-
do-build:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}; ${SETENV} GOPATH=${WRKSRC} go build .
diff --git a/net/syncthing-cli/Makefile b/net/syncthing-cli/Makefile
index e946777acba7..9245d2b5bd73 100644
--- a/net/syncthing-cli/Makefile
+++ b/net/syncthing-cli/Makefile
@@ -16,8 +16,6 @@ GH_TAGNAME= 9594d39
PLIST_FILES= bin/syncthing-cli
-STRIP= # stripping can break go binaries
-
do-build:
@cd ${WRKSRC} ; ${SETENV} GOPATH=${WRKSRC}/Godeps/_workspace:${WRKSRC} go build
@${MV} ${WRKSRC}/syncthing-cli-${GH_TAGNAME} ${WRKSRC}/syncthing-cli
diff --git a/net/syncthing-discosrv/Makefile b/net/syncthing-discosrv/Makefile
index 74d174672217..30763259a757 100644
--- a/net/syncthing-discosrv/Makefile
+++ b/net/syncthing-discosrv/Makefile
@@ -21,8 +21,6 @@ USE_RC_SUBR= syncthing-discosrv
USERS= syncthing
GROUPS= syncthing
-STRIP= # stripping can break go binaries
-
post-patch:
@cd ${WRKSRC} ; ${MKDIR} src/github.com/${GH_ACCOUNT}/${GH_PROJECT} ; \
${MV} .gitignore CONTRIBUTORS LICENSE README.md build.sh \
diff --git a/security/ssh-vault/Makefile b/security/ssh-vault/Makefile
index 936cb408794f..fc7c152c3a12 100644
--- a/security/ssh-vault/Makefile
+++ b/security/ssh-vault/Makefile
@@ -20,8 +20,6 @@ GH_TUPLE= ssh-vault:crypto:ae180e0:crypto/src/github.com/ssh-vault/crypto \
ssh-vault:ssh2pem:c1edc64:ssh2pem/src/github.com/ssh-vault/ssh2pem
GH_SUBDIR= src/github.com/${PORTNAME}/${PORTNAME}
-STRIP= # stripping can break go binaries
-
PLIST_FILES= bin/ssh-vault
post-patch:
diff --git a/sysutils/consul-alerts/Makefile b/sysutils/consul-alerts/Makefile
index 35695899fc33..24e5f7152910 100644
--- a/sysutils/consul-alerts/Makefile
+++ b/sysutils/consul-alerts/Makefile
@@ -25,8 +25,6 @@ PLIST_FILES= ${PREFIX}/bin/${PORTNAME}
USE_RC_SUBR= ${PORTNAME}
-STRIP= #none
-
do-build:
cd ${GO_WRKSRC} && \
${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -v -x \
diff --git a/sysutils/epazote/Makefile b/sysutils/epazote/Makefile
index c1461c353cdc..669ad3a345bc 100644
--- a/sysutils/epazote/Makefile
+++ b/sysutils/epazote/Makefile
@@ -19,8 +19,6 @@ GH_TUPLE= epazote:scheduler:0.1.0:scheduler/src/github.com/epazote/scheduler \
go-yaml:yaml:cd8b52f:yaml/src/github.com/go-yaml/yaml
GH_SUBDIR= src/github.com/${PORTNAME}/${PORTNAME}
-STRIP= # stripping can break go binaries
-
PLIST_FILES= bin/epazote
do-build:
diff --git a/sysutils/ipfs-go/Makefile b/sysutils/ipfs-go/Makefile
index 089e762cef85..91c052735c91 100644
--- a/sysutils/ipfs-go/Makefile
+++ b/sysutils/ipfs-go/Makefile
@@ -25,8 +25,6 @@ PLIST_FILES= bin/${PORTNAME}
USE_RC_SUBR= ${PORTNAME}
-STRIP= # stripping can break go binaries
-
do-build:
cd ${WRKSRC}/src/github.com/ipfs/go-ipfs/cmd/ipfs; \
${SETENV} ${BUILD_ENV} ${MAKE_ENV} go build -v -x \
diff --git a/sysutils/node_exporter/Makefile b/sysutils/node_exporter/Makefile
index 5f15252da7ea..72db5a12cc65 100644
--- a/sysutils/node_exporter/Makefile
+++ b/sysutils/node_exporter/Makefile
@@ -23,8 +23,6 @@ PLIST_FILES= bin/node_exporter
USE_RC_SUBR= node_exporter
-STRIP= # stripping can break go binaries
-
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/bin/node_exporter ${STAGEDIR}${PREFIX}/bin
diff --git a/sysutils/nomad/Makefile b/sysutils/nomad/Makefile
index e2b48febbae4..0dea04908c6b 100644
--- a/sysutils/nomad/Makefile
+++ b/sysutils/nomad/Makefile
@@ -25,8 +25,6 @@ USE_RC_SUBR= nomad
USERS= nomad
GROUPS= nomad
-STRIP=
-
do-build:
@cd ${WRKSRC}/src/github.com/hashicorp/nomad; \
${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -v -x \
diff --git a/sysutils/restic/Makefile b/sysutils/restic/Makefile
index 7845278106b5..c1577a78d265 100644
--- a/sysutils/restic/Makefile
+++ b/sysutils/restic/Makefile
@@ -14,7 +14,6 @@ LICENSE= BSD2CLAUSE
USES= go
USE_GITHUB= yes
-STRIP= # stripping can break go binaries
PLIST_FILES= bin/restic
post-patch:
diff --git a/sysutils/siegfried/Makefile b/sysutils/siegfried/Makefile
index 2fdb9e40bf07..acae7fc7c8c0 100644
--- a/sysutils/siegfried/Makefile
+++ b/sysutils/siegfried/Makefile
@@ -22,6 +22,4 @@ USES= go
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
GO_TARGET= github.com/${GH_ACCOUNT}/${PORTNAME}/cmd/sf
-STRIP= # stripping can break go binaries
-
.include <bsd.port.mk>
diff --git a/sysutils/zfs-snap-diff/Makefile b/sysutils/zfs-snap-diff/Makefile
index 91d4243769b1..10f2853b88de 100644
--- a/sysutils/zfs-snap-diff/Makefile
+++ b/sysutils/zfs-snap-diff/Makefile
@@ -24,6 +24,4 @@ USES= go
PLIST_FILES= bin/zfs-snap-diff
-STRIP= # stripping can break go binaries
-
.include <bsd.port.mk>
diff --git a/textproc/spiff/Makefile b/textproc/spiff/Makefile
index 65382333f1f8..c8683649e034 100644
--- a/textproc/spiff/Makefile
+++ b/textproc/spiff/Makefile
@@ -18,8 +18,6 @@ PLIST_FILES= bin/spiff
PORTDOCS= LICENSE README.md examples/cf-aws.yml \
examples/multi-az-cf-aws.yml examples/tutorial.md
-STRIP= # stripping can break go binaries
-
OPTIONS_DEFINE= DOCS
post-patch:
diff --git a/www/go-www/Makefile b/www/go-www/Makefile
index 7f7fcbf009f4..e9704de3a66f 100644
--- a/www/go-www/Makefile
+++ b/www/go-www/Makefile
@@ -19,8 +19,6 @@ GH_ACCOUNT= nbari:DEFAULT
GH_TUPLE= golang:crypto:847319b:crypto/src/golang.org/x/crypto
GH_SUBDIR= src/github.com/nbari/${PORTNAME}
-STRIP= # stripping can break go binaries
-
PLIST_FILES= bin/www
post-patch:
diff --git a/www/grafana3/Makefile b/www/grafana3/Makefile
index 8430ebe62c50..e8e027be08b4 100644
--- a/www/grafana3/Makefile
+++ b/www/grafana3/Makefile
@@ -97,8 +97,6 @@ SUB_LIST+= GRAFANA_USER=${GRAFANA_USER} \
PLIST_SUB+= GRAFANAHOMEDIR=${GRAFANAHOMEDIR}
-STRIP=
-
post-extract:
@${MKDIR} ${WRKSRC}/src/github.com/grafana/grafana
.for src in .bowerrc .bra.toml .editorconfig .github .gitignore .hooks \
diff --git a/www/minio-client/Makefile b/www/minio-client/Makefile
index cf12815dbb40..7e8459fda53e 100644
--- a/www/minio-client/Makefile
+++ b/www/minio-client/Makefile
@@ -32,7 +32,6 @@ GH_TAGNAME= RELEASE.2017-02-06T20-16-19Z
GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${GH_PROJECT}
MAKE_ENV= GOPATH=${WRKSRC} GOROOT=${LOCALBASE}/go
-STRIP= # stripping can break go binaries
PLIST_FILES= bin/${MC}
do-build:
diff --git a/www/uchiwa/Makefile b/www/uchiwa/Makefile
index 16b33c750070..6d2a7588edc7 100644
--- a/www/uchiwa/Makefile
+++ b/www/uchiwa/Makefile
@@ -46,8 +46,6 @@ GH_TUPLE+= kless:osutil:3ac994847c4376a4b905fc0a19f450c5a4bec647:klessosutil/src
USERS= uchiwa
GROUPS= uchiwa
-STRIP= #
-
post-extract:
@${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}
.for src in .travis.yml Gruntfile.js bower.json package.json uchiwa \