aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/afnix/Makefile2
-rw-r--r--lang/gforth/Makefile2
-rw-r--r--lang/gprolog/Makefile2
-rw-r--r--lang/harbour/Makefile2
-rw-r--r--lang/jruby/Makefile2
-rw-r--r--lang/mlton/Makefile2
-rw-r--r--lang/newlisp-devel/Makefile2
-rw-r--r--lang/newlisp/Makefile2
8 files changed, 11 insertions, 5 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index e4f16e8fca76..01aa7ef8747d 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -24,6 +24,8 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PORTDOCS= *
PLIST_SUB= PORTVER=${PORTVERSION:R}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "powerpc"
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index 058e4c8f8942..4d7b31495f6d 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -38,6 +38,8 @@ PORTDOCS= AUTHORS BUGS Benchres COPYING COPYING.DOC \
INFO= gforth vmgen
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if ${ARCH} == i386 || ${ARCH} == powerpc
diff --git a/lang/gprolog/Makefile b/lang/gprolog/Makefile
index 88c592f760ef..f9829d4e51c3 100644
--- a/lang/gprolog/Makefile
+++ b/lang/gprolog/Makefile
@@ -24,7 +24,7 @@ MAKE_JOBS_UNSAFE= yes
PLIST_SUB+= GPROLOG_VER=${PORTVERSION}
-OPTIONS_DEFINE= FD
+OPTIONS_DEFINE= FD DOCS EXAMPLES
OPTIONS_DEFAULT=FD
FD_DESC= Enable finite domain constraint solver
diff --git a/lang/harbour/Makefile b/lang/harbour/Makefile
index 9413b03fb59e..f10d687bcf12 100644
--- a/lang/harbour/Makefile
+++ b/lang/harbour/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libslang.so:${PORTSDIR}/devel/libslang2\
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS_DEFINE= MYSQL SQLITE FIREBIRD PGSQL
+OPTIONS_DEFINE= MYSQL SQLITE FIREBIRD PGSQL DOCS
NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON= does not compile on sparc64: assertion failed
diff --git a/lang/jruby/Makefile b/lang/jruby/Makefile
index 42d174355ce6..cd2dd4aa980d 100644
--- a/lang/jruby/Makefile
+++ b/lang/jruby/Makefile
@@ -26,6 +26,8 @@ SHEBANG_FILES= rake spec spec_translator Rakefile '*.rb'
PLIST_SUB+= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION} JRUBY_HOME=${JRUBY_HOME:S,${PREFIX}/,,}
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.pre.mk>
pre-patch:
diff --git a/lang/mlton/Makefile b/lang/mlton/Makefile
index c25f8c4d3be4..c8c732c31e88 100644
--- a/lang/mlton/Makefile
+++ b/lang/mlton/Makefile
@@ -26,7 +26,7 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LICENSE_FILE= doc/license/MLton-LICENSE
-OPTIONS_DEFINE= SMLNJ MINGW32
+OPTIONS_DEFINE= SMLNJ MINGW32 DOCS
SMLNJ_DESC= Bootstrap with SML/NJ (can take >15 hours)
MINGW32_DESC= Add the mingw32 target (requires wine)
diff --git a/lang/newlisp-devel/Makefile b/lang/newlisp-devel/Makefile
index 481cab656e9b..78194af7a22c 100644
--- a/lang/newlisp-devel/Makefile
+++ b/lang/newlisp-devel/Makefile
@@ -33,7 +33,7 @@ DOCS= CHANGES CodePatterns.html ExpressionEvaluation.html \
manual_frame.html newLISPdoc.html \
newlisp_index.html newlisp_manual.html \
-OPTIONS_DEFINE= GMP GSL MYSQL PGSQL SQLITE GUISERV
+OPTIONS_DEFINE= GMP GSL MYSQL PGSQL SQLITE GUISERV DOCS EXAMPLES
GSL_DESC= GSL (GNU Scientific Library)
GUISERV_DESC= Install GUI server (in Java)
diff --git a/lang/newlisp/Makefile b/lang/newlisp/Makefile
index 85170685a3d7..42eb82a19cc7 100644
--- a/lang/newlisp/Makefile
+++ b/lang/newlisp/Makefile
@@ -30,7 +30,7 @@ DOCS= CHANGES CodePatterns.html ExpressionEvaluation.html \
manual_frame.html newLISPdoc.html \
newlisp_index.html newlisp_manual.html \
-OPTIONS_DEFINE= GMP GSL MYSQL PGSQL SQLITE GUISERV
+OPTIONS_DEFINE= GMP GSL MYSQL PGSQL SQLITE GUISERV DOCS EXAMPLES
GSL_DESC= GSL (GNU Scientific Library)
GUISERV_DESC= Install GUI server (in Java)