aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Net-SMTP-TLS/Makefile27
-rw-r--r--mail/p5-Net-SMTP-TLS/distinfo3
-rw-r--r--mail/p5-Net-SMTP-TLS/pkg-descr6
-rw-r--r--mail/p5-Net-SMTP-TLS/pkg-plist8
5 files changed, 45 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index ac089dfb92a1..cea07aeefc62 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -336,6 +336,7 @@
SUBDIR += p5-Net-IMAP-Simple-SSL
SUBDIR += p5-Net-QMTP
SUBDIR += p5-Net-SMTP-Server
+ SUBDIR += p5-Net-SMTP-TLS
SUBDIR += p5-Net-Server-Mail
SUBDIR += p5-POE-Component-Client-POP3
SUBDIR += p5-POE-Component-Client-SMTP
diff --git a/mail/p5-Net-SMTP-TLS/Makefile b/mail/p5-Net-SMTP-TLS/Makefile
new file mode 100644
index 000000000000..02d8b7b4cb5f
--- /dev/null
+++ b/mail/p5-Net-SMTP-TLS/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-SMTP-TLS
+# Date created: 2006-07-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SMTP-TLS
+PORTVERSION= 0.12
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= An SMTP client supporting TLS and AUTH
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SMTP::TLS.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Net-SMTP-TLS/distinfo b/mail/p5-Net-SMTP-TLS/distinfo
new file mode 100644
index 000000000000..973522fb2335
--- /dev/null
+++ b/mail/p5-Net-SMTP-TLS/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-SMTP-TLS-0.12.tar.gz) = a845eba3670e56a197ecd37f571d153a
+SHA256 (Net-SMTP-TLS-0.12.tar.gz) = efe772667ac37702b96b6db5297cc827427a3b3a3819b7a4315b08b9d444e4a5
+SIZE (Net-SMTP-TLS-0.12.tar.gz) = 5994
diff --git a/mail/p5-Net-SMTP-TLS/pkg-descr b/mail/p5-Net-SMTP-TLS/pkg-descr
new file mode 100644
index 000000000000..54eb94394be9
--- /dev/null
+++ b/mail/p5-Net-SMTP-TLS/pkg-descr
@@ -0,0 +1,6 @@
+Net::SMTP::TLS is a TLS and AUTH capable SMTP client which offers an
+interface that users will find familiar from Net::SMTP. Net::SMTP::TLS
+implements a subset of the methods provided by that module, but
+certainly not (yet) a complete mirror image of that API.
+
+WWW: http://search.cpan.org/dist/Net-SMTP-TLS/
diff --git a/mail/p5-Net-SMTP-TLS/pkg-plist b/mail/p5-Net-SMTP-TLS/pkg-plist
new file mode 100644
index 000000000000..5172c8eecaf9
--- /dev/null
+++ b/mail/p5-Net-SMTP-TLS/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMTP/TLS/.packlist
+%%SITE_PERL%%/Net/SMTP/TLS.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMTP/TLS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/SMTP
+@dirrmtry %%SITE_PERL%%/Net