aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/cidr/Makefile24
-rw-r--r--net-mgmt/cidr/distinfo1
-rw-r--r--net-mgmt/cidr/files/patch-aa11
-rw-r--r--net-mgmt/cidr/pkg-comment1
-rw-r--r--net-mgmt/cidr/pkg-descr6
-rw-r--r--net-mgmt/cidr/pkg-plist1
-rw-r--r--net/Makefile1
-rw-r--r--net/cidr/Makefile24
-rw-r--r--net/cidr/distinfo1
-rw-r--r--net/cidr/files/patch-aa11
-rw-r--r--net/cidr/pkg-comment1
-rw-r--r--net/cidr/pkg-descr6
-rw-r--r--net/cidr/pkg-plist1
13 files changed, 89 insertions, 0 deletions
diff --git a/net-mgmt/cidr/Makefile b/net-mgmt/cidr/Makefile
new file mode 100644
index 000000000000..8ea6b9e0c0d2
--- /dev/null
+++ b/net-mgmt/cidr/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: sqsh
+# Date created: 18 Jun 2000
+# Whom: Domas Mituzas <midom@dammit.lt>
+#
+# $FreeBSD$
+
+PORTNAME= cidr
+PORTVERSION= 2.3
+CATEGORIES= net
+MASTER_SITES= http://home.netcom.com/~naym/cidr/
+DISTNAME= cidr-current
+
+MAINTAINER= midom@dammit.lt
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+ALL_TARGET= cidr
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cidr ${PREFIX}/bin/cidr
+ ${INSTALL_MAN} ${WRKSRC}/cidr.1 ${PREFIX}/man/man1/cidr.1
+
+MAN1= cidr.1
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/cidr/distinfo b/net-mgmt/cidr/distinfo
new file mode 100644
index 000000000000..645ae8083b36
--- /dev/null
+++ b/net-mgmt/cidr/distinfo
@@ -0,0 +1 @@
+MD5 (cidr-current.tar.gz) = 59b4c94b2a721a0e47973d0f79d72d91
diff --git a/net-mgmt/cidr/files/patch-aa b/net-mgmt/cidr/files/patch-aa
new file mode 100644
index 000000000000..063439a16695
--- /dev/null
+++ b/net-mgmt/cidr/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.old Wed Jul 19 12:44:39 2000
++++ Makefile Sat Jun 17 14:26:22 2000
+@@ -4,7 +4,7 @@
+ OBJS = cidr.o
+
+ cidr: $(OBJS)
+- gcc -Wall -o cidr cidr.c
++ gcc -Wall -o cidr $(OBJS)
+
+ clean:
+ rm $(OBJS) cidr
diff --git a/net-mgmt/cidr/pkg-comment b/net-mgmt/cidr/pkg-comment
new file mode 100644
index 000000000000..44872cd8446e
--- /dev/null
+++ b/net-mgmt/cidr/pkg-comment
@@ -0,0 +1 @@
+RFC 1878 subnet calculator / helper
diff --git a/net-mgmt/cidr/pkg-descr b/net-mgmt/cidr/pkg-descr
new file mode 100644
index 000000000000..486dc316e448
--- /dev/null
+++ b/net-mgmt/cidr/pkg-descr
@@ -0,0 +1,6 @@
+cidr is a tiny command-line tool for determining network and broadcast
+addresses a la RFC 1878. It takes an IP address and netmask and
+outputs the network address, broadcast address, and total number of
+addresses for the corresponding subnet. The IP can be in binary,
+decimal, hex, or dotted quad. The mask can be in binary, decimal, hex,
+dotted quad, or prefix.
diff --git a/net-mgmt/cidr/pkg-plist b/net-mgmt/cidr/pkg-plist
new file mode 100644
index 000000000000..5485d27b325b
--- /dev/null
+++ b/net-mgmt/cidr/pkg-plist
@@ -0,0 +1 @@
+bin/cidr
diff --git a/net/Makefile b/net/Makefile
index dc43f441de6b..7bea83701ffa 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -21,6 +21,7 @@
SUBDIR += cap
SUBDIR += centericq
SUBDIR += choparp
+ SUBDIR += cidr
SUBDIR += ciscoconf
SUBDIR += citrix_ica
SUBDIR += clog
diff --git a/net/cidr/Makefile b/net/cidr/Makefile
new file mode 100644
index 000000000000..8ea6b9e0c0d2
--- /dev/null
+++ b/net/cidr/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: sqsh
+# Date created: 18 Jun 2000
+# Whom: Domas Mituzas <midom@dammit.lt>
+#
+# $FreeBSD$
+
+PORTNAME= cidr
+PORTVERSION= 2.3
+CATEGORIES= net
+MASTER_SITES= http://home.netcom.com/~naym/cidr/
+DISTNAME= cidr-current
+
+MAINTAINER= midom@dammit.lt
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+ALL_TARGET= cidr
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cidr ${PREFIX}/bin/cidr
+ ${INSTALL_MAN} ${WRKSRC}/cidr.1 ${PREFIX}/man/man1/cidr.1
+
+MAN1= cidr.1
+
+.include <bsd.port.mk>
diff --git a/net/cidr/distinfo b/net/cidr/distinfo
new file mode 100644
index 000000000000..645ae8083b36
--- /dev/null
+++ b/net/cidr/distinfo
@@ -0,0 +1 @@
+MD5 (cidr-current.tar.gz) = 59b4c94b2a721a0e47973d0f79d72d91
diff --git a/net/cidr/files/patch-aa b/net/cidr/files/patch-aa
new file mode 100644
index 000000000000..063439a16695
--- /dev/null
+++ b/net/cidr/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.old Wed Jul 19 12:44:39 2000
++++ Makefile Sat Jun 17 14:26:22 2000
+@@ -4,7 +4,7 @@
+ OBJS = cidr.o
+
+ cidr: $(OBJS)
+- gcc -Wall -o cidr cidr.c
++ gcc -Wall -o cidr $(OBJS)
+
+ clean:
+ rm $(OBJS) cidr
diff --git a/net/cidr/pkg-comment b/net/cidr/pkg-comment
new file mode 100644
index 000000000000..44872cd8446e
--- /dev/null
+++ b/net/cidr/pkg-comment
@@ -0,0 +1 @@
+RFC 1878 subnet calculator / helper
diff --git a/net/cidr/pkg-descr b/net/cidr/pkg-descr
new file mode 100644
index 000000000000..486dc316e448
--- /dev/null
+++ b/net/cidr/pkg-descr
@@ -0,0 +1,6 @@
+cidr is a tiny command-line tool for determining network and broadcast
+addresses a la RFC 1878. It takes an IP address and netmask and
+outputs the network address, broadcast address, and total number of
+addresses for the corresponding subnet. The IP can be in binary,
+decimal, hex, or dotted quad. The mask can be in binary, decimal, hex,
+dotted quad, or prefix.
diff --git a/net/cidr/pkg-plist b/net/cidr/pkg-plist
new file mode 100644
index 000000000000..5485d27b325b
--- /dev/null
+++ b/net/cidr/pkg-plist
@@ -0,0 +1 @@
+bin/cidr