aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/macroscope/Makefile4
-rw-r--r--palm/synce-dccm/Makefile8
-rw-r--r--palm/synce-vdccm/Makefile8
-rw-r--r--security/libprelude/Makefile4
4 files changed, 22 insertions, 2 deletions
diff --git a/net-mgmt/macroscope/Makefile b/net-mgmt/macroscope/Makefile
index 03ab21c712cc..24db587a496d 100644
--- a/net-mgmt/macroscope/Makefile
+++ b/net-mgmt/macroscope/Makefile
@@ -51,6 +51,10 @@ USE_FIREBIRD= yes
.include "${PORTSDIR}/Mk/bsd.database.mk"
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile
+.endif
+
do-configure:
@(cd ${WRKSRC}; \
${LOCALBASE}/bin/cmake ${CMAKE_ARGS} .)
diff --git a/palm/synce-dccm/Makefile b/palm/synce-dccm/Makefile
index 9ac8de67632c..b6ac241d4d38 100644
--- a/palm/synce-dccm/Makefile
+++ b/palm/synce-dccm/Makefile
@@ -24,4 +24,10 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE} \
--with-libsynce=${LOCALBASE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/palm/synce-vdccm/Makefile b/palm/synce-vdccm/Makefile
index 9ac8de67632c..b6ac241d4d38 100644
--- a/palm/synce-vdccm/Makefile
+++ b/palm/synce-vdccm/Makefile
@@ -24,4 +24,10 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE} \
--with-libsynce=${LOCALBASE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index a9569560faef..30bdc6b343dd 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -49,6 +49,10 @@ PLIST_SUB+= WITH_PYTHON="@comment "
.if !defined(NOPORTDOCS)
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile
+.endif
+
post-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${DOCSDIR}