aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/gdb6/Makefile4
-rw-r--r--devel/gdb66/Makefile4
-rw-r--r--games/battleball/Makefile8
3 files changed, 15 insertions, 1 deletions
diff --git a/devel/gdb6/Makefile b/devel/gdb6/Makefile
index ffa14b8b6573..0914ce2f2209 100644
--- a/devel/gdb6/Makefile
+++ b/devel/gdb6/Makefile
@@ -34,6 +34,10 @@ CFLAGS+= -DRL_NO_COMPAT -DKGDB
.include <bsd.port.pre.mk>
+.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
+BROKEN= "Does not build on ia64 or sparc64"
+.endif
+
.if ${OSVERSION} < 500000
CFLAGS+= -include ${FILESDIR}/fbsd4.h
.endif
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index ffa14b8b6573..0914ce2f2209 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -34,6 +34,10 @@ CFLAGS+= -DRL_NO_COMPAT -DKGDB
.include <bsd.port.pre.mk>
+.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
+BROKEN= "Does not build on ia64 or sparc64"
+.endif
+
.if ${OSVERSION} < 500000
CFLAGS+= -include ${FILESDIR}/fbsd4.h
.endif
diff --git a/games/battleball/Makefile b/games/battleball/Makefile
index 2b1daf2735ae..eec50c0f5239 100644
--- a/games/battleball/Makefile
+++ b/games/battleball/Makefile
@@ -21,6 +21,12 @@ MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
CFLAGS+= -Wno-deprecated
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
+BROKEN= "Does not compile on ia64 or sparc64"
+.endif
+
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/battleball ${PREFIX}/bin
@@ -32,4 +38,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>