aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/balsa/Makefile8
-rw-r--r--japanese/kon2-16dot/Makefile8
-rw-r--r--japanese/lookup-emacs21/Makefile8
-rw-r--r--japanese/lookup/Makefile8
-rw-r--r--japanese/prn/Makefile8
-rw-r--r--net/ppxp/Makefile4
6 files changed, 39 insertions, 5 deletions
diff --git a/japanese/balsa/Makefile b/japanese/balsa/Makefile
index 29640f3d6a32..b27a992e4b93 100644
--- a/japanese/balsa/Makefile
+++ b/japanese/balsa/Makefile
@@ -31,6 +31,12 @@ CONFIGURE_ENV= CPPFLAGS='-I${LOCALBASE}/include' \
LIBS='-L${LOCALBASE}/lib'
MAN1= balsa.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -45,4 +51,4 @@ pre-configure:
post-install:
${INSTALL_MAN} ${WRKSRC}/balsa.1 ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/kon2-16dot/Makefile b/japanese/kon2-16dot/Makefile
index 93efe8e0290d..1e15ad0e3b02 100644
--- a/japanese/kon2-16dot/Makefile
+++ b/japanese/kon2-16dot/Makefile
@@ -42,6 +42,12 @@ KON14FONT=Startup
@${FALSE}
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-build:
${SED} -e 's,%%PREFIX%%,${PREFIX},' \
-e 's,%%DISTDIR%%,${DISTDIR},' \
@@ -60,4 +66,4 @@ post-install:
${DOCDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/lookup-emacs21/Makefile b/japanese/lookup-emacs21/Makefile
index aa89e7ad010e..05f03e2616ca 100644
--- a/japanese/lookup-emacs21/Makefile
+++ b/japanese/lookup-emacs21/Makefile
@@ -36,6 +36,12 @@ CONFIGURE_ARGS= --with-emacs=${EMACS_CMD} \
--with-lispdir=${ELISPDIR} \
--infodir=${PORTINFODIR}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not build on FreeBSD >= 5.x"
+.endif
+
post-install:
.if (${EMACS_PORT_NAME} == "xemacs21-mule")
${RM} -f ${WRKDIR}/${MANIFEST}
@@ -47,4 +53,4 @@ post-install:
${EMACSDIR}/pkginfo/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/lookup/Makefile b/japanese/lookup/Makefile
index aa89e7ad010e..05f03e2616ca 100644
--- a/japanese/lookup/Makefile
+++ b/japanese/lookup/Makefile
@@ -36,6 +36,12 @@ CONFIGURE_ARGS= --with-emacs=${EMACS_CMD} \
--with-lispdir=${ELISPDIR} \
--infodir=${PORTINFODIR}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not build on FreeBSD >= 5.x"
+.endif
+
post-install:
.if (${EMACS_PORT_NAME} == "xemacs21-mule")
${RM} -f ${WRKDIR}/${MANIFEST}
@@ -47,4 +53,4 @@ post-install:
${EMACSDIR}/pkginfo/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/prn/Makefile b/japanese/prn/Makefile
index f797d41b2d63..7436749ff693 100644
--- a/japanese/prn/Makefile
+++ b/japanese/prn/Makefile
@@ -21,4 +21,10 @@ MANLANG= ja
MAN1= prn.1 cprn.1 cmt.1 psconv.1
MAN5= cmtdefs.5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/ppxp/Makefile b/net/ppxp/Makefile
index 85b857de29c9..14c8cc871a4d 100644
--- a/net/ppxp/Makefile
+++ b/net/ppxp/Makefile
@@ -68,6 +68,10 @@ DOC_ja_JP= QuickStart.txt QuickUsage.txt guide-1.html guide-2.html \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${ARCH} == "ia64"
BROKEN= "Coredump during build on ia64"
.endif