aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/jellyfish/Makefile2
-rw-r--r--biology/jellyfish/files/patch-include_jellyfish_file__header.hpp35
-rw-r--r--devel/jsoncpp/Makefile17
-rw-r--r--devel/llvm60/Makefile4
-rw-r--r--devel/llvm70/Makefile4
-rw-r--r--devel/llvm80/Makefile4
-rw-r--r--devel/llvm90/Makefile4
-rw-r--r--devel/qtcreator/Makefile4
-rw-r--r--devel/sdl2pp/Makefile8
-rw-r--r--dns/powerdns-recursor/Makefile2
-rw-r--r--finance/moneymanagerex/Makefile9
-rw-r--r--finance/moneymanagerex/files/patch-src_import__export_univcsvdialog.cpp32
-rw-r--r--finance/moneymanagerex/files/patch-src_webapp.cpp25
-rw-r--r--games/pioneer/Makefile9
-rw-r--r--games/rlvm/Makefile1
-rw-r--r--games/stonesoup/Makefile8
-rw-r--r--graphics/aseprite/Makefile2
-rw-r--r--graphics/colmap/Makefile2
-rw-r--r--graphics/hiptext/Makefile1
-rw-r--r--graphics/libboard/Makefile1
-rw-r--r--graphics/mapnik/Makefile8
-rw-r--r--graphics/podofo/Makefile8
-rw-r--r--graphics/sekrit-twc-zimg/Makefile2
-rw-r--r--graphics/vapoursynth-waifu2x-w2xc/Makefile2
-rw-r--r--graphics/waifu2x-converter-cpp/Makefile2
-rw-r--r--math/GiNaC/Makefile1
-rw-r--r--math/gringo/Makefile3
-rw-r--r--math/pdal/Makefile3
-rw-r--r--math/yacas/Makefile9
-rw-r--r--multimedia/aegisub/Makefile1
-rw-r--r--multimedia/ffms2/Makefile1
-rw-r--r--multimedia/mpc-qt/Makefile2
-rw-r--r--multimedia/obs-studio/Makefile8
-rw-r--r--multimedia/vapoursynth/Makefile1
-rw-r--r--net-p2p/eiskaltdcpp-daemon/Makefile1
-rw-r--r--net/nethogs/Makefile1
-rw-r--r--net/ulxmlrpcpp/Makefile2
-rw-r--r--net/ulxmlrpcpp/files/patch-ulxmlrpcpp-ulxmlrpcpp.h11
-rw-r--r--net/yami4/Makefile1
-rw-r--r--ports-mgmt/portrac/Makefile3
-rw-r--r--www/node/Makefile9
-rw-r--r--www/node10/Makefile9
-rw-r--r--www/node6/Makefile9
-rw-r--r--www/node8/Makefile9
-rw-r--r--x11-fm/wcmcommander/Makefile8
-rw-r--r--x11/slim/Makefile2
-rw-r--r--x11/slim/files/patch-Ck.cpp11
47 files changed, 18 insertions, 283 deletions
diff --git a/biology/jellyfish/Makefile b/biology/jellyfish/Makefile
index 72abb6bfe9aa..0f29e9b7cdf1 100644
--- a/biology/jellyfish/Makefile
+++ b/biology/jellyfish/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Jellyfish
DISTVERSIONPREFIX= v
DISTVERSION= 2.2.10
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
diff --git a/biology/jellyfish/files/patch-include_jellyfish_file__header.hpp b/biology/jellyfish/files/patch-include_jellyfish_file__header.hpp
deleted file mode 100644
index 3732945ef013..000000000000
--- a/biology/jellyfish/files/patch-include_jellyfish_file__header.hpp
+++ /dev/null
@@ -1,35 +0,0 @@
---- include/jellyfish/file_header.hpp.orig 2018-04-16 12:46:09 UTC
-+++ include/jellyfish/file_header.hpp
-@@ -21,6 +21,8 @@
- #include <jellyfish/generic_file_header.hpp>
- #include <jellyfish/rectangular_binary_matrix.hpp>
-
-+using std::string;
-+
- namespace jellyfish {
- /// A header with jellyfish hash specific entries: size, matrix, etc.
- class file_header : public generic_file_header {
-@@ -42,7 +44,10 @@ class file_header : public generic_file_header { (publ
-
- RectangularBinaryMatrix matrix(int i = 1) const {
- std::string name("matrix");
-- name += std::to_string((long long int)i); // Cast to make gcc4.4 happy!
-+ char buff[100];
-+ // name += std::to_string((long long int)i); // Cast to make gcc4.4 happy!
-+ snprintf(buff, 99, "%d", i);
-+ name += buff;
- const unsigned int r = root_[name]["r"].asUInt();
- const unsigned int c = root_[name]["c"].asUInt();
- if(root_[name]["identity"].asBool())
-@@ -56,7 +61,10 @@ class file_header : public generic_file_header { (publ
-
- void matrix(const RectangularBinaryMatrix& m, int i = 1) {
- std::string name("matrix");
-- name += std::to_string((long long int)i);
-+ char buff[100];
-+ // name += std::to_string((long long int)i);
-+ snprintf(buff, 99, "%d", i);
-+ name += buff;
- root_[name].clear();
- root_[name]["r"] = m.r();
- root_[name]["c"] = m.c();
diff --git a/devel/jsoncpp/Makefile b/devel/jsoncpp/Makefile
index a4e4d0b1cf6f..4b2a8f55454c 100644
--- a/devel/jsoncpp/Makefile
+++ b/devel/jsoncpp/Makefile
@@ -21,21 +21,6 @@ USE_LDCONFIG= yes
PLATFORM= linux-gcc-FreeBSD
MAKE_ARGS= platform=${PLATFORM}
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 33 || \
- ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} >= 48
-# Certain new compiler features unlock parts of jsoncpp API (ex. see JSON_HAS_RVALUE_REFERENCES).
-# Use c++11 above to be the most inclusive.
-USES+= compiler:c++11-lang
-# lang/gcc5 fix
-.if ${COMPILER_TYPE} == clang
-CXXFLAGS+= --std=c++11
-.else
-CXXFLAGS+= --std=gnu++11 -D_GLIBCXX_USE_C99=1
-.endif
-.endif
-
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/jsoncpp
(cd ${WRKSRC}/include/ && ${COPYTREE_SHARE} json/ ${STAGEDIR}${PREFIX}/include/jsoncpp/)
@@ -56,4 +41,4 @@ do-test:
@${ECHO} "Please note that 3 testcases are known to fail: https://github.com/open-source-parsers/jsoncpp/issues/628"
@cd ${WRKSRC} && CXX=${CXX} ${SCONS} platform=${PLATFORM} check
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/llvm60/Makefile b/devel/llvm60/Makefile
index a4c8bdc8523c..3ddf20b12ff2 100644
--- a/devel/llvm60/Makefile
+++ b/devel/llvm60/Makefile
@@ -252,10 +252,6 @@ _COMPILER_RT_LIBS+= \
libclang_rt.ubsan_standalone_cxx-i386.a
.endif
-.if ${OPSYS} == "FreeBSD" && ${COMPILER_TYPE} != clang
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
# Use lld for armv6 on clang 7 and up to avoid binutils ld issues
# PR: 235282
.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 70
diff --git a/devel/llvm70/Makefile b/devel/llvm70/Makefile
index b5a9091eba36..f3614912726e 100644
--- a/devel/llvm70/Makefile
+++ b/devel/llvm70/Makefile
@@ -272,10 +272,6 @@ _COMPILER_RT_LIBS+= \
libclang_rt.ubsan_standalone_cxx-i386.a
.endif
-.if ${OPSYS} == "FreeBSD" && ${COMPILER_TYPE} != clang
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
.if ${ARCH} == "armv6"
BUILD_DEPENDS+= ${LOCALBASE}/bin/ld:devel/binutils
CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
diff --git a/devel/llvm80/Makefile b/devel/llvm80/Makefile
index 60a057956946..b0146a23f57c 100644
--- a/devel/llvm80/Makefile
+++ b/devel/llvm80/Makefile
@@ -357,10 +357,6 @@ _COMPILER_RT_LIBS+= \
libclang_rt.ubsan_standalone_cxx-i386.a
.endif
-.if ${OPSYS} == "FreeBSD" && ${COMPILER_TYPE} != clang
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
# Use lld for armv6 on clang 7 and up to avoid binutils ld issues
# PR: 235282
.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 70
diff --git a/devel/llvm90/Makefile b/devel/llvm90/Makefile
index 8223ba2bca63..5bdd52eb728a 100644
--- a/devel/llvm90/Makefile
+++ b/devel/llvm90/Makefile
@@ -392,10 +392,6 @@ _COMPILER_RT_LIBS+= \
libclang_rt.ubsan_standalone_cxx-i386.a
.endif
-.if ${OPSYS} == "FreeBSD" && ${COMPILER_TYPE} != clang
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
# Use lld for armv6 on clang 7 and up to avoid binutils ld issues
# PR: 235282
.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 70
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index 7620237969aa..d2a8a52b0b73 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -37,10 +37,6 @@ QMAKE_ARGS+= QBS_INSTALL_DIR=${PREFIX} CONFIG+=qbs_enable_project_file_updates
# Enforce installation to ${PREFIX}.
QMAKE_ARGS+= QTC_PREFIX=${PREFIX} LLVM_INSTALL_DIR=${PREFIX}/llvm${LLVM_DEFAULT}
-# Required for building the port with GCC: the define below is required for
-# std::to_string() to exist. More details in ports/193528.
-QMAKE_ARGS+= DEFINES+=_GLIBCXX_USE_C99
-
DESKTOP_ENTRIES="Qt Creator" "" "QtProject-qtcreator" \
"${PREFIX}/bin/${PORTNAME}" "Development;Qt;" true
diff --git a/devel/sdl2pp/Makefile b/devel/sdl2pp/Makefile
index 45919fc7aa45..01bdb9403429 100644
--- a/devel/sdl2pp/Makefile
+++ b/devel/sdl2pp/Makefile
@@ -28,12 +28,6 @@ DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_ALL_TARGET= all doxygen
DOXYGEN_IMPLIES= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-CXXFLAGS+= -D_GLIBCXX_USE_C99 # gcc c++11 support is broken on FreeBSD
-.endif
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/
@@ -41,4 +35,4 @@ post-install-DOCS-on:
post-install-DOXYGEN-on:
cd ${CONFIGURE_WRKSRC} && ${COPYTREE_SHARE} doxygen ${STAGEDIR}${DOCSDIR}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 34b5a981d8b4..3c717562a4a1 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -32,8 +32,6 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/pdns \
--with-protobuf \
--without-net-snmp
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-
SUB_FILES= pkg-message
OPTIONS_DEFINE= LUAJIT SETUID
diff --git a/finance/moneymanagerex/Makefile b/finance/moneymanagerex/Makefile
index ad4c01f0abee..739be4b2da6a 100644
--- a/finance/moneymanagerex/Makefile
+++ b/finance/moneymanagerex/Makefile
@@ -47,13 +47,6 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == "gcc"
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-BUILD_DEPENDS+= ${LOCALBASE}/include/boost/lexical_cast.hpp:devel/boost-libs
-.endif
-
post-extract:
@${MV} ${WRKDIR}/bakefile-0.2.9/autoconf/*.m4 ${WRKSRC}/m4
@@ -71,4 +64,4 @@ post-patch:
@${REINPLACE_CMD} -e \
's| -g0 -O2||' ${WRKSRC}/m4/wxpresets.m4
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/finance/moneymanagerex/files/patch-src_import__export_univcsvdialog.cpp b/finance/moneymanagerex/files/patch-src_import__export_univcsvdialog.cpp
index 4339a2d853d1..05cc8e9d1744 100644
--- a/finance/moneymanagerex/files/patch-src_import__export_univcsvdialog.cpp
+++ b/finance/moneymanagerex/files/patch-src_import__export_univcsvdialog.cpp
@@ -1,37 +1,5 @@
--- src/import_export/univcsvdialog.cpp.orig 2016-03-05 06:10:45 UTC
+++ src/import_export/univcsvdialog.cpp
-@@ -37,6 +37,13 @@
-
- #include "csv_parser/csv_parser.hpp"
-
-+#ifdef _LIBCPP_VERSION
-+#define TO_WSTRING(x) std::to_wstring(x)
-+#else
-+#include <boost/lexical_cast.hpp>
-+#define TO_WSTRING(x) boost::lexical_cast<std::wstring>(x)
-+#endif
-+
- wxIMPLEMENT_DYNAMIC_CLASS(mmUnivCSVDialog, wxDialog);
-
- wxBEGIN_EVENT_TABLE(mmUnivCSVDialog, wxDialog)
-@@ -409,7 +416,7 @@ void mmUnivCSVDialog::SetSettings(const
- csvFieldOrder_.clear();
- for (int i = 0; i < 99; i++)
- {
-- const std::wstring w = to_wstring(i);
-+ const std::wstring w = TO_WSTRING(i);
- const wxString& value = wxString(json::String(o[w]));
- if (!value.empty())
- {
-@@ -536,7 +543,7 @@ void mmUnivCSVDialog::OnSave(wxCommandEv
- int count = 0;
- for (std::vector<int>::const_iterator it = csvFieldOrder_.begin(); it != csvFieldOrder_.end(); ++it)
- {
-- const auto w = to_wstring(count++);
-+ const auto w = TO_WSTRING(count++);
- int i = *it;
- o[w] = json::String(CSVFieldName_[i].ToStdWstring());
- wxLogDebug("%i - %i - %s", count-1, i, CSVFieldName_[i]);
@@ -669,7 +676,7 @@ void mmUnivCSVDialog::OnImport(wxCommand
payeeID_ = -1;
categID_ = -1;
diff --git a/finance/moneymanagerex/files/patch-src_webapp.cpp b/finance/moneymanagerex/files/patch-src_webapp.cpp
deleted file mode 100644
index cdfad4a17cf9..000000000000
--- a/finance/moneymanagerex/files/patch-src_webapp.cpp
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/webapp.cpp.orig 2016-03-05 06:10:45 UTC
-+++ src/webapp.cpp
-@@ -31,6 +31,13 @@ Foundation, Inc., 59 Temple Place, Suite
- #include <wx/sstream.h>
- #include <wx/protocol/http.h>
-
-+#ifdef _LIBCPP_VERSION
-+#define TO_WSTRING(x) std::to_wstring(x)
-+#else
-+#include <boost/lexical_cast.hpp>
-+#define TO_WSTRING(x) boost::lexical_cast<std::wstring>(x)
-+#endif
-+
- //Expected WebAppVersion
- const wxString WebAppParam::ApiExpectedVersion = "1.0.1";
-
-@@ -374,7 +381,7 @@ bool mmWebApp::WebApp_DownloadNewTransac
-
- for (int i = 0; i < static_cast<int>(jsonTransaction.Size()); i++)
- {
-- TrProgrStr = std::to_wstring(i);
-+ TrProgrStr = TO_WSTRING(i);
-
- WebTran.ID = wxAtoi(wxString(json::String(jsonTransaction[TrProgrStr][L"ID"])));
-
diff --git a/games/pioneer/Makefile b/games/pioneer/Makefile
index da5646a981cb..9404b5d80e14 100644
--- a/games/pioneer/Makefile
+++ b/games/pioneer/Makefile
@@ -84,13 +84,6 @@ EXTRA_WARNINGS_CONFIGURE_WITH= extra-warnings
MODELCOMPILER_PLIST_FILES= bin/${PORTNAME}-modelcompiler
PROFILER_CONFIGURE_ON= --enable-profiler
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-# Unhide std::to_string() for GCC (ports/193528)
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
post-patch: .SILENT
${REINPLACE_CMD} -e '/^OPTIMISE=/d ; s|lua5\.2|lua-5.2|' \
${WRKSRC}/configure.ac
@@ -128,4 +121,4 @@ post-install-MODELCOMPILER-on:
${MV} ${STAGEDIR}${PREFIX}/bin/modelcompiler \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}-modelcompiler
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/rlvm/Makefile b/games/rlvm/Makefile
index fdcc58c50b9e..e726fd18b5e4 100644
--- a/games/rlvm/Makefile
+++ b/games/rlvm/Makefile
@@ -34,7 +34,6 @@ USE_SDL= image mixer ttf
EXCLUDE= GLEW SDL_image SDL_mixer SDL_ttf gmock gtest guichan \
luabind utf8cpp # leaving only pygame, xclannad, *.cpp
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude vendor/,}
-CFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
LDFLAGS+= -Wl,--as-needed # avoid overlinking (gtk deps)
MAKE_ARGS= VERBOSE=1
INSTALLS_ICONS= yes
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index bd94fa108bb2..e55b6df8aa22 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -80,12 +80,6 @@ SOUND_MAKE_ARGS= SOUND=y
SOUND_RUN_DEPENDS= sox:audio/sox
LUA_MAKE_ARGS_OFF= NO_LUA_BINDINGS=yes
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} != clang
-CFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
post-patch-SOUND-on:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE}," ${WRKSRC}/sound.h
@${REINPLACE_CMD} -e "s,%%SOUND%%,," ${WRKSRC}/sound.h
@@ -110,4 +104,4 @@ post-install-EXAMPLES-on:
post-install:
@${RM} -r ${STAGEDIR}${DATADIR}/settings/mac
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/aseprite/Makefile b/graphics/aseprite/Makefile
index 7c4e3c9b820a..554aa15ca9f7 100644
--- a/graphics/aseprite/Makefile
+++ b/graphics/aseprite/Makefile
@@ -65,8 +65,6 @@ CMAKE_ON= USE_SHARED_ALLEGRO4 \
USE_SHARED_ZLIB
CMAKE_ARGS= -DFREEBSD_LIB_PATH=${LOCALBASE}/lib
-CXXFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
-
OPTIONS_DEFINE= STEAM WEBP
OPTIONS_DEFAULT= WEBP
diff --git a/graphics/colmap/Makefile b/graphics/colmap/Makefile
index 70ba7affd1b8..b062b7782e8a 100644
--- a/graphics/colmap/Makefile
+++ b/graphics/colmap/Makefile
@@ -34,8 +34,6 @@ USE_QT= qmake_build buildtools_build core gui opengl_build widgets
EXCLUDE= SQLite
EXTRACT_AFTER_ARGS= ${EXCLUDE:S,^,--exclude lib/,}
CMAKE_OFF= BOOST_STATIC CUDA_ENABLED
-CXXFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
- -D_DECLARE_C99_LDBL_MATH # XXX ports/193528
LDFLAGS+= -Wl,--as-needed # gflags, glu, xi, xmu
TEST_TARGET= test ARGS="-V"
diff --git a/graphics/hiptext/Makefile b/graphics/hiptext/Makefile
index 994bcdddd7d4..4d26e0604367 100644
--- a/graphics/hiptext/Makefile
+++ b/graphics/hiptext/Makefile
@@ -25,7 +25,6 @@ GH_ACCOUNT= jart
GH_TAGNAME= f89b44f
USES= compiler:c++11-lib gmake jpeg localbase
-CPPFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
CPPFLAGS+= -I${LOCALBASE}/include/freetype2
MAKE_ENV= GTEST_DIR="${LOCALBASE}" \
TARGET_ARCH=""
diff --git a/graphics/libboard/Makefile b/graphics/libboard/Makefile
index bc67e7764054..c54266f55879 100644
--- a/graphics/libboard/Makefile
+++ b/graphics/libboard/Makefile
@@ -19,7 +19,6 @@ USE_GITHUB= yes
GH_ACCOUNT= c-koi
GH_TAGNAME= 5b38274
-CXXFLAGS+= -D_GLIBCXX_USE_C99 -fPIC # XXX ports/193528
USE_CXXSTD= c++11
CMAKE_ARGS= -DMYPROJ_RAN_ONCE:BOOL=YES \
-DEXECUTABLE_OUTPUT_PATH:PATH="${STAGEDIR}${EXAMPLESDIR}"
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index 9792cf1c6ea6..521d9871ade8 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -80,12 +80,6 @@ CAIRO_LIB_DEPENDS= libcairo.so:graphics/cairo
CAIRO_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:graphics/py-cairo@${PY_FLAVOR}
CAIRO_MAKE_ARGS_OFF= CAIRO=False
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-CXXFLAGS+= -D_GLIBCXX_USE_C99 # gcc c++11 support is broken on FreeBSD
-.endif
-
pre-configure-SQLITE3-on:
@if ! ${LOCALBASE}/bin/sqlite3 :memory: 'create virtual table foo using rtree(pkid, xmin, xmax, ymin, ymax)' > /dev/null 2>&1; then \
${ECHO_MSG} "" ; \
@@ -112,4 +106,4 @@ post-install-DOCS-on:
@cd ${WRKSRC} && ${COPYTREE_SHARE} "AUTHORS.md CHANGELOG.md README.md docs" \
${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 6ca6106ef545..63c7c0d1365e 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -41,14 +41,8 @@ PNG_LIB_DEPENDS= libpng.so:graphics/png
TIFF_CMAKE_BOOL= WANT_TIFF
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} >= 50
-CXXFLAGS+= -std=gnu++11 -D_GLIBCXX_USE_C99=1
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|$${LIBDIRNAME}/pkgconfig|${PREFIX}/libdata/pkgconfig|' ${WRKSRC}/src/CMakeLists.txt
@${REINPLACE_CMD} -e '/^Libs: / s|-@PODOFO_VERSION_MAJOR@||' ${WRKSRC}/src/libpodofo.pc.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/sekrit-twc-zimg/Makefile b/graphics/sekrit-twc-zimg/Makefile
index a422f2b13121..18393b1eeb9b 100644
--- a/graphics/sekrit-twc-zimg/Makefile
+++ b/graphics/sekrit-twc-zimg/Makefile
@@ -20,8 +20,6 @@ CONFLICTS_INSTALL= zimg-[0-9]* # include/zimg.h
USES= autoreconf compiler:c++11-lib gmake libtool pathfix
EXTRACT_AFTER_ARGS= --exclude test/extra
GNU_CONFIGURE= yes
-CPPFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
- -D_DECLARE_C99_LDBL_MATH # XXX ports/193528
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
PORTEXAMPLES= *
diff --git a/graphics/vapoursynth-waifu2x-w2xc/Makefile b/graphics/vapoursynth-waifu2x-w2xc/Makefile
index f6dcc66c10db..d8c7ebc66df0 100644
--- a/graphics/vapoursynth-waifu2x-w2xc/Makefile
+++ b/graphics/vapoursynth-waifu2x-w2xc/Makefile
@@ -21,8 +21,6 @@ GH_PROJECT= VapourSynth-Waifu2x-w2xc
USES= compiler:c++11-lib gmake localbase pkgconfig
HAS_CONFIGURE= yes
-CPPFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
- -D_DECLARE_C99_LDBL_MATH # XXX ports/193528
CONFIGURE_ARGS= --install="${STAGEDIR}${DATADIR}" \
--cxx="${CXX}" \
--extra-cxxflags="${CPPFLAGS} ${CXXFLAGS}" \
diff --git a/graphics/waifu2x-converter-cpp/Makefile b/graphics/waifu2x-converter-cpp/Makefile
index bd695348e9f5..ceb2b2658e01 100644
--- a/graphics/waifu2x-converter-cpp/Makefile
+++ b/graphics/waifu2x-converter-cpp/Makefile
@@ -26,8 +26,6 @@ DOS2UNIX_GLOB= *.cpp *.hpp
CMAKE_ARGS= -DOPENCV_PREFIX:PATH="${LOCALBASE}" \
-DOpenCL_LIBRARY:FILEPATH="${LOCALBASE}/lib/libOpenCL.so"
CMAKE_ON= INSTALL_MODELS
-CFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
- -D_DECLARE_C99_LDBL_MATH # XXX ports/193528
LDFLAGS+= -Wl,--as-needed # avoid overlinking (opencv deps)
TEST_TARGET= test ARGS="-V"
USE_LDCONFIG= yes
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
index 9c8b6c8c33e1..9ae0527bd579 100644
--- a/math/GiNaC/Makefile
+++ b/math/GiNaC/Makefile
@@ -24,7 +24,6 @@ INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CXXFLAGS+= -D_GLIBCXX_USE_C99
INFO= ginac ginac-examples
diff --git a/math/gringo/Makefile b/math/gringo/Makefile
index e2a58b354474..3ff5d22cd9f4 100644
--- a/math/gringo/Makefile
+++ b/math/gringo/Makefile
@@ -21,9 +21,6 @@ MAKE_ARGS= ${MAKE_ENV}
CXXFLAGS+= -std=c++11
MAKE_ENV= WITH_LUA=no
-# Unhide std::to_string() with GCC < 4.9 (ports/193528)
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-
PLIST_FILES= bin/${PORTNAME} bin/clingo
do-install:
diff --git a/math/pdal/Makefile b/math/pdal/Makefile
index cb3fd76a991d..f6fad64f9a3e 100644
--- a/math/pdal/Makefile
+++ b/math/pdal/Makefile
@@ -27,9 +27,6 @@ USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME:tu}
GH_PROJECT= ${GH_ACCOUNT}
-# Unhide std::to_string() to fix build with GCC (see ports/193528 for details).
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-
CMAKE_ON= WITH_LASZIP #LASZIP is recommended
OPTIONS_DEFINE= BASH \
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 2c37c6ffc939..33543596c02b 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -34,12 +34,6 @@ GH_ACCOUNT= grzegorzmazur
PLIST_SUB= SHLIB_VERSION=${PORTVERSION:S/.//}.0
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == "gcc"
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
post-patch:
# Can't use USES=shebangfix here, cause the path appears several
# times in the file.
@@ -47,4 +41,5 @@ post-patch:
${WRKSRC}/tests/test-yacas
@${REINPLACE_CMD} -e '/^install/s|^|#|' \
${WRKSRC}/tests/CMakeLists.txt
-.include <bsd.port.post.mk>
+
+.include <bsd.port.mk>
diff --git a/multimedia/aegisub/Makefile b/multimedia/aegisub/Makefile
index ba341837a68f..392cf6bb2b18 100644
--- a/multimedia/aegisub/Makefile
+++ b/multimedia/aegisub/Makefile
@@ -32,7 +32,6 @@ USE_GL= gl
USE_CSTD= c99
USE_CXXSTD= c++11
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
-CXXFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
LDFLAGS+= -Wl,--as-needed # freetype
GNU_CONFIGURE= yes
CONFIGURE_ENV= ICONV_LIBS="${ICONV_LIB}" PTHREAD_LIBS="-pthread" \
diff --git a/multimedia/ffms2/Makefile b/multimedia/ffms2/Makefile
index 58b913ad2ee9..be78467208aa 100644
--- a/multimedia/ffms2/Makefile
+++ b/multimedia/ffms2/Makefile
@@ -22,7 +22,6 @@ EXCLUDE= VSHelper.h VSScript.h VapourSynth.h
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static
-CPPFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
CPPFLAGS+= `pkg-config vapoursynth --cflags`
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/multimedia/mpc-qt/Makefile b/multimedia/mpc-qt/Makefile
index b9e0006372e1..a3ad8b8ffcde 100644
--- a/multimedia/mpc-qt/Makefile
+++ b/multimedia/mpc-qt/Makefile
@@ -22,8 +22,6 @@ USES= compiler:c++14-lang desktop-file-utils pkgconfig qmake qt:5
USE_QT= qmake_build buildtools_build linguisttools_build \
core dbus gui network svg_run widgets x11extras
USE_GL= gl
-CXXFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
- -D_DECLARE_C99_LDBL_MATH # XXX ports/193528
OPTIONS_DEFINE= DOCS
diff --git a/multimedia/obs-studio/Makefile b/multimedia/obs-studio/Makefile
index 0b4a0b07fbac..4db211e2a3ae 100644
--- a/multimedia/obs-studio/Makefile
+++ b/multimedia/obs-studio/Makefile
@@ -44,14 +44,8 @@ CMAKE_ARGS= -DUNIX_STRUCTURE:BOOL=ON \
-DOBS_VERSION_OVERRIDE:STRING="${PORTVERSION}"
CFLAGS+= -D_WITH_GETLINE
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's| 3.4)| ${PYTHON_VER})|' \
${WRKSRC}/cmake/Modules/FindPythonDeps.cmake
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/vapoursynth/Makefile b/multimedia/vapoursynth/Makefile
index 7cd8e6f125cd..9a0afa5f8127 100644
--- a/multimedia/vapoursynth/Makefile
+++ b/multimedia/vapoursynth/Makefile
@@ -13,7 +13,6 @@ USE_GITHUB= yes
USES= autoreconf gmake libtool localbase pathfix pkgconfig
GNU_CONFIGURE= yes
-CPPFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
DATADIR= ${PREFIX}/lib/vapoursynth
diff --git a/net-p2p/eiskaltdcpp-daemon/Makefile b/net-p2p/eiskaltdcpp-daemon/Makefile
index e8e7928a33a9..50a6a7b9bf02 100644
--- a/net-p2p/eiskaltdcpp-daemon/Makefile
+++ b/net-p2p/eiskaltdcpp-daemon/Makefile
@@ -28,7 +28,6 @@ JSONRPC_DESC= JSONRPC interface support
PLIST_FILES= bin/${PORTNAME}${PKGNAMESUFFIX} \
man/man1/${PORTNAME}${PKGNAMESUFFIX}.1.gz
-CXXFLAGS+= -I${LOCALBASE}/include -D_GLIBCXX_USE_C99
CMAKE_ARGS+= -DUSE_QT:BOOL=OFF
CMAKE_ARGS+= -DUSE_GTK:BOOL=OFF
CMAKE_ARGS+= -DCREATE_MO:BOOL=OFF
diff --git a/net/nethogs/Makefile b/net/nethogs/Makefile
index 890dd1daa904..79bf2b9d85cd 100644
--- a/net/nethogs/Makefile
+++ b/net/nethogs/Makefile
@@ -18,7 +18,6 @@ USE_GITHUB= yes
GH_ACCOUNT= raboof
USES= gmake shebangfix
-CXXFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
SHEBANG_FILES= determineVersion.sh
bash_CMD= /bin/sh
diff --git a/net/ulxmlrpcpp/Makefile b/net/ulxmlrpcpp/Makefile
index 82075d59fe3b..49ff8e54d395 100644
--- a/net/ulxmlrpcpp/Makefile
+++ b/net/ulxmlrpcpp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ulxmlrpcpp
PORTVERSION= 1.7.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net devel
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
diff --git a/net/ulxmlrpcpp/files/patch-ulxmlrpcpp-ulxmlrpcpp.h b/net/ulxmlrpcpp/files/patch-ulxmlrpcpp-ulxmlrpcpp.h
deleted file mode 100644
index bc1df871cf47..000000000000
--- a/net/ulxmlrpcpp/files/patch-ulxmlrpcpp-ulxmlrpcpp.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ulxmlrpcpp/ulxmlrpcpp.h.orig Sat Jan 27 12:57:48 2007
-+++ ulxmlrpcpp/ulxmlrpcpp.h Sat Jan 27 12:58:07 2007
-@@ -743,7 +743,7 @@
- #if defined(__CYGWIN__)
- # define ulxr_snprintf snprintf
- #else
--# define ulxr_snprintf std::snprintf
-+# define ulxr_snprintf snprintf
- #endif
-
- # define ulxr_swprintf std::swprintf
diff --git a/net/yami4/Makefile b/net/yami4/Makefile
index 6c5dd8cca019..ba91e6507a0d 100644
--- a/net/yami4/Makefile
+++ b/net/yami4/Makefile
@@ -16,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/gpl-3.0.txt
USES= compiler:c++11-lang zip
MAKE_ARGS= COMPILER="${CXX}" OPTIONS="${CXXFLAGS}"
-CXXFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
PORTDOCS= *
diff --git a/ports-mgmt/portrac/Makefile b/ports-mgmt/portrac/Makefile
index 771fc5b6494f..c1ec3b1401e1 100644
--- a/ports-mgmt/portrac/Makefile
+++ b/ports-mgmt/portrac/Makefile
@@ -17,9 +17,6 @@ PLIST_FILES= bin/portrac \
share/portrac/up-to-date.png \
share/portrac/updates-available.png
-# Unhide std::to_string() to fix build with GCC (ports/193528)
-CXXFLAGS= -D_GLIBCXX_USE_C99
-
USES= compiler:c++11-lib qmake qt:5 tar:bzip2
USE_CXXSTD= c++11
USE_QT= widgets buildtools_build
diff --git a/www/node/Makefile b/www/node/Makefile
index 4bfca6795e0c..e6b9a0d53b9c 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -82,13 +82,6 @@ BROKEN_SSL+= base
CONFIGURE_ARGS+=--openssl-no-asm
.endif
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-# GCC does not expose std::snprintf() without this define
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/tools/v8_gypfiles/v8.gyp
@@ -106,4 +99,4 @@ post-configure:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/node
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/node10/Makefile b/www/node10/Makefile
index 446ce62c05a5..57bc62cea32d 100644
--- a/www/node10/Makefile
+++ b/www/node10/Makefile
@@ -83,13 +83,6 @@ BROKEN_SSL+= base
CONFIGURE_ARGS+=--openssl-no-asm
.endif
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-# GCC does not expose std::snprintf() without this define
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/deps/v8/gypfiles/v8.gyp
@@ -107,4 +100,4 @@ post-configure:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/node
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/node6/Makefile b/www/node6/Makefile
index b64351850061..3c93bbb0317b 100644
--- a/www/node6/Makefile
+++ b/www/node6/Makefile
@@ -82,13 +82,6 @@ BROKEN_SSL+= base
CONFIGURE_ARGS+=--openssl-no-asm
.endif
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-# GCC does not expose std::snprintf() without this define
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/deps/v8/tools/gyp/v8.gyp
@@ -114,4 +107,4 @@ post-configure:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/node
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/node8/Makefile b/www/node8/Makefile
index 9e8cd581b84d..9ea800386bc7 100644
--- a/www/node8/Makefile
+++ b/www/node8/Makefile
@@ -77,13 +77,6 @@ LIB_DEPENDS+= libcares.so:dns/c-ares\
CONFIGURE_ARGS+=--openssl-no-asm
.endif
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-# GCC does not expose std::snprintf() without this define
-CXXFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/deps/v8/src/v8.gyp
@@ -101,4 +94,4 @@ post-configure:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/node
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-fm/wcmcommander/Makefile b/x11-fm/wcmcommander/Makefile
index 00df35805bcd..9cc229bb8aa6 100644
--- a/x11-fm/wcmcommander/Makefile
+++ b/x11-fm/wcmcommander/Makefile
@@ -34,16 +34,10 @@ SMB_CMAKE_ON= -DSMBCLIENT_LIBRARY=${SAMBALIBS}/libsmbclient.so -DSMBCLIENT_INCL
SSH_LIB_DEPENDS= libssh2.so:security/libssh2
SSH_CMAKE_BOOL= WITH_LIBSSH2
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-CXXFLAGS+= -D_GLIBCXX_USE_C99 # gcc c++11 support is broken on FreeBSD
-.endif
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index b9e674cff1b3..5c9f0c5e8e82 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= slim
PORTVERSION= 1.3.6
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= x11
MASTER_SITES= ftp://ftp.berlios.de/pub/slim/ \
SF/slim.berlios
diff --git a/x11/slim/files/patch-Ck.cpp b/x11/slim/files/patch-Ck.cpp
deleted file mode 100644
index e3a65888b7f0..000000000000
--- a/x11/slim/files/patch-Ck.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Ck.cpp.orig 2012-12-31 07:03:42.000000000 -0600
-+++ ./Ck.cpp 2013-03-23 14:10:35.000000000 -0500
-@@ -91,7 +91,7 @@
-
- vt = *((long *)return_value);
-
-- std::snprintf(device, 32, "/dev/tty%ld", vt);
-+ snprintf(device, 32, "/dev/ttyv%ld", vt - 1);
-
- if(return_value)
- XFree(return_value);