aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/firefox-sync/Makefile8
-rw-r--r--www/weave/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/www/firefox-sync/Makefile b/www/firefox-sync/Makefile
index 83061f2549f6..e10555c03a8e 100644
--- a/www/firefox-sync/Makefile
+++ b/www/firefox-sync/Makefile
@@ -49,4 +49,10 @@ post-install:
${MKDIR} ${PREFIX}/lib/firefox3/extensions
${LN} -sf ${XPI_DIR} ${PREFIX}/lib/firefox3/extensions
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/weave/Makefile b/www/weave/Makefile
index 83061f2549f6..e10555c03a8e 100644
--- a/www/weave/Makefile
+++ b/www/weave/Makefile
@@ -49,4 +49,10 @@ post-install:
${MKDIR} ${PREFIX}/lib/firefox3/extensions
${LN} -sf ${XPI_DIR} ${PREFIX}/lib/firefox3/extensions
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>