aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/pear-Net_Ident/Makefile23
-rw-r--r--net/pear-Net_Ident/distinfo2
-rw-r--r--net/pear-Net_Ident/pkg-descr10
4 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6611c8cc2b68..3d969d2f9d3d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -551,6 +551,7 @@
SUBDIR += pear-Net_Dict
SUBDIR += pear-Net_Finger
SUBDIR += pear-Net_IPv6
+ SUBDIR += pear-Net_Ident
SUBDIR += pear-Net_NNTP
SUBDIR += pear-Net_POP3
SUBDIR += pear-Net_Ping
diff --git a/net/pear-Net_Ident/Makefile b/net/pear-Net_Ident/Makefile
new file mode 100644
index 000000000000..debb4fb542a7
--- /dev/null
+++ b/net/pear-Net_Ident/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: pear-Net_Ident
+# Date created: 07 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Ident
+PORTVERSION= 1.1.0
+CATEGORIES= net www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR identification protocol implementation
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Net
+FILES= Ident.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_Ident/distinfo b/net/pear-Net_Ident/distinfo
new file mode 100644
index 000000000000..445f913a12df
--- /dev/null
+++ b/net/pear-Net_Ident/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Net_Ident-1.1.0.tgz) = dc2b3e0179c485816c171f8822ff0381
+SIZE (PEAR/Net_Ident-1.1.0.tgz) = 3248
diff --git a/net/pear-Net_Ident/pkg-descr b/net/pear-Net_Ident/pkg-descr
new file mode 100644
index 000000000000..b5b911594708
--- /dev/null
+++ b/net/pear-Net_Ident/pkg-descr
@@ -0,0 +1,10 @@
+The PEAR::Net_Ident implements Identification Protocol according
+to RFC 1413.
+
+The Identification Protocol (a.k.a., "ident", a.k.a., "the Ident
+Protocol") provides a means to determine the identity of a user
+of a particular TCP connection. Given a TCP port number pair, it
+returns a character string which identifies the owner of that
+connection on the server's system.
+
+WWW: http://pear.php.net/package/Net_Ident/