aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/lightning-thunderbird/Makefile2
-rw-r--r--deskutils/lightning/Makefile2
-rw-r--r--deskutils/sunbird/Makefile2
-rw-r--r--mail/lightning/Makefile2
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox36/Makefile2
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey2/Makefile2
-rw-r--r--www/xulrunner/Makefile5
10 files changed, 11 insertions, 12 deletions
diff --git a/deskutils/lightning-thunderbird/Makefile b/deskutils/lightning-thunderbird/Makefile
index 167a6c79daf7..23db15f9a4c8 100644
--- a/deskutils/lightning-thunderbird/Makefile
+++ b/deskutils/lightning-thunderbird/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
+USE_GECKO= gecko
WANT_GNOME= yes
WANT_PERL= yes
SUNBIRD= ${PORTNAME}
@@ -44,7 +45,6 @@ GECKO_PLIST_PRE_FILES= lib/sunbird/extensions/{972ce4c6-7e08-4474-a285-3208198ce
.include <bsd.init.mk>
.include <bsd.libnames.mk>
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
.if ${ARCH}=="sparc64"
BROKEN= does not build
diff --git a/deskutils/lightning/Makefile b/deskutils/lightning/Makefile
index 167a6c79daf7..23db15f9a4c8 100644
--- a/deskutils/lightning/Makefile
+++ b/deskutils/lightning/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
+USE_GECKO= gecko
WANT_GNOME= yes
WANT_PERL= yes
SUNBIRD= ${PORTNAME}
@@ -44,7 +45,6 @@ GECKO_PLIST_PRE_FILES= lib/sunbird/extensions/{972ce4c6-7e08-4474-a285-3208198ce
.include <bsd.init.mk>
.include <bsd.libnames.mk>
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
.if ${ARCH}=="sparc64"
BROKEN= does not build
diff --git a/deskutils/sunbird/Makefile b/deskutils/sunbird/Makefile
index 167a6c79daf7..23db15f9a4c8 100644
--- a/deskutils/sunbird/Makefile
+++ b/deskutils/sunbird/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
+USE_GECKO= gecko
WANT_GNOME= yes
WANT_PERL= yes
SUNBIRD= ${PORTNAME}
@@ -44,7 +45,6 @@ GECKO_PLIST_PRE_FILES= lib/sunbird/extensions/{972ce4c6-7e08-4474-a285-3208198ce
.include <bsd.init.mk>
.include <bsd.libnames.mk>
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
.if ${ARCH}=="sparc64"
BROKEN= does not build
diff --git a/mail/lightning/Makefile b/mail/lightning/Makefile
index 2712a23df973..8e622e6e8d1b 100644
--- a/mail/lightning/Makefile
+++ b/mail/lightning/Makefile
@@ -25,6 +25,7 @@ CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
+USE_GECKO= gecko
WANT_GNOME= yes
WANT_PERL= yes
LIGHTNING_DIR= lib/thunderbird/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
@@ -78,5 +79,4 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/${MOZILLA}.desktop ${PREFIX}/share/applications
${LN} -sf ${MOZILLA_ICON_SRC} ${PREFIX}/share/pixmaps/${MOZILLA_ICON}
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 2f3160db5136..b3179a91aa84 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -29,6 +29,7 @@ EXTRA_CFLAGS= -O2
HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GECKO= gecko
WANT_PERL= yes
GECKO_PLIST_PRE_FILES= lib/${MOZILLA}/chrome/icons/default/default.xpm
GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/icons
@@ -110,5 +111,4 @@ post-install:
${LN} -sf ${FIREFOX_ICON_SRC} ${PREFIX}/share/pixmaps/${FIREFOX_ICON}
@${CAT} ${PKGMESSAGE}
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 2f3160db5136..b3179a91aa84 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -29,6 +29,7 @@ EXTRA_CFLAGS= -O2
HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GECKO= gecko
WANT_PERL= yes
GECKO_PLIST_PRE_FILES= lib/${MOZILLA}/chrome/icons/default/default.xpm
GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/icons
@@ -110,5 +111,4 @@ post-install:
${LN} -sf ${FIREFOX_ICON_SRC} ${PREFIX}/share/pixmaps/${FIREFOX_ICON}
@${CAT} ${PKGMESSAGE}
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 2f3160db5136..b3179a91aa84 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -29,6 +29,7 @@ EXTRA_CFLAGS= -O2
HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GECKO= gecko
WANT_PERL= yes
GECKO_PLIST_PRE_FILES= lib/${MOZILLA}/chrome/icons/default/default.xpm
GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/icons
@@ -110,5 +111,4 @@ post-install:
${LN} -sf ${FIREFOX_ICON_SRC} ${PREFIX}/share/pixmaps/${FIREFOX_ICON}
@${CAT} ${PKGMESSAGE}
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 381d579cce28..afcb8c5f3b99 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -18,6 +18,7 @@ COMMENT= The open source, standards compliant web browser
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GECKO= gecko
WANT_GNOME= yes
WANT_PERL= yes
HAS_CONFIGURE= yes
@@ -114,5 +115,4 @@ do-install:
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKDIR}/seamonkey.desktop ${PREFIX}/share/applications
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 381d579cce28..afcb8c5f3b99 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -18,6 +18,7 @@ COMMENT= The open source, standards compliant web browser
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GECKO= gecko
WANT_GNOME= yes
WANT_PERL= yes
HAS_CONFIGURE= yes
@@ -114,5 +115,4 @@ do-install:
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKDIR}/seamonkey.desktop ${PREFIX}/share/applications
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/www/xulrunner/Makefile b/www/xulrunner/Makefile
index 4d35211ea142..2ad41bad843e 100644
--- a/www/xulrunner/Makefile
+++ b/www/xulrunner/Makefile
@@ -23,6 +23,7 @@ ALL_TARGET= default
HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GECKO= gecko
PORT_MOZCONFIG= ${WRKSRC}/xulrunner/config/mozconfig
MOZ_OPTIONS?= --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
@@ -32,6 +33,4 @@ MOZ_EXTENSIONS= default,cookie,permissions
OPTIONS= # Empty, used for generic gecko OPTIONS
USE_GECKO_OPTIONS= java debug logging optimized_cflags
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>