aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/hs-probability/Makefile85
-rw-r--r--math/hs-probability/distinfo3
-rw-r--r--math/hs-probability/pkg-descr7
-rw-r--r--math/hs-probability/pkg-plist42
5 files changed, 138 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 5172f9a67c87..eee72a56acf5 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -116,6 +116,7 @@
SUBDIR += hs-Agda-executable
SUBDIR += hs-category-extras
SUBDIR += hs-erf
+ SUBDIR += hs-probability
SUBDIR += igraph
SUBDIR += isabelle
SUBDIR += itl
diff --git a/math/hs-probability/Makefile b/math/hs-probability/Makefile
new file mode 100644
index 000000000000..d10cc8f4fd02
--- /dev/null
+++ b/math/hs-probability/Makefile
@@ -0,0 +1,85 @@
+# New ports collection makefile for: hs-probability
+# Date created: December 20 2009
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= probability
+PORTVERSION= 0.2.2
+CATEGORIES= math haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= Probabilistic Functional Programming in Haskell
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-transformers>=0.0.1:${PORTSDIR}/devel/hs-transformers
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-transformers>=0.0.1:${PORTSDIR}/devel/hs-transformers
+
+GHC_VERSION= 6.10.4
+PROBABILITY_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DATADIR= ${PREFIX}/share/${DISTNAME}
+PORTDATA= *
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+PROBABILITY_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ PROBABILITY_VERSION=${PROBABILITY_VERSION} \
+ PROBABILITY_LIBDIR_REL=${PROBABILITY_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.15
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal
+.if !defined(NOPORTDATA)
+ cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+.else
+ cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX} \
+ --datadir='' --datasubdir='' --docdir='${DOCSDIR}'
+.endif
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${PROBABILITY_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
+
+.include <bsd.port.mk>
diff --git a/math/hs-probability/distinfo b/math/hs-probability/distinfo
new file mode 100644
index 000000000000..62a615d197e6
--- /dev/null
+++ b/math/hs-probability/distinfo
@@ -0,0 +1,3 @@
+MD5 (probability-0.2.2.tar.gz) = e0b4eef29e488ecabf9b5883c1205a3c
+SHA256 (probability-0.2.2.tar.gz) = 8849f6f6cc6d33be0c44321f03853ae1eada252bf1d72aefa7638a31f4708128
+SIZE (probability-0.2.2.tar.gz) = 22984
diff --git a/math/hs-probability/pkg-descr b/math/hs-probability/pkg-descr
new file mode 100644
index 000000000000..55d41dff84e5
--- /dev/null
+++ b/math/hs-probability/pkg-descr
@@ -0,0 +1,7 @@
+This Haskell library allows exact computation with discrete random variables
+in terms of their distributions by using a monad.
+The monad is similar to the List monad for non-deterministic computations,
+but extends the List monad by a measure of probability.
+Small interface to R plotting.
+
+WWW: http://haskell.org/haskellwiki/Probabilistic_Functional_Programming
diff --git a/math/hs-probability/pkg-plist b/math/hs-probability/pkg-plist
new file mode 100644
index 000000000000..2939a0e0ecac
--- /dev/null
+++ b/math/hs-probability/pkg-plist
@@ -0,0 +1,42 @@
+@comment $FreeBSD$
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSprobability-%%PROBABILITY_VERSION%%.o
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Distribution.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Alarm.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Barber.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Bayesian.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Boys.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Collection.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Diagnosis.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Dice.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/DiceAccum.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/MontyHall.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/NBoys.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Predator.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Profession.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Queuing.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/TreeGrowth.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Expectation.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Monad.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Object.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Percentage.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/PrintList.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Random.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Shape.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Show.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Simulation.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Trace.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Transition.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Visualize.hi
+%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSprobability-%%PROBABILITY_VERSION%%.a
+%%PROBABILITY_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example
+@dirrm %%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability
+@dirrm %%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric
+@dirrm %%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%PROBABILITY_LIBDIR_REL%%
+@exec /bin/sh %D/%%PROBABILITY_LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister probability
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old