aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--security/Makefile1
-rw-r--r--security/samba-vscan/Makefile140
-rw-r--r--security/samba-vscan/distinfo3
-rw-r--r--security/samba-vscan/files/patch-Makefile.in20
-rw-r--r--security/samba-vscan/files/patch-configure95
-rw-r--r--security/samba-vscan/files/patch-vscan-clamav.conf11
-rw-r--r--security/samba-vscan/files/patch-vscan-clamav.h16
-rw-r--r--security/samba-vscan/files/patch-vscan-fprotd.h11
-rw-r--r--security/samba-vscan/files/patch-vscan-fsav.h28
-rw-r--r--security/samba-vscan/files/patch-vscan-icap.h11
-rw-r--r--security/samba-vscan/files/patch-vscan-kavp.h11
-rw-r--r--security/samba-vscan/files/patch-vscan-mcdaemon.h11
-rw-r--r--security/samba-vscan/files/patch-vscan-mksd.h11
-rw-r--r--security/samba-vscan/files/patch-vscan-oav.h11
-rw-r--r--security/samba-vscan/files/patch-vscan-sophos.conf8
-rw-r--r--security/samba-vscan/files/patch-vscan-sophos.h16
-rw-r--r--security/samba-vscan/files/patch-vscan-symantec.h11
-rw-r--r--security/samba-vscan/files/patch-vscan-trend.conf8
-rw-r--r--security/samba-vscan/files/patch-vscan-trend.h16
-rw-r--r--security/samba-vscan/files/pkg-message.in43
-rw-r--r--security/samba-vscan/pkg-descr8
22 files changed, 1 insertions, 490 deletions
diff --git a/MOVED b/MOVED
index e06ec2e1a9a0..2fa941604e0f 100644
--- a/MOVED
+++ b/MOVED
@@ -4642,3 +4642,4 @@ net/samba32||2010-10-18|Has expired: Unsupported by the upstream. Please, consid
net/samba33||2010-10-18|Has expired: Unsupported by the upstream. Please, consider to upgrade.
japanese/samba3||2010-10-18|Has expired: Unsupported by the upstream. Please, consider to upgrade.
net/py-samba||2010-10-18|Has expired: Unsupported by the upstream. Please, consider to upgrade.
+security/samba-vscan||2010-10-18|Removed
diff --git a/security/Makefile b/security/Makefile
index 9514d0a4c598..cdf8f706cb73 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -762,7 +762,6 @@
SUBDIR += saferpay
SUBDIR += safesh
SUBDIR += saint
- SUBDIR += samba-vscan
SUBDIR += samhain
SUBDIR += samhain-client
SUBDIR += samhain-server
diff --git a/security/samba-vscan/Makefile b/security/samba-vscan/Makefile
deleted file mode 100644
index bb4ffabb324e..000000000000
--- a/security/samba-vscan/Makefile
+++ /dev/null
@@ -1,140 +0,0 @@
-# New ports collection makefile for: samba-vscan
-# Date created: 27 February 2004
-# Whom: Jean Milanez Melo <jmelo@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= samba-vscan
-PORTVERSION= 0.3.6c
-PORTREVISION= 4
-CATEGORIES= security
-MASTER_SITES= http://www.openantivirus.org/download/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-beta5
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= On-access virus scanning with Samba
-
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/${VSCAN_SAMBA_PORT}:configure
-
-OPTIONS= VSCAN_ANTIVIR "for use with AntiVir" off \
- VSCAN_CLAMAV "for use with Clam AntiVirus Daemon" off \
- VSCAN_FPROTD "for use with F-Prot Daemon" off \
- VSCAN_FSAV "for use with F-Secure AntiVirus" off \
- VSCAN_ICAP "for use with an ICAP anti-virus" off \
- VSCAN_KAVP "for use with Kaspersky AntiVirus" off \
- VSCAN_MKSD "for use with mks32" off \
- VSCAN_NAI "for use with NAI/McAfee uvscan" off \
- VSCAN_OAV "for use with OpenAntiVirus.org ScannerDaemon" off \
- VSCAN_SOPHOS "for use with Sophos" off \
- VSCAN_TREND "for use with Trend Micro FileScanner" off
-
-PORTDOCS= AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README
-
-USE_AUTOTOOLS= autoconf:268
-VSCAN_SAMBA_PORT?= samba34
-SAMBA_WRKSRC!= cd ${.CURDIR}/../../net/${VSCAN_SAMBA_PORT}; ${MAKE} -V WRKSRC
-HAS_CONFIGURE= yes
-USE_GMAKE= yes
-CONFIGURE_ARGS= --with-samba-source=${SAMBA_WRKSRC}
-ETCDIR= etc/samba-vscan
-SUB_FILES= pkg-message
-VFSDIR?= lib/samba/vfs
-VSCAN_NAME=
-VSCAN_CONF=
-ALL_TARGET=
-
-.include <bsd.port.pre.mk>
-
-VFSDIR=lib/samba
-
-.if defined(WITH_VSCAN_ANTIVIR)
-ALL_TARGET+=antivir
-VSCAN_NAME+=vscan-antivir.so
-VSCAN_CONF+=antivir/vscan-antivir.conf
-.endif
-
-.if defined(WITH_VSCAN_CLAMAV)
-ALL_TARGET+=clamav
-VSCAN_NAME+=vscan-clamav.so
-VSCAN_CONF+=clamav/vscan-clamav.conf
-.endif
-
-.if defined(WITH_VSCAN_FPROTD)
-ALL_TARGET+=fprotd
-VSCAN_NAME+=vscan-fprotd.so
-VSCAN_CONF+=fprot/vscan-fprotd.conf
-.endif
-
-.if defined(WITH_VSCAN_FSAV)
-ALL_TARGET+=fsav
-VSCAN_NAME+=vscan-fsav.so
-VSCAN_CONF+=f-secure/vscan-fsav.conf
-.endif
-
-.if defined(WITH_VSCAN_ICAP)
-ALL_TARGET+=icap
-VSCAN_NAME+=vscan-icap.so
-VSCAN_CONF+=icap/vscan-icap.conf
-.endif
-
-.if defined(WITH_VSCAN_KAVP)
-ALL_TARGET+=kavp
-VSCAN_NAME+=vscan-kavp.so
-VSCAN_CONF+=kaspersky/vscan-kavp.conf
-.endif
-
-.if defined(WITH_VSCAN_MKSD)
-ALL_TARGET+=mksd
-VSCAN_NAME+=vscan-mksd.so
-VSCAN_CONF+=mks/vscan-mks32.conf
-.endif
-
-.if defined(WITH_VSCAN_NAI)
-ALL_TARGET+=nai
-VSCAN_NAME+=vscan-mcdaemon.so
-VSCAN_CONF+=nai/vscan-mcdaemon.conf
-.endif
-
-.if defined(WITH_VSCAN_OAV)
-ALL_TARGET+=oav
-VSCAN_NAME+=vscan-oav.so
-VSCAN_CONF+=openantivirus/vscan-oav.conf
-.endif
-
-.if defined(WITH_VSCAN_SOPHOS)
-ALL_TARGET+=sophos
-VSCAN_NAME+=vscan-sophos.so
-VSCAN_CONF+=sophos/vscan-sophos.conf
-.endif
-
-.if defined(WITH_VSCAN_TREND)
-ALL_TARGET+=trend
-VSCAN_NAME+=vscan-trend.so
-VSCAN_CONF+=trend/vscan-trend.conf
-.endif
-
-PLIST_FILES+= ${VSCAN_NAME:S|^|${VFSDIR}/|} \
- ${VSCAN_CONF:S|^|${ETCDIR}/|:C|(.*/).*/(.*.conf)|\1\2|}
-PLIST_DIRS= ${ETCDIR} ${VFSDIR}
-
-do-install:
-.for i in ${VSCAN_NAME}
- @${MKDIR} ${PREFIX}/${VFSDIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/${VFSDIR}
-.endfor
- @${MKDIR} ${PREFIX}/${ETCDIR}
-.for i in ${VSCAN_CONF}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${ETCDIR}
-.endfor
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/security/samba-vscan/distinfo b/security/samba-vscan/distinfo
deleted file mode 100644
index 6b89fe291139..000000000000
--- a/security/samba-vscan/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (samba-vscan-0.3.6c-beta5.tar.gz) = 8f1dd119172e04e6d7c2d05526a4cf8b
-SHA256 (samba-vscan-0.3.6c-beta5.tar.gz) = bfe910d54add8dcb87d5babdf50127a6dcf079e0e90ad9947b4cbfdbe3e3037d
-SIZE (samba-vscan-0.3.6c-beta5.tar.gz) = 248183
diff --git a/security/samba-vscan/files/patch-Makefile.in b/security/samba-vscan/files/patch-Makefile.in
deleted file mode 100644
index 5538f3ff9911..000000000000
--- a/security/samba-vscan/files/patch-Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig Fri Feb 27 13:07:34 2004
-+++ Makefile.in Fri Feb 27 13:07:11 2004
-@@ -42,7 +42,7 @@
- BINDIR = @SAMBA_BINDIR@
- SBINDIR = @SAMBA_SBINDIR@
-
--LIBDIR = @SAMBA_LIBDIR@
-+LIBDIR = $(prefix)/lib/samba
- VFSLIBDIR = @SAMBA_VFSLIBDIR@
- PDBLIBDIR = @SAMBA_PDBLIBDIR@
- RPCLIBDIR = @SAMBA_RPCLIBDIR@
-@@ -184,8 +184,6 @@
- @echo "to $(DESTDIR)$(VFSLIBDIR) with $(INSTALLPERMS)"
- @$(INSTALLCMD) -m $(INSTALLPERMS) $(patsubst ${builddir}/%.$(SHLIBEXT),%.$(SHLIBEXT),$(wildcard ${builddir}/*.$(SHLIBEXT))) $(DESTDIR)$(VFSLIBDIR)
- @echo ""
-- @echo "NOTE: the corresponding configuration file(s) must be copied manually!"
-- @echo "The default location is /etc/samba. See INSTALL for details!"
-
- # Misc targets
- clean:
diff --git a/security/samba-vscan/files/patch-configure b/security/samba-vscan/files/patch-configure
deleted file mode 100644
index 0b25076397e3..000000000000
--- a/security/samba-vscan/files/patch-configure
+++ /dev/null
@@ -1,95 +0,0 @@
---- configure.orig Thu Mar 24 00:31:42 2005
-+++ configure Mon May 30 16:58:31 2005
-@@ -3902,7 +3902,7 @@
- #
- # Try to get the Samba Version for old releases
- #
--SAMBA_VERSION_H_STR=$(cat ${SAMBA_srcdir}/include/version.h |grep '#define VERSION'|cut -d ' ' -f3-)
-+SAMBA_VERSION_H_STR=`cat ${SAMBA_srcdir}/include/version.h |grep '#define SAMBA_VERSION'|cut -d ' ' -f3-`
-
- SAMBA_VERSION=
- ####################################################
-@@ -3950,26 +3950,21 @@
- esac
- fi;
-
--
--if test -z "$SAMBA_VERSION_STRING";then
-+if /usr/bin/true ;then
-
- if test -z "$SAMBA_VERSION"; then
- SAMBA_VERSION=$SAMBA_VERSION_H_STR
- fi
--
- echo "$as_me:$LINENO: checking for Samba Version" >&5
- echo $ECHO_N "checking for Samba Version... $ECHO_C" >&6
-
-- SAMBA_VERSION_MAJOR=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\1/')
-- SAMBA_VERSION_MINOR=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\2/')
-- SAMBA_VERSION_RELEASE=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\3/')
-- SAMBA_VERSION_SUFFIX=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\4/')
-- SAMBA_VERSION_SUFFIX_RELEASE=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\5/')
-- SAMBA_VERSION_SUFFIX_EXTRA1=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\6/')
-- SAMBA_VERSION_SUFFIX_EXTRA2=$(echo $SAMBA_VERSION | sed -e 's/"\([0-9]\)\.\([0-9]\)[\.]*\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)\([a-zA-Z]*\)\([-]*\)\(.*\)"/\8/')
-+ SAMBA_VERSION_MAJOR=$(echo $SAMBA_VERSION | awk '{print $1}')
-+ SAMBA_VERSION_MINOR=$(echo $SAMBA_VERSION | awk '{print $2}')
-+ SAMBA_VERSION_RELEASE=$(echo $SAMBA_VERSION | awk '{print $3}'| sed -e 's/\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)/\1/')
-+ SAMBA_VERSION_SUFFIX=$(echo $SAMBA_VERSION | awk '{print $3}' | sed -e 's/\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)/\2/')
-+ SAMBA_VERSION_SUFFIX_RELEASE=$(echo $SAMBA_VERSION | awk '{print $3}' | sed -e 's/\([0-9]*\)\([a-zA-Z]*\)\([0-9]*\)/\3/')
-
- SAMBA_VERSION_STRING="${SAMBA_VERSION_MAJOR}.${SAMBA_VERSION_MINOR}"
--
- if test -n "$SAMBA_VERSION_RELEASE";then
- SAMBA_VERSION_STRING="${SAMBA_VERSION_STRING}.${SAMBA_VERSION_RELEASE}"
- fi
-@@ -4085,9 +4080,9 @@
- fi
-
-
--cat >>confdefs.h <<_ACEOF
-+#cat >>confdefs.h <<_ACEOF
- #define SAMBA_VERSION_OFFICIAL_STRING $SAMBA_VERSION_STRING
--_ACEOF
-+#_ACEOF
-
-
- if test -n "${SAMBA_VERSION_VENDOR_SUFFIX}";then
-@@ -4101,9 +4096,9 @@
-
- SAMBA_VERSION_STRING="\"${SAMBA_VERSION_STRING}\""
-
--cat >>confdefs.h <<_ACEOF
-+#cat >>confdefs.h <<_ACEOF
- #define SAMBA_VERSION_STRING $SAMBA_VERSION_STRING
--_ACEOF
-+#_ACEOF
-
-
- echo "$as_me:$LINENO: result: $SAMBA_VERSION_STRING" >&5
-@@ -5128,7 +5123,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lmagic $LIBS"
-+LIBS="-lmagic -lz $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- #include "confdefs.h"
-@@ -5182,7 +5177,7 @@
- #define HAVE_LIBMAGIC 1
- _ACEOF
-
-- LIBS="-lmagic $LIBS"
-+ LIBS="-lmagic -lz $LIBS"
-
- fi
-
-@@ -5190,7 +5185,7 @@
- if test x"$ac_cv_header_magic_h" = x"yes"; then
- if test x"$ac_cv_lib_magic_magic_load" = x"yes"; then
- vscan_cv_filetype=yes
-- MAGIC_LIB="-lmagic"
-+ MAGIC_LIB="-lmagic -lz"
- fi
- fi
- fi
diff --git a/security/samba-vscan/files/patch-vscan-clamav.conf b/security/samba-vscan/files/patch-vscan-clamav.conf
deleted file mode 100644
index 9c48d6c9592c..000000000000
--- a/security/samba-vscan/files/patch-vscan-clamav.conf
+++ /dev/null
@@ -1,11 +0,0 @@
---- clamav/vscan-clamav.conf.old Fri Aug 13 14:15:08 2004
-+++ clamav/vscan-clamav.conf Fri Aug 13 14:16:05 2004
-@@ -59,7 +59,7 @@
-
- ; socket name of clamd (default: /var/run/clamd). Setting will be ignored if
- ; libclamav is used
--clamd socket name = /var/run/clamd
-+clamd socket name = /var/run/clamav/clamd
-
- ; limits, if vscan-clamav was build for using the clamav library (libclamav)
- ; instead of clamd
diff --git a/security/samba-vscan/files/patch-vscan-clamav.h b/security/samba-vscan/files/patch-vscan-clamav.h
deleted file mode 100644
index ab4cfcd3107d..000000000000
--- a/security/samba-vscan/files/patch-vscan-clamav.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- clamav/vscan-clamav.h.orig Wed Sep 29 20:36:09 2004
-+++ clamav/vscan-clamav.h Mon May 30 15:24:08 2005
-@@ -9,11 +9,11 @@
- /* default location of samba-style configuration file (needs Samba >= 2.2.4
- or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-clamav.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-clamav.conf"
-
- /* Clam AntiVirus (clamd) stuff:
- socket name of Clam daemon */
--#define VSCAN_CLAMD_SOCKET_NAME "/var/run/clamd"
-+#define VSCAN_CLAMD_SOCKET_NAME "/var/run/clamav/clamd"
-
- /* Clam AntiVirus (libclamav) stuff:
- maximum number of files in archive */
diff --git a/security/samba-vscan/files/patch-vscan-fprotd.h b/security/samba-vscan/files/patch-vscan-fprotd.h
deleted file mode 100644
index 6af04e06eae6..000000000000
--- a/security/samba-vscan/files/patch-vscan-fprotd.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- fprot/vscan-fprotd.h.old Fri Aug 13 13:52:39 2004
-+++ fprot/vscan-fprotd.h Fri Aug 13 13:53:14 2004
-@@ -7,7 +7,7 @@
- /* default location of samba-style configuration file (needs Samba >= 2.2.4
- or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-fprotd.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-fprotd.conf"
-
-
- /* False = log only infected file, True = log every file access */
diff --git a/security/samba-vscan/files/patch-vscan-fsav.h b/security/samba-vscan/files/patch-vscan-fsav.h
deleted file mode 100644
index b209da0743cf..000000000000
--- a/security/samba-vscan/files/patch-vscan-fsav.h
+++ /dev/null
@@ -1,28 +0,0 @@
---- f-secure/vscan-fsav.h.orig Wed Sep 29 20:36:09 2004
-+++ f-secure/vscan-fsav.h Mon May 30 15:28:24 2005
-@@ -40,7 +40,7 @@
-
- /* default location of samba-style configuration file (needs Samba >= 2.2.4 or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-fsav.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-fsav.conf"
-
- /* FSAV-related settings */
-
-@@ -52,13 +52,13 @@
- #define VSCAN_FSAV_CONNECT_ID 0
-
- /* fsav configuration file */
--#define VSCAN_FSAV_CONFIG_FILE "/etc/fsav.conf"
-+#define VSCAN_FSAV_CONFIG_FILE "/usr/local/etc/fsav.conf"
-
- /* location of fsavd binary */
--#define VSCAN_FSAV_BINARY "/opt/f-secure/fsav/bin/fsavd"
-+#define VSCAN_FSAV_BINARY "/usr/local/bin/fsavd"
-
- /* path to FSAV databases */
--#define VSCAN_FSAV_DB_DIR "/var/opt/f-secure/fsav/databases"
-+#define VSCAN_FSAV_DB_DIR "/var/db/fsav/databases"
-
- /* fsav socket name */
- #define VSCAN_FSAV_SOCKET "/tmp/.fsav-0"
diff --git a/security/samba-vscan/files/patch-vscan-icap.h b/security/samba-vscan/files/patch-vscan-icap.h
deleted file mode 100644
index b1e0cc10bae2..000000000000
--- a/security/samba-vscan/files/patch-vscan-icap.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- icap/vscan-icap.h.old Fri Aug 13 13:54:25 2004
-+++ icap/vscan-icap.h Fri Aug 13 13:54:52 2004
-@@ -8,7 +8,7 @@
- /* default location of samba-style configuration file (needs Samba >= 2.2.4
- or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-icap.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-icap.conf"
-
-
- /* False = log only infected file, True = log every file access */
diff --git a/security/samba-vscan/files/patch-vscan-kavp.h b/security/samba-vscan/files/patch-vscan-kavp.h
deleted file mode 100644
index 87b9ef62c1de..000000000000
--- a/security/samba-vscan/files/patch-vscan-kavp.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- kaspersky/vscan-kavp.h.old Fri Aug 13 13:57:48 2004
-+++ kaspersky/vscan-kavp.h Fri Aug 13 13:58:16 2004
-@@ -8,7 +8,7 @@
- /* default location of samba-style configuration file (needs Samba >= 2.2.4
- or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-kavp.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-kavp.conf"
-
-
- /* False = log only infected file, True = log every file access */
diff --git a/security/samba-vscan/files/patch-vscan-mcdaemon.h b/security/samba-vscan/files/patch-vscan-mcdaemon.h
deleted file mode 100644
index d5380058933e..000000000000
--- a/security/samba-vscan/files/patch-vscan-mcdaemon.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- nai/vscan-mcdaemon.h.old Fri Aug 13 14:01:46 2004
-+++ nai/vscan-mcdaemon.h Fri Aug 13 14:02:26 2004
-@@ -6,7 +6,7 @@
- /* default location of samba-style configuration file (needs Samba >= 2.2.4
- or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-mcdaemon.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-mcdaemon.conf"
-
-
- /* False = log only infected file, True = log every file access */
diff --git a/security/samba-vscan/files/patch-vscan-mksd.h b/security/samba-vscan/files/patch-vscan-mksd.h
deleted file mode 100644
index ad9d804c61fb..000000000000
--- a/security/samba-vscan/files/patch-vscan-mksd.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- mks/vscan-mksd.h.old Fri Aug 13 13:59:26 2004
-+++ mks/vscan-mksd.h Fri Aug 13 13:59:52 2004
-@@ -6,7 +6,7 @@
- /* default location of samba-style configuration file (needs Samba >= 2.2.4
- or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-mks32.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-mks32.conf"
-
-
- /* False = log only infected file, True = log every file access */
diff --git a/security/samba-vscan/files/patch-vscan-oav.h b/security/samba-vscan/files/patch-vscan-oav.h
deleted file mode 100644
index 75f8f7959ac4..000000000000
--- a/security/samba-vscan/files/patch-vscan-oav.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- openantivirus/vscan-oav.h.old Fri Aug 13 14:04:07 2004
-+++ openantivirus/vscan-oav.h Fri Aug 13 14:04:23 2004
-@@ -6,7 +6,7 @@
- /* default location of samba-style configuration file (needs Samba >= 2.2.4
- or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-oav.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-oav.conf"
-
-
- /* False = log only infected file, True = log every file access */
diff --git a/security/samba-vscan/files/patch-vscan-sophos.conf b/security/samba-vscan/files/patch-vscan-sophos.conf
deleted file mode 100644
index 84711f3b4116..000000000000
--- a/security/samba-vscan/files/patch-vscan-sophos.conf
+++ /dev/null
@@ -1,8 +0,0 @@
---- sophos/vscan-sophos.conf.old Fri Aug 13 14:09:44 2004
-+++ sophos/vscan-sophos.conf Fri Aug 13 14:09:58 2004
-@@ -57,4 +57,4 @@
- exclude file types =
-
- ; socket name of Sophie (default: /var/run/sophie)
--sophie socket name = /var/run/sophie
-+sophie socket name = /var/run/sophie/sophie.sock
diff --git a/security/samba-vscan/files/patch-vscan-sophos.h b/security/samba-vscan/files/patch-vscan-sophos.h
deleted file mode 100644
index cb54355b525e..000000000000
--- a/security/samba-vscan/files/patch-vscan-sophos.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- sophos/vscan-sophos.h.orig Tue Sep 28 20:42:51 2004
-+++ sophos/vscan-sophos.h Mon May 30 15:31:29 2005
-@@ -9,11 +9,11 @@
- /* default location of samba-style configuration file (needs Samba >= 2.2.4
- or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-sophos.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-sophos.conf"
-
- /* Sophie stuff:
- socket name of Sophie daemon */
--#define SOPHIE_SOCKET_NAME "/var/run/sophie"
-+#define SOPHIE_SOCKET_NAME "/var/run/sophie/sophie.sock"
-
- /* End Configuration Section */
-
diff --git a/security/samba-vscan/files/patch-vscan-symantec.h b/security/samba-vscan/files/patch-vscan-symantec.h
deleted file mode 100644
index 014896262eb8..000000000000
--- a/security/samba-vscan/files/patch-vscan-symantec.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- symantec/vscan-symantec.h.old Fri Aug 13 14:10:58 2004
-+++ symantec/vscan-symantec.h Fri Aug 13 14:11:22 2004
-@@ -8,7 +8,7 @@
- /* default location of samba-style configuration file (needs Samba >= 2.2.4
- or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-symantec.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-symantec.conf"
-
-
- /* False = log only infected file, True = log every file access */
diff --git a/security/samba-vscan/files/patch-vscan-trend.conf b/security/samba-vscan/files/patch-vscan-trend.conf
deleted file mode 100644
index 501b8e86a1a9..000000000000
--- a/security/samba-vscan/files/patch-vscan-trend.conf
+++ /dev/null
@@ -1,8 +0,0 @@
---- trend/vscan-trend.conf.old Fri Aug 13 14:24:01 2004
-+++ trend/vscan-trend.conf Fri Aug 13 14:26:41 2004
-@@ -59,4 +59,4 @@
- exclude file types =
-
- ; socket name of Trophie (default: /var/run/trophie)
--trophie socket name = /var/run/trophie
-+trophie socket name = /var/run/trophie/trophie.sock
diff --git a/security/samba-vscan/files/patch-vscan-trend.h b/security/samba-vscan/files/patch-vscan-trend.h
deleted file mode 100644
index b8e1887062c9..000000000000
--- a/security/samba-vscan/files/patch-vscan-trend.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- trend/vscan-trend.h.orig Tue Sep 28 20:42:52 2004
-+++ trend/vscan-trend.h Mon May 30 15:33:12 2005
-@@ -9,11 +9,11 @@
- /* default location of samba-style configuration file (needs Samba >= 2.2.4
- or Samba 3.0 */
-
--#define PARAMCONF "/etc/samba/vscan-trend.conf"
-+#define PARAMCONF "/usr/local/etc/samba-vscan/vscan-trend.conf"
-
- /* Trophie stuff:
- socket name of Trophie daemon */
--#define TROPHIE_SOCKET_NAME "/var/run/trophie"
-+#define TROPHIE_SOCKET_NAME "/var/run/trophie/trophie.sock"
-
- /* End Configuration Section */
-
diff --git a/security/samba-vscan/files/pkg-message.in b/security/samba-vscan/files/pkg-message.in
deleted file mode 100644
index cb77535664b8..000000000000
--- a/security/samba-vscan/files/pkg-message.in
+++ /dev/null
@@ -1,43 +0,0 @@
-*****************************************************************************
-You have installed the samba-vscan package.
-
-The vfs object's is in %%PREFIX%%/lib/samba.
-
-The configuration files is in %%PREFIX%%/etc/samba-vscan.
-
-Edit %%PREFIX%%/etc/smb.conf and add the following entry if you are using
-samba 2.X (that's only an example):
-
- [vscan]
- comment = virus-protected /tmp directory
- path = /tmp
- vfs object = %%PREFIX%%/lib/samba/vscan-oav.so
- vfs options = config-file = %%PREFIX%%/etc/samba-vscan/vscan-oav.conf
- writeable = yes
- browseable = yes
- guest ok = yes
-
-If you are using samba 3.X:
-
-Edit %%PREFIX%%/etc/smb.conf and add the following entry (that's only an example):
- [vscan]
- comment = virus-protected /tmp directory
- path = /tmp
- vfs object = vscan-oav
- vscan-oav: config-file = %%PREFIX%%/etc/samba-vscan/vscan-oav.conf
- writeable = yes
- browseable = yes
- guest ok = yes
-
-Basically you have to add a vfs object line to your shares
-which should be virus-protected by this module. If you'd like to use the
-run-time configuration file, simply add the
-vfs options = config-file = /path/config-file
-(different settings for several shares can be achieved by using a different
-name of the configuration file for each share). If you want to protect _all_
-shares your Samba server offers, simply add the vfs object line (and the
-vfs options line, if you like) to the [global] section.
-
-Then restart samba.
-
-Important: Remember, you need to install Clamav, Fprot, Icap, Kaspersky, Mks, Openantivirus, Sophos or Trend Antivirus to samba-vscan works correctly.
diff --git a/security/samba-vscan/pkg-descr b/security/samba-vscan/pkg-descr
deleted file mode 100644
index 99527f74c4be..000000000000
--- a/security/samba-vscan/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-samba-vscan is a proof-of-concept module for Samba, which uses the VFS
-(virtual file system) features of Samba 2.2.x/3.0 to provide an
-on-access Samba anti-virus. Of course, Samba has to be compiled with
-VFS support. It currently works only with FRISK F-Prot Daemon,
-Kaspersky AntiVirus, mks32, OpenAntiVirus ScannerDaemon, Sophos Sweep,
-Symantec AntiVirus Engine (via ICAP) or Trend Micro.
-
-WWW: http://www.openantivirus.org/projects.php