aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED2
-rw-r--r--net/Makefile2
-rw-r--r--net/lmd/Makefile57
-rw-r--r--net/lmd/distinfo2
-rw-r--r--net/lmd/files/lmd.sh35
-rw-r--r--net/lmd/files/patch-Makefile29
-rw-r--r--net/lmd/files/patch-main.c11
-rw-r--r--net/lmd/files/patch-modules_check::Makefile22
-rw-r--r--net/lmd/pkg-descr12
-rw-r--r--net/lmd/pkg-message.in8
-rw-r--r--net/lmd/pkg-plist8
-rw-r--r--net/loadd/Makefile46
-rw-r--r--net/loadd/distinfo2
-rw-r--r--net/loadd/files/010.loadd.sh35
-rw-r--r--net/loadd/files/patch-Makefile29
-rw-r--r--net/loadd/files/patch-define.h11
-rw-r--r--net/loadd/files/patch-main.c11
-rw-r--r--net/loadd/pkg-descr23
-rw-r--r--net/loadd/pkg-message.in14
-rw-r--r--net/loadd/pkg-plist8
20 files changed, 2 insertions, 365 deletions
diff --git a/MOVED b/MOVED
index d674b4c5652c..ddc8ebc93904 100644
--- a/MOVED
+++ b/MOVED
@@ -1442,3 +1442,5 @@ science/ruby-dcl-gtk|science/ruby-dcl|2005-02-24|master port depend on gtk now
www/pear-APC|www/pecl-APC|2005-02-26|software is now pecl
mail/namg||2005-02-27|obsolete/no longer exists
games/scorched3d-devel|games/scorched3d|2005-03-04|move to non-devel directory
+net/lmd||2005-03-04|Project dead and disappeared
+net/loadd||2005-03-04|Project dead and disappeared
diff --git a/net/Makefile b/net/Makefile
index 50356a933bd9..7e2717a9855a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -336,8 +336,6 @@
SUBDIR += linuxigd
SUBDIR += liveMedia
SUBDIR += lla
- SUBDIR += lmd
- SUBDIR += loadd
SUBDIR += loudmouth
SUBDIR += luasocket
SUBDIR += lyntin
diff --git a/net/lmd/Makefile b/net/lmd/Makefile
deleted file mode 100644
index ddf3a9a82a03..000000000000
--- a/net/lmd/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-# New ports collection makefile for: lmd
-# Date created: Thu May 2 11:20:06 CET 2002
-# Whom: Alex Dupre <sysadmin@alexdupre.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= lmd
-PORTVERSION= 0.8
-CATEGORIES= net sysutils
-MASTER_SITES= http://www.bsdshell.net/download/
-
-MAINTAINER= ale@FreeBSD.org
-COMMENT= A Load Monitor Daemon
-
-USE_REINPLACE= YES
-REINPLACE_ARGS= #empty
-
-MODULES= ldd_http_module.so
-DOCS= INSTALL LICENSE README
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-post-patch:
- ${REINPLACE_CMD} -i.bak -e 's|varargs.h|stdarg.h|' \
- ${WRKSRC}/chkmodules.h \
- ${WRKSRC}/main.h \
- ${WRKSRC}/modules_check/ldd_http_module.h
-
-post-build:
- @${REINPLACE_CMD} -e 's,%PREFIX%,${PREFIX},g' \
- ${.CURDIR}/pkg-message.in > ${WRKDIR}/pkg-message
-
-do-install:
- @${ECHO_CMD} "Installing files..."
- @${INSTALL_PROGRAM} ${WRKSRC}/lmd ${PREFIX}/sbin/lmd
- @${INSTALL_SCRIPT} ${FILESDIR}/lmd.sh ${PREFIX}/etc/rc.d/lmd.sh
- @${INSTALL_DATA} ${WRKSRC}/lmd.conf ${PREFIX}/etc/lmd.conf.sample
-.for f in ${MODULES}
- @${INSTALL_DATA} ${WRKSRC}/modules_check/${f} ${PREFIX}/lib/
-.endfor
- @${CAT} ${PKGMESSAGE}
-
-.if !defined(NOPORTDOCS)
-post-install:
- @${MKDIR} ${DOCSDIR}
-.for f in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-MAKE_ENV+= CPPFLAGS="-DPREFIX=\\\"${PREFIX}\\\" -fPIC"
-.else
-MAKE_ENV+= CPPFLAGS="-DPREFIX=\\\"${PREFIX}\\\""
-.endif
-.include <bsd.port.post.mk>
diff --git a/net/lmd/distinfo b/net/lmd/distinfo
deleted file mode 100644
index d913e964fe4e..000000000000
--- a/net/lmd/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (lmd-0.8.tar.gz) = 909e335b4a406d2b14c0db21e4840ab6
-SIZE (lmd-0.8.tar.gz) = 14467
diff --git a/net/lmd/files/lmd.sh b/net/lmd/files/lmd.sh
deleted file mode 100644
index e9d93c2833e7..000000000000
--- a/net/lmd/files/lmd.sh
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/${0##*/}\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 64
-fi
-
-if [ -r /etc/defaults/rc.conf ]; then
- . /etc/defaults/rc.conf
- source_rc_confs
-elif [ -r /etc/rc.conf ]; then
- . /etc/rc.conf
-fi
-
-case "$1" in
-start)
- case ${lmd_enable:-NO} in
- [Yy][Ee][Ss])
- [ -f ${PREFIX}/etc/lmd.conf ] && ${lmd_program:-${PREFIX}/sbin/lmd} ${lmd_flags} && echo -n ' lmd'
- ;;
- esac
- ;;
-stop)
- case ${lmd_enable:-NO} in
- [Yy][Ee][Ss])
- [ -f ${PREFIX}/etc/lmd.conf ] && /usr/bin/killall lmd && echo -n ' lmd'
- ;;
- esac
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- ;;
-esac
-
-exit 0
diff --git a/net/lmd/files/patch-Makefile b/net/lmd/files/patch-Makefile
deleted file mode 100644
index 211e76b7a333..000000000000
--- a/net/lmd/files/patch-Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.orig Mon Nov 26 07:30:14 2001
-+++ Makefile Tue May 14 14:18:21 2002
-@@ -1,18 +1,21 @@
- SRCS=main.c socket.c chkmodules.c conf.c
- OBJS=${SRCS:.c=.o}
- DYNLIB=modules_check/ldd_http_module.so
--OPTS=-O3 -fomit-frame-pointer -pipe -Wall -ansi
-+OPTS=${CFLAGS} ${CPPFLAGS} -Wall -ansi
- #DEBUG=-DDEBUG -g
--LIBS=-L/usr/local/lib -lm
-+LIBS=-L${PREFIX}/lib -lm
-+CC?=cc
-+
-+all: lmd modules_check/ldd_http_module.so
-
- lmd: ${OBJS} ${DYNLIB}
-- gcc ${DEBUG} ${OPTS} ${OBJS} -o lmd ${LIBS}
-+ ${CC} ${DEBUG} ${OPTS} ${OBJS} -o lmd ${LIBS}
-
- .c.o: ${SRCS}
-- gcc ${DEBUG} ${OPTS} -c $<
-+ ${CC} ${DEBUG} ${OPTS} -c $<
-
- modules_check/ldd_http_module.so:
-- cd ./modules_check && make && cd ..
-+ cd ./modules_check && make 'CC=${CC}' 'CFLAGS=${CFLAGS}' 'CPPFLAGS=${CPPFLAGS}' && cd ..
-
- clean:
- rm -rf ${OBJS} lmd *.core *~ modules_check/*.so
diff --git a/net/lmd/files/patch-main.c b/net/lmd/files/patch-main.c
deleted file mode 100644
index 6da527ce86b4..000000000000
--- a/net/lmd/files/patch-main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- main.c.orig Mon Nov 26 06:45:34 2001
-+++ main.c Tue May 14 14:09:46 2002
-@@ -1,7 +1,7 @@
- #include "main.h"
- #include <math.h>
- #define TIMETOSLEEP 60
--#define CONFIGFILE "/usr/local/etc/lmd.conf"
-+#define CONFIGFILE PREFIX "/etc/lmd.conf"
-
- char bufferout[2][1024];
- char **loaddservers;
diff --git a/net/lmd/files/patch-modules_check::Makefile b/net/lmd/files/patch-modules_check::Makefile
deleted file mode 100644
index 312f1b56ce84..000000000000
--- a/net/lmd/files/patch-modules_check::Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- modules_check/Makefile.orig Sun Nov 25 17:31:09 2001
-+++ modules_check/Makefile Sat Feb 21 14:25:58 2004
-@@ -1,14 +1,15 @@
- # If you want to debug lmd comment out this line and recompile it
- # Launch lmd with -v option to see debug messages
- #DEBUG=-DDEBUG
--OPTS=-Wall -fomit-frame-pointer -O2 -pipe -ansi
-+OPTS=${CFLAGS} ${CPPFLAGS} -ansi
-+CC?=cc
-
- all: socket.o
-- gcc ${DEBUG} ${OPTS} -c ldd_http_module.c
-- gcc ${DEBUG} -shared ldd_http_module.o socket.o -o ldd_http_module.so
-+ ${CC} ${DEBUG} ${OPTS} -c ldd_http_module.c
-+ ${CC} ${DEBUG} -shared ldd_http_module.o socket.o -o ldd_http_module.so
-
- socket.o:
-- gcc -c ../socket.c -o socket.o
-+ ${CC} ${OPTS} -c ../socket.c -o socket.o
-
- clean:
- rm *.so *.o
diff --git a/net/lmd/pkg-descr b/net/lmd/pkg-descr
deleted file mode 100644
index c826516b2b30..000000000000
--- a/net/lmd/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-lmd is a daemon that monitors the server load and communicates
-with loadd for Intellingence Load Sharing (Balancing with
-realtime load).
-
-Supported modules:
-
-* http
-
-WWW: http://www.bsdshell.net/hut_loadd.html
-
-- Alex Dupre
-ale@FreeBSD.org
diff --git a/net/lmd/pkg-message.in b/net/lmd/pkg-message.in
deleted file mode 100644
index 5a1875a0a1fb..000000000000
--- a/net/lmd/pkg-message.in
+++ /dev/null
@@ -1,8 +0,0 @@
-##################################################
- !! IMPORTANT !! CONFIGURE YOUR LMD CLIENT WITH
- THE %PREFIX%/etc/lmd.conf CONFIGURATION FILE
- Just set loaddservers to the IP of your loadd
- server. You can specify multiple loadd servers
- with the ',' separator
- Example: loaddservers = 63.2.1.3, 62.3.5.6
-##################################################
diff --git a/net/lmd/pkg-plist b/net/lmd/pkg-plist
deleted file mode 100644
index a4a274a66212..000000000000
--- a/net/lmd/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-sbin/lmd
-etc/rc.d/lmd.sh
-etc/lmd.conf.sample
-lib/ldd_http_module.so
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/net/loadd/Makefile b/net/loadd/Makefile
deleted file mode 100644
index 013ba91e7c69..000000000000
--- a/net/loadd/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-# New ports collection makefile for: loadd
-# Date created: Thu May 2 11:20:06 CET 2002
-# Whom: Alex Dupre <sysadmin@alexdupre.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= loadd
-PORTVERSION= 0.8
-CATEGORIES= net sysutils
-MASTER_SITES= http://www.bsdshell.net/download/
-
-MAINTAINER= ale@FreeBSD.org
-COMMENT= A Load Balancing Daemon
-
-LIB_DEPENDS= glib12.3:${PORTSDIR}/devel/glib12
-
-USE_REINPLACE= YES
-REINPLACE_ARGS= #empty
-
-DOCS= INSTALL LICENSE README TODO
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-MAKE_ENV+= CPPFLAGS="-DPREFIX=\\\"${PREFIX}\\\""
-MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
-
-post-build:
- ${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
- ${.CURDIR}/pkg-message.in > ${WRKDIR}/pkg-message
-
-do-install:
- @${ECHO_CMD} "Installing files..."
- @${INSTALL_PROGRAM} ${WRKSRC}/loadd ${PREFIX}/libexec/
- @${INSTALL_SCRIPT} ${FILESDIR}/010.loadd.sh ${PREFIX}/etc/rc.d/
- @${INSTALL_DATA} ${WRKSRC}/loadd.conf ${PREFIX}/etc/loadd.conf.sample
- @${CAT} ${PKGMESSAGE}
-
-.if !defined(NOPORTDOCS)
-post-install:
- @${MKDIR} ${DOCSDIR}
-.for f in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/net/loadd/distinfo b/net/loadd/distinfo
deleted file mode 100644
index 1651bc5368ac..000000000000
--- a/net/loadd/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (loadd-0.8.tar.gz) = c6cca2534bd987c4ef408033ebf1a0bd
-SIZE (loadd-0.8.tar.gz) = 13547
diff --git a/net/loadd/files/010.loadd.sh b/net/loadd/files/010.loadd.sh
deleted file mode 100644
index 27fcbc9d9ce6..000000000000
--- a/net/loadd/files/010.loadd.sh
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/${0##*/}\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 64
-fi
-
-if [ -r /etc/defaults/rc.conf ]; then
- . /etc/defaults/rc.conf
- source_rc_confs
-elif [ -r /etc/rc.conf ]; then
- . /etc/rc.conf
-fi
-
-case "$1" in
-start)
- case ${loadd_enable:-NO} in
- [Yy][Ee][Ss])
- [ -f ${PREFIX}/etc/loadd.conf ] && ${loadd_program:-${PREFIX}/libexec/loadd} ${loadd_flags:--d} && echo -n ' loadd'
- ;;
- esac
- ;;
-stop)
- case ${loadd_enable:-NO} in
- [Yy][Ee][Ss])
- [ -f ${PREFIX}/etc/loadd.conf ] && /usr/bin/killall loadd && echo -n ' loadd'
- ;;
- esac
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- ;;
-esac
-
-exit 0
diff --git a/net/loadd/files/patch-Makefile b/net/loadd/files/patch-Makefile
deleted file mode 100644
index 4e80c30e23ec..000000000000
--- a/net/loadd/files/patch-Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.orig Mon Nov 26 07:44:48 2001
-+++ Makefile Tue May 14 14:55:55 2002
-@@ -3,18 +3,21 @@
-
- SRCS=main.c socket.c icmp.c conf.c threads.c network.c aliasing.c tri.c
- OBJS=${SRCS:.c=.o}
--OPTS=-pthread -pipe -Wall -ansi -O2 -march=pentiumpro -fomit-frame-pointer -ffast-math
-+OPTS=${CFLAGS} ${CPPFLAGS} -Wall -ansi
- #DEBUG=-DDEBUG -DDEBUGALIAS #-DDEBUGHASHTABLE
- #DEBUG=-DDEBUGMONITOR
--DEFINE=-D_THREAD_SAFE -D_REENTRANT
--LIBS=-L/usr/local/lib `glib12-config --libs`
-+DEFINE=${PTHREAD_CFLAGS}
-+LIBS=-L${PREFIX}/lib `glib12-config --libs` ${PTHREAD_LIBS}
- INCLUDE=`glib12-config --cflags`
-+CC?=cc
-+
-+all: loadd
-
- loadd: ${OBJS}
-- gcc ${INCLUDE} ${DEFINE} ${DEBUG} ${OPTS} ${OBJS} -o loadd ${LIBS}
-+ ${CC} ${INCLUDE} ${DEFINE} ${DEBUG} ${OPTS} ${OBJS} -o loadd ${LIBS}
-
- .c.o: ${SRCS}
-- gcc ${INCLUDE} ${DEFINE} ${DEBUG} ${OPTS} -c $<
-+ ${CC} ${INCLUDE} ${DEFINE} ${DEBUG} ${OPTS} -c $<
-
- clean:
- rm -rf ${OBJS} loadd *.core *~
diff --git a/net/loadd/files/patch-define.h b/net/loadd/files/patch-define.h
deleted file mode 100644
index 8e8351247e59..000000000000
--- a/net/loadd/files/patch-define.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- define.h.orig Tue Oct 2 22:43:20 2001
-+++ define.h Tue May 14 14:45:36 2002
-@@ -5,7 +5,7 @@
- #define MONITORINGPORT 8670 /* En UDP */
- #define PINGINTERVAL 60000000
- #define REFRESHTIMEOUT 1
--#define CONFFILE "/usr/local/etc/loadd2.conf"
-+#define CONFFILE PREFIX "/etc/loadd.conf"
- #define CALC_CHECKSUM(acc, cksum) { \
- acc += cksum; \
- if (acc < 0) \
diff --git a/net/loadd/files/patch-main.c b/net/loadd/files/patch-main.c
deleted file mode 100644
index 8a5be982437d..000000000000
--- a/net/loadd/files/patch-main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- main.c.orig Mon Nov 26 05:59:19 2001
-+++ main.c Tue May 14 14:46:25 2002
-@@ -270,7 +270,7 @@
- break;
- }
- if (! *conffile)
-- strncpy(conffile, "/usr/local/etc/loadd.conf", sizeof(conffile) - 1);
-+ strncpy(conffile, PREFIX "/etc/loadd.conf", sizeof(conffile) - 1);
- argc -= optind;
- argv += optind;
- ht = loadd_main_init(conffile);
diff --git a/net/loadd/pkg-descr b/net/loadd/pkg-descr
deleted file mode 100644
index 44fc9504985b..000000000000
--- a/net/loadd/pkg-descr
+++ /dev/null
@@ -1,23 +0,0 @@
-loadd is a daemon that communicate with ipfw Firewall via the DIVERT
-sockets. You can easily configure a divert rule on your firewall and
-redirect packets you want into the loadd system. Loadd check the
-destination service and do a NAT on packets if the service must be
-load balance. For choosing a host, loadd apply an algorithm that you
-can configure.
-
-For this first release, two algorithms are available
-and you can found this features:
-
-* Round-Robbin Algorithm (Very simple)
-* Intelligence Load Sharing (Balancing with realtime load, work with
- lmd client on real servers)
-* TCP supported (not UDP yet)
-* Support multiples IP services (except SSL for the moment)
-* Choose of IP aliasing
-* Choose of port number to Load Balance
-* Multiple daemons support on the same host without conflict
-
-WWW: http://www.bsdshell.net/hut_loadd.html
-
-- Alex Dupre
-ale@FreeBSD.org
diff --git a/net/loadd/pkg-message.in b/net/loadd/pkg-message.in
deleted file mode 100644
index 33b24963f4f4..000000000000
--- a/net/loadd/pkg-message.in
+++ /dev/null
@@ -1,14 +0,0 @@
-#######################################################################
- Please modify the configuration file %%PREFIX%%/etc/loadd.conf
- before launching %%PREFIX%%/libexec/loadd
- don't forget to recompile your kernel with DIVERT and
- IPFIREWALL options. Don't forget to specify a rule in the ipfw
- firewall like natd: ipfw add divert 8670 tcp from any to any
- 8670 is the default port, you can choose a different port by
- running loadd with -p option like
- %%PREFIX%%/libexec/loadd -p 8671
- ipfw add divert 8671 tcp from any to any
- !! IMPORTANT !! There is no support for UDP at this time.
- You cannot use loadsharing method (broken) use intlloadsharing
- insteed and don't forget to launch lmd on server(s) to load balance
-#######################################################################
diff --git a/net/loadd/pkg-plist b/net/loadd/pkg-plist
deleted file mode 100644
index 87b92dc89b22..000000000000
--- a/net/loadd/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-libexec/loadd
-etc/loadd.conf.sample
-etc/rc.d/010.loadd.sh
-%%PORTDOCS%%share/doc/loadd/TODO
-%%PORTDOCS%%share/doc/loadd/README
-%%PORTDOCS%%share/doc/loadd/INSTALL
-%%PORTDOCS%%share/doc/loadd/LICENSE
-%%PORTDOCS%%@dirrm share/doc/loadd