aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/libslang/Makefile4
-rw-r--r--net-im/gaim-hotkeys/Makefile8
-rw-r--r--net-im/pidgin-hotkeys/Makefile8
-rw-r--r--security/p5-Authen-Krb5/Makefile4
-rw-r--r--security/putty/Makefile12
-rw-r--r--security/putty/files/patch-uxucs.c19
6 files changed, 3 insertions, 52 deletions
diff --git a/devel/libslang/Makefile b/devel/libslang/Makefile
index 84f5b3210fae..1b326a669892 100644
--- a/devel/libslang/Makefile
+++ b/devel/libslang/Makefile
@@ -34,10 +34,6 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.if defined(WITH_UTF8)
-. if ${OSVERSION} < 500000
-IGNORE= UTF8 support doesn't work on FreeBSD < 5.x
-. endif
-
PATCH_SITES+= http://www.emaillab.org/mutt/tools/
PATCHFILES+= slang-1.4.8-utf8.diff.gz
PATCH_DIST_STRIP+= -p1
diff --git a/net-im/gaim-hotkeys/Makefile b/net-im/gaim-hotkeys/Makefile
index 6148938a0ca0..8e18c1b2465b 100644
--- a/net-im/gaim-hotkeys/Makefile
+++ b/net-im/gaim-hotkeys/Makefile
@@ -23,10 +23,4 @@ GNU_CONFIGURE= yes
PLIST_FILES= lib/gaim/hotkeys.so \
lib/gaim/hotkeys.la
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= net-im/libgaim doesn't build on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-hotkeys/Makefile b/net-im/pidgin-hotkeys/Makefile
index 6148938a0ca0..8e18c1b2465b 100644
--- a/net-im/pidgin-hotkeys/Makefile
+++ b/net-im/pidgin-hotkeys/Makefile
@@ -23,10 +23,4 @@ GNU_CONFIGURE= yes
PLIST_FILES= lib/gaim/hotkeys.so \
lib/gaim/hotkeys.la
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= net-im/libgaim doesn't build on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Authen-Krb5/Makefile b/security/p5-Authen-Krb5/Makefile
index daaf9b68ee16..a0dae2c76dec 100644
--- a/security/p5-Authen-Krb5/Makefile
+++ b/security/p5-Authen-Krb5/Makefile
@@ -26,10 +26,6 @@ KRB5_HOME?= ${LOCALBASE}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Doesn't build on 4.x
-.endif
-
post-patch:
@${PERL} -pi -e 's:/usr/local/krb5:${KRB5_HOME}:g; \
s:/usr/local:${LOCALBASE}:g;' \
diff --git a/security/putty/Makefile b/security/putty/Makefile
index 779c7e28bf7f..db82660c4a2a 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -39,14 +39,4 @@ post-patch:
s,prefix=/usr/local,prefix=${PREFIX},' \
${WRKSRC}/${MAKEFILE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-CFLAGS+= -DFREEBSD_MB_SUPPORT
-
-do-configure:
- ${CP} ${FILESDIR}/wcrtomb.c ${FILESDIR}/mbrtowc.c \
- ${WRKSRC}/
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/putty/files/patch-uxucs.c b/security/putty/files/patch-uxucs.c
deleted file mode 100644
index c602fdda4dda..000000000000
--- a/security/putty/files/patch-uxucs.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- uxucs.c.orig Sat Apr 26 16:22:42 2003
-+++ uxucs.c Fri Feb 13 15:27:13 2004
-@@ -12,6 +12,16 @@
- #include "terminal.h"
- #include "misc.h"
-
-+#ifdef FREEBSD_MB_SUPPORT
-+size_t mbrtowc __P((wchar_t * __restrict, const char * __restrict, size_t,
-+ mbstate_t * __restrict));
-+size_t wcrtomb __P((char * __restrict, wchar_t, mbstate_t * __restrict));
-+
-+#include "mbrtowc.c"
-+#include "wcrtomb.c"
-+
-+#endif
-+
- /*
- * Unix Unicode-handling routines.
- */