aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-rdiscount/Makefile26
-rw-r--r--textproc/rubygem-rdiscount/distinfo3
-rw-r--r--textproc/rubygem-rdiscount/pkg-descr9
4 files changed, 39 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 28c8751808bc..4d5adf3ae6bb 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -957,6 +957,7 @@
SUBDIR += rubygem-htmltools
SUBDIR += rubygem-ini
SUBDIR += rubygem-rak
+ SUBDIR += rubygem-rdiscount
SUBDIR += rubygem-spreadsheet-excel
SUBDIR += rubygem-syntax
SUBDIR += rubygem-tidy
diff --git a/textproc/rubygem-rdiscount/Makefile b/textproc/rubygem-rdiscount/Makefile
new file mode 100644
index 000000000000..65ea68626dbd
--- /dev/null
+++ b/textproc/rubygem-rdiscount/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: rubygem-rdiscount
+# Date created: 2008-11-02
+# Whom: Daniel Roethlisberger <daniel@roe.ch>
+#
+# $FreeBSD$
+
+PORTNAME= rdiscount
+PORTVERSION= 1.2.10
+CATEGORIES= textproc rubygems
+MASTER_SITES= RF/gems
+
+MAINTAINER= daniel@roe.ch
+COMMENT= A fast Markdown converter for ruby based on discount
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+post-install:
+ @${ECHO} ${GEM_CACHE} > ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-rdiscount/distinfo b/textproc/rubygem-rdiscount/distinfo
new file mode 100644
index 000000000000..d3b6fe178ff0
--- /dev/null
+++ b/textproc/rubygem-rdiscount/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/rdiscount-1.2.10.gem) = 6c1b220c136d215440eb1552f8f56dd1
+SHA256 (rubygem/rdiscount-1.2.10.gem) = dab826a59aeb021a600661ba4987e4a28e3955ffa14b5e6adafbf46cc1beebd2
+SIZE (rubygem/rdiscount-1.2.10.gem) = 31232
diff --git a/textproc/rubygem-rdiscount/pkg-descr b/textproc/rubygem-rdiscount/pkg-descr
new file mode 100644
index 000000000000..c823db470e25
--- /dev/null
+++ b/textproc/rubygem-rdiscount/pkg-descr
@@ -0,0 +1,9 @@
+Ruby wrapper around David Loren Parsons' discount, a fast,
+BSD-licensed c implementation of John Gruber's Markdown plus
+some aspects of SmartyPants. Markdown is a text-to-HTML
+conversion language for web writers, inspired by the format
+of plain-text e-mail messages. Markdown allows you to write
+in an easy-to-read, easy-to-write plain text format, then
+convert it to structurally valid XHTML (or HTML).
+
+WWW: http://github.com/rtomayko/rdiscount/