aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pip/Makefile22
-rw-r--r--devel/py-pip/distinfo3
-rw-r--r--devel/py-pip/pkg-descr16
-rw-r--r--devel/py-pip/pkg-plist14
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ecb576147ab3..f7d9e8fa4031 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2247,6 +2247,7 @@
SUBDIR += py-pefile
SUBDIR += py-period
SUBDIR += py-phpserialize
+ SUBDIR += py-pip
SUBDIR += py-plex
SUBDIR += py-ply
SUBDIR += py-pmock
diff --git a/devel/py-pip/Makefile b/devel/py-pip/Makefile
new file mode 100644
index 000000000000..5570ee25fb2a
--- /dev/null
+++ b/devel/py-pip/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: pip
+# Date created: 2009-01-19
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pip
+PORTVERSION= 0.2.1
+#PORTREVISION= 0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP \
+ LOCAL/nivit/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Pip installs (Python) packages. An easy_install replacement
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/devel/py-pip/distinfo b/devel/py-pip/distinfo
new file mode 100644
index 000000000000..5c1781abb110
--- /dev/null
+++ b/devel/py-pip/distinfo
@@ -0,0 +1,3 @@
+MD5 (pip-0.2.1.tar.gz) = d2af655c1a87e03799442d045c1d6743
+SHA256 (pip-0.2.1.tar.gz) = 83522005c1266cc2de97e65072ff7554ac0f30ad369c3b02ff3a764b962048da
+SIZE (pip-0.2.1.tar.gz) = 39802
diff --git a/devel/py-pip/pkg-descr b/devel/py-pip/pkg-descr
new file mode 100644
index 000000000000..6947c868ab9d
--- /dev/null
+++ b/devel/py-pip/pkg-descr
@@ -0,0 +1,16 @@
+pip is a replacement for easy_install. It uses mostly the same techniques
+for finding packages, so packages that were made easy_installable should
+be pip-installable as well.
+
+pip is meant to improve on easy_install. Some of the improvements:
+
+ * All packages are downloaded before installation. Partially-completed
+ installation doesn't occur as a result.
+ * Care is taken to present useful output on the console.
+ * The reasons for actions are kept track of. For instance, if a package
+ is being installed, pip keeps track of why that package was required.
+ * Error messages should be useful.
+ * Packages don't have to be installed as egg archives, they can be
+ installed flat (while keeping the egg metadata).
+
+WWW: http://pip.openplans.org/
diff --git a/devel/py-pip/pkg-plist b/devel/py-pip/pkg-plist
new file mode 100644
index 000000000000..58a8ef9569d6
--- /dev/null
+++ b/devel/py-pip/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+bin/pip
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/scripts/pip
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pip.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pip.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pip.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/scripts
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%