aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-View-Templated/Makefile27
-rw-r--r--www/p5-Catalyst-View-Templated/distinfo3
-rw-r--r--www/p5-Catalyst-View-Templated/pkg-descr4
-rw-r--r--www/p5-Catalyst-View-Templated/pkg-plist5
5 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 64ce4c847176..5205b068bf4f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -692,6 +692,7 @@
SUBDIR += p5-Catalyst-View-Mason
SUBDIR += p5-Catalyst-View-TT
SUBDIR += p5-Catalyst-View-TT-ControllerLocal
+ SUBDIR += p5-Catalyst-View-Templated
SUBDIR += p5-Class-DBI-FromForm
SUBDIR += p5-ClearSilver
SUBDIR += p5-Compress-LeadingBlankSpaces
diff --git a/www/p5-Catalyst-View-Templated/Makefile b/www/p5-Catalyst-View-Templated/Makefile
new file mode 100644
index 000000000000..19f2e1cd345a
--- /dev/null
+++ b/www/p5-Catalyst-View-Templated/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Catalyst-View-Templated
+# Date created: 18 Jan 2008
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-View-Templated
+PORTVERSION= 0.02
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/J/JR/JROCKWAY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Generic base class for template-based views
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ ${SITE_PERL}/${PERL_ARCH}/Catalyst/Component/ACCEPT_CONTEXT.pm:${PORTSDIR}/www/p5-Catalyst-Component-ACCEPT_CONTEXT \
+ ${SITE_PERL}/Class/C3.pm:${PORTSDIR}/devel/p5-Class-C3
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::View::Templated.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-View-Templated/distinfo b/www/p5-Catalyst-View-Templated/distinfo
new file mode 100644
index 000000000000..481b3c14473e
--- /dev/null
+++ b/www/p5-Catalyst-View-Templated/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-View-Templated-0.02.tar.gz) = 49c7b948d4a1579846e2a638e5947700
+SHA256 (Catalyst-View-Templated-0.02.tar.gz) = 9f2e8c4731bbd8ecf1b070cb67f071b97569899c2bb7feb5b04bae46af4c8fba
+SIZE (Catalyst-View-Templated-0.02.tar.gz) = 16371
diff --git a/www/p5-Catalyst-View-Templated/pkg-descr b/www/p5-Catalyst-View-Templated/pkg-descr
new file mode 100644
index 000000000000..a1ba9e8eca7c
--- /dev/null
+++ b/www/p5-Catalyst-View-Templated/pkg-descr
@@ -0,0 +1,4 @@
+View::Templated makes all (template-based) Catalyst views work
+the same way.
+
+WWW: http://search.cpan.org/dist/Catalyst-View-Templated/
diff --git a/www/p5-Catalyst-View-Templated/pkg-plist b/www/p5-Catalyst-View-Templated/pkg-plist
new file mode 100644
index 000000000000..db2f051ada5f
--- /dev/null
+++ b/www/p5-Catalyst-View-Templated/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Catalyst/View/Templated.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/Templated/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/Templated
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View
+@dirrmtry %%SITE_PERL%%/Catalyst/View